Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 17 Oct 2017, 09:35
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
geany-1.30.1
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
festus


Joined: 14 Jan 2015
Posts: 135

PostPosted: Thu 08 Jun 2017, 13:27    Post subject:  geany-1.30.1
Subject description: text editor-IDE
 

Here are geany pets, compiled compatible with slack-14.1 & ubuntu-xenial 7.0.8.1

I have been practicing compiling from the sources, and there are no plugins builtin.

Homepage:https://www.geany.org/

Geany is a text editor using the GTK+ toolkit with basic features of an integrated development environment. It was developed to provide a small and fast IDE, which has only a few dependencies from other packages. It supports many filetypes and has some nice features. For more details see About.

*BEFORE installing to pups, remove-blt-in-pkgs Geany, search geany in pfind & delete all geany files except /usr/share, then install this pet.

Downloads:
slack-14.1 (4.4 MB)
https://www.mediafire.com/?w2al428y4zhz7nt

ubuntu-xenial: (5.9 MB)
https://www.mediafire.com/?kn7k25n99cbtxlm

Just want to share what works for me,
festus
Back to top
View user's profile Send private message 
april


Joined: 14 Sep 2013
Posts: 984
Location: Off Lizard Island for a bit

PostPosted: Thu 08 Jun 2017, 14:24    Post subject:  

I see in precise 5.7.1 the Geany version is 0.19.1

This version is 1.30.1 so I'm assuming there must be some useful changes in it .

Do you have a pet that will work in Precise 5.7.1 ?

I can compile one but hav'nt got the pet thing worked out yet and don't have the time to work it out right now.
Back to top
View user's profile Send private message Yahoo Messenger 
festus


Joined: 14 Jan 2015
Posts: 135

PostPosted: Fri 09 Jun 2017, 08:00    Post subject:  

april wrote:
Do you have a pet that will work in Precise 5.7.1 ?


april, I used to run tahr, and precise-pets would usually work with it, so you may try the xenial geany pet on precise, it may work.

If you do try it on precise, please let us know if it will work.

festus Smile
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1610
Location: London, England

PostPosted: Fri 09 Jun 2017, 17:59    Post subject:  

I compiled geany-1.30.1 in Precise and split off the DEV, DOC and NLS packages.
Treat it as "for testing" and take precautions.
EDIT:- Version upgrade to 1.31
Uploaded to http://smokey01.com/OscarTalks
geany-1.30.1.jpg
 Description   Geany-1.30.1 compiled in Precise
 Filesize   61.52 KB
 Viewed   91 Time(s)

geany-1.30.1.jpg


_________________
Oscar in England

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0293s ][ Queries: 14 (0.0033s) ][ GZIP on ]