Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 19 Nov 2017, 18:01
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Puppy Precise 5.7.1 PXE Boot funktioniert nicht.
Moderators: MU
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
SirNibo

Joined: 29 Jul 2017
Posts: 1

PostPosted: Sat 29 Jul 2017, 12:10    Post subject:  Puppy Precise 5.7.1 PXE Boot funktioniert nicht.  

Hi, ich versuche Puppy Precise 5.7.1 vom Netzwerk zu starten. Leider kommt immer beim booten ein Kernel Panic. Ich habe mich an diese Anleitung gehalten. http://sirlagz.net/2011/06/13/how-to-boot-puppy-5-2-5-over-pxe/
Anstatt der lupu_525.sfs ist in der Precise die Puppy_pr.sfs enthalten.
Der PXE Server funktioniert bei anderen Sachen problemlos. Clonezilla, Gparted bzw. WinPE lassen sich ohne Probleme starten. Danke für die Hilfe.

Code:
mkdir /tftpboot/puppy/
cp /mnt/initrd.gz /tftpboot/puppy/
cp /mnt/vmlinuz /tftpboot/puppy/
cp /mnt/puppy_pr.sfs /tftpboot/puppy/
mkdir /tftpboot/puppy/temp
cd /tftpboot/puppy/temp
zcat /tftpboot/puppy/initrd.gz | cpio -i -H newc -d
mv /tftpboot/puppy/puppy_pr.sfs /tftpboot/puppy/temp/puppy_precise_5.7.1.sfs
find | cpio -o -H newc | gzip -4 > ../newinitrd.gz

PXELINUX.CFG
Code:
LABEL Puppylinux
MENU LABEL Puppy Linux 5.2.5
kernel puppy/vmlinuz
append initrd=puppy/newinitrd.gz

Back to top
View user's profile Send private message 
HoerMirAuf


Joined: 22 Jan 2008
Posts: 252
Location: Würzburg

PostPosted: Mon 31 Jul 2017, 05:54    Post subject:  

Hi.

... ist da möglicherweise schon eine (evtl defekte) Speicherdatei auf dem Zielrechner vorhanden die er sich beim booten greift? ...

Bin jetzt nicht der große pxe-boot Profi aber was mir auffällt ist das Du in Deiner pxelinux.cfg gar kein subir "psubdir=puppy" definierst.

oder schon mal mit den Bootparamnetern gespielt? "pfix=ram" etc.?

_________________
Slacko-5.6 / Kernel 4.8.15
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0259s ][ Queries: 11 (0.0041s) ][ GZIP on ]