Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 10 Dec 2019, 20:02
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Create Debian 9 (Stretch) minimal ISO similar to DebianDog
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 27 of 103 [1533 Posts]   Goto page: Previous 1, 2, 3, ..., 25, 26, 27, 28, 29, ..., 101, 102, 103 Next
Author Message
jd7654

Joined: 06 Apr 2015
Posts: 297

PostPosted: Sat 19 Aug 2017, 14:09    Post subject:  

fredx181 wrote:
The good thing about the new mklive-stretch setup with use of config file is that we can share configs that work directly.

Ok, I begin... Smile
As a start here's peebee's LxDD setup I transformed (for now) to a working config file, attached lxdd.conf (remove fake .gz)
Run with -cli or -gui , for cli :
Code:
./mklive-stretch -cli lxdd.conf


Small issue, specifically with this config, but could be more general issue:

This config loaded in script fails if run from 64-bit host. Only because of wrong package gnome-mplayer-1.0.7 instead of 1.0.6.
To fix, either select FORCE32 or change package to gnome-mplayer-1.0.6 instead.

So the config doesn't state whether it is for i686 or x86_64, it only shows if FORCE32 was in effect.
Instead, the script could alter the config to show ARCH, with Yad selecting ARCH from dropdown box, and 32-bit hosts not given the 64-bit option.(and move up the uname/ARCH detection)

Don't know if this would be an issue in the future with 32/64-bit package differences or if this is a worthwhile change, just a note.
Back to top
View user's profile Send private message 
festus


Joined: 14 Jan 2015
Posts: 221

PostPosted: Sat 19 Aug 2017, 16:14    Post subject: cups printing issue  

Hello, everyone

I can't get my printer, HP-Envy-5530, setup. It seems to me that cups isn't installed or not like it should be.

I installed, hplip_print_scan-3.16.11.pet, with pet2stretch, then went to http://localhost:631and got this message:

Here is the cups-locations:

Any ideas?

Thanks for helping,
festus Smile
cups_locations.jpg
 Description   
 Filesize   56.02 KB
 Viewed   978 Time(s)

cups_locations.jpg

cups_localhost-631-error.jpg
 Description   
 Filesize   28.15 KB
 Viewed   993 Time(s)

cups_localhost-631-error.jpg

Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 1413

PostPosted: Sat 19 Aug 2017, 23:05    Post subject:  

Festus

Type "cups start" in terminal and try again or maybe "service cups restart".
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4208
Location: holland

PostPosted: Sun 20 Aug 2017, 05:46    Post subject:  

jd7654 wrote:
This config loaded in script fails if run from 64-bit host. Only because of wrong package gnome-mplayer-1.0.7 instead of 1.0.6.
To fix, either select FORCE32 or change package to gnome-mplayer-1.0.6 instead.

So the config doesn't state whether it is for i686 or x86_64, it only shows if FORCE32 was in effect.
Instead, the script could alter the config to show ARCH, with Yad selecting ARCH from dropdown box, and 32-bit hosts not given the 64-bit option.(and move up the uname/ARCH detection)


Yes, good point, it's a complicated thing, I can make it so that the generated build_setup.conf shows if it's a i386 or amd64 build (or something like that)
To replace FORCE32=... with ARCH=... (I understand that's your suggestion, correct me if I'm wrong) would be another option, difficult to do, but probably good solution, not sure though.
Btw, there's (only) one more package with the version in its name, that is transmission (2.31 for 32bit and 2.60 for 64bit)

The best would be to change name of e.g gnome-mplayer-<version> to just gnome-mplayer but that has other consequences (some other custom dog packages depend on it)

Fred
Back to top
View user's profile Send private message 
Rangan Masti

Joined: 01 Jan 2013
Posts: 38
Location: Germany, Berlin

PostPosted: Sun 20 Aug 2017, 06:20    Post subject:    

Hi, good morning.
i was able to creat both 32 bit and 64 bit live iso using mklive-stretch -cli lxdd.conf. Good work. Trying to include devx. Have a good day.

Rangan
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12801
Location: Stratford, Ontario

PostPosted: Sun 20 Aug 2017, 11:22    Post subject: Re: cups printing issue  

festus wrote:
I can't get my printer, HP-Envy-5530, setup. It seems to me that cups isn't installed or not like it should be.


Code:
apt-get update
apt-get install cups


Run pet2stretch again and check for missing dependencies. IIRC, hplip needs something like libjpeg8.

Code:
apt-get install libjpeg8

Last edited by rcrsn51 on Sun 20 Aug 2017, 14:42; edited 1 time in total
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12801
Location: Stratford, Ontario

PostPosted: Sun 20 Aug 2017, 12:51    Post subject:  

This is CamPhoneTab from here. Look for it in the Accessories menu.

The default dependencies are: gphoto2, gphotofs, jmtpfs, mtp-tools.

The iDevice option is untested and probably needs work, so I have left it off the Depends list. To access iDevices, you will need these additional packages: ifuse, usbmuxd, libimobiledevice-utils

Hint: On many Android devices, there is a standard procedure to enable USB downloads:
1. Swipe down on the notification bar.
2. Select the USB connection dialog.
3. Select PTP or MTP mode.

--------------------
camphonetab_1.6-3_all.deb.gz
Description  Updated 2019-11-20
Remove the fake .gz extension
gz

 Download 
Filename  camphonetab_1.6-3_all.deb.gz 
Filesize  3.5 KB 
Downloaded  6 Time(s) 
snappie.png
 Description   
 Filesize   6.36 KB
 Viewed   308 Time(s)

snappie.png

camphonetab_1.6-1.deb.gz
Description  Updated 2018-04-05
Minor changes to the user interface
gz

 Download 
Filename  camphonetab_1.6-1.deb.gz 
Filesize  3.44 KB 
Downloaded  107 Time(s) 

Last edited by rcrsn51 on Sun 24 Nov 2019, 15:29; edited 14 times in total
Back to top
View user's profile Send private message 
festus


Joined: 14 Jan 2015
Posts: 221

PostPosted: Sun 20 Aug 2017, 13:16    Post subject: Re: cups printing issue  

rcrsn51 wrote:
festus wrote:
I can't get my printer, HP-Envy-5530, setup. It seems to me that cups isn't installed or not like it should be.


Code:
apt-get update
apt-get install cups


Run pet2stretch again and check for missing dependencies. IIRC, hplip needs something like libjpeg8.

Code:
apt-get install lijpeg8
Thank you, oh so very much, the printing problem is solved.

hplip was missing libjpeg.so.8 & the install fixed it.

btw, at first apt-get wouldn't install libjpeg8, so I looked at the cmd again & I saw that it was misspelled in your last code

bliss, festus
Back to top
View user's profile Send private message 
jd7654

Joined: 06 Apr 2015
Posts: 297

PostPosted: Sun 20 Aug 2017, 13:36    Post subject:  

fredx181 wrote:
Yes, good point, it's a complicated thing, I can make it so that the generated build_setup.conf shows if it's a i386 or amd64 build (or something like that)
To replace FORCE32=... with ARCH=... (I understand that's your suggestion, correct me if I'm wrong) would be another option, difficult to do, but probably good solution, not sure though.
Btw, there's (only) one more package with the version in its name, that is transmission (2.31 for 32bit and 2.60 for 64bit)


So if this is just a single case issue, you may not want to spend that much time on any changes.

Actually, I found out the gnome-mplayer doesn't work properly anyway, at least on the machines I've tried. It doesn't seem to do full screen resize, but I may be missing something.

Not familiar with the packages and why installing mpv acts as the parent package and also installs mplayer and gnome-mplayer, usually it is the other way around. But I ran into a conflict with chromium and mpv cause script to fail, so that's why I tried just gnome-mplayer package, which installed mplayer but not mpv. But since that didn't work right, I tried smplayer instead, which also installed mplayer but not mpv, but that works correctly with full screen resize. Strange. If mpv installed with firefox then gnome-mplayer worked properly.

Another option tried, vlc installs but I guess I need a workaround for running as root?
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 4093
Location: Worcestershire, UK

PostPosted: Sun 20 Aug 2017, 13:50    Post subject:  

I've uploaded a replacement zz-lxdd-config-1708.squashfs which should replace the version in /live/modules obtained from the LxDD-17.08.1.iso

Not really sure why light-locker caused the permanent screen blanking problem but in the new .squashfs it is disabled (as is lightdm so there is no tty7 desktop - tty2 is still there and the root password is toor if you need to login).

Cheers
peebee

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
fredx181


Joined: 11 Dec 2013
Posts: 4208
Location: holland

PostPosted: Sun 20 Aug 2017, 15:25    Post subject:  

jd7654 wrote:
Not familiar with the packages and why installing mpv acts as the parent package and also installs mplayer and gnome-mplayer, usually it is the other way around. But I ran into a conflict with chromium and mpv cause script to fail, so that's why I tried just gnome-mplayer package, which installed mplayer but not mpv. But since that didn't work right, I tried smplayer instead, which also installed mplayer but not mpv, but that works correctly with full screen resize. Strange. If mpv installed with firefox then gnome-mplayer worked properly.


Maybe this info helps:
gnome-mplayer (from dog repo) has mplayer already included.
Installing mplayer will install the official Debian package and will uninstall gnome-mplayer.
What you say about mpv being a parent package I don't understand, AFAIK it's independent of mplayer or gnome-mplayer
To make full screen work for gnome-mplayer , go in the Preferences > Tab Mplayer and add in the box "Extra options for mplayer":
Code:
-zoom


To make vlc run as root:
Code:
sed -i 's/geteuid/getppid/' /usr/bin/vlc


Fred
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4208
Location: holland

PostPosted: Sun 20 Aug 2017, 15:34    Post subject:  

peebee wrote:
I've uploaded a replacement zz-lxdd-config-1708.squashfs which should replace the version in /live/modules obtained from the LxDD-17.08.1.iso

Not really sure why light-locker caused the permanent screen blanking problem but in the new .squashfs it is disabled (as is lightdm so there is no tty7 desktop - tty2 is still there and the root password is toor if you need to login).

Cheers
peebee


My simple fix was to just disable the screen-locker
Extract attached tar.gz in the file system or in rootcopy frugal install folder.

Fred
disable-screen-locker.tar.gz
Description  Extract in the file system or in rootcopy frugal install folder
gz

 Download 
Filename  disable-screen-locker.tar.gz 
Filesize  1.32 KB 
Downloaded  144 Time(s) 
Back to top
View user's profile Send private message 
jd7654

Joined: 06 Apr 2015
Posts: 297

PostPosted: Sun 20 Aug 2017, 16:40    Post subject:  

fredx181 wrote:
What you say about mpv being a parent package I don't understand, AFAIK it's independent of mplayer or gnome-mplayer
To make full screen work for gnome-mplayer , go in the Preferences > Tab Mplayer and add in the box "Extra options for mplayer":
Code:
-zoom


That was my bad. I see that dogradio was the package installing mplayer and gnome-mplayer, not mpv. Only conflict was mpv and chromium.
EDIT: I see that mpv installed was old 0.13.0 version and prolly conflicts with newest chromium. On my Debian full install, mpv full with pseudo-gui is 0.23.0.

Last edited by jd7654 on Sun 20 Aug 2017, 16:51; edited 1 time in total
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4208
Location: holland

PostPosted: Sun 20 Aug 2017, 16:49    Post subject:  

Hi All,

I made JWM config deb package "jwmconf" , it;s in the repos, so can be added to install list, it will automatically install jwm and rox (and some more)

I made a build using this successfully:
Code:
DESK_APPS_INSTALL="jwmconf pcmanfm lxrandr lxinput"


Attached jwm.conf (remove fake .gz)
To build (using cli in this example):
Code:
./mklive-stretch -cli jwm.conf

(requires latest mklive-stretch)

It's a bit of an experiment by using deb package for make a build with configured Desktop environment, not sure yet if it's the right way.

EDIT: THe JWM configuration is rather simple, I'm personally not much into JWM/ROX, if anyone feels like improving and share the results it would be nice!
(then I can include the changes in a new deb package)

EDIT2: Made a fix for jwmconf deb package, when changing jwm theme, conky stays transparent now (with previous version it turned black)

Fred
stretchlive-jwm.jpg
 Description   Stretch Live with JWM
 Filesize   39.83 KB
 Viewed   546 Time(s)

stretchlive-jwm.jpg

jwm.conf.gz
Description  JWM config (remove fake .gz)
gz

 Download 
Filename  jwm.conf.gz 
Filesize  2.55 KB 
Downloaded  140 Time(s) 
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12801
Location: Stratford, Ontario

PostPosted: Mon 21 Aug 2017, 10:37    Post subject:  

I burned some Stretch-Live ISOs to DVD and got an interesting result.

If I booted an Athlon machine with the 32bit disc, I got an immediate kernel-panic.

But the 64bit version booted fine.

This machine will boot 32bit Puppy discs OK.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 27 of 103 [1533 Posts]   Goto page: Previous 1, 2, 3, ..., 25, 26, 27, 28, 29, ..., 101, 102, 103 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0790s ][ Queries: 12 (0.0160s) ][ GZIP on ]