Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Aug 2017, 15:45
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Compose key doesn't create certain letters
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
frenchiveruti

Joined: 15 Feb 2017
Posts: 65

PostPosted: Sun 20 Aug 2017, 08:06    Post subject:  Compose key doesn't create certain letters
Subject description: I have to rely on unicode typing.
 

Hello everyone, I have an standar 105 spanish keyboard, that includes the "tilde" --> "~" that should be able to be composed like on DOS to be placed on top of the vowels to be able to write portuguese words such as "não", the thing is that I have to use "Shift+CTRL+U" then "E3" to write this one, and it would be far easier to do "RAlt+4" (where the ~ is) and "compose it" with the "A" key.
I have set the "Compose" key to my RWin key, so I can write things like ½⅓ etc. but can't find the way to do the ã in the same way, it doesn't recognize it.
Is there a way to add it? I really need this one key.
Back to top
View user's profile Send private message 
tallboy


Joined: 21 Sep 2010
Posts: 739
Location: Oslo, Norway

PostPosted: Sun 20 Aug 2017, 11:16    Post subject:  

Hi frenchiveruti. I have a norwegian 105 key keyboard, and my tilde sign is placed in a different location compared to the spanish keyboard.
But, I tried to replicate your problem in Geany, and found another problem. I can make a standalone tilde ~, by holding the AltGr + two taps on the tilde key. But when I tried to make an ã: Hmm, sorry I cannot make it, it just produces this ã!
So I tried in Abiword, and everything was perfect, an a with a tilde on top!
So I looked at the fonts. In my Geany 1.23, default with my Lucid 5.2.8.7, I use the font Monospace 13, and I could not make an a with a tilde, only the a with a overhead line. So I switched font to the same as I use in my Abiword 2.8.6, Nimbus Roman No.9 L, and hey presto!, it makes an a with a tilde!
Here in my Palemoon 27.4.1 browser, I have set the serif font to Nimbus Roman No.9 L, and Sans-serif to Verdana, so you should think I could produces an a with a tilde? No, because I also checked Allow pages to choose their own fonts. I shall restart my Palemoon after I have read all the new posts, adjust the preferences, and see if I can make another post below, with my own fonts, and maybe an a with a tilde. You have to wait a few minutes for that!
You should also Google or DuckDuck 'pan-Unicode font', to be certain of using a font that definitely use all the unicode possibilities, even if most modern fonts do that. Here is some other interesting reading: https://www.cl.cam.ac.uk/~mgk25/unicode.html

tallboy

_________________
True freedom is a live Puppy on a multisession CD/DVD.
Back to top
View user's profile Send private message 
tallboy


Joined: 21 Sep 2010
Posts: 739
Location: Oslo, Norway

PostPosted: Sun 20 Aug 2017, 12:00    Post subject:  

I have now restarted Palemoon with the monospace font set to Liberation Mono, which produce an excellent a with a tilde, as shown in the picture. I also unchecked the Allow pages to choose their own fonts, but unfortunately, the forum chooses it's own font anyway, so I cannot reproduce it here! But it is clear that the choice of font and which preferences setting you use, will influence on the result. Please report back if you find a good solution.

tallboy
fonter.jpg
 Description   
 Filesize   10.18 KB
 Viewed   50 Time(s)

fonter.jpg


_________________
True freedom is a live Puppy on a multisession CD/DVD.
Back to top
View user's profile Send private message 
frenchiveruti

Joined: 15 Feb 2017
Posts: 65

PostPosted: Mon 21 Aug 2017, 01:19    Post subject:  

So the issue is more related to software than the Puppy linux itself?
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 4660
Location: Ontario

PostPosted: Mon 21 Aug 2017, 20:05    Post subject:  

A font doesn't have to have the accented characters, however most truetype ones do have them.
Back to top
View user's profile Send private message 
Peterm321

Joined: 29 Jan 2009
Posts: 372

PostPosted: Mon 21 Aug 2017, 21:12    Post subject:  

Any of the modern particularly true type ones, support at least the extended latin characters some rather a lot more.

As to the original question, I'm sure that there are some of the language options in the various setup programs that can be reached through the menus.

However for a more thorough remapping (NB if you have a particular key or keys that you use a lot) is to use xmodmap.

A couple of useful sites that explain xmodmap can be viewed at these urls:

https://wiki.archlinux.org/index.php/xmodmap

https://superuser.com/questions/417568/setting-hyper-and-super-modifiers-for-certain-keys-with-setxkbmap-or-xmodmap

The command

Code:
xmodmap -pke


Lists the current keymap. From that I learned that the format of the xmodmap to modify a key is to find its keycode and use xmodmap to set its direct value, its value when used with shift, and value when used with various modifiers.

Code:
xmodmap -e "keycode <code> = char    shift+char   Mode_switch+char ..."


Looking at the output of xmodmap -pke, it said my Mode_switch key was keycode 93. No idea what that was even after investigating with xev. Instead I used xev to find out what keycode was Alt Gr and decided to set that as my Mode_switch key:

Code:
xmodmap -e "keycode 113 = Mode_switch"


To discover the keycodes for the letters n , o , and a I used
Code:
xev|grep keycode
then used xmodmap to modify them, --

Code:
xmodmap -e "keycode 57 = n N ntilde"

xmodmap -e "keycode 32 = o O ocircumflex"

xmodmap -e "keycode 38 = a A atilde"


The result? Typing Alt Gr+n produces ñ , Alt Gr+o produces ô, Alt Gr+a produces ã

Não prôblem!
SCRDUMP.JPG
 Description   
 Filesize   24.56 KB
 Viewed   10 Time(s)

SCRDUMP.JPG

Back to top
View user's profile Send private message 
frenchiveruti

Joined: 15 Feb 2017
Posts: 65

PostPosted: Mon 21 Aug 2017, 21:34    Post subject:  

Peterm321 wrote:

To discover the keycodes for the letters n , o , and a I used
Code:
xev|grep keycode
then used xmodmap to modify them, --

Code:
xmodmap -e "keycode 57 = n N ntilde"

xmodmap -e "keycode 32 = o O ocircumflex"

xmodmap -e "keycode 38 = a A atilde"


The result? Typing Alt Gr+n produces ñ , Alt Gr+o produces ô, Alt Gr+a produces ã

Não prôblem!

I love when comments have both the issue and the answer!
I'll try it out when I reach home, thanks a lot Very Happy
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0641s ][ Queries: 12 (0.0039s) ][ GZIP on ]