(OLD) (ARCHIVED) Puppy Linux Discussion Forum Forum Index (OLD) (ARCHIVED) Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

This forum can also be accessed as http://oldforum.puppylinux.com
It is now read-only and serves only as archives.

Please register over the NEW forum
https://forum.puppylinux.com
and continue your work there. Thank you.

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups    
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 27 Sep 2020, 23:45
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
[TAHRPUP 6.X] désinstaller un package, impossible ?
Moderators: Béèm, darkerror05, linuxcbon
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
fabrice_035


Joined: 28 Apr 2014
Posts: 768
Location: Bretagne / France

PostPosted: Sun 17 Sep 2017, 08:13    Post subject:  [TAHRPUP 6.X] désinstaller un package, impossible ?
Subject description: PPM
 

Salut,

Pourquoi avec Puppy Package Manager il n'est pas possible de désinstaller un package sans tomber systématiquement sur une boite de dialogue dans ce style, rendant la suppression du package épique et dangereuse ?

Ne serait-il pas possible comme cela existe par ailleurs avec windowze de créer un fichier uninstall qui contiendrai la liste des fichiers installés et ceux déjà présent ou moment de l'installation ?

Qu'en pensez-vous ? Existe-t-il une autre méthode de suppression ?
snapshot-2.png
 Description   
 Filesize   23.66 KB
 Viewed   288 Time(s)

snapshot-2.png

Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3822
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sun 17 Sep 2017, 10:04    Post subject:  

Bonjour fabrice_035,
Quote:
Ne serait-il pas possible comme cela existe par ailleurs avec windowze de créer un fichier uninstall qui contiendrai la liste des fichiers installés et ceux déjà présent ou moment de l'installation ?

Ça existe bel et bien et la liste des paquets installés, ainsi que des fichiers des paquets correspondants se trouvent dans le dossier caché /root/.packages (/root/.packages/user-installed-packages et fichiers dans le fichier "nom-du-paquet.files"). Dans ton cas, la désinstallation est refusée car il faut d'abord que tu désinstalles les autres paquets dépendants listés dans la fenêtre (et qui doivent par là même figurer dans la liste des paquets installés du PPM).

Une fois cela fait, tu pourras sans doute faire la désinstallation de Google Earth sans soucis. Wink

Cordialement.

_________________

Puppy Search
Back to top
View user's profile Send private message Visit poster's website 
fabrice_035


Joined: 28 Apr 2014
Posts: 768
Location: Bretagne / France

PostPosted: Sun 17 Sep 2017, 12:07    Post subject:  

D'accord merci pour l'info mais pourquoi le des-installateur de PPM n'est pas capable de prendre le chemin inverse de l'installateur et virer seul l'autre paquet ?

Car lorsque je vais (tenter) de désinstaller les autres dépendances, je risque d'avoir un autre avertissement car il faut d'abord désinstaller un autre paquet lié ... c'est lourd dingue. Sachant que le risque n'est-il pas de virer un paquet partagé par plusieurs applications ? Je crois avoir déjà tenté le coup et au final j'avais une ou plusieurs applications qui ne se lançaient plus Sad
Car certains paquets ont en plus des noms similaires.
Sur d'autres distri, avec apt-get, on peut virer et purger sans risques je crois.
Back to top
View user's profile Send private message 
Dorothée


Joined: 27 Nov 2012
Posts: 259

PostPosted: Sun 17 Sep 2017, 14:41    Post subject:  

Bonjour Fabrice,

ta question renvoie à l'intérêt des sfs, que l'on monte et démonte sans problème, pour les applications qui ne servent pas continuellement (c'est mon cas pour google earth, que j'utilise de temps en temps en montant le sfs). C'est surtout aux dépendances et aux librairies auxquelles je pense: j'ai remarqué que je dois monter precisedev si je veux utiliser kdenlive, mais si je veux utiliser flowblade, il ne marche pas si precisedev est installé. Si je monte le pet (et donc quasi définitivement) precisedev, c'est foutu pour flowblade. Alors que si je fonctionne en sfs, je les monte et démonte à la demande. C'est un exemple comme un autre, mais on est souvent ennuyé quand on installe un pet qui peut bloquer le fonctionnement d'autres applications, sans compter le problème de la désinstallation dont tu as parlé.

Qu'en penses-tu?

PS: je suis sur Precise Triton, mais c'est le même principe pour toutes les distros Puppy, me semble-t-il.
Back to top
View user's profile Send private message 
fabrice_035


Joined: 28 Apr 2014
Posts: 768
Location: Bretagne / France

PostPosted: Sun 17 Sep 2017, 14:44    Post subject:  

@Dorothée, pour moi sfs ne répond pas à la question de la désinstallation avec PPM Smile

Cdt.
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3822
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sun 17 Sep 2017, 17:16    Post subject:  

Bonsoir,
Certaines des dernières Puppies ont un "PPM2" beaucoup moins souple et plus exigeant* que le "PPM" des Puppies antérieures, par exemple Puppy Precise 5.7.1 (et par là-même les dérivées comme Triton, Toutou, ToOpPy, et quelques autres) qui est selon moi la dernière version de Puppy avec laquelle on ne se sent pas gêné aux entournures (avec, peut-être les risques que ça comporte...). Après je trouve que ça commence à se gâter et je me demande d'ailleurs ce que ça apporte vraiment, cette raideur, sinon des complications du genre de celle à laquelle tu as à faire.
Mais bon, chacun voit midi à sa porte!
*Exemple parmi d'autres qui surgissent ça et là:
slavvo67 wrote:
This pet does not install correctly for those using PPM2. There is a glitch or coding that requires the file inside the pet to match the pet. Why? Good question. Anyway, unpacking the pet and repackaging it seems to work.

Arrow http://www.murga-linux.com/puppy/viewtopic.php?t=98640

Concernant les SFS, je suis entièrement d'accord avec Dorothée. Je ne fonctionne qu'avec et en recommande vivement l'usage (ToOpPy a été optimisée - merci à notre regretté et irremplaçable ASRI Crying or Very sad - pour prendre en charge jusqu'à 50 SFS. Je n'ai jamais poussé le bouchon jusque là [25/30 maxi], mais en principe, ça le fait!), hormis quelques applications très rares (ex: Seamonkey?) et certaines mises à jour système qui ne semblent pas supporter ce mode d'installation (glibc, etc).

Cordialement.

_________________

Puppy Search
Back to top
View user's profile Send private message Visit poster's website 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Thu 21 Sep 2017, 23:43    Post subject: Testé hier avec Audacious et Alexandra  

PPM Tahrpup versions à utiliser : rien se sert de prendre les dernières versions si elles perdent vis et boulons. La version 6.0.5 de tahrpup a un PPM qui marche impeccable. Testé hier avec Audacious et Alexandra ajoutés et enlevés. Tout est OK.
Google Earth est un cas unique, perhaps.
Personne n'oblige a prendre les dernières versions sorties des Puppies et des navigateurs. Y'a pas de honte à tourner en Puppy Precise, car on a plus d'applis et moins d'ennuis. (et de l'assistance en ligne)
Firefox , ses libavcodecs, et son pulseaudio; çà fait poster les usagers Puppy qui veulent se dépanner. La solution est de continuer à tourner avec une version qui fonctionnait bien. La solution n'est pas au coup par coup, on trouves des astuces, mais tout Linux a le souci, voir les ubuntistes qui postent à ce sujet. Actuellement is disent de garder un Firefox qui tourne ou de tromper la nouvelle version en shuntant les libavcodecs récents
Les améliorations apportés par le dernier Firefox sont pour des matériels que vous n'avez pas.
Achetez des films 3d, utilisez le Bluetooh, et brancher un phone androïd, voilà ce que permettent les dernières libs des Puppies 6. Mais il faut qu'on achète le matos qui va avec.

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Fri 22 Sep 2017, 12:43    Post subject: Tahrpup Topless 6.0.2 et Gramps chargé du PPM  

je va tester le fonctionnement des pets avec la Tahrpup Topless 6.0.2 et Gramps chargé du PPM
feed-back ici

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0771s ][ Queries: 12 (0.0371s) ][ GZIP on ]