Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 18 Oct 2017, 05:54
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
ZestyPup - Beta build
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 13 [189 Posts]   Goto page: 1, 2, 3, ..., 11, 12, 13 Next
Author Message
peebee


Joined: 21 Sep 2008
Posts: 2919
Location: Worcestershire, UK

PostPosted: Fri 06 Oct 2017, 06:33    Post subject:  ZestyPup - Beta build  

ZestyPup-17.10.12 is ready for download.... download 17.10.11 iso then apply delta....

Beta quality - but testing is still required! Thanks go to @zigbert for help with initial bug squashing.

Taking @666philb's configuration files for xenialpup as a starting point (with many thanks)
ZestyPup is a Woof-CE 32-bit pae build using Ubuntu Zesty Zapus (17.04) components. (n.b. Ubuntu support for Zesty Zapus expires in Jan 2018).

Kernel is 4.9.56 (LxPup build) and requires a separate fdrv to provide firmware.

The included lightweight web browser is light-48.0 in a separate adrv - the following more heavyweight browsers work:
chromium_61.0.3163.100+pepper_27.0.0.159_lx.sfs
firefox-56.0.1-lxsc.sfs

ZestyPup is a more "traditional" Puppy build than xenialpup in other ways....
Deadbeef, VLC, Qt5 and GTK3+ are no longer there...
instead
PMusic, gnome-mplayer are provided and other changes are PTheme and TAS.

PPM (Puppy Package Manager) is set to use the xenialpup repository (there is no ZestyPup repository)
as well as the Ubuntu Zesty repositories.

The devx and separate kernel sources are also available.

The Woof-CE configuration files will be uploaded after further testing has been completed.

I do not plan to do a 64-bit version currently.

I personally only ever do frugal installs so will be unable to help on full install issues - sorry!

If you do test and provide bug reports - please provide sufficient information to allow the bug to be duplicated - I only have a limited range of hardware to test on so cannot help with hardware specific bugs, but would recommend that you see if the problem exists on xenialpup and include that in your bug report please.

Thanks also to @scottman and @mavrothal for useful advices and to all the people who tested the Alpha versions.
Screenshot.png
 Description   
 Filesize   146.7 KB
 Viewed   1870 Time(s)

Screenshot.png


Last edited by peebee on Sun 15 Oct 2017, 12:05; edited 10 times in total
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 2919
Location: Worcestershire, UK

PostPosted: Fri 06 Oct 2017, 07:04    Post subject:  

Known bugs and issues:
_________________
LxPup = Puppy + LXDE

Last edited by peebee on Sun 15 Oct 2017, 06:18; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 2919
Location: Worcestershire, UK

PostPosted: Fri 06 Oct 2017, 07:04    Post subject:  

Reserved
_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
ally


Joined: 19 May 2012
Posts: 1522
Location: lincoln, uk

PostPosted: Fri 06 Oct 2017, 08:44    Post subject:  

mirrored here: http://archive.org/details/Puppy_Linux_Zestypup

Smile
Back to top
View user's profile Send private message Visit poster's website 
Sailor Enceladus

Joined: 22 Feb 2016
Posts: 1248

PostPosted: Fri 06 Oct 2017, 09:11    Post subject:  

It's running ok for me so far. The choice of apps seems good, and it looks pretty. Sound and wifi are working here. Performance seems smooth enough on my Pentium M laptop or similar to comparative newer distros, seems at least as stable as Xenialpup for me too. I included the fdrv but not the adrv, and downloaded your Firefox56 to browse (as I remember Light-48 having the youtube playing way too fast bug, but 46 was ok). The entry for Light was still in the menu though (but had no icon), the Firefox sfs had no icon in the menu as well. That's all I noticed so far. Nice to see the Ubuntu puppies moving forward into new challenges. Smile
Back to top
View user's profile Send private message 
Limbomusic


Joined: 15 Apr 2016
Posts: 188
Location: Norway

PostPosted: Fri 06 Oct 2017, 09:33    Post subject: very
Subject description: good
 

Running very well on a Dell Vostro1000 1.5gb ram (from 2005).
Using the chromium-sfs. Everything looks good and works.
Tested from usb and frugal install.
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 6489
Location: Valåmoen, Norway

PostPosted: Fri 06 Oct 2017, 09:34    Post subject:  

Thumbs up Smile

Zesty doesn't give correct resolution on my system (1920x1080). Xenial does it correct and it seems that Zesty is lacking a driver.

The following info is taken from PupSysInfo

Zesty
Code:
VGA compatible controller
• Advanced Micro Devices, Inc.
• VendorID=AMD/ATI BeaverCreek
• VendorID=Radeon HD 6550D
• VendorID=1002  DeviceID=9640
• Kernel Module=radeon



Xenial
Code:
VGA compatible controller
• Advanced Micro Devices, Inc.
• VendorID=AMD/ATI BeaverCreek
• VendorID=Radeon HD 6550D
• VendorID=1002  DeviceID=9640
• Kernel Driver=radeon
• Kernel Module=radeon

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
mavrothal


Joined: 24 Aug 2009
Posts: 2881

PostPosted: Fri 06 Oct 2017, 11:08    Post subject:  

On a fast (VM based) test, things look past alpha.
Light icon is missing from the menu. I guess because you install in /usr/local instead of /usr. Giving the full path for the U icon in mozilla-light.desktop, also fixes that.
Some of the JWM themes fail because have tags that the version of JWM used does not understand. Xenial has 2.3.5 and Zesty 2.3.2. The latest JWM is 2.3.7
You may also want to set defaults off in a number of sharing apps at startup. Is handy for the user but in a system that runs as root and no firewall, may become problematic.
So, nothing major. Looks good

_________________
== Here is how to solve your Linux problems fast ==
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 2919
Location: Worcestershire, UK

PostPosted: Fri 06 Oct 2017, 11:33    Post subject:  

mavrothal wrote:
On a fast (VM based) test, things look past alpha.
Light icon is missing from the menu. I guess because you install in /usr/local instead of /usr. Giving the full path for the U icon in mozilla-light.desktop, also fixes that.
Some of the JWM themes fail because have tags that the version of JWM used does not understand. Xenial has 2.3.5 and Zesty 2.3.2. The latest JWM is 2.3.7
You may also want to set defaults off in a number of sharing apps at startup. Is handy for the user but in a system that runs as root and no firewall, may become problematic.
So, nothing major. Looks good

Hi @mav....

JWM is a nightmare!!! I used 2.3.2 from Slacko because anything later seems to be incompatible with Ptheme.... this was @Zigbert's advice due to Ptheme giving errors with 2.3.5...I think you're now saying that some of the themes are not compatible with 2.3.2?? Which themes errored? Any clues as to what changes are needed?

As for 2.3.7 - then that's probably incompatible with everything!!!

Maybe I should just ditch JWM and move to LXDE as jlst is proposing I think - but then this wouldn't be a Pup - it would be an LxPup....

'Fraid I don't understand "You may also want to set defaults off in a number of sharing apps at startup. Is handy for the user but in a system that runs as root and no firewall, may become problematic. " - which sharing apps? what defaults?

Cheers
peebee

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
Marv


Joined: 04 May 2005
Posts: 900
Location: SW Wisconsin

PostPosted: Fri 06 Oct 2017, 13:34    Post subject:  

peebee wrote:
Maybe I should just ditch JWM and move to LXDE as jlst is proposing I think - but then this wouldn't be a Pup - it would be an LxPup....

Hi peebee,
Installed and runs well on my i5 based laptop. All the video and wireless drivers are there, touchpad etc. all completely useable on first boot. I used SNS for the wireless connect. No problems. I set up Slimjet 15.1.2.0 from SFS in my usual manner. No issues there. Disabled intel_pstate and set up the acpi_cpu driver and a governor or two. No problems there. Installed pcmanfm using the PPM and made it the default filemanager. That went well. I didn't get to setting up rightclicks or checking the suspends though because the jwm theme and panel setup and the myriad sort of functional wallpaper and theme setters sent me scuttling back to lxde. I tried. It seems solid and functional, but I guess I'm way too used to either lxde (my slight preference at this time for its more robust panel) or XFCE.

Thanks for the venture,

_________________
Pups currently in kennel Very Happy X-slacko 4.4 and X-tahr 2.0 for my users; LxPupSc,LxPupXenial & XFCE_XenialPup64 for me. All good pups indeed, and all running browsers, office etc. solely from SFS.
Back to top
View user's profile Send private message 
Robert123

Joined: 20 May 2016
Posts: 358
Location: Pacific

PostPosted: Fri 06 Oct 2017, 13:52    Post subject:  

Congrats Peebee on going ahead with this - look forward to playing with it.
_________________
Devuan Linux, Stardust 013 (4.31) updated https://archive.org/details/Stardustpup013glibc2.10
s57(2018)barebonehttps://sourceforge.net/projects/puppy-linux-minimal-builds/files/s57%282018%29barebones.iso/download
Back to top
View user's profile Send private message 
Robert123

Joined: 20 May 2016
Posts: 358
Location: Pacific

PostPosted: Fri 06 Oct 2017, 15:14    Post subject:  

Well had a play.
Machine: T42 Thinkpad with celeron m chip

Booted live using unetbootin using forcepae option.

Video, Booting to desktop, Connecting to the web and sound all working. Xcalc crashing xserver still a bug. Light Browser - first experience seems nice and light to use. Overall very nice Peebee for an Alpha build.


Thank you.

_________________
Devuan Linux, Stardust 013 (4.31) updated https://archive.org/details/Stardustpup013glibc2.10
s57(2018)barebonehttps://sourceforge.net/projects/puppy-linux-minimal-builds/files/s57%282018%29barebones.iso/download
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 6707
Location: Kentucky

PostPosted: Fri 06 Oct 2017, 16:24    Post subject:  

Quick manual frugal install and test. Booted to the correct screen resolution with working sound and internet.

Installed 4 or 5 packages with the PPM, all work.

Code:
# inxi -Fxx
System:    Host: puppypc1714 Kernel: 4.9.50-lxpup-32-pae i686 (32 bit gcc: 7.1.0)
           Desktop: JWM 2.3.2 dm: N/A Distro: ZestyPup 17.10.01
Machine:   Device: desktop Mobo: ASUSTeK model: M5A97 LE R2.0 v: Rev 1.xx serial: 150545593600028
           BIOS: American Megatrends v: 2601 date: 03/24/2015
CPU:       Hexa core AMD FX-6300 Six-Core (-MCP-) cache: 12288 KB
           flags: (lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 42140
           clock speeds: min/max: 1400/3500 MHz 1: 1400 MHz 2: 2000 MHz
           3: 1400 MHz 4: 2000 MHz 5: 1400 MHz 6: 2000 MHz
Graphics:  Card: NVIDIA GT218 [GeForce 210] bus-ID: 01:00.0 chip-ID: 10de:0a65
           Display Server: X.org 1.19.3 drivers: nouveau (unloaded: modesetting,fbdev,vesa)
           tty size: 80x24 Advanced Data: N/A for root
Audio:     Card-1 NVIDIA High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1 chip-ID: 10de:0be3
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2 chip-ID: 1002:4383
           Sound: Advanced Linux Sound Architecture v: k4.9.50-lxpup-32-pae
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000
           bus-ID: 02:00.0 chip-ID: 10ec:8168
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full
           mac: 1c:87:2c:5a:bb:e2
Drives:    HDD Total Size: 1120.2GB (5.6% used)
           ID-1: /dev/sda model: KINGSTON_SV300S3 size: 120.0GB serial: N/A
           ID-2: /dev/sdb model: WDC_WD10EZEX size: 1000.2GB serial: N/A
Partition: ID-1: swap-1 size: 8.60GB used: 0.00GB (0%) fs: swap dev: /dev/sdb5
RAID:      System: supported: linear raid0 raid1 raid10 raid6 raid5 raid4
           No RAID devices: /proc/mdstat, md_mod kernel module present
           Unused Devices: none
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 186 Uptime: 16 min Memory: 316.4/16111.7MB
           Init: SysVinit v: N/A runlevel: 5 Gcc sys: N/A
           Client: Shell (bash 4.3.291 running in lxterminal) inxi: 2.3.8



Code:
# free
             total       used       free     shared    buffers     cached
Mem:      16498392    1065396   15432996     337504     121432     656112
-/+ buffers/cache:     287852   16210540
Swap:      8396796          0    8396796


I'll try to squeeze in some more testing as time allows.Looks pretty solid so far.
Zesty.jpg
 Description   
 Filesize   52.14 KB
 Viewed   1442 Time(s)

Zesty.jpg

Back to top
View user's profile Send private message 
belham2

Joined: 15 Aug 2016
Posts: 1145

PostPosted: Fri 06 Oct 2017, 17:56    Post subject:  

Hi Peebee,

Good stuff. Overall nice job. Added Slimjet & Slimjet-Silent-Launch (ditched the adrv altogether), RedshiftGUI, Sakura and so far all seems ok and to be playing nice together. Right-click menu options could use some sprucing up, as they're pretty sparce. Only major thing I am coming across is a glitch/bug in JWMDesktop Control or just JWM itself....any changes you try to make for either jwm-tray (top or bottom), no matter what the changes are, crashes things and you get an error box (as shown in pic below) and jwm resets all of your "jwm" work back to the pristine backup.jwmrc. This stinks because it wipes everything you've previously set up. Other than that (and a few desktop and symlink things, which were easily fixed), everything seems to be running good. I've been squashing/unsquashing, threw some HD videos at gnome & it did ok, and tomorrow I will give some compiling a few things a go. Also, love the fat Zestypup background Laughing
Zestypup-alpha.png
 Description   
 Filesize   170.19 KB
 Viewed   1404 Time(s)

Zestypup-alpha.png

jwmDeskmanager-touchy-and-crashing-with-any-changes-made.png
 Description   
 Filesize   89.22 KB
 Viewed   1398 Time(s)

jwmDeskmanager-touchy-and-crashing-with-any-changes-made.png

Back to top
View user's profile Send private message 
wiak

Joined: 11 Dec 2007
Posts: 340
Location: not Bulgaria

PostPosted: Fri 06 Oct 2017, 19:32    Post subject:  

peebee wrote:

Maybe I should just ditch JWM and move to LXDE as jlst is proposing I think - but then this wouldn't be a Pup - it would be an LxPup....


Hi Peebee,

I really don't see that the desktop type used in any way defines what a Puppy is. Many systems nowadays provide quick desktop user-change util - doesn't change the overall system... It's the underlying system control scripts that really define a different distribution - a desktop manager is basically just an application. So no such thing as a JWMPup or an OpenboxPup - if built using Puppy system scripts, such as via woof-CE, then its a Puppy whatever window manager is used IMO.

Once upon a time Puppy iso strived to be as small as possible - prior even to xz compression being available around 50MB and certainly less than 100MB (and a little bit, pretty much irrelevant, less RAM). The very small JWM was useful back then to try and help achieve that. These days have gone at least to the extent that using JWM or openbox etc doesn't make much of an overall iso size difference issue. Certainly, different WMs have their own different config and menu util requirements.

wiak
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 13 [189 Posts]   Goto page: 1, 2, 3, ..., 11, 12, 13 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1021s ][ Queries: 14 (0.0067s) ][ GZIP on ]