Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 19 Nov 2017, 16:00
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
ArtfulPup
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 22 of 24 [360 Posts]   Goto page: Previous 1, 2, 3, ..., 20, 21, 22, 23, 24 Next
Author Message
peebee


Joined: 21 Sep 2008
Posts: 3004
Location: Worcestershire, UK

PostPosted: Wed 01 Nov 2017, 12:35    Post subject:  

How-to build ArtfulPup is now in post #3
_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
escucha


Joined: 14 Mar 2009
Posts: 59
Location: In the Euro Zone next the Mediterranean Sea

PostPosted: Thu 02 Nov 2017, 03:32    Post subject:  

I can not build an Artfulpup. No level. If I could I would in 64bit that checked in Tahr and Xenial I see better performance in graphics and video.
What a shame a actual, recent, project a day (October 2017) is reduced to only 32bit.
Sure no improvement plan for 64bit?

Artful frugal tested to complete satisfaction, except video jerking (64bit maybe?)

_________________
Definitely moving to linux 64bit. A great step for me.
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 2908

PostPosted: Thu 02 Nov 2017, 05:11    Post subject:  

17.11 looks fine in a brief test.
pmcputemp does not have an ~/.config/Autostart or ~/Startup entry in the pet used so will not autostart.

BTW I was wondering if the omission of cryptsetup in the Artfulpups (~300k with libs - would allow LUKS encryption of the savefile) is intentional or just never bothered with it.
Either way you may want to add a note or something for the unaware, to suggest installation before the first shutdown so the option will be offered

_________________
== Here is how to solve your Linux problems fast ==
Back to top
View user's profile Send private message 
artsown

Joined: 12 Sep 2012
Posts: 245

PostPosted: Thu 02 Nov 2017, 06:27    Post subject:  

No problems with 17.11 installing and using my usual stuff via PPM and
pets. I'll mention a oddity I noticed on previous versions as well. While
doing my initial work, and before creating a save folder, I left the computer
for well over 10 minutes ... and the screensaver didn't activate. It works ok
after save folder creation and reboot. I have no idea what significance this
might have ... probably none. But I thought I would pass on the info anyway.

Art
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 6508
Location: Valåmoen, Norway

PostPosted: Thu 02 Nov 2017, 08:43    Post subject:  

There is an issue with the 'kill' command in ArtfulPup. It will not accept the signal 'continue' - SIGCONT - signal number 18.
This is used as pause-function in pMusic and works as expected in Slacko.
Code:
# ffmpeg -i "/root/test.mp3" -f au - 2> /dev/null | aplay 2> /dev/null &
[2] 13098
# ps | grep aplay | grep -v 'grep'
13098 root       0:00 aplay
# kill -STOP 13098
# ps | grep aplay | grep -v 'grep'
13098 root       0:01 aplay
# kill -CONT 13098
# ps | grep aplay | grep -v 'grep'
[2]-  Exit 1                  ffmpeg -i "/root/test.mp3" -f au - 2> /dev/null | aplay 2> /dev/null
# ps | grep aplay | grep -v 'grep'
#

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
mavrothal


Joined: 24 Aug 2009
Posts: 2908

PostPosted: Thu 02 Nov 2017, 10:19    Post subject:  

zigbert wrote:
There is an issue with the 'kill' command in ArtfulPup. It will not accept the signal 'continue' - SIGCONT - signal number 18.
This is used as pause-function in pMusic and works as expected in Slacko.

it maybe an aplay rather than kill problem
If you do that with an open geany document or a browser page for example, appears to stop and resume fine. With aplay exits with an I/O error after the kill -CONT command. If you actually stop it for just a bit is OK.
Code:

# aplay test.au &
[1] 7614
# Playing Sparc Audio 'test.au' : Signed 16 bit Big Endian, Rate 44100 Hz, Stereo

# ps | grep aplay | grep -v grep
 7614 root       0:00 aplay test.au
# kill -STOP 7614 ; sleep 0.1; kill -CONT 7614

[1]+  Stopped                 aplay test.au
# ps | grep aplay | grep -v grep
 7614 root       0:01 aplay test.au # >>> keeps playing OK with 0.1sec pause
# kill -STOP 7614 ; sleep 0.5; kill -CONT 7614

[1]+  Stopped                 aplay test.au
# aplay: xrun:1624: read/write error, state = RUNNING

_________________
== Here is how to solve your Linux problems fast ==
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 6508
Location: Valåmoen, Norway

PostPosted: Thu 02 Nov 2017, 12:15    Post subject:  

Thank you mavrothal for your testing.

aplay 1.1.3 in Arftul
aplay 1.1.1 in Slacko

I grabbed the aplay from Slacko and put it into Artful. Everything works as before. Did NOT fix the pause issue.
Hmmm... ?

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
mavrothal


Joined: 24 Aug 2009
Posts: 2908

PostPosted: Thu 02 Nov 2017, 12:58    Post subject:  

alsa also depends on kernel. you may want to also change the kernel from slack.
btw ubuntu zesty proper uses 4.10.x kernels. and artfull 4.13
btw2, ffplay pauses and restarts fine in atrful.
btw3, tried aplay -STOP/-CONT in Lubuntu Zesty and Lubuntu Artful live CDs. Resumes properly in both.
it looks like something is missing from artful if not the kernel.

_________________
== Here is how to solve your Linux problems fast ==
Back to top
View user's profile Send private message 
wiak

Joined: 11 Dec 2007
Posts: 371
Location: not Bulgaria

PostPosted: Thu 02 Nov 2017, 16:34    Post subject:  

zigbert wrote:
There is an issue with the 'kill' command in ArtfulPup. It will not accept the signal 'continue' - SIGCONT - signal number 18.
This is used as pause-function in pMusic and works as expected in Slacko.
Code:
# ffmpeg -i "/root/test.mp3" -f au - 2> /dev/null | aplay 2> /dev/null &
[2] 13098
# ps | grep aplay | grep -v 'grep'
13098 root       0:00 aplay
# kill -STOP 13098
# ps | grep aplay | grep -v 'grep'
13098 root       0:01 aplay
# kill -CONT 13098
# ps | grep aplay | grep -v 'grep'
[2]-  Exit 1                  ffmpeg -i "/root/test.mp3" -f au - 2> /dev/null | aplay 2> /dev/null
# ps | grep aplay | grep -v 'grep'
#


Issues like that are often caused by some systems using more than one CPU or using separate threads. If you run ps you may find the process ID you are trying to STOP and CONT isn't the one your coding expected, especially if the play command involves a pipe of different commands such that the one you target for the kill signal has a different than expected process ID.

EDIT: oops, sorry, I should have read what you wrote more carefully - seems that is what you were checking. Oh well, ignore my comment (except if newer aplay or ffmpeg code, or more likely maybe the different kernel, is using separate threads - perhaps sending kill signal to the process isn't effecting the relevant thread - I don't know much about threads in Linux unfortunately so I'm just wondering... But I would use the likes of ps aux to get more indication of what is exactly being stopped or is running or whatever).

wiak
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1492
Location: Italy

PostPosted: Fri 03 Nov 2017, 05:31    Post subject:  

mavrothal wrote:

BTW I was wondering if the omission of cryptsetup in the Artfulpups (~300k with libs - would allow LUKS encryption of the savefile) is intentional or just never bothered with it.
Either way you may want to add a note or something for the unaware, to suggest installation before the first shutdown so the option will be offered


I was able to create both a lightencrypted and an heavyencrypted savefile at first shutdown after installing cryptsetup as suggested. The heavyencrypted savefile (crypta) works and can be mounted by filemnt: I copied the previously created savefolder in it. Is this the luks encryption you refer to? The last time I saw it was in xenialpup64 7.0.8.5 and the savefile had the "luks" suffix in its name. The lightencrypted savefile cannot be mounted: so, is lightencryption no longer supported as obsolete? And in this case why is a chance to create a lightencrypted savefile offered? Some advices are needed in my opinion about these news in puppy's encryption of the savefile.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3004
Location: Worcestershire, UK

PostPosted: Fri 03 Nov 2017, 08:28    Post subject:  

https://sourceforge.net/projects/zestypup/files/ArtfulPup1711/updates/

+1

cryptsetup was missing because it was not "inherited" from XenialPup....as far as I know, if LUKS is found then that is the only savefile encryption offered for new savfiles....but old crypta-heavy and cryptx-light savefiles can still be opened.

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
watchdog

Joined: 28 Sep 2012
Posts: 1492
Location: Italy

PostPosted: Fri 03 Nov 2017, 09:06    Post subject:  

peebee wrote:
but old crypta-heavy and cryptx-light savefiles can still be opened.


Yes, I confirm. I can't reproduce my malfunction: I created a lightencrypted savefile which filemnt could not mount but at successive trials it's now working.


LATER
Tested artfulpup 17.11+1: luks working but there is something buggish with my hardware. At first shutdown my machine failed rebooting freezing at saving the savefile (I did a hard poweroff after waiting and waiting but the artfulpupsave_luks-xxx.4fs was created and it works).
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3004
Location: Worcestershire, UK

PostPosted: Fri 03 Nov 2017, 12:34    Post subject:  

watchdog wrote:
LATER
Tested artfulpup 17.11+1: luks working but there is something buggish with my hardware. At first shutdown my machine failed rebooting freezing at saving the savefile (I did a hard poweroff after waiting and waiting but the artfulpupsave_luks-xxx.4fs was created and it works).

I get the same "hang" on both my desktop and laptop - I got out of it with ctrl-alt-del

Not sure how to debug - no error messages appear to give clues.....

Doesn't happen with LxPupSc.....

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
mavrothal


Joined: 24 Aug 2009
Posts: 2908

PostPosted: Fri 03 Nov 2017, 15:16    Post subject:  

Something must be very wrong with the update.
It froze on me in 3/4 boots before even I get to savefile.
It froze on LUKS save too and the file did not include all the data, so I got the first boot screen again.
On the next boot trying to connect with SNS ip_tables worked the CPU to the max and never got out of it.

What is in these 6MB besides cryptsetup and friends, because what ever it is, is not working.
aamof, I reverted to 17.11, added cryptsetup and dependencies, plus the pmcputemp desktop entry and everything is stable.

_________________
== Here is how to solve your Linux problems fast ==
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1492
Location: Italy

PostPosted: Fri 03 Nov 2017, 16:01    Post subject:  

I just deleted everything from the problematic artfulpupsave_luks-xxx.4fs and copied my install from savefolder into it. I was not aware that the original artfulpupsave_luks file had something wrong. I had no problems booting and browsing with the artfulpupsave_luks with the savefolder's content replaced. If something is wrong then it's at first shutdown.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 22 of 24 [360 Posts]   Goto page: Previous 1, 2, 3, ..., 20, 21, 22, 23, 24 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0607s ][ Queries: 14 (0.0075s) ][ GZIP on ]