Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 11 Dec 2017, 02:00
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
ArtfulPup
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 26 of 27 [400 Posts]   Goto page: Previous 1, 2, 3, ..., 24, 25, 26, 27 Next
Author Message
hamoudoudou


Joined: 24 Jul 2014
Posts: 218
Location: rabat

PostPosted: Fri 24 Nov 2017, 21:12    Post subject: i worry about that..icons ppm missing..  

icons ppm missing... in the menu too, not only for U-light, when you install new apps. That is true.. i worry about that.. but i will not loose time with that.
What is more my cup of tea is why apt-get find apps that PPM does not..
They are not many, but they are.. (from Xenial Packages)
Then when these really tiny bugs are solved where is the difference between a Dpup-stretch and Slacko and 'Ubuntu's Puppies.. in what they produce, not in how they produce.. The package source is the same
That is not very exciting.. gnee would be more exciting when somebody makes it work.. The process is known under Windows, however prohibited in multi users systems.
It repeats a sequence of mouse clicks and keyboards inputs (it should do it, it was created for it)
Lot of packages are to try from the PPM, even those for which the icon is missing.
needs="X11"\
section="Applications/Programming"\
title="GNU gnee"\
command="gnee"\
icon="/usr/share/pixmaps/xnee.xpm"
Programming ? Gnee is for you !

...
xnee.jpg
 Description   Why Icon not in the menu ?
 Filesize   46.56 KB
 Viewed   474 Time(s)

xnee.jpg

Back to top
View user's profile Send private message 
Marv


Joined: 04 May 2005
Posts: 918
Location: SW Wisconsin

PostPosted: Fri 24 Nov 2017, 23:09    Post subject:  

I'm running ArtfulPup as my daily on my i5 based laptop and have my must-haves working well in it. An integrated, albeit non-gvfs, pcmanfm as the default filemanager and a functional trash can accessable from pcmanfm, rox-filer, and desktop. A genuine don't ask don't tell permanent remove, and wrappers so rox-filer is used as the file manager when running the configuration utilities that depend on it ie. Puppy Theme Manager, PupControl, Desktop Settings. May not have gotten them all but for now seems ok. I'm going to upload my mods as a tgz, not a pet as they are meant as a mad-tinkers guide for the fellow-mad Confused

Oh yea, it's also running my samba server on a Bay Trail Desktop and it's rock solid there.

@belham2, Tis true that without gvfs, pcmanfm will not show the drives. I just bookmark my main drives and any removables show up on the desktop and mounting opens pcmanfm. Works for me. Screenie attached also..

Edit: Omitted a thanks to festus. I used the PcManFM from here: http://www.murga-linux.com/puppy/viewtopic.php?p=970683#970683
my_artfulpup.png
 Description   
 Filesize   162.44 KB
 Viewed   461 Time(s)

my_artfulpup.png

artfulpup_marvmods.tar.gz
Description 
gz

 Download 
Filename  artfulpup_marvmods.tar.gz 
Filesize  8.17 KB 
Downloaded  12 Time(s) 

_________________
Pups currently in kennel Very Happy LxPupSc, X-slacko 4.4 and X-tahr 2.0 for my users; LxPupSc, LxPupArtful, ArtfulPup & XFCE_XenialPup64 for me. All good pups indeed, and all running savefiles for look'n'feel only. Browsers, etc. solely from SFS.

Last edited by Marv on Sat 25 Nov 2017, 10:03; edited 2 times in total
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 2921

PostPosted: Sat 25 Nov 2017, 02:19    Post subject: Re: Lost icons and trouble to mount units  

peebee wrote:
01101001b wrote:
- Why does Puppy Package Manager show no icons now in results hits when searching?

You're right - package type icons are missing in PPM in ArtfulPup compared to XenialPup.....

No idea why - probably some sort of iconset issue?? Perhaps @mavrothal can suggest the reason?


I actually prefer it without icons (which are too small and often cryptic or misleading) and is the case in slacko and Lxpup for quite some time now, so I wouldn't bother...
However, I believe that the issue is because of the missing icons in /usr/share/icons/hicolor.
I think this is related to pTheme so maybe Ziggy could take a look.

_________________
== Here is how to solve your Linux problems fast ==
Back to top
View user's profile Send private message 
Sailor Enceladus

Joined: 22 Feb 2016
Posts: 1323

PostPosted: Sat 25 Nov 2017, 08:40    Post subject: Re: Lost icons and trouble to mount units  

mavrothal wrote:
peebee wrote:
01101001b wrote:
- Why does Puppy Package Manager show no icons now in results hits when searching?

You're right - package type icons are missing in PPM in ArtfulPup compared to XenialPup.....

No idea why - probably some sort of iconset issue?? Perhaps @mavrothal can suggest the reason?


I actually prefer it without icons (which are too small and often cryptic or misleading) and is the case in slacko and Lxpup for quite some time now, so I wouldn't bother...
However, I believe that the issue is because of the missing icons in /usr/share/icons/hicolor.
I think this is related to pTheme so maybe Ziggy could take a look.

I thought they were removed in modern puppies because mini-icons directory was deleted so they would show up as broken now. It is interesting that 666philb brought the feature back in xenialpup somehow (using seemingly a few generic ones?). Smile
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 1362
Location: GERMANY

PostPosted: Sat 25 Nov 2017, 13:46    Post subject:  

Hey you guys !

Can not boot ArtfulPup from a Usb-Stick when copy the extracted Content from the Iso into a Subfolder .
In my case created a Folder named artfulpup on an Usb-stick .

menu.lst looks :
title Puppy artfulpup (sdb1)
root (hd0,0)
kernel /artfulpup/vmlinuz pupsubdir=artfulpup pmedia=usbflash pfix=fsck,nocopy
initrd /artfulpup/initrd.gz

When copying the extracted Content from the Iso to / root ......it does boot .
Same Problem with newest Xenialpup .
What am i doing wrong?
Any Idea?
Back to top
View user's profile Send private message 
Sailor Enceladus

Joined: 22 Feb 2016
Posts: 1323

PostPosted: Sat 25 Nov 2017, 13:51    Post subject:  

Hi backi,

I think your USB would be root (hd1,0) if have an sda too, or maybe root (hd2,0) if you have HDD and CD drive?

Not sure what you mean by copying to / root though. I think your current menu.lst will look in /artfulpup folder in sda1.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3033
Location: Worcestershire, UK

PostPosted: Sat 25 Nov 2017, 15:30    Post subject:  

backi wrote:
kernel /artfulpup/vmlinuz pupsubdir=artfulpup pmedia=usbflash
What am i doing wrong?

Should be psubdir

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
backi

Joined: 27 Feb 2011
Posts: 1362
Location: GERMANY

PostPosted: Sat 25 Nov 2017, 15:43    Post subject:  

Hi Sailor !

Quote:
Not sure what you mean by copying to / root though.

It means instead copying extracted Contents of the Iso into (Sub) Folder named artfulpup on my Usb-Stick .......placing the content just on the ext4 partition (root?) of sdb1(my Usb-Stick) outside a Folder.......and my menu.lst looks like this:

title Puppy artfulpup (sdb1)
root (hd0,0)
kernel /vmlinuz pupsubdir= pmedia=usbflash pfix=fsck,nocopy
initrd /initrd.gz

it does boot .
But not from a Folder.
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 1362
Location: GERMANY

PostPosted: Sat 25 Nov 2017, 15:55    Post subject:  

Hi PeeBee !

psubdir also does not help .

Could maybe someone ,who is booting successfully artfulpup from Folder on Usb-Stick , give me his menu.lst Entry as a working Example ?
Back to top
View user's profile Send private message 
sheldonisaac

Joined: 21 Jun 2009
Posts: 702
Location: Philadelphia, PA

PostPosted: Sat 25 Nov 2017, 16:09    Post subject: booting Artful  

backi wrote:
psubdir also does not help .

Could maybe someone ,who is booting successfully artfulpup from Folder on Usb-Stick , give me his menu.lst Entry as a working Example ?

I'll try, and will edit this post.
Is this the one?
https://sourceforge.net/projects/zestypup/files/ArtfulPup1711/artfulpup-17.11.iso/download
--------------
Using this Dell E6410 under musher0's Xenial 7.07, I used gparted to reformat an Emtec 16GB USB flash drive to ext4 and set the boot flag.
Then copied files from the Artful iso to the flash drive.
Used grub4config on the flash drive.
Rebooted from the flash drive.
It booted Artful.
Here is the directory:
Code:
 ls -la /mnt/sdc1/
total 254700
drwxr-xr-x  3 root root      4096 Nov 26  2017 .
drwxr-xr-x 13 root root        80 Nov 25 15:42 ..
-rw-r--r--  1 root root  21594112 Nov  1 19:38 adrv_artfulpup_17.11.sfs
-rw-r--r--  1 root root  18067456 Nov  1 19:38 fdrv_artfulpup_17.11.sfs
-rw-r--r--  1 root root    220049 Nov 26  2017 grldr
-rw-r--r--  1 root root   2281149 Nov  1 19:34 initrd.gz
drwx------  2 root root     16384 Nov 26  2017 lost+found
-rw-r--r--  1 root root      2652 Nov 26  2017 menu.lst
-rw-r--r--  1 root root 189218816 Nov  1 19:45 puppy_artfulpup_17.11.sfs
-rw-r--r--  1 root root     32256 Nov 26  2017 sdc_mbr.bak
-rw-r--r--  1 root root   5489216 Oct 31 22:13 vmlinuz
-rw-r--r--  1 root root     32768 Nov  1 19:38 ydrv_artfulpup_17.11.sfs
-rw-r--r--  1 root root  23842816 Nov  1 00:06 zdrv_artfulpup_17.11.sfs

Here is menu.lst, only the relevant parts:
Code:
# menu.lst produced by grub4dosconfig-v1.9.2
timeout 10
default 0
# Frugal installed Puppy
title Puppy artfulpup 17.11 (sdc1)
  find --set-root --ignore-floppies --ignore-cd /puppy_artfulpup_17.11.sfs
  kernel /vmlinuz    pmedia=usbflash pfix=fsck
  initrd /initrd.gz

_________________
Dell E6410: Xenial, etc
Dell Mini 9, Acer Aspire One, EeePC 1018P, PowerBook G4
Intel D865GBF, Intel DQ35JOE

Last edited by sheldonisaac on Sat 25 Nov 2017, 16:53; edited 1 time in total
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 1362
Location: GERMANY

PostPosted: Sat 25 Nov 2017, 16:17    Post subject:  

Yes sheldonisaac !
Thanks !
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 9642
Location: Charleston S.C. USA

PostPosted: Sat 25 Nov 2017, 16:41    Post subject:  

What boot loader you using?
_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 1362
Location: GERMANY

PostPosted: Sat 25 Nov 2017, 16:48    Post subject:  

Hi sheldonisaac !

No luck with your Tip .
When using Grub4dos ----artfulpup is even not recognized from Grub4Dos when inside a folder .
means not shown when put into a Folder .

I cant exactly remember ,there was awhile ago some Discussion because someone could not boot Xenialpup (as far as i remember) when putting it in a Folder but boots when placed on root.
When using Tahrpup 6.0.6 ( which i have installed also to this Usb-Stick) it won`t boot from a Folder....just from / ----- ....while Tahrpup 6.0.5 does boot when copied inside a Folder.
Back to top
View user's profile Send private message 
sheldonisaac

Joined: 21 Jun 2009
Posts: 702
Location: Philadelphia, PA

PostPosted: Sat 25 Nov 2017, 17:56    Post subject: booting  

backi (in part) wrote:
Hi sheldonisaac !
No luck with your Tip .
When using Grub4dos ----artfulpup is even not recognized from Grub4Dos when inside a folder.
OH, I will put the artful files into a folder, and then try booting.
-----------------
It boots.
Code:
# menu.lst produced by grub4dosconfig-v1.9.2
timeout 4
default 0
# Frugal installed Puppy
title Puppy artfulpup 17.11 (sdc1/artful)
  find --set-root --ignore-floppies --ignore-cd /artful/initrd.gz
  kernel /artful/vmlinuz psubdir=artful pmedia=usbflash pfix=fsck
  initrd /artful/initrd.gz

This time I did make a save folder when rebooting:
Code:
ls -lt /mnt/home/
total 244
-rw-rw-rw- 1 root root     37 Nov 25 17:07 fsckme.flg
drwxr-xr-x 3 root root   4096 Nov 25 17:05 artful
-rw-r--r-- 1 root root    292 Nov 25 17:04 menu.lst
-rw-r--r-- 1 root root 220049 Nov 25 16:58 grldr
drwx------ 2 root root  16384 Nov 25 15:22 lost+found
Code:
ls -lt /mnt/home/artful/
total 254684
drwxr-xr-x 8 root root      4096 Nov 25 17:06 artfulpupsave-nov25
-rw-r--r-- 1 root root     32256 Nov 25 15:29 sdc_mbr.bak
-rw-r--r-- 1 root root    220049 Nov 25 15:29 grldr
-rw-r--r-- 1 root root      2652 Nov 25 15:29 menu.lst
-rw-r--r-- 1 root root 189218816 Nov  1 07:45 puppy_artfulpup_17.11.sfs
-rw-r--r-- 1 root root  21594112 Nov  1 07:38 adrv_artfulpup_17.11.sfs
-rw-r--r-- 1 root root  18067456 Nov  1 07:38 fdrv_artfulpup_17.11.sfs
-rw-r--r-- 1 root root     32768 Nov  1 07:38 ydrv_artfulpup_17.11.sfs
-rw-r--r-- 1 root root   2281149 Nov  1 07:34 initrd.gz
-rw-r--r-- 1 root root  23842816 Oct 31 12:06 zdrv_artfulpup_17.11.sfs
-rw-r--r-- 1 root root   5489216 Oct 31 10:13 vmlinuz

_________________
Dell E6410: Xenial, etc
Dell Mini 9, Acer Aspire One, EeePC 1018P, PowerBook G4
Intel D865GBF, Intel DQ35JOE
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 732
Location: Pennsylvania U.S.

PostPosted: Sun 26 Nov 2017, 00:25    Post subject: Artful Pup 17.11+3  

First off, Artful is a really nice 32-bit program!!!

I ran it through my usual bunch of tests and it performs really well and graphics are exceptional with videos, on-line movies etc.

I did encounter one problem... I updated the PPM and all program entries went totally BLANK. There was then no function on the update-icon so couldn't try another up-date. PPM is now without ANY entries in it.

The uninstall works (as far as listing my added programs but I didn't try to delete any of them.)

I might add that prior to doing the update the 'category' entries did not function to individual areas when clicked on, the only thing that moved (up an down) was the slider-bar

Running with: Live CD, savefile on HDD

>>>---Indian------>

EDIT: 11/26/2017 - Tried loading without the savefile (pfix=ram)... PPM works as it should so the problem appears to be related to my savefile and NOT Artful Pup 17.11+3 version... is there a way to get it back? or do I have to start over?

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192

Last edited by sszindian on Sun 26 Nov 2017, 10:54; edited 1 time in total
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 26 of 27 [400 Posts]   Goto page: Previous 1, 2, 3, ..., 24, 25, 26, 27 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0812s ][ Queries: 14 (0.0200s) ][ GZIP on ]