Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 19 Jul 2018, 04:10
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
ArtfulPup (& Upup-Bionic-Beaver-RC)
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 28 of 49 [730 Posts]   Goto page: Previous 1, 2, 3, ..., 26, 27, 28, 29, 30, ..., 47, 48, 49 Next
Author Message
futwerk

Joined: 07 May 2011
Posts: 362

PostPosted: Fri 22 Dec 2017, 00:32    Post subject:  

new wallpaper.
artful22.jpg
 Description   http://www.mediafire.com/?x4v77bi1p58ox
 Filesize   48.75 KB
 Viewed   1092 Time(s)

artful22.jpg

artful21.jpg
 Description   http://www.mediafire.com/?x4v77bi1p58ox
 Filesize   48.92 KB
 Viewed   1091 Time(s)

artful21.jpg

Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 1508
Location: GERMANY

PostPosted: Fri 22 Dec 2017, 07:14    Post subject: Ubuntu 17.10 Temporarily Pulled Due To A BIOS Corrupting  

Ubuntu 17.10 Temporarily Pulled Due To A BIOS Corrupting Problem .

https://www.phoronix.com/scan.php?page=news_item&px=Ubuntu-17.10-BIOS-Corrupter
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 12407
Location: Gatineau (Qc), Canada

PostPosted: Fri 22 Dec 2017, 07:27    Post subject: Re: Ubuntu 17.10 Temporarily Pulled Due To A BIOS Corrupting  

backi wrote:
Ubuntu 17.10 Temporarily Pulled Due To A BIOS Corrupting Problem .

https://www.phoronix.com/scan.php?page=news_item&px=Ubuntu-17.10-BIOS-Corrupter

Thanks backi.

For everyone's information, mistfire is providing other references to other articles
about it at
http://murga-linux.com/puppy/viewtopic.php?p=978053&sort=lastpost#978053

Would anyone know if this snafu is affecting peebee's ArtfulPup?

BFN.

_________________
musher0
~~~~~~~~~~
Siempre será canción nueva... (V. Jara, Manifiesto)
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 2971

PostPosted: Fri 22 Dec 2017, 09:23    Post subject:  

If someone looks at the actual bug report, is clear that the Ubuntu-17.10-bricks-some-Lenovo-laptops bug, does not affecet Artfulpup.
The problematic driver (intel_spi) does not even exist in the 4.9.x kernel artfulpup is using.

_________________
== Here is how to solve your Linux problems fast ==
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 12407
Location: Gatineau (Qc), Canada

PostPosted: Fri 22 Dec 2017, 09:41    Post subject:  

mavrothal wrote:
If someone looks at the actual bug report, is clear that the Ubuntu-17.10-bricks-some-Lenovo-laptops bug, does not affecet Artfulpup.
The problematic driver (intel_spi) does not even exist in the 4.9.x kernel artfulpup is using.
Ah. Many thanks, mavrothal, for reassuring us.
_________________
musher0
~~~~~~~~~~
Siempre será canción nueva... (V. Jara, Manifiesto)
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3171
Location: holland

PostPosted: Fri 22 Dec 2017, 14:24    Post subject:  

Question Re: Ubuntu-17.10-bricks-some-Lenovo-laptops: (sorry for being off-topic)
I'm experimenting with Bionic (Dog) development version, it has kernel 4.13 (some kernel package version of 4.13 should be affected by this terrible bug, don't know which one, they only say it's fixed in 4.13.0-21.24)

When I check if some "intel-spi-*" driver is loaded on my Bionic, there's none
EDIT: Forgot to mention that some intel-spi-* .ko driver modules do exist in /lib/modules... (but apparently not loaded?).

Code:
root@live:~# lsmod | grep spi
mptspi                 24576  0
scsi_transport_spi     32768  1 mptspi
mptscsih               40960  2 mptsas,mptspi
mptbase               102400  3 mptscsih,mptsas,mptspi
root@live:~# lsmod | grep intel
snd_hda_intel          40960  1
snd_hda_codec         126976  4 snd_hda_intel,snd_hda_codec_analog,snd_hda_codec_hdmi,snd_hda_codec_generic
snd_hda_core           81920  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_analog,snd_hda_codec_hdmi,snd_hda_codec_generic
snd_pcm                98304  4 snd_hda_intel,snd_hda_codec,snd_hda_core,snd_hda_codec_hdmi
snd                    81920  13 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_hda_codec_analog,snd_timer,snd_rawmidi,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_seq_device,snd_pcm


(on HP Compaq 6710b laptop, no BIOS corruption has happened)

My guess is that there is no such danger of BIOS corruption if no intel-spi-* module is loaded, but I could be wrong, any thoughts ?

Thanks,

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
hamoudoudou


Joined: 24 Jul 2014
Posts: 1317
Location: rabat

PostPosted: Sun 24 Dec 2017, 14:42    Post subject: PuppyOCR does the job Intalled in Artfulpup
Subject description: Files Fr added in Hunspell for OCR old texts and spell check with Abiword
 

This driver is not needed by Artfulpup users, is it ?
"The problematic driver (intel_spi) does not even exist in the 4.9.x kernel artfulpup is using."
Pupsaveconfig added,
Intensive daily usage of Artfulpup to write the Story of 'Afrique', a ship like Titanic, Departure to Africa from Bordeaux 1920 With 580 passengers on board.. Quite an Indiana Jones story.
OCR.jpg
 Description   Files Fr added in Hunspell for OCR old texts and spell check with Abiword
 Filesize   98.87 KB
 Viewed   241 Time(s)

OCR.jpg


Last edited by hamoudoudou on Sun 31 Dec 2017, 05:10; edited 3 times in total
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3171
Location: holland

PostPosted: Sun 24 Dec 2017, 14:59    Post subject: Re: This driver is not needed by Artfulpup users, is it ?  

hamoudoudou wrote:
This driver is not needed by Artfulpup users, is it ?
"The problematic driver (intel_spi) does not even exist in the 4.9.x kernel artfulpup is using."


Again, sorry for being off-topic in my previous post , and NOTE: there's NO danger for ArtfulPup at all ! (as said, the intel_spi driver does not exist in Artfulpup indeed AND IS NOT NEEDED)
(just thought someone with more knowledge than me could answer question about the 4.13 kernel bug subject, which is btw already answered by pemasu in Xenialdog thread)

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3392
Location: Worcestershire, UK

PostPosted: Tue 26 Dec 2017, 05:11    Post subject:  

@mavrothal has reported:
Quote:
aplay, used in pmusic, crashes if you pause playback so you can not resume
in the dpup-stretch thread.

For me, playback does resume if the Play/Pause button is clicked twice....

@radky has determined that:
Quote:
the problem in Dpup was immediately fixed after I copied usr/lib/libasound.so.2.0.0 from xenialpup-7.5.

Please test if the issue is fixed in ArtfulPup by installing:

zz_libasound2_xenial-1.1.0.pet

Thanks

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
mavrothal


Joined: 24 Aug 2009
Posts: 2971

PostPosted: Tue 26 Dec 2017, 06:37    Post subject:  

peebee wrote:

Please test if the issue is fixed in ArtfulPup by installing:

zz_libasound2_xenial-1.1.0.pet


It solves the crash-after-pause issue but regenerates the flac-gives-white-noise issue...

You may consider a (n spi_intel fixed) 4.13.0 kernel (a thought you had one from LxPupSc) to see if this works with native artful ubuntu packages.

Latter: ffmpeg 2.8.13 with the libasound xenial (1.1.0? ) appear to work in both pause and flac. Though the downgrading to "xenial sound" may give other problems elsewhere.

_________________
== Here is how to solve your Linux problems fast ==
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3392
Location: Worcestershire, UK

PostPosted: Tue 26 Dec 2017, 14:00    Post subject:  

mavrothal wrote:
It solves the crash-after-pause issue but regenerates the flac-gives-white-noise issue...

You may consider a (n spi_intel fixed) 4.13.0 kernel (a thought you had one from LxPupSc) to see if this works with native artful ubuntu packages.

Latter: ffmpeg 2.8.13 with the libasound xenial (1.1.0? ) appear to work in both pause and flac. Though the downgrading to "xenial sound" may give other problems elsewhere.

ArtfulPup-17.11+8....with zz_ .pet installed - no problem playing the test .flac file - no white noise....

Tried kernel 4.14.9-lxpup64 - same behaviour.

Error message from pmusic with libasound2-1.1.3-5 is:
aplay: xrun:1624: read/write error, state = RUNNING

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
sszindian


Joined: 24 Apr 2010
Posts: 761
Location: Pennsylvania U.S.

PostPosted: Tue 26 Dec 2017, 19:33    Post subject: mtpaint  

The current version of mtpaint 3.49.13-4 (I believe it's 13-4) at any rate, the version now in your current +8... It won't load .gif graphics, other graphic extensions seem OK.

>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3392
Location: Worcestershire, UK

PostPosted: Wed 27 Dec 2017, 06:00    Post subject: Re: mtpaint  

sszindian wrote:
The current version of mtpaint 3.49.13-4 (I believe it's 13-4) at any rate, the version now in your current +8... It won't load .gif graphics, other graphic extensions seem OK.

>>>---Indian------>

Many thanks

Also applies to mtpaint in XenialPup-7.5

mtpaint from Xenial requires libgif.so.4 and this is provided as a link to libgif.so.7 in both XenialPup and ArtfulPup, but this is not sufficient.

Can be fixed by installing mtpaint from slacko:
http://distro.ibiblio.org/puppylinux/pet_packages-slacko14.2/mtpaint-3.49.12-i686_s700.pet
which has been built against libgif.so.7

or by copying libgif.so.4.1.6 from TahrPup and remaking the link to libgif.so.4

Will be fixed in next update.

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3392
Location: Worcestershire, UK

PostPosted: Wed 27 Dec 2017, 07:54    Post subject:  

Update +9 - libasound2 from xenial to fix pMusic pause/play; libgif4 from tahr to fix mtpaint; + Ubuntu updates
_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
don570


Joined: 10 Mar 2010
Posts: 5085
Location: Ontario

PostPosted: Wed 27 Dec 2017, 12:45    Post subject:  

Quote:
The current version of mtpaint 3.49.13-4 (I believe it's 13-4) at any rate, the version now in your current +8... It won't load .gif graphics, other graphic extensions seem OK.


When mtpaint will save a GIF format , but won't open GIF files then
it has been compiled on a distro that had a different version of libgif

Here is my experience with compiling mtpaint in fatdog linux to obtain
a version that would run in stretch.

http://murga-linux.com/puppy/viewtopic.php?p=971483#971483
_________________________________________________
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 28 of 49 [730 Posts]   Goto page: Previous 1, 2, 3, ..., 26, 27, 28, 29, 30, ..., 47, 48, 49 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1449s ][ Queries: 14 (0.0112s) ][ GZIP on ]