Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 11 Dec 2018, 15:59
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
ArtfulPup (& Upup-Bionic-Beaver-RC)
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 31 of 49 [730 Posts]   Goto page: Previous 1, 2, 3, ..., 29, 30, 31, 32, 33, ..., 47, 48, 49 Next
Author Message
Marv


Joined: 04 May 2005
Posts: 1099
Location: SW Wisconsin

PostPosted: Mon 22 Jan 2018, 12:49    Post subject:  

I run a modified artfulpup with pcmanfm and its trashcan integrated into the structure so I booted both a pristine +12 and a +12 updated from my +11 to check the savefile finding and the closing of mounted drives from the desktop icon button. Both are ok for me both on the pristine boot and on the update. I do run the 4.14.14 kernel from LxPupSc as it has the kpti patches in FWIW. My Grub4Dos entry for the Frugal install to a 2nd gen i5 laptop (Fujitsu S761) is below and my savefile name is artfulpupsave-fresh.2fs in this case. It is an unencrypted EXT2, usually 256Mb:
Code:
title ArtfulPup 17.11.10 with 4.14.14 kernel
  uuid 2598-C220
  kernel /ArtfulPup/vmlinuz pmedia=ataflash intel_pstate=disable pdev1=sda1 psubdir=ArtfulPup pfix=copy,fsck ipv6.disable=1
  initrd /ArtfulPup/initrd.gz
The deltas are a bit more work but I like them as they force/allow me to scrub my savefile before updating. It greatly prolongs its life I find and also gives me a fallback in case of troubles with the update.
Edit: Yes the menuentry title lags the actual pup. I try to keep the description current but it happens.

_________________
Pups currently in kennel Very Happy LxPupSc and X-slacko-4.4 for my users; LxPupSc, LxPupSc64, LxPupBionic, upupbb and upupcc for me. All good pups indeed, and all running savefiles for look'n'feel only. Browsers, etc. solely from SFS.

Last edited by Marv on Mon 22 Jan 2018, 14:44; edited 2 times in total
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 773
Location: Pennsylvania U.S.

PostPosted: Mon 22 Jan 2018, 14:28    Post subject: Unmount Drive = Desktop  

peebee wrote:
Weird - unmount via green 'mark' on drive on desktop works just fine for me - is this a pristine install or with a savefolder?
--------------------------------------------------------------------

I use a savefolder (in fact on every pup now)

>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
B.K. Johnson

Joined: 12 Oct 2009
Posts: 686

PostPosted: Sun 28 Jan 2018, 12:58    Post subject:
Subject description: catch-22 with ndiswrapper
 

peebee wrote here
Quote:
ndiswrapper_1.61-k4.9.59-lxpup-pae.pet
should be available from PPM after a database update

peebee, I am caught in a catch-22 situation: I can't download the pet from PPM without a connection for which I need ndiswrapper.

Would you please provide a link to it or post the pet in this thread.
TIA
[UPDATE]
Found a way to get the pet via smokey:http://archive.org/download/Puppy_Linux_Artfulpup/

_________________
B.K. Johnson
tahrpup-6.0.5 PAE (upgraded from 6.0 =>6.0.2=>6.0.3=>6.0.5 via quickpet/PPM=Not installed); slacko-5.7 occasionally. Frugal install, pupsave file, multi OS flashdrive, FAT32 , SYSLINUX boot, CPU-Dual E2140, 4GB RAM

Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3566
Location: Worcestershire, UK

PostPosted: Sun 28 Jan 2018, 14:47    Post subject:
Subject description: catch-22 with ndiswrapper
 

B.K. Johnson wrote:
Would you please provide a link to it


http://ftp.nluug.nl/ftp/pub/os/Linux/distr/puppylinux/pet_packages-artful/ndiswrapper_1.61-k4.9.59-lxpup-pae.pet

also in post #2

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
B.K. Johnson

Joined: 12 Oct 2009
Posts: 686

PostPosted: Mon 29 Jan 2018, 12:59    Post subject:  

@peebee
I can't get a working connection with ndiswrapper.
lsusb recognizes the Netgear WNA3100
Code:
Bus 001 Device 005: ID 0846:9020 NetGear, Inc. WNA3100(v1) Wireless-N 300 [Broadcom BCM43231]

Using Network Wizard, I get screeny-1
Using SNS, I get screeny-2
I am using the same XP driver I use successfully with tahrpup-6.0.2, 6.0.5 & 6.0.6
After getting these results in artfulpup, I boot up tahrpup-6.0.6 ... connected for this post.

Any advice/suggestions?
TIA
screeny-2.png
 Description   output error from SNS
 Filesize   9.36 KB
 Viewed   979 Time(s)

screeny-2.png

screeny-1.png
 Description   output from Network Wizard is blank
 Filesize   2.71 KB
 Viewed   970 Time(s)

screeny-1.png


_________________
B.K. Johnson
tahrpup-6.0.5 PAE (upgraded from 6.0 =>6.0.2=>6.0.3=>6.0.5 via quickpet/PPM=Not installed); slacko-5.7 occasionally. Frugal install, pupsave file, multi OS flashdrive, FAT32 , SYSLINUX boot, CPU-Dual E2140, 4GB RAM

Back to top
View user's profile Send private message 
hamoudoudou

Joined: 24 Jul 2014
Posts: 1467
Location: rabat

PostPosted: Mon 29 Jan 2018, 15:12    Post subject: Wireless antenna  

Wireless antennas :
Not all operators show good results.. Perhaps driver has to be added for some operators.. Then it depends on the computer model too..
my dongle is n300 as yours
Bus 002 Device 003: ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter
Mine is ok 66/100 but some are 12/100
At home i don't use dongle, winter time, only during summer season to compute in my garden.
capture10542.png
 Description   without adding any driver to artfulpup
 Filesize   44.61 KB
 Viewed   941 Time(s)

capture10542.png

Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3566
Location: Worcestershire, UK

PostPosted: Wed 31 Jan 2018, 06:05    Post subject:  

B.K. Johnson wrote:
I can't get a working connection with ndiswrapper. Any advice/suggestions?

All I can say is that the ndiswrapper .pet appears to install correctly....
Code:
# depmod -a
# modprobe ndiswrapper
# lsmod
Module                  Size  Used by
ndiswrapper           170696  0

Why it then does not like your XP driver I'm afraid I have no idea Sad
Are there any clues in dmesg??

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 3566
Location: Worcestershire, UK

PostPosted: Wed 31 Jan 2018, 06:07    Post subject:  

Update +13 - updates from upstream Ubuntu
_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
B.K. Johnson

Joined: 12 Oct 2009
Posts: 686

PostPosted: Fri 02 Feb 2018, 14:46    Post subject:  

I posted an update to inform that I had found an ndiswrapper-4.6.59* at smokey's.
It was that version that I reported on.

As suggested:
Code:
root# dmesg | grep ndiswrapper
#root
 

Nothing returned

Results of other tests are:

- lsmod does not list ndiswrapper
- PupSysInfo does not show ndiswrapper for drivers
- PupSysInfo (USB Devices) shows this for WNA3100

VendorID=0846 ProductID=9020 Rev=00.01
Manufacturer=Broadcom
Product=BCMUSB 802.11 Wireless Adapter
SerialNumber=7960
which agrees with results of lsusb reported earlier
Code:
 
    modprobe ndiswrapper

    modprobe: FATAL: Module ndiswrapper not found in directory /lib/modules/4.9.59-lxpup-32-pae


In a good puppy with ndiswrapper, I expect to see ndiswrapper.ko in the directory, /lib/modules/4.9./misc/. Neither the misc sub-directory nor ndiswrapper.ko exists.
Code:

    # modinfo ndiswrapper

    modinfo: ERROR: Module ndiswrapper not found.


pFind's only success when searching for ndiswrapper in system files was /usr/sbin/ndiswrapperGUI.sh


These suggest that ndiswrapper is NOT installed.

So I installed a new artful1711+12 - situation unchanged.

Despite confirmation that ndiswrapper has not been installed in artfulpup, I chose to attempt installing the ndiswrapper pet in post #2. Error - could not be installed (see screeny).

artful1711+13 installed - ndiswrapper is NOT installed.
Attempt to install ndiswrapper pet in post #2 FAILED. (see screeny).

*The reason for the different results when trying to install the ndiswrapper pet is that the first pet from smokey is really, ndiswrapper_1.61-k4.9.56-lxpup-pae.pet and those at post #2 and the post here is ndiswrapper_1.61-k4.9.59-lxpup-pae.pet. Mea culpa!

@hamoudoudou
Please try these terminal commands and report. TIA

modprobe ndiswrapper
modinfo ndiswrapper
ndiswrapper pet fails to install.png
 Description   Fatal error when attempting ndiswrapper pet
 Filesize   11.17 KB
 Viewed   702 Time(s)

ndiswrapper pet fails to install.png


_________________
B.K. Johnson
tahrpup-6.0.5 PAE (upgraded from 6.0 =>6.0.2=>6.0.3=>6.0.5 via quickpet/PPM=Not installed); slacko-5.7 occasionally. Frugal install, pupsave file, multi OS flashdrive, FAT32 , SYSLINUX boot, CPU-Dual E2140, 4GB RAM

Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3566
Location: Worcestershire, UK

PostPosted: Fri 02 Feb 2018, 15:49    Post subject:  

B.K. Johnson wrote:
Attempt to install ndiswrapper pet in post #2 FAILED. (see screeny).

Ooops - sorry - problem with downloading things from nluug with a web browser which has been seen before. (download with wget is OK)

I've changed the link in post #2 to ibiblio - should now download an uncorrupted .pet which will install correctly.

PPM should have downloaded correctly.....???

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
hamoudoudou

Joined: 24 Jul 2014
Posts: 1467
Location: rabat

PostPosted: Mon 05 Feb 2018, 17:28    Post subject: Pictures from smartphone  

camphone tab
Pictures from smartphone
Transfer to computer from your phone will work if you install pet libcrypto in artfulpup
Try different plug if not workinfg first try.
Ndiswrapper : See Peebee answer above..
About wireless with dongle i transfer my screenshot to Facebook Puppy Linux communauty, showing a lot more interest for that subject.
however i cannot agree on 'Xenialpup was made to dislike usb wifi adapters" Xenialpup is not made to dislike them.. Old puppy makers stay home, chained to wall, and even don't test wireless as they never use that technology.
japy.jpeg
 Description   Next version will be less noisy, and colorized keyboard. US keyboard available on request.
 Filesize   244.29 KB
 Viewed   478 Time(s)

japy.jpeg


Last edited by hamoudoudou on Tue 06 Feb 2018, 06:54; edited 2 times in total
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3566
Location: Worcestershire, UK

PostPosted: Tue 06 Feb 2018, 06:25    Post subject:  

Update +14 - updates from upstream Ubuntu & fix for run-as-spot under LXDE (does not affect ArtfulPup)
_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
Smithy


Joined: 12 Dec 2011
Posts: 963

PostPosted: Wed 07 Feb 2018, 15:52    Post subject:  

Hello Peebee,
Could you possibly document the changes here on murga?
Sourceforge has gone dark, absolutely full of javascript. I don't mind a few adverts but sheesh.
Artful is running really fast. And it loads up on an old atom.
Just needs the rox sourceforge fixing up a bit. The icons on right click are missing a few things.
And if you opt to have puppy icons on the desktop, the hard drive icons clash with them. Might I suggest:
#091208 adjust drive icons placement, read by /sbin/pup_event_frontend_d
#TODO: GUI in /usr/sbin/eventmanager
#gap between icons and edge of screen (>0 if need to leave space for a tray)...
ICON_PLACE_EDGE_GAP=100
#indent from edge before icons start...
ICON_PLACE_START_GAP=32
#spacing between successive icons (64 matches other icons on desktop)...
ICON_PLACE_SPACING=64 #56
#left, right, bottom, or top of screen...
ICON_PLACE_ORIENTATION='bottom'
Seems like a good puppy. I've built an openbox for it.
Back to top
View user's profile Send private message 
B.K. Johnson

Joined: 12 Oct 2009
Posts: 686

PostPosted: Wed 07 Feb 2018, 18:00    Post subject:  

@peebee
The new pet installed without error. However, output from running Network Wizard and SNS is the same as when I mistakenly used ndiswrapper_1.61-k4.9.56-lxpup-pae.pet (screeny-1 & screeny-2) shown here. Ain't that strange?

Another strange thing: The ndiswrapper_1.61-k4.9.59-lxpup-pae.pet (download from nluug) is 245,760 bytes whereas, the allegedly same pet downloaded from ibiblio is 94,962 bytes.
Explanation offered
Quote:

Ooops - sorry - problem with downloading things from nluug with a web browser which has been seen before. (download with wget is OK)
What caused this size difference? nluug? If browser, which? Or a mystery middle-man? I could open the pets for a look-see but can't be bothered. When puppies allowed choosing repository from PPM, nluug was always my choice primarily because of speed. Sad to hear that downloads from it via browsers now get corrupted. The purported unreliability is news I never heard before. Post a link to the discussion.

The ndiswrapper_1.61-k4.9.56-lxpup-pae.pet downloaded from smokey is 94,958, just a few bytes different from ibiblio's. It therefore is not surprising that the output in both is the same.

So, now that the ndiswrapper pet does not cause an error on installation (I refuse to say 'installed correctly'). And my wifi adapter uses a Broadcom chipset which lsusb and its alias PupSysInfo recognizes (VendorID=0846 ProductID=9020ID NetGear, Inc. WNA3100(v1) Wireless-N 300 [Broadcom BCM43231]. And the Windows XP driver is one I have successfully used for a long time in different versions of Slacko and tahrpup. I still do. It's fair to say that it is the distribution that is missing something.

You wrote earlier when the ndiswrapper did not work:
Quote:

Why it then does not like your XP driver I'm afraid I have no idea Sad

If you still have no idea, then it is time for me to close the book on Artfulpup.

One question before I pack it in:

When compiling artful, what do you have in your .config re CONFIG_MODULE_SIG?

_________________
B.K. Johnson
tahrpup-6.0.5 PAE (upgraded from 6.0 =>6.0.2=>6.0.3=>6.0.5 via quickpet/PPM=Not installed); slacko-5.7 occasionally. Frugal install, pupsave file, multi OS flashdrive, FAT32 , SYSLINUX boot, CPU-Dual E2140, 4GB RAM

Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3566
Location: Worcestershire, UK

PostPosted: Wed 07 Feb 2018, 19:17    Post subject:  

B.K. Johnson wrote:
When compiling artful, what do you have in your .config re CONFIG_MODULE_SIG?
Code:
CONFIG_MODULE_SIG=y
# CONFIG_MODULE_SIG_FORCE is not set
CONFIG_MODULE_SIG_ALL=y
CONFIG_MODULE_SIG_SHA1=y
# CONFIG_MODULE_SIG_SHA224 is not set
# CONFIG_MODULE_SIG_SHA256 is not set
# CONFIG_MODULE_SIG_SHA384 is not set
# CONFIG_MODULE_SIG_SHA512 is not set
CONFIG_MODULE_SIG_HASH="sha1"

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 31 of 49 [730 Posts]   Goto page: Previous 1, 2, 3, ..., 29, 30, 31, 32, 33, ..., 47, 48, 49 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0844s ][ Queries: 12 (0.0167s) ][ GZIP on ]