Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

READ-ONLY-MODE: PLEASE DO NOT POST NEW STUFF!
  New Forum: http://puppylinux.rockedge.org
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 11 Aug 2020, 14:40
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
ArtfulPup (& Upup-Bionic-Beaver-RC)
Moderators: Flash, JohnMurga
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 46 of 49 [730 Posts]   Goto page: Previous 1, 2, 3, ..., 44, 45, 46, 47, 48, 49 Next
Author Message
peebee


Joined: 21 Sep 2008
Posts: 4391
Location: Worcestershire, UK

PostPosted: Fri 06 Apr 2018, 06:07    Post subject:  

font icons are fixed in delta +3 above

Needed an edit to /usr/share/mime/packages/freedesktop.org.xml
this comes from:
:shared-mime-info:|pet|Packages-puppy-common32-official|shared-mime-info-1.9-i686_common32|shared-mime-info|1.9-i686_common32||BuildingBlock|400||shared-mime-info-1.9-i686_common32.pet||mimetype information||||

so I'll propose an update

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
666philb


Joined: 07 Feb 2010
Posts: 3635
Location: wales ... by the sea

PostPosted: Fri 06 Apr 2018, 08:51    Post subject:  

hi peebee ,

concerning
Moat wrote:

I somehow managed to lock up the desktop while setting the screen lock password (Xlock?), requiring a hard shutdown.
Bob


this happens if compton is running when executing xlock.
editing /usr/local/apps/Xlock/AppRun from line 171 with the following fixes it for me
might need sleep 2 for older comps
Code:
if [ ! -f /root/.xlockrc ];then
 XLOCKPARAMS="`cat /root/.config/Xlock/xlockscreenparams`"
 rxvt -g 36x1 -title "Create key (password)" -e ${XLOCKEXE} ${XLOCKPARAMS}
else
ps cax | grep compton
if [ $? -eq 0 ]; then
touch /tmp/comptonrunning
chmod a+x /tmp/comptonrunning
killall compton &
sleep 1
 ${XLOCKEXE} `cat /root/.config/Xlock/xlockscreenparams`
else
  ${XLOCKEXE} `cat /root/.config/Xlock/xlockscreenparams`
fi
fi

#100608 lobster: restore...
if [ -f /tmp/comptonrunning ];then
exec compton &
rm /tmp/comptonrunning
xmodmap -e 'keycode 37=Control_L'
xmodmap -e 'keycode 109=Control_R'
else
xmodmap -e 'keycode 37=Control_L'
xmodmap -e 'keycode 109=Control_R'
fi


###end###

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
ETP


Joined: 19 Oct 2010
Posts: 1202
Location: UK

PostPosted: Fri 06 Apr 2018, 12:04    Post subject: Upup_Bionic_Beaver-18.04+3.
Subject description: Testing
 

Hi peebee,

Thanks for 18.04+3. I can confirm that the TTF fonts icon display issue has been resolved plus
the included GTK3 items are suffice to run Chromium.
No problems with CUPS or your Palemoon SFS which was loaded on the fly.
In order to try out the latest SMPlayer's new ability to cast to a chromecast dongle together with the latest mpv,
I installed the items detailed below: (Lists deps followed by package)

chromium-60.0.3112.78-i586+pepper_26.0.0.137-etp|Access the Internet
chromium-codecs-ffmpeg_65.0.3325.181|Free ffmpeg codecs for the Chromium Browser

    libegl1-mesa_18.0.0|transitional dummy package
    libjack-jackd2-0_1.9.12|JACK Audio Connection Kit libraries
    liblua5.2-0_5.2.4|Shared library for the Lua interpreter version 5.2
    libpulse0_11.1|PulseAudio client libraries
    libwayland-client0_1.14.0-2|wayland compositor infrastructure - client library
    libwayland-cursor0_1.14.0-2|wayland compositor infrastructure - cursor library
    libass9_0.14.0-1|library for SSA/ASS subtitles rendering
    librubberband2_1.8.1|audio time-stretching and pitch-shifting library
    libsdl2-2.0-0_2.0.8+dfsg1|Simple DirectMedia Layer
    libuchardet0_0.0.6-2|universal charset detection library - shared library
    libva-wayland2_2.1.0-3|Video Acceleration VA API for Linux -- Wayland runtime
    libva-drm2_2.1.0-3|Video Acceleration VA API for Linux -- DRM runtime
    libva-x11-2_2.1.0-3|Video Acceleration VA API for Linux -- X11 runtime
mpv_0.27.0|video player based on MPlayer/mplayer2

    qtcore4-l10n_4.8.7+dfsg|Qt 4 core module translations
    libqtcore4_4.8.7+dfsg|Qt 4 core module
    libqt4-declarative_4.8.7+dfsg|Qt 4 Declarative module
    libqt4-network_4.8.7+dfsg|Qt 4 network module
    libqt4-script_4.8.7+dfsg|Qt 4 script module
    libqt4-sql_4.8.7+dfsg|Qt 4 SQL module
    libqt4-xml_4.8.7+dfsg|Qt 4 XML module
    libqt4-xmlpatterns_4.8.7+dfsg|Qt 4 XML patterns module
    libqtdbus4_4.8.7+dfsg|Qt 4 D-Bus module library
    libqtgui4_4.8.7+dfsg|Qt 4 GUI module
smplayer_18.3.0-1_bionic1_i386|A great MPlayer front-end

NOTE: All the above obtained from (updated) PPM except SMPlayer which was sourced from here:
https://launchpad.net/~rvm/+archive/ubuntu/smplayer/+packages
https://launchpad.net/~rvm/+archive/ubuntu/smplayer/+packages?field.name_filter=&field.status_filter=published&field.series_filter=bionic

Screenshot:
Please press F11 to toggle into full-screen then click on link below;---
https://drive.google.com/uc?export=view&id=1x85gfKS_kR9p7Sh-kVkvMkp8m_bRshuU

_________________
Regards ETP

Kennels
Back to top
View user's profile Send private message 
foxpup

Joined: 29 Jul 2016
Posts: 1141

PostPosted: Fri 06 Apr 2018, 14:57    Post subject:  

I am still on 18.04+2. I cannot keep up Smile

I installed it also on a i5 laptop. It runs very well on this too Very Happy
Quote:
I cannot get the keyboard be-latin1 to work. I choose be Belgian.
This did not happen on this install, so I began to doubt and decided to reinstall on my dualcore. The problem seems to have gone! Surprised I don't know what I did before to make this happen.
No other problems to report so far. It's a very nice build peebee.
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3721
Location: Ontario Canada

PostPosted: Fri 06 Apr 2018, 16:22    Post subject: ArtfulPup (& Upup-Bionic-Beaver-RC)  

I installed 18.04+3 to a usb-3.0 SSD:

# inxi -b
System: Host: puppypc28332 Kernel: 4.9.92-lxpup-32-pae i686 bits: 32 Desktop: JWM 2.3.7 Distro: UPupBB 18.04
Machine: Device: desktop System: Hewlett-Packard product: p7-1246s serial: MXX232077R
Mobo: Foxconn model: 2ADA v: 1.00 serial: N/A BIOS: AMI v: 7.12 date: 06/07/2012
CPU: Quad core Intel Core i5-3550 (-MCP-) speed/max: 1600/3301 MHz
Graphics: Card: NVIDIA GF108 [GeForce GT 430]
Display Server: X.Org 1.19.6 driver: nvidia Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
OpenGL: renderer: GeForce GT 430/PCIe/SSE2 version: 4.5.0 NVIDIA 384.130
Network: Card-1: Ralink RT5390 Wireless 802.11n 1T/1R PCIe driver: rt2800pci
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
Drives: HDD Total Size: 2126.7GB (0.4% used)
Info: Processes: 198 Uptime: 50 min Memory: 293.5/12110.1MB Client: Shell (bash) inxi: 2.3.56
#

Installed the usual applications + proprietary nvidia driver

It's working okay so far,
Thanks.
screenshot.jpg
 Description   
 Filesize   48.67 KB
 Viewed   1038 Time(s)

screenshot.jpg

Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3635
Location: wales ... by the sea

PostPosted: Fri 06 Apr 2018, 17:54    Post subject:  

nouveau doesn't work with this card and the 4.9 kernel and i only get the vesa driver even if i install the latest firmware.

upgraded to 4.14 and the nouveau driver loaded.
the nvidia proprietary driver also installed fine

steam works Smile https://youtu.be/VD8KFixFDtw
i think the steam tray icon needs libappindicator1

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 4391
Location: Worcestershire, UK

PostPosted: Sat 07 Apr 2018, 09:56    Post subject:  

+4 (see above) has a profile for Light that fixes the Google Certificate Authority and adds Duckduckgo as a search engine. If you have a savefolder with an existing Light profile /root/.light then this will take precedence.
_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
jrb


Joined: 11 Dec 2007
Posts: 1539
Location: Smithers, BC, Canada

PostPosted: Sat 07 Apr 2018, 13:45    Post subject:  

peebee wrote:
+4 (see above) has a profile for Light that fixes the Google Certificate Authority and adds Duckduckgo as a search engine. If you have a savefolder with an existing Light profile /root/.light then this will take precedence.

Thanks, Is the devx changed?
Back to top
View user's profile Send private message 
foxpup

Joined: 29 Jul 2016
Posts: 1141

PostPosted: Sat 07 Apr 2018, 13:54    Post subject:  

peebee wrote:
+4 (see above) has a profile for Light that fixes the Google Certificate Authority
Works! What did you have to change in the profile?

I forgot to mention that I needed to add iwlwifi-7265D-26.ucode in /lib/firmware/ in my laptop. Dmesg reported that versions 17 up to 26 are good for this kernel.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 4391
Location: Worcestershire, UK

PostPosted: Sun 08 Apr 2018, 02:07    Post subject:  

devx is not changed....

I got Root-R2.crt from a link found at:
https://textslashplain.com/2017/10/23/google-internet-authority-g3/
Quote:
You might instead try downloading the R2 GlobalSign Root Certificate directly and then installing it in your Trusted Root Certification Authorities

and then imported it into the Certificate Authority list:

Preferences -> Advanced -> Certificates -> View Certificates -> Authorities -> Import

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
foxpup

Joined: 29 Jul 2016
Posts: 1141

PostPosted: Sun 08 Apr 2018, 07:00    Post subject:  

Peebee

Thank you to fill me in. I read it, without understanding much Smile . Luckily, the solution isn't too complicated, but still, you have to find out. I had already tried installing certificates from ubuntu repo, but that did not work.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 4391
Location: Worcestershire, UK

PostPosted: Sun 08 Apr 2018, 07:25    Post subject:  

Also available from: https://pki.goog/

with different name but same md5 check

GSR2.crt

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
Terry H

Joined: 29 Mar 2009
Posts: 782
Location: The Heart of Muskoka, ON Canada

PostPosted: Sun 08 Apr 2018, 13:15    Post subject:  

I've been running upupBB-18.04 +4 as frugal install on 32GB SanDisk Flash drive for a couple of days on Dell 3350 Core i3-5005U laptop. All working very well.

Thanks peebee for your excellent work on this project and all your work on puppy development.

Code:

# inxi -Fxz
System:    Host: puppypc25435 Kernel: 4.9.92-lxpup-32-pae i686 (32 bit gcc: 7.3.0) Desktop: JWM 2.3.7
           Distro: UPupBB 18.04
Machine:   Device: laptop System: Dell product: Latitude 3350
           Mobo: Dell model: 0KVTCC v: A00 UEFI: Dell v: A13 date: 01/23/2018
Battery    BAT0: charge: 59.0 Wh 123.3% condition: 47.9/59.0 Wh (81%)
           model: Samsung SDI DELL 6C0FN58 status: Full
CPU:       Dual core Intel Core i3-5005U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7982
           clock speeds: max: 2000 MHz 1: 1000 MHz 2: 800 MHz 3: 1700 MHz 4: 600 MHz
Graphics:  Card: Intel HD Graphics 5500 bus-ID: 00:02.0
           Display Server: X.org 1.19.6 drivers: modesetting (unloaded: fbdev,vesa)
           tty size: 149x38 Advanced Data: N/A for root
Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Broadwell-U Audio Controller driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.9.92-lxpup-32-pae
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
           Card-2: Intel Wireless 7265 driver: iwlwifi bus-ID: 04:00.0
           IF: wlp4s0 state: up mac: <filter>
Drives:    HDD Total Size: 530.9GB (0.7% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ACF0 size: 500.1GB
           ID-2: /dev/sdb model: Ultra_Fit size: 30.8GB
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 186 Uptime: 6 min Memory: 222.5/7756.6MB Init: SysVinit runlevel: 5 Gcc sys: N/A
           Client: Shell (bash 4.4.191) inxi: 2.3.8     
Back to top
View user's profile Send private message 
recobayu


Joined: 15 Sep 2010
Posts: 389
Location: indonesia

PostPosted: Mon 09 Apr 2018, 05:24    Post subject:  

Yeay!
Thank's Peebee, Finally I can connect to my campus's network that use WPA2Enterprise using this Bionicpup+4. But I use the previous file from artful: /etc/frisbee/wpa_supplicant.conf. And after several time i connect manual by terminal:
Code:
wpa_supplicant -iwlp3s0 -Dwext -c /etc/frisbee/wpa_supplicant.conf

I think there are some different code in the new woof-CE for frisbee. I post my problem also in woof-CE thread: http://www.murga-linux.com/puppy/viewtopic.php?p=987922#987922
Back to top
View user's profile Send private message 
nilsonmorales


Joined: 15 Apr 2011
Posts: 973
Location: El Salvador

PostPosted: Tue 10 Apr 2018, 00:19    Post subject:  

Hi guys, is olny me or the ttf mimetypes problem is back?
Upup_Bionic_Beaver-18.04.iso___Upup_Bionic_Beaver-18.04+4.iso.delta MD5SUM 74c22c6ee94ea6e8bf87927efbc28197
Upup_Bionic_Beaver-18.04+4.iso MD5SUM 23a54b63aa48956f50a3e10495e96b1e

_________________
My blog | | Github


Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 46 of 49 [730 Posts]   Goto page: Previous 1, 2, 3, ..., 44, 45, 46, 47, 48, 49 Next
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0952s ][ Queries: 12 (0.0326s) ][ GZIP on ]