Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 11 Dec 2018, 03:32
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
StretchDog
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 9 of 11 [163 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9, 10, 11 Next
Author Message
fredx181


Joined: 11 Dec 2013
Posts: 3573
Location: holland

PostPosted: Mon 01 Oct 2018, 12:13    Post subject: Re: Abiword No Print  

sszindian wrote:
Finally got abiword 3.0.2 to install in stretchdog (64bit) using the instructions fred posted on page 1 of this thread (yes, even the BIG download file)! However, although everything appears to work in it, 'It Won't Print'.

It says: Unable to send raster data to the driver (in the same line where it lists my printer config).

Any suggestions???

>>>---Indian------>


Hi sszindian, sorry, I have very little knowledge about printing, hopefully someone else can help ?
Btw, does printing work for you in general ? i.e. from other programs besides abiword ?

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 773
Location: Pennsylvania U.S.

PostPosted: Mon 01 Oct 2018, 13:14    Post subject: reply  

fredx181 wrote:
Btw, does printing work for you in general ? i.e. from other programs besides abiword ?
----------------------------------------
Yes, works fine : Leafpad, mtpaint, internet stuff etc.

and... I asked earlier in this thread (Guess you missed it) about a google earth 6.2.2 (my box won't run the 7+ versions on any distro) for stretchdog nor will it run any distro above a 4.12 kernel without a kernel panic... bummer... but still a few pup's and distros left to play with Smile Sadly, old computers are being forgotten for the sake of newer programming ideas. I still believe an older say- 4.9 + LTS kernel would do as well, maybe even better, as a 4.18 + kernel would for most distro needs and the old computers wouldn't be left out! (sorry for the off-topic here but since you are a programmer I thought I'd mention it... keep up your excellent work fred!)

>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3573
Location: holland

PostPosted: Mon 01 Oct 2018, 14:18    Post subject:  

Hi sszindian,

Maybe you followed from what I wrote here:
http://murga-linux.com/puppy/viewtopic.php?p=972532#972532
and installed libabiword 3.0.2-4 from NoRepo
https://fredx181.github.io/StretchDog/NoRepo/
Check with:
Code:
apt-cache policy libabiword-3.0

For me it is:
Code:
root@live:~#  apt-cache policy libabiword-3.0
libabiword-3.0:
  Installed: 3.0.2-4
  Candidate: 3.0.2-4
  Version table:
 *** 3.0.2-4 100
        100 /var/lib/dpkg/status
     3.0.2-2+deb9u2 500
        500 http://deb.debian.org/debian stretch/main i386 Packages


Update.. It seems that the bug I wrote about (flickering) is now solved, so if you have version 3.0.2-4 installed, try:
Code:
apt-get install libabiword-3.0=3.0.2-2+deb9u2

(will install official libabiword-3.0 from Debian)
Perhaps that will solve the printing problem.

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 773
Location: Pennsylvania U.S.

PostPosted: Mon 01 Oct 2018, 16:04    Post subject: Abiword - Printing  

Here's what I have fred!


root@live:~# apt-cache policy libabiword-3.0
libabiword-3.0:
Installed: 3.0.2-2+deb9u2
Candidate: 3.0.2-2+deb9u2
Version table:
*** 3.0.2-2+deb9u2 500
500 http://deb.debian.org/debian stretch/main amd64 Packages
100 /var/lib/dpkg/status
root@live:~#

-------------------------------------------------------------------

Where (or how) do I get that 3.0.2-4 versoin?

'Thanks for your time'

>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3573
Location: holland

PostPosted: Mon 01 Oct 2018, 16:18    Post subject:  

sszindian wrote:
Where (or how) do I get that 3.0.2-4 versoin?


Well.. I was just thinking that you did install that 3.0.2-4 version (from Ubuntu) and that would possibly cause the problem you get with printing, but apparently you have official Debian version (3.0.2-2+deb9u2) installed.
So... don't know, but if you want to try the libabiword 3.0.2-4 version, download and install from here:
https://fredx181.github.io/StretchDog/NoRepo/
(32-bit: libabiword-3.0_3.0.2-4_i386.deb)
Install with right-click > install deb
But my guess is that there's small chance it will solve your problem.

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 773
Location: Pennsylvania U.S.

PostPosted: Mon 01 Oct 2018, 20:25    Post subject: Stretchdog  

Pretty much tried everything with still No Printing fred? Guess I'll leave it ride for now as is.

Other testing results I found:

Last Two (2) updates to firefox ESR from package manager (Debian) resulted in Internet Audio not playing at all. MP4's and other local stuff plays just fine... just no Internet sound? Installing Palemoon (27+ version) from package manager... sound on Internet works fine.

As time permits, will do some more testing on Stretchdog as I like the feel of this program and how it functions a lot.

Oh by the way you've suggested trying some 32bit stuff for the no-printing thing, I thought I first mentioned I was running the 64bit version?

Thanks for your help!

>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3573
Location: holland

PostPosted: Tue 02 Oct 2018, 13:05    Post subject:  

sszindian wrote:
Last Two (2) updates to firefox ESR from package manager (Debian) resulted in Internet Audio not playing at all. MP4's and other local stuff plays just fine... just no Internet sound?


Yes, now the newest firefox-esr depends on pulseaudio, a good (light) workaround to make sound work is to run it with apulse (using alsa, simulating pulse), like :
Code:
apulse firefox

Needs installed apulse:
Code:
apt-get update
apt-get install apulse


Btw, updated apulse package in repository, changes:
- Removed the message something like "change needed in about:config for firefox" after install. (this is not required anymore with newest firefox)
- From Menu > Internet > Firefox-apulse will execute firefox with apulse, but changed Exec=apulse /opt/firefox/firefox to just: Exec=apulse firefox, so it will execute firefox in PATH, e.g. /usr/bin/firefox

EDIT: With newest firefox-esr (60.2.2esr) it's "fixed", no need for pulseaudio or apulse, see below.

Fred

_________________
Dog Linux website

Last edited by fredx181 on Thu 04 Oct 2018, 04:50; edited 1 time in total
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 773
Location: Pennsylvania U.S.

PostPosted: Wed 03 Oct 2018, 22:22    Post subject: Firefox No Sound  

Not sure which corrected the Internet-Audio with Firefox? Either your suggestion above... or ... the download of the new firefox ESR update that was posted today in the package-manager??? Anyway it's back working as it should.

If we can keep getting a fix-at-a-time eventually this will be a great Dog! Just wish there were more users involved here.

>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3573
Location: holland

PostPosted: Thu 04 Oct 2018, 04:40    Post subject: Re: Firefox No Sound  

sszindian wrote:
Not sure which corrected the Internet-Audio with Firefox? Either your suggestion above... or ... the download of the new firefox ESR update that was posted today in the package-manager??? Anyway it's back working as it should.

If we can keep getting a fix-at-a-time eventually this will be a great Dog! Just wish there were more users involved here.

>>>---Indian------>


Indeed, that's very nice, with newest firefox-esr (60.2.2esr) the sound works, doesn't require pulseaudio or apulse.
Thanks for info !

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
stroudmw

Joined: 17 Mar 2017
Posts: 19

PostPosted: Sat 06 Oct 2018, 02:10    Post subject:  

Quote:
Not sure why the firewall isn't working under user puppy (shows as green when logged in as root, but under puppy I can't seem to turn it on).


Did you ever solve this? I'm having the same issue with the firewall and user "puppy".
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3573
Location: holland

PostPosted: Sat 06 Oct 2018, 09:47    Post subject:  

Updated firewall-ng (to v 1.0.2)
This should solve the issue when logged in as puppy.
Added password-less sudo configuration for firewall-ng (in /etc/sudoers.d/firewall_ng)
This way, users that are member of group "wheel" can start/stop the firewall without the need to enter password.
User puppy is by default member of group wheel.

Install firewall-ng with Synaptic (reload first) or with apt-get:
Code:
apt-get update
apt-get install firewall-ng


Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3573
Location: holland

PostPosted: Sat 06 Oct 2018, 14:31    Post subject:  

Install Debian Stretch-Backports kernel

EDIT: Updated to v 0.0.3, see EDIT2 in above linked post.

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
jss83

Joined: 06 Jan 2015
Posts: 267

PostPosted: Fri 12 Oct 2018, 14:01    Post subject:  

Hi fred, I am using this now with JWM but the left click on the desktop is opening the programs menu. How can I disable that?

Also, how can I change the default apps?
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 1162

PostPosted: Fri 12 Oct 2018, 16:27    Post subject:  

fredx181 wrote:
Install Debian Stretch-Backports kernel

EDIT: Updated to v 0.0.3, see EDIT2 in above linked post.

Fred


Is there any reason to install the backports kernel on an older machine that is running fine?
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3573
Location: holland

PostPosted: Sun 14 Oct 2018, 13:38    Post subject:  

dancytron wrote:
fredx181 wrote:
Install Debian Stretch-Backports kernel

EDIT: Updated to v 0.0.3, see EDIT2 in above linked post.

Fred


Is there any reason to install the backports kernel on an older machine that is running fine?


Probably not. Just thought there might be interest to use latest stable kernel (4.18 now)
Anyway, it works fine on my 11 years old laptop.
Also, the good thing about this package is that it is self-supporting (i.e. should still work if the latest backports version changes to e.g. 4.19),
On the contrary, "upgrade-kernel" (for the 4.9 kernel) is not, it depends on me every time for compiling new squashfs kernel module (for LZ4 support).

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 9 of 11 [163 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9, 10, 11 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.2203s ][ Queries: 12 (0.0565s) ][ GZIP on ]