Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 19 Nov 2017, 01:11
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
puppy-get 1.5 beta
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 4 [49 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Author Message
ally


Joined: 19 May 2012
Posts: 1582
Location: lincoln, uk

PostPosted: Wed 18 Oct 2017, 01:53    Post subject:  

https://drive.google.com/open?id=0B3lzw8mj5dU4RE1fNTc0NkIxMVk

Smile
Back to top
View user's profile Send private message Visit poster's website 
mistfire

Joined: 04 Nov 2008
Posts: 643
Location: PH

PostPosted: Wed 18 Oct 2017, 02:21    Post subject:  

Wow! your master package database was huge! at least it will gave me a clue to fix that error on that script
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 643
Location: PH

PostPosted: Wed 18 Oct 2017, 02:40    Post subject:  

@ally I find now the culprit. the dependency names in the master database must not include version numbers. I will try to correct that.
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 643
Location: PH

PostPosted: Fri 20 Oct 2017, 05:34    Post subject:  

puppy-get 1.1 beta released

changes:

* bugfix on dependency sniffing for debian-based puppy package database
* some overhaul on package installation
* with summary report on install command after executed

@ally I finally now fixed the error the dependency sniffing now works on puppy xenial. I finally make some revisions on package install function
puppy-get-1.1-beta.gz
Description  fake gz. remove .gz extension
set permission to 777
rename as puppy-get
gz

 Download 
Filename  puppy-get-1.1-beta.gz 
Filesize  76.27 KB 
Downloaded  18 Time(s) 
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1582
Location: lincoln, uk

PostPosted: Fri 20 Oct 2017, 11:50    Post subject:  

hi

1.1 fixes the install, dependencies corrected for my two installs, gweled and dillo

remove still failing with package not installed

I re-ran the database update prior to new installs of the above

Smile
Back to top
View user's profile Send private message Visit poster's website 
mistfire

Joined: 04 Nov 2008
Posts: 643
Location: PH

PostPosted: Fri 20 Oct 2017, 20:56    Post subject:  

@ally do the downloading and installation of packages works?
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1582
Location: lincoln, uk

PostPosted: Fri 20 Oct 2017, 21:06    Post subject:  

yes, apologies if I was not clear

I did a database rebuild

puppy-get install dillo, this corrected the missing dependencies, fully working

puppy-get install gweled, this corrected the missing dependencies and is also fully working

I tried puppy-get remove dillo and gweled but get the same 'not installed' error

I tried a new install (netsurf), this also correctly installed (but icon to network) but this also failed on remove with the 'not installed' error

hth

Smile
Back to top
View user's profile Send private message Visit poster's website 
mistfire

Joined: 04 Nov 2008
Posts: 643
Location: PH

PostPosted: Fri 20 Oct 2017, 23:48    Post subject:  

Thanks for the comment @ally. It seems on adding package entry on install function has a problem. I will try to fix that. Few fixes to go we will have a fully working apt-get alternative.
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1582
Location: lincoln, uk

PostPosted: Fri 20 Oct 2017, 23:52    Post subject:  

its a powerful tool

thanks Smile
Back to top
View user's profile Send private message Visit poster's website 
mistfire

Joined: 04 Nov 2008
Posts: 643
Location: PH

PostPosted: Sat 21 Oct 2017, 01:05    Post subject:  

New puppy-get version released

Changes:
* Failed to register installed package is fixed
* Fix menu action is now builtin on script
puppy-get_1.2-beta.gz
Description  Fake gz
Remove .gz extension
Rename as puppy-get
Set permission to 777 or +x
gz

 Download 
Filename  puppy-get_1.2-beta.gz 
Filesize  78.83 KB 
Downloaded  32 Time(s) 
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 643
Location: PH

PostPosted: Sat 21 Oct 2017, 01:10    Post subject:  

@ally you may now test this latest script
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1582
Location: lincoln, uk

PostPosted: Sat 21 Oct 2017, 07:34    Post subject:  

hey mistfire

seems to be working well

I rebooted a pristine xenialpup, ran puppyget update to build the database

pg install dillo

installed correctly

pg remove dillo almost completely removed dillo (? pixmaps from memory), like that it removed the dillo*.files entry in .packages

however it does not remove the dependency (libmikmod), when running pg remove libmikmod package not installed returned, had to remove manually using contents of libmikmod*.files entry

ran pg install mah-jong (no dependencies), installed correctly and was able to completely remove all components except for mah-jong folder


this is excellent - nice work

would like to see the removal of the .deb files also, perhaps a 'would you like to remove .deb', over time this could end up quite a large file base and better dependency removal although I accept this could be tricky

Smile
Back to top
View user's profile Send private message Visit poster's website 
mistfire

Joined: 04 Nov 2008
Posts: 643
Location: PH

PostPosted: Sat 21 Oct 2017, 08:12    Post subject:  

@ally the removal of deb files downloaded by puppy-get depends on your choice whether to delete it or not. But I will consider your suggestion.
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 643
Location: PH

PostPosted: Sat 21 Oct 2017, 09:40    Post subject:  

@ally I test the libmikmod on puppy-get it works fine, it install and uninstall. I think you are entering a wrong package name thats why it returned not installed the correct package name for libmikmod in gweled dependencies was libmikmod3 not libmikmod
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 1582
Location: lincoln, uk

PostPosted: Sat 21 Oct 2017, 09:40    Post subject:  

I'll try again, give me a few mins...

Smile
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 2 of 4 [49 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0801s ][ Queries: 12 (0.0111s) ][ GZIP on ]