Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 25 Sep 2018, 16:55
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Dpup Stretch 7.5 CE (RC-3)
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 23 of 25 [374 Posts]   Goto page: Previous 1, 2, 3, ..., 21, 22, 23, 24, 25 Next
Author Message
radky

Joined: 02 May 2010
Posts: 820

PostPosted: Mon 02 Jul 2018, 15:19    Post subject:  

01101001b wrote:
Quote:
...apologies to Sailor E. for my delay in answering (I've not passed by this forum since my post)

Dpup Stretch 7.5 RC3 is available with many updates since RC2, including the requested wget_1.19.5.

_________________
PupMates
Back to top
View user's profile Send private message 
01101001b


Joined: 08 Mar 2017
Posts: 40
Location: Buenos Aires, Argentina

PostPosted: Mon 02 Jul 2018, 19:31    Post subject:  

radky wrote:
Dpup Stretch 7.5 RC3 is available with many updates since RC2, including the requested wget_1.19.5.

Yes! I updated my system yesterday! Thanks so much!

At first, X session didn't start because nvidia drivers previously installed didn't match new kernel version. It took me a while to solve this issue... then I made some "findings"...

-Main menu categories titles dissapeared (I explain: I use LxPanel instead of FbPanel) but submenues worked fine.

-"Minimize all windows" icon (in systray) changed for an ugly one, don't know why (again, LxPanel related). No icon set change improved this issue.

-Really liked PPM interface improvement Smile

And last but not least, wget version was indeed newer (1.19.5 as Radky said) but not only "error" message (rather a warning) still persisted when installing software, it worsened too. Now installing just one package is enough to trigger that issue Shocked (but, again, second attempt succeeded Confused )

So I got back to my former system running Dpup RC2 (thanks God for backups!). All in all I'm not installing software all the time and I really like this pup (good enough to put up with that ocassional issue Cool ).

Radky, thanks again!
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3554
Location: Ontario Canada

PostPosted: Tue 03 Jul 2018, 08:44    Post subject: Dpup Stretch 7.5 CE (RC-3)  

I installed to a 64gb flash drive, pc is an Acer mid tower.

System: Host: puppypc13342 Kernel: 4.9.101-stretch i686 bits: 32 Console: tty 0
Distro: Dpup Stretch 7.5
Machine: Type: Desktop Mobo: Acer model: Aspire X3950 serial: U02C120500059 BIOS: American Megatrends
v: P01-A3 date: 05/05/2010
CPU: Dual Core: Intel Core i3 540 type: MT MCP speed: 1200 MHz min/max: 1200/3067 MHz
Graphics: Card-1: Intel Core Processor Integrated Graphics driver: i915 v: kernel
Display: server: X.Org 1.19.2 driver: intel resolution: 1600x900~60Hz
OpenGL: renderer: Mesa DRI Intel Ironlake Desktop x86/MMX/SSE2 v: 2.1 Mesa 13.0.6
Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
Card-2: D-Link System AirPlus G DWL-G122 Wireless Adapter(rev.C1) [Ralink RT2571W] type: USB
driver: rt73usb
Drives: HDD Total Size: 524.50 GiB used: 1.27 GiB (0.2%)
Weather: Temperature: 21 C (70 F) Conditions: Partly Cloudy
Current Time: Tue 03 Jul 2018 08:33:29 AM EDT (America/Rainy_River)
Info: Processes: 186 Uptime: 6m Memory: 5.86 GiB used: 138.1 MiB (2.3%) Shell: bash inxi: 3.0.12

Installed some applications with PPM.
Works well,
Thanks.
screenshot.jpg
 Description   
 Filesize   32.36 KB
 Viewed   1052 Time(s)

screenshot.jpg

Back to top
View user's profile Send private message 
radky

Joined: 02 May 2010
Posts: 820

PostPosted: Sat 07 Jul 2018, 10:24    Post subject:  

Re: error message when using Puppy Package Manager (PPM) -> "unable to obtain size of remote file, although it does seem to exist"

01101001b wrote:
Quote:
If you wish, try installing "Torcs", just to mention a rather "big" installation.

Hi 01101001b,

I can't reproduce the error message you describe.

The following installation of Torcs works fine for me in Stretch RC3. No error message, and all dependencies install OK.

1 - In Puppy Package Manager (PPM), go to "Configure Package manager" -> go to second tab (Update database) - > select "Update now" button
2 - Return to PPM and enter "Torcs" in search box
3 - Select torcs_1.3.3+dfsg2-1
4 - Select Auto install and click "Do it" button
image-1.png
 Description   
 Filesize   38.05 KB
 Viewed   951 Time(s)

image-1.png


_________________
PupMates
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3554
Location: Ontario Canada

PostPosted: Sat 07 Jul 2018, 11:17    Post subject: Dpup Stretch 7.5 CE (RC-3)  

Hi

Torcs installs from PPM and runs fine here.

Thanks.
torcs.jpg
 Description   
 Filesize   67.35 KB
 Viewed   932 Time(s)

torcs.jpg

Back to top
View user's profile Send private message 
darry19662018

Joined: 31 Mar 2018
Posts: 228

PostPosted: Sat 07 Jul 2018, 16:46    Post subject:  

Have made a trimmed down barebonish version of it here:
https://archive.org/download/Stretch700bare/stretch-7.5-k4.1.48thin.iso

I have managed to remaster 2 CE builds with woofy 0.91 by first removing the adrive from the original iso using isomaster then the resulting iso with woofy to produce a trimmed down version, I still have not figured out how to remaster an iso with ydrives etc yet.
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3554
Location: Ontario Canada

PostPosted: Wed 11 Jul 2018, 21:02    Post subject: Dpup Stretch 7.5 CE (RC-3)  

Installed to an HP mini:

video-info-glx 1.5.3 Wed 11 Jul 2018 on Dpup Stretch 7.5 Linux 4.9.101-stretch i686
2.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)

X Server: Xorg Driver: intel
X.Org version: 1.19.2
dimensions: 1920x1080 pixels (507x285 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile x86/MMX/SSE2
OpenGL core profile version string: 3.3 (Core Profile) Mesa 13.0.6

Intel(R) Celeron(R) 2957U @ 1.40GHz
Core 0: @1000 1: @800 MHz

Running Windows 10 from the 32gb SSD and Dpup Stretch 7.5 from an 1tb usb
hard drive.

Works great.
screenshot2.jpg
 Description   
 Filesize   71.31 KB
 Viewed   709 Time(s)

screenshot2.jpg

screenshot.jpg
 Description   
 Filesize   87.23 KB
 Viewed   763 Time(s)

screenshot.jpg

Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3554
Location: Ontario Canada

PostPosted: Sat 14 Jul 2018, 09:19    Post subject: Dpup Stretch 7.5 CE (RC-3)  

I did a new install to a 16gb SDHC card, pc is an 11 year old HP:

System: Host: puppypc7577 Kernel: 4.17.6-lxpup64 x86_64 bits: 64 Console: tty 0 Distro: Dpup Stretch 7.5
Machine: Type: Desktop System: HP-Pavilion product: GN559AA-ABA a6220n v: N/A serial: MXF7470DNX
Mobo: ASUSTeK model: Berkeley v: 1.04 serial: X312345678 BIOS: American Megatrends v: 5.13
date: 10/24/2007
CPU: Dual Core: Intel Core2 Duo E4500 type: MCP speed: 1400 MHz min/max: 1200/2200 MHz
Graphics: Card-1: Advanced Micro Devices [AMD/ATI] Oland [Radeon HD 8570 / R7 240/340 OEM] driver: radeon
v: kernel
Display: server: X.Org 1.19.2 driver: radeon resolution: 1920x1080~60Hz, 1920x1080~60Hz
OpenGL: renderer: Gallium 0.4 on AMD OLAND (DRM 2.50.0 / 4.17.6-lxpup64 LLVM 3.9.1)
v: 4.3 Mesa 13.0.6
Network: Card-1: Intel 82566DC-2 Gigabit Network Connection driver: e1000e
Drives: HDD Total Size: 387.52 GiB used: 1.11 GiB (0.3%)
Weather: Temperature: 24 C (75 F) Conditions: Overcast
Current Time: Sat 14 Jul 2018 09:00:50 AM EDT (America/Toronto)
Info: Processes: 116 Uptime: 54m Memory: 3.86 GiB used: 281.5 MiB (7.1%) Shell: bash inxi: 3.0.12

I changed the kernel to peebee's latest.
Vlc is now at version 3.0.2 Vetinari

The Palemoon Updater no longer works but that's the only problem so
far.

EDIT: Rolled kernel back to 4.9.101 then changed kernels to 4.9.114
# uname -a
Linux puppypc7577 4.9.114 #1 SMP Tue Jul 24 08:48:40 EDT 2018 i686 GNU/Linux
#
Updated Palemoon to 27.9.4 - it supports a legacy version of ublock origin.
screenshot.jpg
 Description   
 Filesize   60.81 KB
 Viewed   649 Time(s)

screenshot.jpg


Last edited by Billtoo on Tue 24 Jul 2018, 14:58; edited 1 time in total
Back to top
View user's profile Send private message 
01101001b


Joined: 08 Mar 2017
Posts: 40
Location: Buenos Aires, Argentina

PostPosted: Fri 20 Jul 2018, 18:06    Post subject:  Re: Dpup Stretch 7.5 CE (RC-3)  

radky wrote:
The following installation of Torcs works fine for me in Stretch RC3. No error message, and all dependencies install OK.

Billtoo wrote:
Torcs installs from PPM and runs fine here.

Radky, Billtoo: Thanks so much for your help. Your feedback is greatly apreciated. I'll install RC-3 from scratch next time my system implodes Embarassed
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1210
Location: Saint-Gérard / Walloon part of Belgium

PostPosted: Mon 23 Jul 2018, 00:27    Post subject: wacom.ko driver missing on RC-3  

Hi radky,
trying to use a wacom tablet using Dpup-Stretch 7.5 RC-3 with kernel 4.9.101:
it seems that the iso is missing the wacom.ko tablets input driver:
Quote:
/lib/modules/4.9.101-stretch/kernel/drivers/input/tablet

acecad.ko: 8714 bytes
aiptek.ko: 23 K
gtco.ko: 13 K
hanwang.ko: 10 K
kbtab.ko: 8246 bytes
pegasus_notetaker.ko: 11 K
wacom_serial4.ko: 11 K


Nor in /lib/modules/4.9.101-stretch/kernel/drivers/hid

Only the wacom_serial4.ko is present which is needed only for serial connected tablets.

If I good remember the Dpup-Stretch 7.5 RC-2 kernel 4.1.48 came with wacom.ko as I have one currently running on another PC with a USB wacom tablet.
Checked on Dpup-Stretch 7.5 RC-3 kernel 4.1.48: wacom.ko is also missing (search using Pfind)

Tried to build the wacom.ko kernel module from here:
https://github.com/linuxwacom/input-wacom/wiki/Installing-input-wacom-from-source
Then failed to build of wacom.ko input-wacom-0.41 kernel driver (having previously loaded the devxXXX.sfs and kernel_sources-4.9.101-stretch):
the «./configure --prefix=/usr» step went well, but the «make» step reported the following error message:
Quote:
# make
make all-recursive
make[1]: Entering directory '/initrd/mnt/tmpfs/tmp/input-wacom-0.41.0'
Making all in 4.5
make[2]: Entering directory '/initrd/mnt/tmpfs/tmp/input-wacom-0.41.0/4.5'
Building input-wacom drivers for 4.5 kernel.
make -C /lib/modules/4.9.101-stretch/source M=/initrd/mnt/tmpfs/tmp/input-wacom-0.41.0/4.5
make[3]: Entering directory '/usr/src/linux'
/initrd/mnt/tmpfs/tmp/input-wacom-0.41.0/4.5/Makefile:14: *** You requested to build wacom with configure, but wacom is configured as built-in in your kernel config. Stop.
Makefile:1508: recipe for target '_module_/initrd/mnt/tmpfs/tmp/input-wacom-0.41.0/4.5' failed
make[3]: *** [_module_/initrd/mnt/tmpfs/tmp/input-wacom-0.41.0/4.5] Error 2
make[3]: Leaving directory '/usr/src/linux'
Makefile:27: recipe for target 'all' failed
make[2]: *** [all] Error 2
make[2]: Leaving directory '/initrd/mnt/tmpfs/tmp/input-wacom-0.41.0/4.5'
Makefile:371: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/initrd/mnt/tmpfs/tmp/input-wacom-0.41.0'
Makefile:302: recipe for target 'all' failed
make: *** [all] Error 2
#

So I gave up here as I could not fix the «...but wacom is configured as built-in in your kernel config. Stop.» issue.

Thanks for any advice.

Best regards
Charlie

last edited:
read this recent post in Wacom tablet thread (thanks to forum member don570)
http://murga-linux.com/puppy/viewtopic.php?p=969742#969742
don570 wrote:
...
I have noticed that wacom.ko is not inside some recent distros using the 4.9 kernel. This seems to be a bug.
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5147
Location: Ontario

PostPosted: Tue 24 Jul 2018, 19:43    Post subject:  

Quote:
I have noticed that wacom.ko is not inside some recent distros using the 4.9 kernel. This seems to be a bug.


Maybe the individual making the recipe for the kernel compiling made an unusual
setting??
_________________________________________________
Back to top
View user's profile Send private message 
radky

Joined: 02 May 2010
Posts: 820

PostPosted: Tue 24 Jul 2018, 23:55    Post subject:  

charlie6 wrote:
Quote:
trying to use a wacom tablet using Dpup-Stretch 7.5 RC-3 with kernel 4.9.101:
it seems that the iso is missing the wacom.ko tablets input driver:


Hi charlie6,

I have reviewed the prior Dpup Stretch RC-2 release (4.1.48 and 4.9.71) and it seems neither iso has the wacom.ko tablet input driver (same deficit as the RC-3 isos).

Is it possible you successfully compiled the wacom.ko driver in your working installation of RC-2?

It seems the devx generated by Woof-CE for Dpup Stretch is significantly smaller for RC-3 (109 Mb) than for RC-2 (146 MB), primarily due to fewer files in /usr/lib.

I don't know if the smaller devx has any impact on your inability to compile the wacom.ko kernel module in RC-3. but maybe you could try building again, using the larger RC-2 devx.

Thanks

_________________
PupMates
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1210
Location: Saint-Gérard / Walloon part of Belgium

PostPosted: Wed 25 Jul 2018, 11:50    Post subject:  

radky wrote:
...
I have reviewed the prior Dpup Stretch RC-2 release (4.1.48 and 4.9.71) and it seems neither iso has the wacom.ko tablet input driver (same deficit as the RC-3 isos).

Is it possible you successfully compiled the wacom.ko driver in your working installation of RC-2?
... you could try building again, using the larger RC-2 devx.


Hi radky,
thanks for your reply Smile
In my Strecth-4.1.48 RC-2 current install, I've found the wacom.ko driver «quite lost and lonely» among hid modules inside «zdrv_stretch_7.5.sfs/lib/modules/4.1.48/kernel/drivers/hid/wacom.ko»
See screenshot hereunder ...the «Last modifies date» is identical to other modules one...so I believe the date should be later if it were been built afterwards... Confused
Best regards
Charlie

Question:
Quote:
... you could try building again, using the larger RC-2 devx.

Would the larger RC-2 devx be compatible with the kernel-4.9.101 RC-3 system? Rolling Eyes
wacom(1).png
 Description   wacom.ko inside the /lib/modules/4.1.48/kernel/drivers/hid folder
 Filesize   42.55 KB
 Viewed   264 Time(s)

wacom(1).png

Back to top
View user's profile Send private message 
radky

Joined: 02 May 2010
Posts: 820

PostPosted: Wed 25 Jul 2018, 19:01    Post subject:  

charlie6 wrote:

In my Strecth-4.1.48 RC-2 current install, I've found the wacom.ko driver «quite lost and lonely» among hid modules inside «zdrv_stretch_7.5.sfs/lib/modules/4.1.48/kernel/drivers/hid/wacom.ko»

Hi charlie6 and don570,

Thanks for the correction. The wacom.ko module is indeed present in the 4.1.48 isos of RC-2 and RC-3, but not in the 4.9.71 (RC-2) or 4.9.101 (RC-3) isos.

However, after a slight change in the DotConfig parameters (CONFIG_HID_WACOM=m), a rebuild of the 4.9.101 kernel for RC-3 appears to generate the wacom.ko module. I don't have a Wacom Tablet to test, but maybe you could download the module and test in your installation of Dpup Stretch 4.9.101. Just remove the fake gz extension below and place the wacom.ko module in the following folder: /lib/modules/4.9.101-stretch/kernel/drivers/hid/

Edit:
Then run: depmod -a
(thanks rcrsn51).
wacom.ko.gz
Description  /lib/modules/4.9.101-stretch/kernel/drivers/hid/wacom.ko
gz

 Download 
Filename  wacom.ko.gz 
Filesize  110.48 KB 
Downloaded  32 Time(s) 

_________________
PupMates

Last edited by radky on Wed 25 Jul 2018, 19:47; edited 2 times in total
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12324
Location: Stratford, Ontario

PostPosted: Wed 25 Jul 2018, 19:31    Post subject:  

Then run: depmod -a
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 23 of 25 [374 Posts]   Goto page: Previous 1, 2, 3, ..., 21, 22, 23, 24, 25 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1034s ][ Queries: 12 (0.0243s) ][ GZIP on ]