Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 24 Mar 2018, 21:37
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
DELL Inspiron 600M with older parallel port floppy drive
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [16 Posts]   Goto page: 1, 2 Next
Author Message

Joined: 16 Aug 2009
Posts: 819
Location: Ann Arbor MI USA

PostPosted: Wed 14 Feb 2018, 17:47    Post subject:  DELL Inspiron 600M with older parallel port floppy drive
Subject description: Will older parport floppy drive work in 'newer' (2004) laptop?

I have several older DELL floppy drives (from Latitudes circa 1999-2001 in which they could be used internally instead of CD-ROM or second battery, or externally on a cable). I plugged one into a 2004 DELL Inspiron 600m and Wary puppy does not notice it.

Do I need to insert a module or is this simply hopeless?

I have two such laptops both with dead USB and it is inconvenient to load files via ethernet or wifi or parallel-cable transfer. (Large sfs and 2fs files do not transfer fully with wget either). I foolishly sold all my parport zip drives on ebay. The laptop would be ideal for use wiith XP and a DOS CAD program - are there parport floppy drivers for XP other than Backpack?

Apart from this everything works beautifully in Wary puppy and Lupu 2017 and Tahr - sound, wifi (on one, at 11MBps theoretical), video (ATI Radeon 9000). The 1.6GHz one plays youtube at 360p but the 1.5GHz is a bit jerky (with Palemoon SSE - the standard Palemoon lacks something needed). 768MB PC2700. Clear non-glare screen (1024x768) and mushy but functional keyboard.
Back to top
View user's profile Send private message 

Joined: 16 Jun 2008
Posts: 2280
Location: 500 seconds from Sol

PostPosted: Thu 15 Feb 2018, 00:57    Post subject: Does anyone know a command to tell what the OS sees?  

Hi Sindi,

First off, I'm a little confused about what's going on. As I've said elsewhere I think visually: I have to see the situation/problem.

The vision I have of your situation is that your computer has a parallel port (female end) into which you can plug either a floppy-drive or some other peripheral and that you've plugged a floppy drive (which has a 'male' end) into the port. Despite that connection, Wary doesn't see the floppy drive as available. Is that correct?

Before plugging something into it, I would think that the most an operating system could do is recognize it as an available parallel port. After something was plugged in, I would think that the OS might be able to recognize the nature of what's been plugged in. But to use it, perhaps even just to recognize it, the OS would have to have appropriate drivers and firmware. But that's a guess.

And I'm also guessing that there are probably some bash commands which might tell you what your OS sees. But bash requires me to speak its language, which I don't.

So, for now, maybe install the latest version of PupSysInfo, http://murga-linux.com/puppy/viewtopic.php?p=579411#579411, and check out what it reports with the port empty, and after you've plugged something in.

It's also possible that either port or the pluggable floppy drive is "dead".

Mostly, I'm posting to keep the thread alive in the hope that someone with greater knowledge may have an interest.

Back to top
View user's profile Send private message 

Joined: 16 Aug 2009
Posts: 819
Location: Ann Arbor MI USA

PostPosted: Thu 15 Feb 2018, 15:21    Post subject: parport floppy drive in wary 5.5
Subject description: gave up, using other file transfer methods instead

This is a standard DELL Latitude black plastic floppy drive that can plug into a laptop bay, or into the parallel cable that plugs into the back of the laptop.

Someone suggested modprobe parport_pc and parport_serial.
The computer finds the parallel port 0x378 irq7.
I think Wary is missing some driver. I did not try Puppy 4.

I found other file transfer solutions that require network connection.

mini_httpd (borrowed from another linux) - webserver
Turn off firewall on server, or set it to allow http connections.
cd to directory with files to share
Enter to get back the prompt

Then use wget or a browser to download the files.
(wget fails near the ends of large files)

When done

kill `pidof mini_httpd`

(Kill the process - or top to find the number and kill the number).

Upload files to some online storage, then download to the target computer. Requires internet connection.

ftp would also work but I did not figure out how to use it.

To transfer photos from a fancy new camera use wifi directly from camera to computer.

I have a parallel transfer cable which I used to use in DOS.
Has anyone used those in linux? I did not find my serial nullmodem cable but I have 9-pin to 25-pin adapters.

Today wifi no longer worked in my 600M (the slot appears to have failed - rfkill says it is not turned off) but a pcmcia card did. I even found the XP driver and my partner can now upload files to and from XP as well as between XP and linux. Two other identical or similar laptops also have failed USB ports and wifi slots. The USB ports are on the back and this pair feels loose so resoldering might be yet another fix.

I also found a parallel port 120MB Imation drive that I can test. It weighs more than a small new laptop.

And some place I have a pcmcia USB card that worked once in an older linux. Maybe puppy has the driver module for it.

The network transfer solution does not require extra hardware or drivers.
Back to top
View user's profile Send private message 

Joined: 13 Dec 2007
Posts: 61
Location: East Devon, GB

PostPosted: Thu 15 Feb 2018, 16:50    Post subject:  

I have an ancient (2000AD) Dell Latitude CPt S500GT laptop that works fine with a pmcia card type of USB adapter on every Puppy that I've had on this machine (and with Windows XP SP2 for that matter) so it's worth a try.

I obtained a couple of cheap unbranded pmcia/USB cards from Ebay and both worked straight away "out of the box" - every version 4 or 5 Puppy that I tried, (and I've tried more than a dozen on this machine) picked up the pmcia/USB card automatically without me having to do anything.

One of these Ebay cards was completely unlabelled. The other had a label on it that said "Cardbus USB:FB-204".

Hope this helps.


Back to top
View user's profile Send private message 

Joined: 16 Aug 2009
Posts: 819
Location: Ann Arbor MI USA

PostPosted: Thu 15 Feb 2018, 17:52    Post subject: pcmcia usb in puppy 5
Subject description: works!

Thanks very much for the encouragement. I found my two pcmcia USB cards with two slots each.
I recall using them in something so old it never had USB slots.

D-Link USB 2.0 DUB-C2 worked 'out of the box'. Pmount found sdb1.

The ADS USB Port for Notebooks gets power from the PS/2 port so I would need to turn off the
laptop to install it, but my note on it says 'works puppy 4'. The plastic casing is bulging
but it can be coaxed into the slot. Does not say USB 2.0.

I am testing with 'Kinda Lucid' on the second Dell Inspiron 600m. I put in my 30GB hard disk
from a failed D600 (bad USB, bad wifi slot, completely separated hinges, broken wire in power
jack area so it runs as 600MHz instead of 1.6GHz ), that came with XP, and XP surprisingly works
despite needing drivers for the modem and CD drive, even though the 600m is I think a year newer.
I read that since Windows 8 you cannot move Windows between identical models of computer.
I have on here various interesting early puppies - 4.3.2, Kinda Lucid, Pulp.

The wifi works, but in Windows XP found only two signals, neither of them mine.
Repeatedly. Odd. In Kinda Lucid it found my signal too.

I can use the D-Link USB card in the single PCMCIA slot, and internal wifi.
The other computer can use either pcmcia wifi (browsing) or pcmcia USB (with a non-wifi camera) at one time.

My partner likes some old non-widescreen DELLs (and a few TP, ACER and HP) for doing CAD because the dimensions are exact.
Widescreen and many narrow-screen ones distort drawings. These two are unusually new and fast and even do Youtube.

The ADS card has both male and female PS/2 ports so you can still plug in your PS/2 mouse or
keyboard. I have a splitter that lets me plug in both at a time. Luckily the keyboards and
touchpads work on both laptops.
Back to top
View user's profile Send private message 

Joined: 11 Oct 2009
Posts: 10196
Location: Charleston S.C. USA

PostPosted: Thu 15 Feb 2018, 18:54    Post subject:  

with older parallel port floppy drive

First, try to see what happens when the drive is plugged in and you boot Puppy from a could start.
Computer powered off, power on, boot up.

If no good.

Try one of the older Puppies.

Sorry, I am in a area of little knowledge, so only guessing.

The newer Puppies could have the kernel module for parallel ports not loaded.

menu>Boot Manager>Modules>Add new module

There are several listed that look like they could have something to do with parallel ports.
Maybe they would help.

Found this info that does seem to indicate you need the parport module loaded.
 Filesize   27.05 KB
 Viewed   112 Time(s)


I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 

Joined: 16 Aug 2009
Posts: 819
Location: Ann Arbor MI USA

PostPosted: Thu 15 Feb 2018, 21:29    Post subject: Parport floppy only works on oldest DELL laptops  

A web search on parallel
floppy DELL found that many
people tried to use floppy
drives from old DELL Latitude
CpX or 3000-4000 series DELL
laptops in newer laptops such
as D600 (similar to mine) and
the hardware/BIOS/firmware
does not support them. I
also proved this does not work
in Puppy 4.3.1. (And that
both Puppy 4.1.2 and Lucid
Puppy -5.1.1? - cause loud
continuous squealing on this
laptop, though Lucid 2016
works okay on the other 600m).

Compaq made external floppy
drives that connected via a
SCSI pcmcia card. I have
several scsi-looking cables
labelled HP and floppy with
small plugs that are not
parallel type. Probably
specific to certain floppy
drives and ports (on pcmcia
card or motherboard). This
made the laptops more portable
(before USB accomplished the
Back to top
View user's profile Send private message 

Joined: 16 Aug 2009
Posts: 819
Location: Ann Arbor MI USA

PostPosted: Fri 16 Feb 2018, 01:21    Post subject: getting camera files into a laptop without working USB
Subject description: via wifi and an iPad

Olympus camera does wifi file transfer, but ONLY using its app, to an android (OS 4.4 or later) or apple (iOS 9.3+) mobile device.

Not directly to a computer, as many annoyed owners discovered. One clever person wrote a script with wget to
collect files from the phone's IP addres but I could not figure it out. Someone put an android emulator on his laptop.

I tried an older version from 2013 on our newest android phone (OS 4.3) but it would not connect.
Luckily we have an iPad 3rd gen (iOS 9) and eventually transferred one photo to it.

Then downloaded the Olympus photo editor, which refused to let us produce a square cropped image.

Used the built-in photo editor to crop out a square, which without asking overwrote the original image.

Uploaded that image to online file storage and downloaded with Wary to the laptop.
Fastmail renames every uploaded image to image.jpg (or image[2].jpg if you tell it not to overwrite).
You can then edit the file name, each one individually.

The file shrank from 4000x4000 pixels to 2000x2000 pixels (1.3MB), as listed at fastmail.
This probably happened during transfer to the iPad.
This is an Olympus Share app to share photos, not a file transfer app.

Fuji shrinks photos above a certain size during wifi file transfer, we read.

* * * * *

We then tried to transfer the 1.3MB file directly from iPad to linux laptop via ftp or http.

Apple App store offers nothing with the word httpd or ftpd in it.

A search for FTP found several programs with no menus - blank white screens some with lines, and various mystery
'web servers'. No instructions - are they hidden some place?

Finally I found a PhotoServer for sharing photos with menu.

It says browse to (the IP number of the iPad).

Right click on the small image that appears and save image as.

We ended up with a much smaller photo (99KB) 256x256 pixels. Same size as it appeared on the screen.
Did PhotoServer shrink the file again or did we download the photo incorrectly?

Most people simply give up on the wifi and use a USB cable or SD card reader.
Back to top
View user's profile Send private message 

Joined: 12 Aug 2006
Posts: 2974
Location: Tamworth UK

PostPosted: Fri 16 Feb 2018, 08:05    Post subject:  

I used to have the same problem with my Dell 8400. I can't remember whether I solved it or not because I got hold of a docking station for it and the drive plugged into that.
"Just think of it as leaving early to avoid the rush" - T Pratchett
Back to top
View user's profile Send private message 

Joined: 12 May 2008
Posts: 1410
Location: N.E. USA

PostPosted: Fri 16 Feb 2018, 09:21    Post subject:  

One of the nice things you have in that old dinosaur is that PCMCIA slot. The original use for that slot was for Compact Flash cards (new ones run 600x, but yours will max out at 200x) ... Windows can boot from that slot, and so will Puppy as you have found using USB adapter.

If interested... CF is a little faster than USB2.0. Transcend has 133x CF-cards at reasonable prices, your choice ebay, amazon, or aliexpress. 2Gb or 4Gb only for that old machine. Check for fat16 or fat32 partitions in the hdd. fat32 =4Gb, fat16 =2Gb.


Linux user #498913

Good God!, by the stars in the sky we are lost!
And into the breach we got tossed!
And the world is comin' on fast! --Florence Welch
Back to top
View user's profile Send private message 
Mike Walsh

Joined: 28 Jun 2014
Posts: 3513
Location: King's Lynn, UK.

PostPosted: Fri 16 Feb 2018, 10:12    Post subject:  


Just FYI, if you want a PCMCIA wifi card that'll work with most Puppies OOTB, try one of these:-


A NetGear WPN-511 'RangeMax' PCMCIA wireless adapter card. It uses the venerable 'ath5k' kernel driver module, which seems to have been in the Linux kernel literally forever.

Although I'm in the UK, I looked it up on the US site for you.....so you've got a better idea of price.

I use one of these in a 15-yr old Dell Inspiron 1100, from 2002, and it's worked with every Pup I've ever tried on there.

Mike. Wink

If I've helped you.....please say 'Thanks'!

Back to top
View user's profile Send private message Visit poster's website 

Joined: 16 Aug 2009
Posts: 819
Location: Ann Arbor MI USA

PostPosted: Fri 16 Feb 2018, 11:23    Post subject: pcmcia cards in laptop with dead USB
Subject description: wifi and memory card readers

Thanks for the link to the $8 ath5k wifi card.

I forgot we used to have a pcmcia CF card reader. They are $4 on ebay. Some cameras from just a few years ago use CF

Ebay has $25 or so Mercedes Benz pcmcia sd card readers new from China (labelled Mercedes Benz)
and also $11 Vaio and $14 generic cards for notebooks and sewing machines (to add memory to them).

$35 gets you a 4 in 1 card reader including SONY memory stick and Olympus smart media.

Online research found that the Olympus image share app (which refuses to work on my Android 4.4 phone - will not connect,
nor will an Android 4.3 version on an Android 4.3 phone) only transfers jpeg not RAW files, and people complain you cannot
even use the remote control shutter feature to take RAW photos, which my partner and his daughter want to do. So it has
to be USB or SD card file transfer. If you take a RAW photo, the app converts it to jpeg before or as it transfers.

Someone wrote a java program for wifi file transfer that I have not tried.

We could transfer files via SD card to a different laptop with working USB and then directly or via online file storage
using wifi (or serial or parallel transfer cable....) to the dead-USB computer with the perfectly 4:3 screen where they
will be edited. wget has failed on 180MB files near the end (sfs or tgz). I could learn to set up ftp server.

The challenge is to use what we already have. We have LOTS of old laptops from 120MHz up.
Back to top
View user's profile Send private message 

Joined: 16 Aug 2009
Posts: 819
Location: Ann Arbor MI USA

PostPosted: Fri 16 Feb 2018, 22:58    Post subject: Photo editor that crops showing pixel size  

The pcmcia usb card works well (in linux and XP) and has two USB ports so I could in theory plug a USB wifi card into the second slot except none of the USB wifi cards I purchased cheap on ebay could be made to work with Lucid Puppy. Maybe a newer Puppy would work.

We want to upload both a full-size picture of bean pods and seeds, and a cropped portion of the same picture, both square . The camera will not crop square. Mtpaint is overkill. I installed fotoxx 5 in Wary puppy. It crops but does not show the size in pixels of the result and my dyslexic and somewhat obsessive partner insists on a completely square photo.

So I installed DPup and downloaded Photos 15 or 16, much larger and with no labels on the cartoonish menu choices. I had to specify which directory I was working in and where to put thumbnails,

I selected a photo and then clicked on the Trim/Rotate icon and it swapped to disk for at least 10 minutes then exited telling me not enough disk space and something about memory.

dmesg gives me pages and pages of 'Purging GPU memory'.
Perhaps recent fotoxx requires a video card with its own memory, not integrated 852GM chip in a computer where it probably shares the 1GB memory.

My partner finds Gimp overwhelming, so we booted XP to use Faststone free image viewer and editor. XP works immediately with the pcmcia wifi and usb cards. It also works (!) with a USB mouse plugged into the USB port in back, which somehow fixed itself. (Tarnish?).

Maybe the wifi slot is also okay and the card is bad (unlike DELLS D600, 600M, 8500, 8100 and a least one HP that I have used with bad wifi slots and usually also bad USB ports).

A pcmcia SD card reader may be faster than the USB 1.0 in this computer. But we have taken and edited only about 10 photos in a week.

Is there some simple linux photo/image editor that is less demanding of hardware and lets you make 256x256 pixel cropped squares?
Back to top
View user's profile Send private message 

Joined: 11 Oct 2009
Posts: 10196
Location: Charleston S.C. USA

PostPosted: Sat 17 Feb 2018, 03:10    Post subject:  

Already in Puppy.
Try Mtpaint.

That is all I use to edit images.

I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 

Joined: 16 Aug 2009
Posts: 819
Location: Ann Arbor MI USA

PostPosted: Sat 17 Feb 2018, 20:00    Post subject: mtpaint crops well  

Mtpaint has no crop in the menus but you can use the mouse to crop, displaying the pixel size of the
cropped area, then save the file under another name. Thanks.

Canon 'Camera Connect' (with a Canon camera) lets you take and probably move RAW files (not compressed to jpeg)
to an Android or iOS device. The app works on Android 4.4 (unlike the Olympus program). Someone suggested
running an Android emulator on a computer for direct wifi file transfer (assuming wifi works in the emulator).
There are several ways to move files from android device to computer (via cable or wifi).
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [16 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0760s ][ Queries: 12 (0.0182s) ][ GZIP on ]