Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 01 Sep 2014, 20:34
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
wireless / wifi cards confirmed to work in puppy - OLD LIST
Post new topic   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 5 of 13 [186 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, ..., 11, 12, 13 Next
Author Message
hornplayer

Joined: 29 Dec 2007
Posts: 1

PostPosted: Sat 29 Dec 2007, 20:58    Post subject: Networking
Subject description: Linksys wireless-G adapter
 

Computer Dell Inspiron 2500 model
Network card Linksys Wireless-G Notebook adapter 2.4GHz 802.11g
Model # WPC54G v2

Linux Puppy version 3.01

Puppy Hardware - Interfaces application read the
adapter as follows:

Texas Instruments ACX III 54 mbps wireless interface Vendor 104C Device 9066 Kernel module: ACX

Interface ONLY works with NO Encryption...I don't like that...Anyone have a solution?

Number two: When I tried to use ndiswrapper to load a .inf file called "lstinds.inf" I got the following messages:

bcmwl5 driver installed
istinds:invalid

The reason I used LSTINDS.INF file was from some information that this was the driver for this particular TEXAS chip...Apparently puppy linux v3.01 will not accept this module....Unless I am installing it wrong...

I have been a Puppy Linux user for only a week and much to learn...

Another problem: Computer Dell Inspiron B130...using a Dell Wireless 1470 dual band wlan mini-pci card...which has a BCM4318 chip made by Broadcom...I haven't been able to locate the proper driver to work with linux....I tried the module bcm43xxpci doesn't work...unless again I turn off the router's encryption codes....

So anybody out there in the world can give me some help would be greatly appreciated....
Back to top
View user's profile Send private message 
BlackWhizz

Joined: 25 Dec 2007
Posts: 13

PostPosted: Thu 17 Jan 2008, 13:19    Post subject:  

jonyo wrote:
BlackWhizz wrote:
The box of the card says its an E-Tech WL-101.

Thx for that info. Any detailed info can greatly help others with a search.

How do i get the info? I really want to help, but i dont know how?
Back to top
View user's profile Send private message 
Delboy

Joined: 30 Jan 2006
Posts: 33

PostPosted: Mon 04 Feb 2008, 09:05    Post subject:  

pg99 wrote:
Linksys WMP54G (v2) PCI card works well with Puppy 1.07/1.08/1.09 under ndiswrapper


I have just finished a full install and setup of NOP pUppy (based on 3.01 I believe) uisng my Linksys WPC54GS speedbooster card. Unlike several other distros (eg. Tinyme,Sam) the Broadcom chip driver supplied in this Puppy works properly loading it under Network Wizard and using ndiswrapper with the Linksys supplied windows .inf driver doesn't work ("driver invalid"). Great stuff! There is a fair bit of chat in other forums about the broadcom chip not quite working - Puppy works! Speed is good.
This card works well in other distros too using ndiswrapper.
I am using a cheap Micronet wireless and adsl router from Maplins in britain. This works brillaintly with wired ethernet connection into my main PC. box with several distros running live including Puppy.

_________________
Toshiba Portege 3440CT, 192mbRAM, 300mhz., 11.5" LCD wth Savage S3 IX MV graphics, Linksys WPC54G-S wireless card and Micronet ADSL2+ router on Tiscali UK.
Back to top
View user's profile Send private message 
Linus

Joined: 11 Feb 2008
Posts: 2

PostPosted: Mon 11 Feb 2008, 09:38    Post subject:  2WIRE 802.11g PCMCIA (PC Card) H/W Revision 0.3  

2WIRE 802.11g PCMCIA (PC Card) H/W Revision 0.3

I finally got this card to work.

Computer:

Compaq Presario 1200 Notebook
AMD K-6 498 Mhz Processor
Type 2 card bus
192 MB RAM

OS:

Puppy Linux 3.01

First I download and installed NDISWrapper-1.51.pet from here:

http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-4/ndiswrapper-1.51.pet

Then I downloaded the windows drivers from here:

http://www.2wire.com/pages/drvrs/twwgpc_2.3.1.3.exe

You can extract this exe with your archiver of choice.

Copy the WlanUIG.inf & the wlanCIG.sys into a separate folder that you will be able to browse to in Ndiswrapper later.

Now do a search for "prism54". I will edit this post later, but basically you need to remove (Move to another folder for safe keeping...do not delete) the prism54 wlan modules so that the network wizard won't automatically recognize your card as prism54 module.

Once you have moved it out of the 2.21.6.7 (or whatever I'll edit this later) folder......open up the network wizard and click on the Load Button.

Then Click on the "More" tab in the new screen that appears. Then click on NDISWrapper and drill down on the left to the folder where you saved WlanUIG.inf & the wlanCIG.sys. Select the WlanUIG.inf.

At this point, it should say:

wlanuig: driver installed
device (XXXX:XXXX) present (alternate driver: prism54)

Click finish.

Now click on the DHCP button if you have you ip address auotmatically assigned from the wireless access point. Otherwise click Static IP and set it up.

Now click on the "Wireless" button. Press the "Scan" button. Select you Access Point. Then click what type of encryption you have setup on your wireless access point (I clicked on WPA2, then entered my SSID and Passkey, changed the security to restricted and left the other selection on managed....unless you connect to you access point through another computer (Which is Ad Hoc) leave this setting as it's default.


My set up on the wireless was :

Wireless G Only

SSID Broadcast: Off

MAC ADDRESS Filtering ON

WPA-Pre Shared Key (WPA-PSK)

AES

9 alphnumeric passkey for testing purposes (I usually use a 63 random alpha-numeric characters (a-z, A-Z, 0-9) from https://www.grc.com/passwords.htm)

Hopefully this has worked for you.
Back to top
View user's profile Send private message 
howarddy

Joined: 13 Feb 2008
Posts: 5

PostPosted: Wed 13 Feb 2008, 21:24    Post subject: wireless / WiFi cards confirmed to work  

Interesting set of posts....

I am trying to get Puppy installed on an old Hitachi notebook with 128 MB of RAM and a 300 Mhz Pentium II chip.

I was mostly able to install AntiX Mepis but it complains a bit about the BIOS being pre-year-2000 [its 1998].

AntiX finds and automagically uses my older Zyxel wireless card. Just Boots.

Puppy does not see the card or the PCIMCA interfaces....

Is there a customization I need to perform to get the cardbus interface running??? Or should I try to load the cardbus modules from AntiX, after booting, to get the wireless card running.

Puppy takes up less RAM and look friendlier, so I'd prefer to get it running in the 2nd partition, perhaps as part of a dual boot setup.....
Back to top
View user's profile Send private message 
jonyo

Joined: 28 Dec 2006
Posts: 2727

PostPosted: Thu 14 Feb 2008, 09:34    Post subject:  

Got 12 hits with a search of Zyxel that might help. At a glance, didn't notice a pcmcia card though. A separate post in beginner section'd get way more attention. USB wifi dongle might be an option.

Lotsa pup friendly wifi gear are a snap to setup.

Last edited by jonyo on Fri 15 Feb 2008, 05:12; edited 1 time in total
Back to top
View user's profile Send private message 
howarddy

Joined: 13 Feb 2008
Posts: 5

PostPosted: Thu 14 Feb 2008, 17:28    Post subject: wireless / wifi cards confirmed to work in puppy
Subject description: WiFi and PCMCIA support
 

One part of the issue is support for older laptops.... Mine is 1998.

Its USB 1 or 1.1

Should I be using a back-dated version of puppy??
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5245
Location: Australia

PostPosted: Thu 14 Feb 2008, 20:10    Post subject:  

Check if the PCMCIA system recognises your device with these 2 commands -

cardctl status
cardctl ident

If you can't see the card listed, try resetting the PCMCIA interface, as explained here -
http://www.murga-linux.com/puppy/viewtopic.php?p=31707#31707
Back to top
View user's profile Send private message 
jonyo

Joined: 28 Dec 2006
Posts: 2727

PostPosted: Fri 15 Feb 2008, 14:05    Post subject:  

I'd pay close attention to anything tempestuous has to say. Your gear is fine (even live cd) with any 2xx series & maybe even 3. Usb 1.1 can work wifi with pup & I can recommend a few usb adapters that i've used.

Quickest way to go is pick & burn a few isos & fire them up live cd. So far I run almost all my pups live cd with save files to HD that have other OSs fully installed to HD & takes but a matter of minutes to set up good to go wifi.
Back to top
View user's profile Send private message 
howarddy

Joined: 13 Feb 2008
Posts: 5

PostPosted: Mon 18 Feb 2008, 04:05    Post subject: Wireless still not working
Subject description: no response from wireless card
 

Thanks for all the suggestions. They haven't helped, tho'

The cardctl status command show a 3.3V card, its ready but without details.

The cardctl ident command has empty strings.... there is no card info.

I also tried the reset options:

cardctl eject
cardctl insert

No luck so I added:

read PID</var/run/cardmgr.pid
kill $PID
sleep 3
cardmgr

I did notice that the link light had been flashing but the power light did not light. I tried a new Airlink WLC 3025, but there were no lights on that one

I am trying to install puppy to the hard disk, but the process seems to hang on the GRUB installation step.... The RAM indicator is flashing 48.0 K so I think I have too little RAM [125 MB reported].
Back to top
View user's profile Send private message 
RePete

Joined: 10 Jan 2008
Posts: 9

PostPosted: Wed 20 Feb 2008, 20:38    Post subject: Can't Get My Wireless To Work...  

Card is a Belkin F5D7010v7. Puppy version 3.01. I tried loading the drivers that came with the card in ndiswrapper, but Puppy still couldn't see the card, and said the drivers were wrong. Any suggestions? Thanks!
Back to top
View user's profile Send private message 
portly

Joined: 11 Mar 2008
Posts: 1

PostPosted: Tue 11 Mar 2008, 07:00    Post subject: finally got working !  

I'm now working wirelessly with the following set-up

Netgear MA101 USB

128-bit WEP

uname -a shows me the following;

Linux puppypc 2.6.21.7 #1 Sun Sep 9 02:29:54 GMT-8 2007 i686 AMD Athlon(tm) XP 2700+ AuthenticAMD GNU/Linux


the trick to getting this little puppy working was to choose a HEXADECIMAL key when I set up the router (A BT Voyager 2091) rather than using a passphrase. Although the setup wizard found teh network ok, it always failed to give me a DHCP address when I used teh passphrase ! Anyway, working now, so happy boy !

hope this information helps somebody


I will also try it out on my IBM Thinkpad 600 soon and post an update
Back to top
View user's profile Send private message 
ichido


Joined: 12 Mar 2008
Posts: 23
Location: Ohio, USA

PostPosted: Wed 12 Mar 2008, 17:27    Post subject: Belkin 54g PCMCIA  

Belkin 54g, PCMCIA, model F5D7011 with HSM, Version 1.0000.
This is running on my Dell Latitude C600, P-III 1002MHz, 515MB Shared RAM.
Using Puppy 2.15CE-final.
I am using the pci bcm43xx driver.
Back to top
View user's profile Send private message 
PageMaster


Joined: 25 Feb 2008
Posts: 15
Location: Ghedi, Brescia, Italy

PostPosted: Fri 14 Mar 2008, 03:58    Post subject:  

Dell 1390 miniPCI card, recognized as being a Broadcom 4311 card.

Puppy 3.01 on Compaq Presario V6131EU

It does NOT run with installed bcm43xx module, you must use ndiswrapper and producer's Windows bcmwl5.inf and bcmwl5.sys files.

_________________
"Computer is not an intelligent machine which helps stupid people, it is rather a stupid machine which runs only if used by intelligent people" - Umberto Eco, Italian philosopher and writer
Back to top
View user's profile Send private message 
jonyo

Joined: 28 Dec 2006
Posts: 2727

PostPosted: Fri 14 Mar 2008, 16:09    Post subject:  

How do you setup the bcmwl5.sys files? Reason i ask is i've only used the .inf file so far.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 5 of 13 [186 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, ..., 11, 12, 13 Next
Post new topic   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0984s ][ Queries: 12 (0.0151s) ][ GZIP on ]