Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 22 Apr 2018, 22:28
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Problems with installing cryptsetup
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
WIckedWitch

Joined: 29 Mar 2018
Posts: 32
Location: West Wales bandit country

PostPosted: Thu 29 Mar 2018, 18:54    Post subject:  Problems with installing cryptsetup
Subject description: After installing cryptsetup from ubuntu main repo, system no longer shuts down and hangs in limbo.
 

Newbie to the forum but with 43 yrs software engineering experience - so here goes:

Hardware: IBM ThinkPad R40e, 2.4 Ghz Celeron M, 1GB RAM, 160 GB IDE HDD

OS: tahrpup 6.0.5 PAE 32-bit

Was recently given the h/w and have put above OS on it.

PROBLEM:

I have installed python3, tk toolkit, gcc, gnat, sml and swi-prolog, and scrub. No problems after installing these with PPM.

If, however, I install cryptsetup from the ubuntu main repository, the package installation reports a missing library (libatm.so.1). Thereafter, if I shut down, the shut down fails and the computer ends in a kind of limbo state whence the only exit I've found is to press the power-down switch on the laptop. Thereafter it won't boot properly.

This is not an undue problem for me as I have cryptsetup on other machines. I'm just posting it here so people know about it. A fix would be great but not disastrous if not forthcoming.

Please advise of any fuller details that may be needed to resolve.

Happidaze,
The Wicked Witch

_________________
Sometimes I post mindfully, sometimes not mindfully, and sometimes both mindfully and not mindfully. It all depends on whether and when my mind goes walkies while I'm posting Confused
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1558
Location: Italy

PostPosted: Fri 30 Mar 2018, 00:36    Post subject:  

Cryptsetup requires a kernel support. I managed to install cryptsetup in precise and slacko 5.7 using the kernel of xenialpup but I have abandoned my experiments. I would suggest to switch the kernel and see if it ends up in a success.
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1558
Location: Italy

PostPosted: Fri 30 Mar 2018, 03:33    Post subject:  

I tried to install cryptsetup in tahr 6.0.6 with kernel from xenialpup: the dependent package upstart breaks the puppy's shutdown. Do not install it.
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1558
Location: Italy

PostPosted: Fri 30 Mar 2018, 03:59    Post subject:  

Success! I propose for testing the following procedure for tahr 6.0.6 (with kernel from xenialpup 7.5) and cryptsetup:

-install cryptsetup and all dependencies but upstart;
-copy from xenialpup in /sbin mount.crypto_LUKS and umount.crypto_LUKS;
-move in /usr/sbin the attached filemnt1 (a modded script from my experiments in precise) (remove the fake .gz);

-to mount a luks file:

Code:
filemnt1 /path-to/file-luks.4fs


-to unmount it open another console and again:

Code:
filemnt1 /path-to/file-luks.4fs
filemnt1.gz
Description 
gz

 Download 
Filename  filemnt1.gz 
Filesize  6.7 KB 
Downloaded  16 Time(s) 
Back to top
View user's profile Send private message 
WIckedWitch

Joined: 29 Mar 2018
Posts: 32
Location: West Wales bandit country

PostPosted: Thu 05 Apr 2018, 18:44    Post subject:  

Many thanks to you, watchdog. I've noted your method but now no longer need it as, among my hardly-ever-jettisoned kit, I have a ThinkPad R50e that runs Lubuntu 16.04 LTS well and that does not the cryptsetup problem.

The R40e is now running Win XP (vomit) for a small VBA job for a client but I'll put it back into tahrpup afterwards and try what you suggest.

Happidaze Smile

_________________
Sometimes I post mindfully, sometimes not mindfully, and sometimes both mindfully and not mindfully. It all depends on whether and when my mind goes walkies while I'm posting Confused
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0318s ][ Queries: 12 (0.0063s) ][ GZIP on ]