Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 20 Nov 2018, 03:31
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
XenialPup keyboard layout problem
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [12 Posts]  
Author Message
markwiering

Joined: 11 Oct 2015
Posts: 8

PostPosted: Fri 27 Apr 2018, 09:10    Post subject:  XenialPup keyboard layout problem
Subject description: XenialPup doesn't save keyboard layout
 

Hello there,

I have an extremely frustrating problem with XenialPup regarding the keyboard layout.

1. Every time I add as my keyboard layout "US - international with dead keys", it doesn't work. No matter what. I change it ten times in a row and restart X ten times in a row: nothing. It's still just the US keyboard layout, without the dead keys. All the while, when I try this in Tahrpup, everything works immediately. Why doesn't the keyboard layout "US internatoinal with dead keys" work with Xenialpup? The option is there, but it doesn't seem to do anything.

2. Every time I add "Russian" to the keyboard layout as the alternative keyboard layout, it works, at that time. After restarting X, it also works. However, after a computer reboot, the added Russian keyboard layout is gone. I then have to manually restore the Russian keyboard layout.

Why is that? Why do I have absolutely no possibility of using "US international with dead keys" ? And why doesn't the keyboard layout get saved? Why do I have to reconfigure my keyboard layout after EVERY boot-up?

Tahrpup doesn't have any of these problems, but XenialPup has. Why?

Is there a specific way to solve this in XenialPup? Or do I have to wait until the next update?
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11281
Location: Charleston S.C. USA

PostPosted: Fri 27 Apr 2018, 19:57    Post subject:  

See if this helps any.

There is a script in /startup/disabled called:

keyboardlayoutfix.

You just drag that to the startup directory.

Reboot so the change is saved and the script gets used on startup.

Does that fix it?

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11281
Location: Charleston S.C. USA

PostPosted: Fri 27 Apr 2018, 20:03    Post subject:  

Please, when you state a Puppy version.
Be very specific.
Xenialpup could be about 8 different versions.

I am assuming you are talking about xenialpup64 7.5

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
markwiering

Joined: 11 Oct 2015
Posts: 8

PostPosted: Sat 28 Apr 2018, 06:10    Post subject:  

Thank you, Bigpup! Smile

Yes, I am indeed using Xenialpup 7.5 64-bit.

Unfortunately, putting keyboardlayoutfix into /root/Startup only solved one of my problems. Now, after each boot-up, the keyboard variant "US international with dead keys" is being remembered, meaning that I can easily produce letters like é, ä, ô and č.

However, XenialPup 7.5 64-bit still forgets the alternative keyboard layout. I still have to manually add Russian to the keyboard layout after each boot-up. Also, after having added the Russian keyboard layout, XenialPup seems to forget the keyboard variant "US international with dead keys". When the Russian keyboard layout is added, I can switch between keyboard layouts, but I lose the possibility to produce letters like é, ä, ô and č in the US keyboard layout, since the dead keys are suddenly gone.

Is there also a way for XenialPup to remember alternative keyboard layouts after a reboot? And is there also a way to use multiple keyboard layouts without forgetting the keyboard variant of the first keyboard layout?

Because in Tahrpup, after each boot-up, I can switch between "US international with dead keys" and "Russian" with one button (Right Control), where the Scroll Lock LED starts shining when the Russian one is activated. I really like that system; switching between two keyboard layouts with just one button and even being informed by looking at my keyboard LEDs which one is active.

I wonder: why is all this functionality lost in XenialPup?
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11281
Location: Charleston S.C. USA

PostPosted: Sat 28 Apr 2018, 14:33    Post subject:  

As I understand it, that should have fixed the problem.

I put a post in the Xenialpup64 7.5 topic about your problem.
http://www.murga-linux.com/puppy/viewtopic.php?p=990092#990092
666philb (the developer of Xenialpup) should see it and hopefully he will have an answer for you or someone else may have more ideas.

A new version of Puppy never gets really bug tested until it is released and people start really using it.
Tahrpup was tested to the max and has been well used.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
markwiering

Joined: 11 Oct 2015
Posts: 8

PostPosted: Tue 01 May 2018, 04:33    Post subject:  

Thank you for reporting this problem to the person who made XenialPup64 7.5.

To summarise, my situation is as follows.
When I booted XenialPup, I added a keyboard variant (US international with dead keys), which did not work at all. Although it said that it was added, I still couldn't produce letters like é, ž, č, ô etcetera. Then I added the keyboard variant Russian, which did work. I could switch between two keyboard layouts, but without the dead keys in the US-layout, unfortunately.

However, after a reboot, the Russian keyboard layout was gone and I was stuck with only the default keyboard layout again (US), also without the dead keys, because they didn't work at all.

After moving keyboardfix from the disabled subfolder of /root/Startup into /root/Startup itself, one of the problems were solved. Now I could configure the keyboard variant "US international with dead keys" and it even remembered it after a reboot. Very Happy

However, the alternative keyboard layout, Russian, was still begin forgotten after every reboot. After each boot-up, I can use "US international with dead keys". However, whenever I manually load "Russian" as the alternative keyboard layout, XenialPup suddenly forgets the keyboard variant "US international with dead keys". Although I can switch between two keyboard variants, it's in once session only and I lose again the possibility to produce letters like é, č and ž until the next reboot. In the next reboot, "US international with dead keys" has been restored, but Russian is gone again. When I manually add it, the "US international with dead keys" is gone again.

I hope my bug report is clear. Smile
Back to top
View user's profile Send private message 
Auronius

Joined: 04 May 2018
Posts: 3
Location: Latvia

PostPosted: Fri 04 May 2018, 09:59    Post subject:  

I have similar problem, but with Latvian keyboard layout variants. Hope it will be fixed soon.
Back to top
View user's profile Send private message 
Auronius

Joined: 04 May 2018
Posts: 3
Location: Latvia

PostPosted: Sat 17 Nov 2018, 13:08    Post subject:  

Was this fixed or not?
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 12996
Location: Gatineau (Qc), Canada

PostPosted: Sat 17 Nov 2018, 15:25    Post subject:  

Hello all.

Puppy has an utility called chooselayout, at /usr/sbin, that does what
you need.

I am surprised to be the first to inform you.

Drag /usr/sbin/chooselayout to your desktop for easy access.
It forms an icon on the desktop.

Click on that icon every time you need to change your keyboard layout.

The change should be immediate. If not, type
Code:
killall X
(on some Puppies, X is called Xorg) --
or return to the initial black console and type xwin.

Either action reinitializes the X server and registers your new keyboard.

~~~~~~~~~
You can beautify this desktop icon by associating with it the image
at /usr/share/icons/Puppy Standard/48/devices/keyboard.svg.-

IHTH.

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 12996
Location: Gatineau (Qc), Canada

PostPosted: Sat 17 Nov 2018, 15:53    Post subject:  

Hello again

Puppy has another utility like the above called: xkbconfigmanager
It is a little more complex to use, but just follow the prompts.

This one offers access to more languages / keyboard layouts and to
some variants of them.

With this one, you can also ADD a keyboard. Just specify ADD instead
of CHANGE when asked.

Once your changes or additions are registered, I believe that you simply
need to hit the keys ALT+Shift at the same time to change between
keyboards.

I say "I believe" because i have not tested it myself. (No malice is
involved: I simply do not need to do this with my chosen keyboard.)
Some other experienced member please confirm?

I also vaguely remember that, on this bazaar of a forum, a member,
perhaps a century Wink ago, presented a tray icon to do exactly what you
guys need.

I will do some searching, but I will need help: the proverbial needle in
the hay stack is never easy to find!...

TIA.

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 12996
Location: Gatineau (Qc), Canada

PostPosted: Sat 17 Nov 2018, 16:32    Post subject:  

Hello again, guys.

I promise this is the absolute last post I will write in this thread!!! Wink
(I hear people in the crowd mumbling: "Yeah, sure...") Laughing

Come to think of it, I use the following script in /root/Startup to
activate my French Canadian (aka Quebec) keyboard.

I do not know the languages you guys use, which is why I am
providing this script verbatim.

As it is, it is designed for variants of the French keyboard, with an
option for Portuguese. But if you know Bash a little, it should not
be too difficult for you to modify it for your own language(s).
Code:
#!/bin/ash
# qc.sh
# IMPORTANT ###########################
# Objectif : activer le clavier Québec (dit "fr-legacy") ou
# un autre clavier francophone. /
#
# Goal: properly activate the "fr-legacy" keyboard or other Francophone keyboard.
# (The usual way was too iffy.)
#
# Note to Anglophones: since you don't need this, the script is made such
# that your keyboard set-up is not altered in any way.
#
# Persons speaking a language other than French or English : you may use the section
# "other_laguages_here" reserved expressly for you.
##########################################################################
# Dérivé d'une astuce de "Médor" sur le forum Puppy francophone vers le temps du
# premier jet. / Derived from a trick by Médor on the French side of the Puppy forum
# at the time of first writing.
#
# (c) Christian L'Écuyer (alias musher0 [forum PuppyLinux]), Gatineau (Qc), Canada, 12 mai 2013.
# Rév. : 26 déc. 2014; 16 janv., 3 févr., 1er mai 2016.
# GPL3
#### set -xe
case "${LANG:0:2}" in
   fr)case "${LANG:3:2}" in
      CA)Clav="qc" ;; # Vérifié
      FR)Clav="fr" ;; # Vérifié
#      CH)Clav= ;;
#      BE)Clav= ;;
      esac ;;
#   autres_langues_ici|other_languages_here)
#   pt)case "${LANG:3:2}" in
#      PT)Clav="?????????" ;;
#      BR)Clav="?????????" ;;
#   esac ;;
#   autres_langues_ici|other_languages_here)
#          ;;
esac

# setxkbmap -v 1 "$Clav" &>/dev/null
setxkbmap -model pc105 -layout ca -variant fr

# setxkbmap -option "terminate:ctrl_alt_bksp"
# Notes :
# -option compose:ralt (entre la commande et le param. -v )
# Ne pas utiliser. Prévient l'utilisation de AltGr + autre_touche...
#### set +xe

# /usr/share/X11/xkb/symbols/pc/qc
# OU
# /etc/X11/xkb/symbols/pc/qc
Please let me draw your attention to line 41:
Code:
setxkbmap -model pc105 -layout ca -variant fr
You should be able to replace ca and fr with positional parameters,
so that you have
Code:
script $1 $2
$1 being the variant
$2 being the layout
(Please forgive me in advance, I do not know Russian at all, so this
example will look completely silly to you)
Code:
script vladivostok ru
which will be activated as:
Code:
setxkbmap -model pc105 -layout $2 -variant $1
(Assuming that a variant of Russian is spoken/written in Vladivostok,
[probably not] with perhaps different written accents, etc.)

I hope you get the idea. There are tentative examples for French and
Portuguese within my original script.

Once adapted, you should be able to run that script in console or
perhaps through a YAD dialog (if you know how to program such
dialogs) to change keyboards "on the fly".

IHTH. Good luck!

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11281
Location: Charleston S.C. USA

PostPosted: Sun 18 Nov 2018, 11:36    Post subject:  

Try this.
/etc/X11/xorg.conf
Open xorg.conf in text editor.
Go to the keyboard inputdevice section and remove the # from the beginning of any entry line.
Save changes.

Make section of xorg.conf look like this:

Example of my setup:
Code:
Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
   Option      "XkbRules" "xorg"
   Option      "XkbModel" "pc102" #xkbmodel0
   Option      "XkbLayout" "us" #xkeymap0
   Option      "XkbVariant" "" #xkbvariant0
   Option      "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [12 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0786s ][ Queries: 11 (0.0095s) ][ GZIP on ]