Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 21 Mar 2019, 11:35
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Error when starting Audacity 2.1.2-1
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
soniabu


Joined: 01 Feb 2018
Posts: 56
Location: Paris

PostPosted: Wed 26 Dec 2018, 15:40    Post subject:  Error when starting Audacity 2.1.2-1  

I have this problem with Audacity 2.1.2-1 with Xenialpup64 7.5
when I launch it a box comes out with this message:

../include/wx/strvararg.h(456): assert "(argtype & (wxFormatStringSpecifier<T>::value)) == argtype" failed in wxArgNormalizer(): format specifier doesn't match argument type

and I can only stop Audacity, so it won't start.
Can anyone suggest a way forward for me?
Thank you
Sonia

Last edited by soniabu on Thu 27 Dec 2018, 12:20; edited 1 time in total
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1780
Location: Italy

PostPosted: Wed 26 Dec 2018, 18:25    Post subject:  

Audacity-static-1.3.12.pet by mikeb still works in a lot of puppies:

http://www.murga-linux.com/puppy/viewtopic.php?t=85629

Audacity-2.2.2-s-i686.pet by norgo also works in xenialpup after installing libpng16 by ppm and with a symlink:

Code:
ln -s /usr/lib/libFLAC.so.8.3.0 /usr/lib/libFLAC++.so.6


http://murga-linux.com/puppy/viewtopic.php?p=985089#985089
Back to top
View user's profile Send private message 
soniabu


Joined: 01 Feb 2018
Posts: 56
Location: Paris

PostPosted: Thu 27 Dec 2018, 12:09    Post subject:  

Thank you for your answers, Watchdog.. But with Audacity I'm a little unlucky.
Audacity 1.3.12 static I have installed. I have to start it from the terminal, however, and it returns this error:
error while loading shared libraries: libgtk-x11-2.0.so.0: wrong ELF class ELFCLASS64
and I'm stopping here because I don't understand it.

****

I also tried with audacity 2.1.2 s-i-686 and, always started from terminal, the error is similar to the previous one that is:
error while loading shared libraries: libsndfile.so.1 wrong ELF class: ELFCLASS64
I have installed libsndfile 1_1.0.25

I still use your courtesy to ask you if you know how to show me a way to solve it.
Sonia
P.S. My S.O is xenialpup64 7.5; second I do not understand:

with a symlink
Code: ln -s /usr/lib/libFLAC.so.8.3.0 /usr/lib/libFLAC++.so.6

many thx Watchdog
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1780
Location: Italy

PostPosted: Thu 27 Dec 2018, 14:30    Post subject:  

I see you are using xenialpup64: this is a misunderstanding. My first answer was related to xenialpup 32 bit. In 64 bit puppies I still use audacity-quirky64-2.1.pet. I do not remember who compiled it but I saved a copy. It works in 64 bit puppies with few more libs or symlinks. Read:

http://www.murga-linux.com/puppy/viewtopic.php?p=983804&sid=14648eee7cf928e19a6a349cf23b0563

and:

http://murga-linux.com/puppy/viewtopic.php?t=111056&sid=b03f91dcdf675823b01ad57cb27a1ec9

I'm sure it works also in xenialpup64. Wait for my testing. I'll edit this post as soon as possible.

Edit: download audacity-quirky64-2.1.pet from:

http://murga-linux.com/puppy/viewtopic.php?p=961067#961067

Install it. Open a console and type:

Code:
ln -s /usr/lib/libvpx.so.3.0.0 /usr/lib/libvpx.so.1


Start audacity in multimedia menu. Summarily tested working in xenialpup64.
Back to top
View user's profile Send private message 
soniabu


Joined: 01 Feb 2018
Posts: 56
Location: Paris

PostPosted: Thu 27 Dec 2018, 18:02    Post subject:    

Watchdog, FANTASTIC! WORK.

you were very kind and professional. You solved my problem brilliantly and I am very grateful for that.
I would like to be able to help others as well as you did me. Thanks Watchdog, I hope that one day I will be able to repay myself.
sonia
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1780
Location: Italy

PostPosted: Fri 28 Dec 2018, 23:01    Post subject:  

Sorry: audacity-quirky64-2.1.pet breaks SimpleGTKRadio and mpv overwriting libva.so.1:

http://www.murga-linux.com/puppy/viewtopic.php?t=115000

I have a package audacity-quirky64-2.1-2.pet without libva.so.1 which keeps working audacity in xenialpup64 without breaking mpv and SimpleGTKRadio. But I do not share it because they are experimental packages.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0348s ][ Queries: 11 (0.0043s) ][ GZIP on ]