Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 26 Mar 2019, 12:29
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Audacity and libneon.so.27
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
Scott99

Joined: 21 Feb 2016
Posts: 62

PostPosted: Sun 03 Feb 2019, 10:49    Post subject:  Audacity and libneon.so.27
Subject description: missing shared library
 

Hello, I am running the current version of Slacko puppy on an ancient panasonic cf-28. I just attempted to install Audacity via the package manager and received the message that I am missing the shared library libneon.so.27. Can someone please help me solve this? Please let me know if you need any additional information. Thanks, Scott
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 3046
Location: 500 seconds from Sol

PostPosted: Sun 03 Feb 2019, 11:30    Post subject:  

Hi Scott99,

Which of the half-dozen or so Slackos? Always be specific. Slackos are built using Slackware binaries and Slackware doesn't use version names, just numbers. The Puppy Package Manager of your Puppy accesses the 'correct' repositories for its version, assuming those repos still exist. pkgs.org maintains links to repos of packages built for Slackware versions 13.37, 14.0, 14.1 and 14.2.

Sometimes it is possible to use libraries from newer or older versions of slackware by creating a symbolic link to it and giving that link the name your application is looking for. But I can't point you to any slackware version of libneon.so.27 because pkgs.org's search engine shows none for any version of Slackware. Googling "libneon.so.27 slackware" also found no results.

Sometimes its possible to use a library from a different Linux --say Ubuntu Trusty Tahr in Slackware 14.0-- but frequently the attempt fails: the packages have the proper name but were compiled with different constructions and dependencies.

pkgs.org's search box finds versions of Audacity for each of the above listed Slackware versions. So, my best guess is that slackware builds audacity without a libneon library and that you've tried to install an Audacity version built for a non-slacko Puppy.

My recommendation is to uninstall your current version of Audacity, and try any of those which this dedicated puppy google search engine finds, https://cse.google.com/cse?cx=015995643981050743583%3Aabvzbibgzxo&q=#gsc.tab=0 when you include both search terms "audacity slacko". I note that it finds several.

Also suggest you bookmark the search engine: its impossible to memorize and very difficult to find.
Back to top
View user's profile Send private message 
norgo


Joined: 13 Nov 2015
Posts: 313
Location: Germany

PostPosted: Sun 03 Feb 2019, 11:46    Post subject: audacity  

How about

this:
audacity-2.1.2-s-i686.pet (Slacko 630)
or this:
audacity-2.2.2-s-i686.pet (Slacko 700)
Back to top
View user's profile Send private message Visit poster's website 
Mike Walsh


Joined: 28 Jun 2014
Posts: 4743
Location: King's Lynn, UK.

PostPosted: Tue 05 Feb 2019, 08:33    Post subject:  

@ Mike/Scott99:-

While I agree with Mike that pkgs.org doesn't return anything for 'libneon' in Slackware, I find that you usually need to cast your net a wee bit wider on that site. It's often a waste of time only looking in the 'proper' place for what you want...!

Dynamic libraries are a case in point. For a given architecture, they will work anywhere. .txz, .deb, .rpm, .pet.....these are all simply packaging conventions. It's the contents of the package we're interested in, and, regardless of the suffix attached thereto, invariably they're all the same item 'under the hood' (for any given version).

------------------------------------------------

@ Scott99:-

If you still want to try this particular route, I've attached a .pet package for libneon.so.27. Maybe it'll help.There again, it might send you off on an extended 'lib-chase'.....

Up to you, of course. It may simply be easier, in the long run, to try one of norgo's packages; they usually work pretty well!


Mike. Wink
libneon27-0.29.6-i686.pet
Description  32-bit Neon libraries....
pet

 Download 
Filename  libneon27-0.29.6-i686.pet 
Filesize  75.11 KB 
Downloaded  19 Time(s) 

_________________
My 'Puppy' Packages
--------------------------------------

Back to top
View user's profile Send private message Visit poster's website 
night flight

Joined: 19 Feb 2019
Posts: 9
Location: Northern Germany

PostPosted: Sat 16 Mar 2019, 08:28    Post subject:  

Dear Mike Walsh, thank you very much for this PET. It enabled me to get external access via WebDAV, on Slacko 5.7, in combination with the old davs2-1.4.6-i486.pet that plinej created 2012 for access to box.com. First, I tried to use his libneon-27.2.6.pet, too, but it led to the error message "SSL disabled due to library version mismatch". So I was lucky to find your PET dated 2019. And both PETs do work together! Very Happy
_________________
I use a Lenovo IdeaPad S10-2, built in 2009. I love it. My Slacko 5.7 (32 Bit) is on a 10 GB SD Card. So I can boot it everywhere (Smartphones excluded Razz ).
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0319s ][ Queries: 12 (0.0040s) ][ GZIP on ]