Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

READ-ONLY-MODE: PLEASE DO NOT POST NEW STUFF!
  New Forum: http://puppylinux.rockedge.org
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 11 Aug 2020, 15:05
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Precise-light - 17March2019 - for older hardware
Moderators: Flash, JohnMurga
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 32 of 34 [507 Posts]   Goto page: Previous 1, 2, 3, ..., 30, 31, 32, 33, 34 Next
Author Message
perdido


Joined: 09 Dec 2013
Posts: 1601
Location: ¿Altair IV , Just north of Eeyore Junction.?

PostPosted: Wed 19 Feb 2020, 16:35    Post subject: Re: install modem wifi  

theeastsun wrote:
how to install a wifi modem


Hi theeastsun,

Modem? or wifi adapter?

.
Back to top
View user's profile Send private message 
theeastsun

Joined: 18 Feb 2020
Posts: 13

PostPosted: Wed 19 Feb 2020, 19:59    Post subject:  

problem solved,thanks
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 2626

PostPosted: Thu 20 Feb 2020, 01:56    Post subject:  

Another package that we need to block is "upstart". This package installed via a dependency of something that I installed. It replaced the puppy script at /sbin/init

I think this is why my save file was having syncing issues on switchroot. Related packages that we might also want to block are sysv-rc and sysvinit. Both of these packages installed as a dependency but I'm not sure yet if they cause any problems.

Edit: Verified that at least one youtube video plays on firefox 52. I don't know if all youtube formats will work for me yet.

_________________
Find me on minds and on pearltrees.

Last edited by s243a on Thu 20 Feb 2020, 02:15; edited 3 times in total
Back to top
View user's profile Send private message Visit poster's website 
s243a

Joined: 02 Sep 2014
Posts: 2626

PostPosted: Thu 20 Feb 2020, 02:10    Post subject:  

s243a wrote:

I was able to install firefox_52.0.2+build1-0ubuntu0.12.04.1 with precise light running in a sandbox (using psandbox), over an ssh connection using pkg. I tested that firefox would start up properly using X11 forwarding but I didn't test it further.

Code:

pkg --repo precise-updates
pkg --get firefox_52.0.2+build1-0ubuntu0.12.04.1


For instructions on how to run a puppy in a sandbox over ssh see: SSH/sandbox/chroot folder

I tried rebooting with my save file and I got a kernal syncing error after selecting the save file. I think that perhaps I have to delete some files from my save folder. I think that puppies remaster script will give me clues on which files to delete.

P.S. I might re-consider the fallback order for precise-updates. I'm wondering if for precise-updates if the newer repos (e.g. precise-backports) should be checked first. Needless to say installing firefox worked with the current fallback order .

P.S. #2 The command "pkg --repo precise-updates" changes the ~/.pkg/pkgrc file to match the info about precise-updates.


I can verify that firefox 52 is working. I'm posting from it now. I was able to sucesfully boot the computer via the save file I created in the sandbox. The only problem, that I know about was that upstart, seems to have gotton installed as a dependecy. This overwote /sbin/init (see post)

Prior to doing this I tried some other fixes like creating a basic save file and overwriting some files based on this save file and I also tried cleaning up some stuff that I thought might be sandbox related. I don't think these failed atempts at solving my sync issue are relevant but are probably usefull for other applications so I'll post about them later.

I only so far tested firefox 52 on this forum. I'm not ready to surf the web with it yet because I don't know how god it's security is...on second thoughts, maybe I'll give youtube a try.

Edit: Verified that at least one youtube video plays on firefox 52. I don't know if all youtube formats will work for me yet. Facebook also works Smile

_________________
Find me on minds and on pearltrees.
Back to top
View user's profile Send private message Visit poster's website 
jrb


Joined: 11 Dec 2007
Posts: 1539
Location: Smithers, BC, Canada

PostPosted: Fri 21 Feb 2020, 00:54    Post subject:  

s243a wrote:
I can verify that firefox 52 is working.
OK, I finally got PortaBrowseInstall up to date and working for Precise-light. The Seamonkey website had changed and the latest Firefox Quantum no longer works in Precise-light.

I rejigged things to download and install the latest Firefox ESR which is at 68.5 and Fredx181's ff32-additions.tar.gz which enables sound. The ESR's change once a year or so but for now its working quite well.

Give it a try. Let me know of any bugs. I'll include this in the next update but there are some things I want to add before then.

Enjoy, J
PortaBrowseInstall-i386-0.5A.pet
Description  Portable browsers for Precise-light
pet

 Download 
Filename  PortaBrowseInstall-i386-0.5A.pet 
Filesize  21.28 KB 
Downloaded  194 Time(s) 
Back to top
View user's profile Send private message 
nic007


Joined: 13 Nov 2011
Posts: 3444
Location: Cradle of Humankind

PostPosted: Fri 21 Feb 2020, 20:50    Post subject:  

Where can I download the small glibc2.20 package that is built into Precise Lite?
_________________
nicOS-Utility-Suite
Back to top
View user's profile Send private message 
jrb


Joined: 11 Dec 2007
Posts: 1539
Location: Smithers, BC, Canada

PostPosted: Fri 21 Feb 2020, 20:56    Post subject:  

nic007 wrote:
Where can I download the small glibc2.20 package that is built into Precise Lite?
http://distro.ibiblio.org/quirky/quirky6/x86/packages/pet_packages-april/glibc-2.20.pet. This is one of Barry K's packages. Many thanks to him.
Back to top
View user's profile Send private message 
nic007


Joined: 13 Nov 2011
Posts: 3444
Location: Cradle of Humankind

PostPosted: Fri 21 Feb 2020, 21:10    Post subject:  

Thanks, jrb.
_________________
nicOS-Utility-Suite
Back to top
View user's profile Send private message 
theeastsun

Joined: 18 Feb 2020
Posts: 13

PostPosted: Fri 21 Feb 2020, 23:04    Post subject: ask firefox  

sorry,where can i download the latest firefox pet for precise light,thanks
Back to top
View user's profile Send private message 
jrb


Joined: 11 Dec 2007
Posts: 1539
Location: Smithers, BC, Canada

PostPosted: Fri 21 Feb 2020, 23:40    Post subject: Re: ask firefox  

theeastsun wrote:
sorry,where can i download the latest firefox pet for precise light,thanks
Here or direct download Here

Edit: Sorry for the brief reply, I was on my way to bed. As I mention above, at present the very latest Firefox is not working in Precise-light so I switched the PortaBrowseInstaller over to Firefox ESR which is a long term support version.

If you want a language other than English you can go to https://www.mozilla.org/en-US/firefox/all/#product-desktop-esr and download the 32bit version in a language of your choice. You will also need:
Code:
wget --no-check-certificate "https://dl.dropboxusercontent.com/s/3rn1a4e4scmfdyv/ff32-additions.tar.gz?dl=1" -O ff32-additions.tar.gz
which is fredx181's apulse package for sound. It needs to be extracted and placed in the same folder with the Firefox files.

You could also install PortaBrowseInstaller and then modify /usr/local/PortableBrowserInstaller/ffesrportable-inst line 49. Change "FFLANG=en-US" to the language of your choice. Sorry I don't know all the language codes. PortaBrowseInstaller is on the Setup Menu.

I am presently working on getting the latest Firefox Quantum working again in Precise-light. It requires some upgrades from Tahrpup and I'm sorting that out now.

Edit2: Language codes and Firefox-esr available at https://ftp.mozilla.org/pub/firefox/releases/68.5.0esr/linux-i686/
Back to top
View user's profile Send private message 
theeastsun

Joined: 18 Feb 2020
Posts: 13

PostPosted: Tue 25 Feb 2020, 06:55    Post subject: ask flash player  

sorry,where can i download the latest flash player for precise light,thanks
Back to top
View user's profile Send private message 
jrb


Joined: 11 Dec 2007
Posts: 1539
Location: Smithers, BC, Canada

PostPosted: Tue 25 Feb 2020, 11:12    Post subject: Re: Update to Precise-light Mk2.3  

OK, The latest Firefox wasn't working in Precise-light so I managed to get that fixed by swapping in some Tahrpup-6.0.5 libs. Very Happy Precise-light is even more of a mongrel now. Surprisingly the new libs make Vivaldi and Iron work as well, coincedence or conspiracy? Wink

I've just uploaded precise-light-5.7.2-mk2.0.iso___precise-light-5.7.2-mk2.3.iso.delta - 32Mb - md5sum 875869f3cea2facb37cca052203cfded

If you have Mk2.0 just download the .delta and:
jrb wrote:
Put the original precise-light-5.7.2-mk2.0.iso file and the precise-light-5.7.2-mk2.0.iso___precise-light-5.7.2-mk2.3.iso.delta file in the same directory.
Click once on the .delta file and then click "Generate" and its a done deal. Cool
Whats fixed:
    All the previous fixes
    ca-certificates updated (eliminates need for --no-check-certificate)
    pmusic radio stations screened to include only ones that work (.mp3 $ .m3u)
    Flash Player Updater 1.9_1 working
    PortaBrowseInstall included with these latest browsers working:
    Firefox ESR
    Firefox Quantum
    Vivaldi
    Iron
    Seamonkey
    Palemoon
    Thunderbird
If you install Frisbee from PPM make sure you rename /usr/sbin/connectwizard_2nd-orig to /usr/sbin/connectwizard_2nd to put Frisbee on the connectwizard menu.

This is a MAJOR IMPROVEMENT which I hope will extend Precise-lights working life for several more years!!!

Enjoy, J

Note: Sorry no ISO upload, but it took 1 1/2 hours just to upload the .delta. Life in the bush. Rolling Eyes
Back to top
View user's profile Send private message 
jrb


Joined: 11 Dec 2007
Posts: 1539
Location: Smithers, BC, Canada

PostPosted: Tue 25 Feb 2020, 11:17    Post subject: Re: ask flash player  

theeastsun wrote:
sorry,where can i download the latest flash player for precise light,thanks
I strongly suggest using the update in the post above and then going to Menu->Internet->FlashPlayerUpdater.

You could also download FlashPlayer_updater-1.9_1-Redux.pet and use it in any Puppy.
Back to top
View user's profile Send private message 
theeastsun

Joined: 18 Feb 2020
Posts: 13

PostPosted: Thu 12 Mar 2020, 08:23    Post subject:  

jrb wrote:
Put the original precise-light-5.7.2-mk2.0.iso file and the precise-light-5.7.2-mk2.0.iso___precise-light-5.7.2-mk2.3.iso.delta file in the same directory.
Click once on the .delta file and then click "Generate" and its a done deal.


I installed via USB but failed:

could not find kernel image: vesamenu.c32

help me,thanks
Back to top
View user's profile Send private message 
jrb


Joined: 11 Dec 2007
Posts: 1539
Location: Smithers, BC, Canada

PostPosted: Thu 12 Mar 2020, 10:10    Post subject:  

theeastsun wrote:
jrb wrote:
Put the original precise-light-5.7.2-mk2.0.iso file and the precise-light-5.7.2-mk2.0.iso___precise-light-5.7.2-mk2.3.iso.delta file in the same directory.
Click once on the .delta file and then click "Generate" and its a done deal.


I installed via USB but failed:

could not find kernel image: vesamenu.c32

help me,thanks
Does your USB install have these files:
    initrd.gz
    puppy_precise_light-5.7.2.sfs
    vmlinuz
    zdrv_precise_light-5.7.2.sfs
    menu.lst
menu.lst should not be in a seperate folder. The others may be.

What does your menu.lst say? Here's mine:
Code:
title 0_puptest2
  uuid 68ec550b-e5ce-477b-a83f-d275f32dfe74
  kernel /0_puptest2/vmlinuz net.ifnames=0 pdrv=68ec550b-e5ce-477b-a83f-d275f32dfe74 pmedia=ataflash psubdir=/0_puptest2 pfix=fsck
  initrd /0_puptest2/initrd.gz
Yours will be different. Please copy it and show us.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 32 of 34 [507 Posts]   Goto page: Previous 1, 2, 3, ..., 30, 31, 32, 33, 34 Next
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0656s ][ Queries: 12 (0.0044s) ][ GZIP on ]