Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 11 Dec 2019, 05:57
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
How to Uninstall Libre Office 6.1.0.3?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
pp4mnklinux


Joined: 23 Aug 2013
Posts: 363

PostPosted: Mon 14 Oct 2019, 01:38    Post subject:  How to Uninstall Libre Office 6.1.0.3?  

Hello everybody:

I have got a problem with the installation of Libre Office 6.3

I installed it without problems, but now both coexists so I want to uninstall the 6.1.0.3 version, but I can't find it at the puppy package manager.


How can I unistall this version (wich comes preinstalled with my original puppy?


Thanks a lot for your help.

(I solved the problem configuring the default associations to open .doc with open office 6.3, but I wanna know how to uninstall the previous version... in case I need to to this other day.- THANKS)

_________________
Distro: xenialpup64 7.5 XXL
Desktop Panel: JWM ~ FbBox 5.0
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 12986
Location: S.C. USA

PostPosted: Mon 14 Oct 2019, 06:54    Post subject:  

Quote:
How can I unistall this version (wich comes preinstalled with my original puppy?

menu>Setup>Remove Builtin Packages

Builtin packages are in the main Puppy sfs that is read only.
So nothing can actually be removed from it.
Remove builtin packages will white-list the package.
To the system, it will be invisible like it was not there.

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer)
Back to top
View user's profile Send private message 
pp4mnklinux


Joined: 23 Aug 2013
Posts: 363

PostPosted: Mon 14 Oct 2019, 11:20    Post subject: Thanks, but...  

Thanks a lot , but I went to this program (Remove....) and libre office doesn't appears as it.

It's possible people who know a lot a about libre office know what are the programs it includes, but for me it's imposible to unninstall.

Is there other way to do this?

or... can you tell me what programs must I unnistall?


THANKY

_________________
Distro: xenialpup64 7.5 XXL
Desktop Panel: JWM ~ FbBox 5.0
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 3544
Location: 500 seconds from Sol

PostPosted: Mon 14 Oct 2019, 12:20    Post subject:  

Odd that Remove Builtins doesn't show the Libre 6.1.0.3 package. But as Bigpup pointed out Remove Builtins would not have actually removed it, just white-listed the package. To remove the Menu Listing, you can file-browse to /usr/share/applications and delete the unwanted LibreOffice desktop files. All those will have the designation 6.1.0.3 in their names.

Those files are actually symbolic links to files in /opt/libreoffice6.1.03/share/xdg. So, rather than deleting them, you can open the desktop files in .../xdg in a text editor and change their categories to ones which Puppy doesn't recognize. For example just adding a "z" to the beginning of whatever Category name appears: e.g., Categories=RasterGraphics to Categories=zRasterGraphics.

Easier still if your Puppy uses radky's jwmdesk manager. You'll probably find the application Menu>Setup>Menu Manager Edit the Menu. Open it and select the unwanted Libreoffice listings. You'll see either a red or green radio button. It's a toggle: clicking a green button turns it red and hides the listing. [What the toggle does is to either write or delete the argument "NoDisplay=true" in the desktop file].

Devs creating Puppies should never include LibreOffice. The organization which creates it, surprisingly Very Happy, often improves it. For example, the 6 Series, 'though taking up slightly more disk space, actually uses less RAM. Users will frequently want to upgrade. Including LibreOffice just wastes space and transmission resources.

Along the same lines, Users should prefer SFSes to pets. SFSes require no space in SaveFiles; use less RAM when not open; and provide for an easier upgrade. While an installed pet may overwrite the files of a different installed version, SFSes don't. If there's a problem with the last SFS loaded you can easily unload it and re-load the previous version.
Back to top
View user's profile Send private message 
pp4mnklinux


Joined: 23 Aug 2013
Posts: 363

PostPosted: Mon 14 Oct 2019, 14:29    Post subject: THANKS A LOT  

THANKS A LOT.... I'll try next weekend.

Have a nice day, my friend.

mikeslr wrote:
Odd that Remove Builtins doesn't show the Libre 6.1.0.3 package. But as Bigpup pointed out Remove Builtins would not have actually removed it, just white-listed the package. To remove the Menu Listing, you can file-browse to /usr/share/applications and delete the unwanted LibreOffice desktop files. All those will have the designation 6.1.0.3 in their names.

Those files are actually symbolic links to files in /opt/libreoffice6.1.03/share/xdg. So, rather than deleting them, you can open the desktop files in .../xdg in a text editor and change their categories to ones which Puppy doesn't recognize. For example just adding a "z" to the beginning of whatever Category name appears: e.g., Categories=RasterGraphics to Categories=zRasterGraphics.

Easier still if your Puppy uses radky's jwmdesk manager. You'll probably find the application Menu>Setup>Menu Manager Edit the Menu. Open it and select the unwanted Libreoffice listings. You'll see either a red or green radio button. It's a toggle: clicking a green button turns it red and hides the listing. [What the toggle does is to either write or delete the argument "NoDisplay=true" in the desktop file].

Devs creating Puppies should never include LibreOffice. The organization which creates it, surprisingly Very Happy, often improves it. For example, the 6 Series, 'though taking up slightly more disk space, actually uses less RAM. Users will frequently want to upgrade. Including LibreOffice just wastes space and transmission resources.

Along the same lines, Users should prefer SFSes to pets. SFSes require no space in SaveFiles; use less RAM when not open; and provide for an easier upgrade. While an installed pet may overwrite the files of a different installed version, SFSes don't. If there's a problem with the last SFS loaded you can easily unload it and re-load the previous version.

_________________
Distro: xenialpup64 7.5 XXL
Desktop Panel: JWM ~ FbBox 5.0
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 12986
Location: S.C. USA

PostPosted: Mon 14 Oct 2019, 14:33    Post subject:  

pp4mnklinux,

You are talking about this remastered version of Xenialpup64 7.5?
http://www.murga-linux.com/puppy/viewtopic.php?t=114160

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer)
Back to top
View user's profile Send private message 
pp4mnklinux


Joined: 23 Aug 2013
Posts: 363

PostPosted: Tue 15 Oct 2019, 02:28    Post subject: Yes  

bigpup wrote:
pp4mnklinux,

You are talking about this remastered version of Xenialpup64 7.5?
http://www.murga-linux.com/puppy/viewtopic.php?t=114160



Yes, but I added (to the installed programs) a lot more.



Original Installed programs

Removed:
- Palemoon
- Claws Mail
- Simple GTK Radio
- Hexalate
- Gplanarity
- IQpuzzle
- PicPuz
- Rubix
- MtPaint
- Abiword
- Gnumeric
- Pplog
- DidiWiki
- HexChat
- PuppyPhone
- Cgtkcalc
- Osmo
- DeadBeef
- PmCPUtemp
- Ycalc
- Pdict

Added:
- Latest bugfix (3)
- Firefox 61.0.2
- Thunderbird 52.9.1
- Spotify 1.0.66.478
- Latest Steam Client
- 32bit Compatibility
- Gimp 2.8.16
- Cursor themes 1.1
- Rambox 0.5.17
- Nextcloud 2.3.3
- Libre Office 6.1.0
- Gxlat 0.4
- Java 8u144
- JOSM 14066
- Firmware 20180804

_________________
Distro: xenialpup64 7.5 XXL
Desktop Panel: JWM ~ FbBox 5.0
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1825s ][ Queries: 11 (0.0737s) ][ GZIP on ]