Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 26 Jan 2020, 10:35
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
How to run Zotero literature reference application? (solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [12 Posts]  
Author Message
memo

Joined: 28 Jun 2018
Posts: 168

PostPosted: Fri 22 Nov 2019, 12:02    Post subject:  How to run Zotero literature reference application? (solved)
Subject description: It won't run as root
 

hi all,

I am trying to install zotero literature reference application https://www.zotero.org/ I installed it then I got an error message because it is running as a root ( screenshot 1) then I press continue. The apps starts and then I try to install an addon that link zotero to libreoffice but it fails.

from that main window of the app, i choose tools>addons> zotero libreoffice integration > preferences >cite ( from the top menu) > word processor (screenshot 2)

then I click install llibreoffice addin, but it faill (scrrenshot 3).

then it require a package called, default-jre, I have installed it. the I got this error (screenshot 4).

then I pressed next and I get this window (screenshot 5)

I pressed next, and I got this final error (screenshot 6).

Hope you guys can help me solving this one as I need this app to work.

thanks
Screenshot_6.png
 Description   
 Filesize   51.6 KB
 Viewed   184 Time(s)

Screenshot_6.png

Screenshot_5.png
 Description   
 Filesize   32.34 KB
 Viewed   180 Time(s)

Screenshot_5.png

Screenshot_4.png
 Description   
 Filesize   20.8 KB
 Viewed   180 Time(s)

Screenshot_4.png

Screenshot_3.png
 Description   
 Filesize   22.27 KB
 Viewed   180 Time(s)

Screenshot_3.png

Screenshot_2.png
 Description   
 Filesize   35.07 KB
 Viewed   180 Time(s)

Screenshot_2.png

Screenshot_1.png
Description 
png

 Download 
Filename  Screenshot_1.png 
Filesize  94.32 KB 
Downloaded  20 Time(s) 

Last edited by memo on Fri 22 Nov 2019, 15:34; edited 1 time in total
Back to top
View user's profile Send private message 
memo

Joined: 28 Jun 2018
Posts: 168

PostPosted: Fri 22 Nov 2019, 15:17    Post subject:  

with the help of Atto, fumbduck and 666philb we could work out a solution.

you need to install it manually , then go to tool>option> advanced and choose the other java built 1.8.0_222.

you should be able not to do your citation. good luck and thanks again Smile
Back to top
View user's profile Send private message 
Puppyt

Joined: 09 May 2008
Posts: 900
Location: Gatton, Queensland

PostPosted: Sat 23 Nov 2019, 00:09    Post subject:  

Hi memo -
glad to see you persevered with your install of Zotero. It is one of my "desert island" softwares and I use it across all my computers, in both Puppy and Windows installs. I have been using it since it began as a Firefox extension. I am also disappointed to see the "panic message" pervading the recent stand-alone versions of Zotero.
Rock on Wink
Zotero1.png
 Description   Zotero's current chicken-switch message - sad joke for Puppians
 Filesize   146.43 KB
 Viewed   129 Time(s)

Zotero1.png


_________________
Search engines for Puppy
http://puppylinux.us/psearch.html; Google Custom Search; http://wellminded.net63.net/ others TBA...
Back to top
View user's profile Send private message Visit poster's website 
memo

Joined: 28 Jun 2018
Posts: 168

PostPosted: Sun 24 Nov 2019, 05:52    Post subject:  

@ Puppyt

thanks for your replay. unfortunately, it is far from stable. I have stalled Xenilla 32 bit two many times since then, one time works the other not, no idea why, same procedures same os and same machine.
Back to top
View user's profile Send private message 
Puppyt

Joined: 09 May 2008
Posts: 900
Location: Gatton, Queensland

PostPosted: Sun 24 Nov 2019, 23:31    Post subject:  

memo I've been migrating all my platforms to 64-bit environments, so have no recent experience with 32-bit Puppy + Zotero. I will try later with radky's Dpup Stetch to see if I can catch your stability issues - at least you got java sorted...
_________________
Search engines for Puppy
http://puppylinux.us/psearch.html; Google Custom Search; http://wellminded.net63.net/ others TBA...
Back to top
View user's profile Send private message Visit poster's website 
memo

Joined: 28 Jun 2018
Posts: 168

PostPosted: Mon 25 Nov 2019, 08:05    Post subject:  

@Puppyt

Thanks man!
Back to top
View user's profile Send private message 
Puppyt

Joined: 09 May 2008
Posts: 900
Location: Gatton, Queensland

PostPosted: Tue 26 Nov 2019, 06:43    Post subject:  

Embarassed - slipped my mind memo - will zip out of BionicPup64 for now and into Dpup Stretch - thanks for your patience...
(anything I can do for a fellow Zoterian...)

UPDATE - strangely, the only-available 32-bit puppy install i have is not playing nice with the wifi card - I will have to try again tomorrow evening - huge day for me, sorry Sad

_________________
Search engines for Puppy
http://puppylinux.us/psearch.html; Google Custom Search; http://wellminded.net63.net/ others TBA...
Back to top
View user's profile Send private message Visit poster's website 
memo

Joined: 28 Jun 2018
Posts: 168

PostPosted: Tue 26 Nov 2019, 08:27    Post subject:  

thanks Puppyt , take your time.
Back to top
View user's profile Send private message 
B.K. Johnson

Joined: 12 Oct 2009
Posts: 793

PostPosted: Tue 26 Nov 2019, 09:56    Post subject:  

Hello memo
I downloaded zotero last night, but haven't tried it yet. I can't find openjdk-8. Can you help?
TIA

_________________
B.K. Johnson
tahrpup-6.0.5 PAE (upgraded from 6.0 =>6.0.2=>6.0.3=>6.0.5 via quickpet/PPM=Not installed); slacko-5.7 occasionally. Frugal install, pupsave file, multi OS flashdrive, FAT32 , SYSLINUX boot, CPU-Dual E2140, 4GB RAM

Back to top
View user's profile Send private message 
Mike Walsh


Joined: 28 Jun 2014
Posts: 5827
Location: King's Lynn, UK.

PostPosted: Tue 26 Nov 2019, 13:26    Post subject:  

Best way to get OpenJDK ( or JRE-8 as it's better known - the Java Runtime Environment), is direct from Oracle's relevant downloads page, here:-

https://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html

The only 'fly in the ointment' being that where before you were able to download it, no strings attached, Oracle now require an account to be created before you can download anything from them.... Rolling Eyes

The current JRE8 release is Update_231. Although not the newest, I did manage to snag the last but one, Update 211, some months back, just before Oracle started getting all snotty about the free downloads.

This will do what's required for the Zotero plug-in, indeed any Java app that most of us will ever wish to run in Puppy. For anyone who wants them, they can be found at my Google Drive, here:-

https://drive.google.com/drive/folders/18y31muQvN3cDY42G1ChIKA3bGfYS6P0i?usp=sharing

Just navigate through and help yourself to the one you want. Also available is the Java Information Panel created by rerwin, which gives you some degree of control over the beast.....


Mike. Wink

_________________
MY 'PUPPY' PACKAGES

Back to top
View user's profile Send private message 
memo

Joined: 28 Jun 2018
Posts: 168

PostPosted: Tue 26 Nov 2019, 15:08    Post subject:  

Hi B.K. Johnson ,

B.K. Johnson wrote:
Hello memo
I downloaded zotero last night, but haven't tried it yet. I can't find openjdk-8. Can you help?
TIA


here is what I have done. a while a go the java was already installed (from the quickpet) so I didn't install it again. after unzipping the zotero and run it and follow the procedure you will fail to install the openlibre addon, that is fine because you are going to install it manually.

after libreoffice fails to install the addon, click on manual installation and make sure that you are connected to the internet, zotero will download the addon that is needed although it wouldnot install it for you.

then you openlibre office and install it like any normal addon. then restart libreoffice and try to use the installed addon. you will fine that the libreoffice crashes and that is also fine.

restart libre office and this time donot use the addon, but go directly to tools > option> advanced and wait few seconds, you will find that there is another java build in the box, click it and restart . then try the addon and it should be working fine now.

good luck Smile
Back to top
View user's profile Send private message 
B.K. Johnson

Joined: 12 Oct 2009
Posts: 793

PostPosted: Wed 27 Nov 2019, 15:27    Post subject:  

@Mike
As soon as I saw the first link, anxious as I was, I clicked on it. Laughing After pussy-footing around on the site with name and password log-in issues, I gave up, only to return to your post to see that you had had a similar experience. Smile

Thanks for the sfs on your Google Drive. Got it OK!

@memo
Thank you, memo.
Your experience will be beneficial.

_________________
B.K. Johnson
tahrpup-6.0.5 PAE (upgraded from 6.0 =>6.0.2=>6.0.3=>6.0.5 via quickpet/PPM=Not installed); slacko-5.7 occasionally. Frugal install, pupsave file, multi OS flashdrive, FAT32 , SYSLINUX boot, CPU-Dual E2140, 4GB RAM

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [12 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1017s ][ Queries: 12 (0.0135s) ][ GZIP on ]