Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 22 Jul 2014, 13:37
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Where does unrpm put rpm files?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
penguinman007
Guest


PostPosted: Wed 13 Jul 2005, 23:55    Post subject:  Where does unrpm put rpm files?  

Hi,

I downloaded the pup containing unrpm, it all installed fine.

I tested the unrpm utility on a an rpm file:

unrpm file.rpm

And I got the message: "50 blocks"

Does this mean that the rpm file was unrpmed ?
Is there a way to find where the file contained within the rpm file was put ?

"50 blocks"

mmmm,

I typed "Computer, please tell me where you put the file contained within that damn rpm file",

And I got a response:
Invalid command.

Penguinman007
Back to top
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Thu 14 Jul 2005, 01:26    Post subject:  

it sounds like it worked ok
usually it will make a dir called usr in the same dir as the rpm file

i usually make a new empty dir (so i can see what gets uncompressed), move the rpm into the empty dir, open an rxvt window in the dir, and type unrpm and press the tab key
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Thu 14 Jul 2005, 03:44    Post subject: OO RPM  

Yesterday whilst recovering from electric shock treatment I decided to install Open Office Beta.

When I dezipped I was left with a host of .rpm files. I felt pretty sure that using the dotpup .rpm and deb program would not have given me a working program?
- or would it have?

Anyway decided to wait for the open office coming as a pupget in Puppy 1.0.4

. . . only I was a little too frisky and decided to instally OO stable 1.1.4 anyways . . .

It worked. Yowsa!

If you must then I suggest you first of all increase the size of your pup001 by 512meg (Utilities /resize) - I resized by only 256 meg and this was only big enough for a minimum install

then download the ISO
use (Tkzip) to unzip
then run the setup program

The reason for trying the Beta is I know it is stable and I like the database . . .

You lucky Pups! Cool

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
Bruce B


Joined: 18 May 2005
Posts: 11080
Location: The Peoples Republic of California

PostPosted: Thu 14 Jul 2005, 03:57    Post subject:  

Slightly off topic, but not much.

I have a hard time unrpming some SuSE rpms. I think the use a signature or something.

I've had good success with Debian precompiled binaries in terms of compatibility and directory locations with Puppy. Of course they need undeb wich is included with G2's package.

Really, AlienX's Midnight Commander Plus dotpup makes it real easy to unpup, untargz, unrpm, untgz and undeb by offering to put everything in a subdirectory.

Put the cursor on the file, then hit F2 for the menu options.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0647s ][ Queries: 11 (0.0239s) ][ GZIP on ]