Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

READ-ONLY-MODE: PLEASE DO NOT POST NEW STUFF!
  New Forum: http://forum.puppylinux.com
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 12 Aug 2020, 12:47
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Fatdog linux and abiword
Moderators: Flash, JohnMurga
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
jtouso

Joined: 29 May 2008
Posts: 121
Location: Barcelona, España

PostPosted: Wed 15 Apr 2020, 15:40    Post subject:  Fatdog linux and abiword
Subject description: installing abiword
 

How can I install ABIWORD in Fatdog last version?
Thanks
Back to top
View user's profile Send private message 
step

Joined: 04 May 2012
Posts: 1352

PostPosted: Wed 15 Apr 2020, 17:32    Post subject:  

Abiword and gnumeric have been replaced by LibreOffice Writer and LibreOffice Calc respectively since Fatdog64-710 (2016), see Fatdog64 710 Beta2 history.
Abiword isn't officially supported in the current release but there is a way to install the version built for Fatdog64-710.

To install the unsupported Abiword:

1. Download the old package abiword 3.0.1 for Fatdog64-710.
2. Download this dependency libical 1.0 for Fatdog64-710.
3. Download osmo 0.2.10 for Fatdog64-710.
4. Right-click and install the package downloaded in #1.
5. Right-click and install the package downloaded in #2. You will be asked to confirm that you want to replace (downgrade) the currently installed libical 3.0.3. Say yes. This will break osmo (see next step).
6. Step #5 broke osmo. Right-click and install the package downloaded in #3. This should repair osmo.

Following the above steps I was able to install Abiword in Fatdog64-810 and start with an empty document inside. I didn't go any further because I much prefer LibreOffice, so YMMV. Also, downgrading libical could be incompatible with other packages in the Fatdog64-810 repositories, I just don't know.

_________________
Fatdog64-810|+Packages|Kodi|gtkmenuplus
Back to top
View user's profile Send private message 
step

Joined: 04 May 2012
Posts: 1352

PostPosted: Thu 16 Apr 2020, 03:23    Post subject:  

Another option: http://murga-linux.com/puppy/viewtopic.php?p=1023684#1023684
_________________
Fatdog64-810|+Packages|Kodi|gtkmenuplus
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0363s ][ Queries: 11 (0.0143s) ][ GZIP on ]