Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 16 Apr 2014, 09:51
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
mkkde: create your custom KDE 3.5.5
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 6 [84 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Author Message
jason.b.c


Joined: 08 Feb 2006
Posts: 758
Location: Marshfield,MO

PostPosted: Thu 21 Dec 2006, 02:38    Post subject:    

I think i would certanly try this if i could get my puppy on the internet...
_________________
Puppy is Awesome..!!!!

Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Thu 21 Dec 2006, 06:59    Post subject:  

you need no internet to build KDE.
You only must download the required files before, but you could do that in Ubuntu or Windows, if your internet-connection works there.

Mark
Back to top
View user's profile Send private message Visit poster's website 
Sir Savant

Joined: 31 Dec 2006
Posts: 9

PostPosted: Mon 01 Jan 2007, 19:02    Post subject:  

I don't mean to kick this topic, but I don't want to crowd up the forum with a separate one.

I recently ran the mkkde script, and everything seemed to go well. I used that last list in the first post for my tgz. I moved the sfs file to "/mnt/home/" and then ran the DotPup file as required. Then I reboot, logged out of XFCE, and ran "startkde" A series of errors popped up, so I went into xfce, opened up a terminal, and tried to run "Kicker" but all it gives are errors. Any help?

Running Puppy 2.12
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 01 Jan 2007, 22:22    Post subject:  

you must run the dotpup after rebooting, not before.
Maybe you can fix it by installing it again.

If not, try these steps:
Boot WITHOUT the .sfs
Then delete these folders:
/initrd/pup_rw/opt
/initrd/pup_rw/usr/lib/qt
/initrd/pup_rw/usr/local/MU-XDG-activator

Then reboot WITH the .sfs.
Then install the dotpup again.


To say more, please post the errors you get (after these steps):
Run "Kicker" in the consolewindow.
Select the errormessages with the mouse, then middle-click in a forum-message to paste them.

Mark
Back to top
View user's profile Send private message Visit poster's website 
shrdlu

Joined: 09 Nov 2005
Posts: 25
Location: NE Illinois

PostPosted: Fri 05 Jan 2007, 16:36    Post subject:  

Thanks, Mark.

This cleared up a problem I was having with KDEmini.

There were some broken symlinks in /usr/lib/qt/lib (to libqt-mt.so and libqt-mt.so.3 in /usr/lib/qt-3.3.6). I also added a symlink to libqt.so. Don't know if the last thing was needed but everything works now. Very Happy

Best wishes!

_________________
If only I could be half as good as my dog thinks I am
Back to top
View user's profile Send private message 
lickthefrog2


Joined: 22 Nov 2006
Posts: 57

PostPosted: Fri 05 Jan 2007, 19:51    Post subject:  

Specifically re: BasKet
MU wrote:

The gpgme-error appears, if you install the wrong gpgme with gslapt.
Be sure to use the version I mentioned above.
I also had tried another one before, and got the same error.

Mark


Hi Mark,

So I uninstalled with Gslapt the incorrect gpgme then installed the specific one you described: gpgme-1.0.3-i486-2df

But I'm still getting the error message. The more notes I make the more times the error comes up.

Any advice?

When you say install gpgme with gslapt, that's independent of KDE, right? Meaning, I don't put that package in with the other packages I'm using to customize my miniKDE?

And thanks again. I'm having fun (and only a little frustration) as a now-dedicated Linux user.

- lickthefrog2
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Fri 05 Jan 2007, 20:24    Post subject:  

did you all these as suggested?:
attr 2.4.32_1-i486-1
acl 2.2.39_1-i486-1
libgpg-error1.4-i486-1df
gpgme 1.0.3-i486-2df

Yes, simply install with gslapt.
Uninstall old versions with it first.

Does that work?

Mark
Back to top
View user's profile Send private message Visit poster's website 
lickthefrog2


Joined: 22 Nov 2006
Posts: 57

PostPosted: Sat 06 Jan 2007, 01:25    Post subject:  

No luck. Do I need to reboot after the uninstall before the reinstall?



The initial trouble I had, and why I tried it first with a different gpgme, is because I couldn't see the exact one you specified.

Since it didn't work, I went searching around and realized that I could add a different Gslapt Package Source.

After adding one or two, I then saw the correct gpgme and installed it with Gslapt.

The error message didn't go away, so I uninstalled mkkde and redid it.

Still the same problem.

I saw that gpgme was compiled with pth-2.0.7, so I'm going to try that.
Back to top
View user's profile Send private message 
lickthefrog2


Joined: 22 Nov 2006
Posts: 57

PostPosted: Sat 06 Jan 2007, 04:21    Post subject:  

DELETED
Back to top
View user's profile Send private message 
lickthefrog2


Joined: 22 Nov 2006
Posts: 57

PostPosted: Fri 02 Feb 2007, 11:36    Post subject: mkkde in Muppy 007  

Hi,

I set up my own mkkde in Muppy007 as I am upgrading and starting from a clean slate.

I set up BasKet Note Pads in my KDE on Muppy006 but was getting an error message. Mark, you suggested that I install 4 Slackware packages with gslapt:

attr 2.4.32_1-i486-1
acl 2.2.39_1-i486-1
libgpg-error1.4-i486-1df
gpgme 1.0.3-i486-2df

Whereas in Muppy006, I might have made a mistake with gpgme, this time I didn't.

So I'm thinking there's something else I'm missing. How can I find out?

Everything else is great. Thanks again.

-lickthefrog2
Back to top
View user's profile Send private message 
sml

Joined: 09 Jan 2006
Posts: 162

PostPosted: Sat 24 Feb 2007, 09:02    Post subject:  

What has happened to the dotpups.de server? I cannot reach it Sad
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sat 24 Feb 2007, 09:09    Post subject:  

It moved to a new server.
It is back in some hours, when the DNS servers were updated.
Meanwhile use:
http://puppyfiles.org/dotpupsde/files/
http://puppyfiles.org/dotpupsde/dotpups/

Or this tool:
http://puppyfiles.org/dotpupsdelink.php

Mark
Back to top
View user's profile Send private message Visit poster's website 
zsero

Joined: 18 Feb 2007
Posts: 16

PostPosted: Sat 03 Mar 2007, 05:49    Post subject:  

I have installed the mini KDE sfs&dotpup package, and I'm happily living using it. But now, I need to install KDevelop. What should I do now? Is it possible to integrate a downloaded KDevelop package into the already installed KDE package, or I shell make my whole new KDE package?
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sat 03 Mar 2007, 06:36    Post subject:  

If it is a .tar.gz from slakware, you could try to install it with gslapt.

But I think the cleaner way is to add it to the folder with the KDE-.tar.gz files and run mkkde again.
Then it will be added to the new .sfs, and the new dotpup will delete any .wh files in the folders it installs to.
Those .wh files are a bug from unionfs, so if you encounter problems when installing with gslapt, create a new kde.sfs.

Mark
Back to top
View user's profile Send private message Visit poster's website 
orbisvicis

Joined: 06 Mar 2007
Posts: 42

PostPosted: Sat 17 Mar 2007, 16:20    Post subject:  

Where are the kde environment variables? I can't seem to find them. Specifically the one that starts kwin.

orbisvicis
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 6 [84 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0727s ][ Queries: 11 (0.0046s) ][ GZIP on ]