Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Apr 2014, 02:20
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Problem with Firefox Java in 1.0.4 multisession (Solved?)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
Jeff
Guest


PostPosted: Tue 19 Jul 2005, 21:12    Post subject:  Problem with Firefox Java in 1.0.4 multisession (Solved?)  

I have downloaded and installed the main iso for Puppy 1.0.4 . The problems i experienced with saving sessions to CD seem to have been solved with this release!

When I download and install the DotPup Java package, it installs perfectly, and I can then view java applets in Firefox, which I have also installed. However, after a reboot, neither Mozilla nor Firfox will display java, although the java folder is still present. Could someone please guide me through the steps necessary to make it work with Firefox?

Many thanks!
Back to top
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Tue 19 Jul 2005, 22:40    Post subject:  

the plugins folder for Puppy 1.0.4 is /usr/lib/mozilla-1.8b1.4/plugins/

the Java installer puts a symlink in /root/.mozilla/plugins/ to libjavaplugin_oji.so

the symlink in /root/.mozilla/plugins/ should work with Mozilla/Firefox

do you have libjavaplugin_oji.so in /root/.mozilla/plugins/ ? (.mozilla is a hidden folder)

if you don't, you can open a rox window showing the java plugin file ... probably /root/jre1.5.0_02/plugin/i386/ns7/libjavaplugin_oji.so ... and another rox window showing /root/.mozilla/plugins/

drag /root/jre1.5.0_02/plugin/i386/ns7/libjavaplugin_oji.so to /root/.mozilla/plugins/ using the middle mouse button, and select Link from the menu

java should now work

if it doesn't, you can drag the symlink to /usr/lib/mozilla-1.8b1.4/plugins/ instead

i have java jre1.5.0_03 installed, and it works ok with Puppy's Mozilla, Firefox 1.0.5, and Firefox DeerPark Alpha ... i didn't need to reinstall the symlink

i should make a new dotpup to install the latest java jre1.5.0_04
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0425s ][ Queries: 11 (0.0120s) ][ GZIP on ]