Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Oct 2014, 16:39
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects » Localization Project
How to put portuguese accentuation in an US keyb? (resolved)
Moderators: Lobster, MU, raffy
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
kkpity


Joined: 27 Nov 2006
Posts: 112
Location: Brazil

PostPosted: Wed 29 Nov 2006, 06:53    Post_subject:  How to put portuguese accentuation in an US keyb? (resolved)  

Hi,

I'm trying to put Portuguese accentuation on my laptop that has a US keyboard.

I've tried to change keyboard layout, but I think the layout is correct (US).

Maybe I have to change to the abnt2 (Brazilian accentuation???) but I do not know how to do that.

I've already tried to search on this forum with no success.

Just to exemplify...

When I type ' plus c the result should be ç (I'm using a different keyboard).

I cannot produce ç using my laptop keyboard.

Can somebody help me?

Thanks in advance!

kkpity

Edited_time_total
Back to top
View user's profile Send_private_message 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Wed 29 Nov 2006, 12:44    Post_subject:  

which version of Puppy are you using? ... there are differences in the version of Xorg and xkb ... the newer xkb is a little bit different from the older versions of xkb

for Puppy 212:

you can edit the file xorg.conf in /etc/X11/, then restart X windows (from the menu, or you can press ctrl+alt+backspace, then type startx)

Portuguese keymap:

Option "XkbLayout" "pt" #xkeymap0

or:

Option "XkbLayout" "pt" #xkeymap0
Option "XkbVariant" "basic"

or (i don't think you want this):

Option "XkbLayout" "pt" #xkeymap0
Option "XkbVariant" "sundeadkeys"

or:

Option "XkbLayout" "pt" #xkeymap0
Option "XkbVariant" "nodeadkeys"

Brazillian keymaps:

Option "XkbLayout" "br" #xkeymap0

or:

Option "XkbLayout" "br" #xkeymap0
Option "XkbVariant" "abnt2"

or:

Option "XkbLayout" "br" #xkeymap0
Option "XkbVariant" "nodeadkeys"

US keymaps:

Option "XkbLayout" "us" #xkeymap0

or:

Option "XkbLayout" "us" #xkeymap0
Option "XkbVariant" "basic"

or:

Option "XkbLayout" "us" #xkeymap0
Option "XkbVariant" "intl"

or:

Option "XkbLayout" "us" #xkeymap0
Option "XkbVariant" "alt-intl"

or:

Option "XkbLayout" "us" #xkeymap0
Option "XkbVariant" "dvorak"

or:

Option "XkbLayout" "us" #xkeymap0
Option "XkbVariant" "rus"

you may want to set the number of keys on your keyboard, if it is not set properly, for example:

Option "XkbModel" "pc105"

the older versions of xkb had "en_US" and "us_intl" ... the newer xkb does not seem to have those keymaps, i think you have to specify the keymap variant instead, which may not give you exactly the same keymap

on the pt keymap, ç seems to be the ; key on a us keyboard ... you do not need to press 2 keys to get a ç

there are at least 4 ways to get an accented diacritical:

1) remapping the keys ... just press a key to get the character ... like pressing the ; on a us keyboard gives you a ç with the pt keymap

2) the Mode_switch key ... like an extra shift key, holding the Mode_switch key and pressing a key will give you a different character, just like holding the shift key gives you different characters

3) the Multi_key ... press and release the Multi_key, press and release an accent key, like the ' key, then press and release a character, like e, to get é

4) dead keys ... press ' (nothing is displayed) then press e to get é

various keymaps have the keys set up in different ways ... i'm not sure what keymaps you were using before, it might have been "en_US" or "us_intl" ... i'm not sure if the newer variants have exactly the same mapping ... you might be able to copy the old keymap file and use it, i'm not sure if that would work properly or not

you could also try using setxkbmap, like this:

setxkbmap -layout us -variant alt-intl

see: http://www.murga-linux.com/puppy/viewtopic.php?t=12380
and: http://www.murga-linux.com/puppy/viewtopic.php?t=13215
Back to top
View user's profile Send_private_message 
dewdrop


Joined: 29 Aug 2005
Posts: 298
Location: Texas USA

PostPosted: Wed 29 Nov 2006, 13:11    Post_subject: How to put portuguese accentuation in a US keyboard?  

Hi kkpity,

If you know your 2 letter brazilian keyboard letters, go to the topic noted below, go thru the step by step, and put them where you see the latam (meaning Latin American) keyboard. That step by step is for Puppy 2.12....but it should work for other versions as well.

It looks like the 2 letters you use for Brazilian are pt....according to the GuessToo post.

http://www.murga-linux.com/puppy/viewtopic.php?t=13215

With this method, you will have the 2 languages on your keyboard... English and Brazilian

Regards,

dewdrop
Back to top
View user's profile Send_private_message 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Wed 29 Nov 2006, 14:01    Post_subject:  

br = Brazillian Portuguese
pt = Portuguese
Back to top
View user's profile Send_private_message 
kkpity


Joined: 27 Nov 2006
Posts: 112
Location: Brazil

PostPosted: Wed 29 Nov 2006, 20:07    Post_subject:  

Thanks everybody for your fast reply and so detailed steps!

Unfortunately I couldn't fix the keyboard issues, but I think I am almost there.

I'm using puppy 2.12

File /etc/X11/xorg.conf is pretty small here.

I couldn't find any line related to keyboard Confused

Anyway, I inserted the following lines at the end of the file:
# us keyboard with Brazilian accentuation
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,br"
Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll,caps:shift,altwin:menu"
EndSection

After that I re-started X (ALT Backspace -> startx).

There were no changes.

#############
Testing with command "setxkbmap -layout br -variant alt-intl "

It changed the keyboard in a way that I didn't like:

Now, when I press the key :; (it is a key right after L letter) I can produce the "cedilla", but I miss the character : and ;

I would like to have the way that I always had used (at least for this time):

press ' plus c to produce the "cedilla".

It's getting late... so I will perform more tests tomorrow.

Thanks again for your replies.

Regards,

kkpity
Back to top
View user's profile Send_private_message 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Wed 29 Nov 2006, 22:51    Post_subject:  

as i said, i think the newer version of xkb has changed a little (not just in Puppy) ... i'm not sure if the exact configuration you used before is available (you can probably makes the keys do exactly what you want, if you know how, the keymaps are very configurable)

the keymaps i tried had deadkeys ... i could press ~ then o to get õ ... but , then c did not work to produce ç ... so i'm not sure if that method is configured in one of the keymaps or not

you might be able to copy the keymap file from an older version of Puppy, i don't know if it would work ... maybe the file would be named us_intl ... in Puppy 212 the keymap files are in /etc/X11/xkb/symbols/ ... then you would put
Option "XkbLayout" "us_intl"
in xorg.conf

you can get the regular ; and : keys by holding the modeswitch key ... it's probably the extra alt key on the right (AltGr)

i think what you want is not a pt or br keymap ... i think you want a us_intl keymap (or en_US, something like that ... en_US does not seem to be included with xkb anymore)
Back to top
View user's profile Send_private_message 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Thu 30 Nov 2006, 20:56    Post_subject:  

i think that the us intl variant is set up this way:

press level3 key plus , to get ç
press level3 key plus < to get Ç

i think that the us alt-intl variant is set up this way:

press level3 key plus , to get cedilla dead key ... then press c to get ç

press level3 key plus < to get caron dead key ... then press c to get č

on my keyboard, the level3 key has been set to the right alt key

that is, if you use the us alt-intl keymap, you can get the cedilla dead key by pressing the level3 key plus the , key (as opposed to just pressing the , key)

if you want, you can make the , key work as the dead cedilla key:

for Puppy 212, edit /etc/X11/xkb/symbols/us
change line 118 from this:

key <AB08> { [ comma, less, ...

to this:

key <AB08> { [ dead_cedilla, less, ...

this makes the , key a dead cedilla key, for us intl ... set the keymap in xorg.cong to us variant intl, and restart x

this does not affect rxvt, but with aterm and mrxvt, the , key no longer works

or you can change the us alt-intl keymap ...
change line 173 from this:

key <AB08> { [ comma, less, ...

to this:

key <AB08> { [ dead_cedilla, less, ...

set the keymap to us alt-intl, and restart X, or use setxkbmap
Back to top
View user's profile Send_private_message 
pakt


Joined: 04 Jun 2005
Posts: 1089
Location: Sweden

PostPosted: Sun 03 Dec 2006, 15:45    Post_subject:  

kkpity wrote:

I'm using puppy 2.12

File /etc/X11/xorg.conf is pretty small here.

I couldn't find any line related to keyboard Confused

kkpity, are you using Xvesa or Xorg for your graphics? If you can't find a line related to keyboard in xorg.conf, then it sounds like you are running Xvesa. In that case Xkb will not work for you - that only works if you are running Xorg. Sad

If you switch to Xorg, then I have also written a work-around for you to get a 'ç' on your keyboard. I had not read this thread when I posted it. My work-around is here:
http://www.murga-linux.com/puppy/viewtopic.php?p=82064#82064

Paul

_________________
Testing Puppy since v0.9.2 - my desktop OS since v1.0.7
Running SlaxerPup-4.12 - Puppy with a Slackware 12.2 heart Cool
Back to top
View user's profile Send_private_message 
kkpity


Joined: 27 Nov 2006
Posts: 112
Location: Brazil

PostPosted: Mon 04 Dec 2006, 18:42    Post_subject:  

Paul,

You got the point!

In fact I was not using Xorg Embarassed

After changed everything, I could solve this issue.

Please see more details at this post:
http://www.murga-linux.com/puppy/viewtopic.php?p=82391#82391

I will change this post to "resolved".

Thanks everybody for the valuable helps!

I'm loving puppy!

kkpity
Back to top
View user's profile Send_private_message 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Mon 04 Dec 2006, 20:52    Post_subject:  

Quote:
Testing with command "setxkbmap -layout br -variant alt-intl "

It changed the keyboard in a way that I didn't like:

Now, when I press the key :; (it is a key right after L letter) I can produce the "cedilla", but I miss the character : and ;


i read this so i assumed that your keymap was being changed, so i figured that you must have been running Xorg

so ... setxkbmap can change the keymap, whether you are using Xorg or Xvesa ... that is interesting to know ... so a keymap wizard can set the keymap whether you are running Xvesa or not
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects » Localization Project
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0774s ][ Queries: 11 (0.0044s) ][ GZIP on ]