Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 23 Jan 2020, 02:04
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Filesystem
pFind 6.3
Post new topic   Reply to topic View previous topic :: View next topic
Page 50 of 50 [744 Posts]   Goto page: Previous 1, 2, 3, ..., 48, 49, 50
Author Message
Argolance


Joined: 06 Jan 2008
Posts: 3732
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Mon 15 Oct 2018, 15:29    Post subject:  

Bonsoir,
musher0 wrote:
Which version of XenialPup-32 are you running?

Sorry, I should have given more details: xenialpup-7.5-uefi.iso, downloaded from official repository.
This happens running Puppy Precise too. I will test some other Puppies when I have the opportunity.

Cordialement

_________________

A second life for your PCs...
Back to top
View user's profile Send private message Visit poster's website 
musher0

Joined: 04 Jan 2009
Posts: 14723
Location: Gatineau (Qc), Canada

PostPosted: Mon 15 Oct 2018, 18:02    Post subject:  

Rebonjour, Argolance.

To check your find utility, please run in succession:
Code:
cd /usr/bin
ldd find
ldd find | grep not
find --version
You should get this:
Code:
[/usr/bin][/usr/bin]>ldd find
   linux-gate.so.1 =>  (0xb7730000)
   libselinux.so.1 => /lib/libselinux.so.1 (0xb76cb000)
   libm.so.6 => /lib/libm.so.6 (0xb7675000)
   libc.so.6 => /lib/libc.so.6 (0xb74bf000)
   libpcre.so.3 => /lib/libpcre.so.3 (0xb744a000)
   libdl.so.2 => /lib/libdl.so.2 (0xb7445000)
   /lib/ld-linux.so.2 (0x80011000)
   libpthread.so.0 => /lib/libpthread.so.0 (0xb7428000)

[/usr/bin]>ldd find | grep not

[/usr/bin]>find --version
find (GNU findutils) 4.7.0-git
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later
(...)
As you can see, there are no libraries missing when I run
Code:
ldd find | grep not
and that is how it should be.

In any case, I am attaching my find utility, for checking only. (Just in
case, make a back-up of the faulty find utility you have now?)

You could spend hours playing detective to pinpoint how this "lib64"
situation happened.

However, the best and most time-saving solution, IMO, given what you have
reported above, would be for you to recompile and install the GNU find
utilities from source, on and for your XenialPup-7.5-uefi.

I feel that it is the only way by which you will be absolutely sure that your
find utility is truly adapted to your version of XenialPup.

Of course, once recompiled, please re-run pfind to validate.

IHTH. / J'espère que cela t'aide.
find.zip
Description  Find utility from musher0's xenialPup-7.0.6 (32-bit). To test or check (only),
unzip in /usr/bin and make executable.
zip

 Download 
Filename  find.zip 
Filesize  107.21 KB 
Downloaded  232 Time(s) 

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3732
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Fri 19 Oct 2018, 05:40    Post subject:  

Bonjour,
Thank you for replying (sorry I didn't answer sooner!).
So, I replaced the 4.4.2 Puppy Precise find version with yours (4.7.0) but I get the same error message and cannot jump to the place where is any selected found item.
Here are the results of the commands you gave above:
Code:
root@puppypc28983 ~
# cd /usr/bin
root@puppypc28983 /usr/bin
# ldd find
   linux-gate.so.1 =>  (0xb77a7000)
   librt.so.1 => /lib/librt.so.1 (0xb779b000)
   libm.so.6 => /lib/libm.so.6 (0xb7758000)
   libc.so.6 => /lib/libc.so.6 (0xb75a3000)
   libpthread.so.0 => /lib/libpthread.so.0 (0xb7588000)
   /lib/ld-linux.so.2 (0xb77a8000)
root@puppypc28983 /usr/bin
# ldd find | grep not
root@puppypc28983 /usr/bin
# find --version
find (GNU findutils) 4.4.2
Copyright (C) 2007 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by Eric B. Decker, James Youngman, and Kevin Dalley.
Built using GNU gnulib version e5573b1bad88bfabcda181b9e0125fb0c52b7d3b
Features enabled: D_TYPE O_NOFOLLOW(enabled) LEAF_OPTIMISATION FTS() CBO(level=0)

Code:
# cd /usr/bin
root@puppypc28983 /usr/bin
# ldd find
   linux-gate.so.1 =>  (0xb7732000)
   libselinux.so.1 => /lib/libselinux.so.1 (0xb76d5000)
   libm.so.6 => /lib/libm.so.6 (0xb7692000)
   libc.so.6 => /lib/libc.so.6 (0xb74dd000)
   libdl.so.2 => /lib/libdl.so.2 (0xb74d8000)
   /lib/ld-linux.so.2 (0xb7733000)
root@puppypc28983 /usr/bin
# ldd find | grep not
root@puppypc28983 /usr/bin
# find --version
find (GNU findutils) 4.7.0-git
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by Eric B. Decker, James Youngman, and Kevin Dalley.
Features enabled: D_TYPE O_NOFOLLOW(enabled) LEAF_OPTIMISATION FTS(FTS_CWDFD) CBO(level=2)

[EDIT]: I uninstalled the pFind 6.3 version while keeping your 4.7.0 find version. It seems working fine. No error message. So, maybe the problem is still coming from pFind.

Cordialement.

_________________

A second life for your PCs...
Back to top
View user's profile Send private message Visit poster's website 
Argolance


Joined: 06 Jan 2008
Posts: 3732
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Mon 03 Dec 2018, 07:43    Post subject:  

Hello,
Is there anyone on the flight?
Doesn't my problem deserve to be taken into account? Rolling Eyes

Cheers.

_________________

A second life for your PCs...
Back to top
View user's profile Send private message Visit poster's website 
don570


Joined: 10 Mar 2010
Posts: 5454
Location: Ontario

PostPosted: Sat 14 Dec 2019, 14:45    Post subject:  

I was using pfind 6.3 in latest fatdog64 and to search a partition
I made a right click link.

So I right clicked on a mounted partition and launched pfind.
Search field was empty initially. I accidentally clicked on the 'Search' button
rather than the 'Advanced' button.

pfind appeared to work but it is very slow since it must show every file.

So I suggest if the search field is empty and a search of a partition is required,
that a warning be shown.

I wonder if James or Kirk of fatdog team have changed the pfind code
to make the field empty initially??
_____________________________________________________________________________________________________
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 6627
Location: Valåmoen, Norway

PostPosted: Sun 15 Dec 2019, 12:43    Post subject:  

@don570
fixed in Woof - https://github.com/puppylinux-woof-CE/woof-CE/commit/ae3f93d29d962622e20184547da3e73e7f13cf83

Thank you

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
don570


Joined: 10 Mar 2010
Posts: 5454
Location: Ontario

PostPosted: Sun 15 Dec 2019, 16:55    Post subject:  

WOOF change...
Code:
case "$1" in
-search)
   if [ ! "$SEARCHSTRING" ]; then
      FRAME=Info; IMG=dialog-info; TXT1="$(gettext '<b>No searchstring.</b> Please define the textstring you want to search for.')";
      . $PROGPATH/box_ok
      exit
   fi


____________________________________________

I noticed in an old version of pfind 4.2 in fluppy linux
that when I relaunched pfind the previous search text is in the field.
This is useful in some situations.

__________________________________________________
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5454
Location: Ontario

PostPosted: Mon 16 Dec 2019, 16:40    Post subject:  

Slightly different wording is possible.

'searchstring' doesn't appear to be an English word???
'search-string' is in dictionary but not used often.

...and 'text string' is apparently spelt as two separate words.
___________________________________________
screenshot-pfind.png
 Description   
 Filesize   12.88 KB
 Viewed   70 Time(s)

screenshot-pfind.png

Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 6627
Location: Valåmoen, Norway

PostPosted: Wed 18 Dec 2019, 11:53    Post subject:  

@don570
Very Happy English is far from my better skills, so please correct more of my spellings.
It would be preferable if you just pulled the changes to WoofCE

Thank you
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 50 of 50 [744 Posts]   Goto page: Previous 1, 2, 3, ..., 48, 49, 50
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Filesystem
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1254s ][ Queries: 12 (0.0677s) ][ GZIP on ]