Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 18 Jul 2018, 22:27
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Puppy 2.13 does not see thumb drive
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [17 Posts]   Goto page: 1, 2 Next
Author Message
kent41


Joined: 26 Nov 2006
Posts: 242

PostPosted: Thu 22 Feb 2007, 15:10    Post subject:  Puppy 2.13 does not see thumb drive
Subject description: New Toshiba computer running Live CD
 

When booted from Microsoft XP the computer sees thumb drives.
However when booted from Live CD thumb drive does not show up in Media Utility.

Laptop booted from live CD running Puppy 2.13

Also noted thumb drive lite not active.

Also noted on bootup IRQ #11 disabled but log file shows it was then enabled.

Does IRQ have anything to do with USB ports?

The chip set is Mobil Intel 945GM Express

Note: The usb mouse works.

_________________
Toshiba M35X S-111 - Aspire 5100-3357 using puppy 2.12 - 2.13 - 2.14 - 4.3.1 -
Bootable CD and no hard drive

Acer Aspire 1 netbook using thumbdrive or CD

Last edited by kent41 on Fri 23 Feb 2007, 20:26; edited 1 time in total
Back to top
View user's profile Send private message 
gary101


Joined: 08 Oct 2006
Posts: 556
Location: Boston, Lincs. UK

PostPosted: Fri 23 Feb 2007, 12:05    Post subject:  

Does it show in Pmount? (Menu/Network)

Sometimes MUT loses my usb pendrive but Pmount always shows it
Back to top
View user's profile Send private message 
kent41


Joined: 26 Nov 2006
Posts: 242

PostPosted: Fri 23 Feb 2007, 16:34    Post subject:  

gary101 wrote:
Does it show in Pmount? (Menu/Network)

Sometimes MUT loses my usb pendrive but Pmount always shows it

gary101
The USB pendrives do not show up in Pmount. Hovever as mentioned before the wireless USB mouse works ok.

It must have something to do with Puppy because the pendrives work in the same laptop computer when running XP.

We have tried San Disk cruzer and Verbatim Store 'n' Go pendrives.

Looking again at the message log it shows the IRQ #11 as disabled.

_________________
Toshiba M35X S-111 - Aspire 5100-3357 using puppy 2.12 - 2.13 - 2.14 - 4.3.1 -
Bootable CD and no hard drive

Acer Aspire 1 netbook using thumbdrive or CD
Back to top
View user's profile Send private message 
kent41


Joined: 26 Nov 2006
Posts: 242

PostPosted: Sat 24 Feb 2007, 20:31    Post subject:  

Looking over past posts I see lots of problems with USB ports but most have to do with MUT or Pmount that do not recognize USB ports.

My friends problem is puppy does not recognize any pendrives plugged into the computer.
Puppy only recognizes the USB mouse.

My question is since puppy has had may problems with USB ports is this a new BUG?

NOTE After looking over tons and tons of web post about IRQ 11 (per Google 120,000) it looks like IRQ 11 is a long standing Linux problem. any comments?

_________________
Toshiba M35X S-111 - Aspire 5100-3357 using puppy 2.12 - 2.13 - 2.14 - 4.3.1 -
Bootable CD and no hard drive

Acer Aspire 1 netbook using thumbdrive or CD
Back to top
View user's profile Send private message 
sml

Joined: 09 Jan 2006
Posts: 162

PostPosted: Sun 25 Feb 2007, 03:12    Post subject:  

This was my experience ...
http://murga-linux.com/puppy/viewtopic.php?t=14193

I think it is related to USB2.0 module (ehci_hcd) although I cant seem to get it working with USB either.

Try booting with pfix=ram and you should be ok.
Back to top
View user's profile Send private message 
sml

Joined: 09 Jan 2006
Posts: 162

PostPosted: Sun 25 Feb 2007, 03:39    Post subject:  

BTW Kent41

For anyone to help you need to post the last few lines from the output of the command 'dmesg'.
Back to top
View user's profile Send private message 
John Doe

Joined: 01 Aug 2005
Posts: 1689
Location: Michigan, US

PostPosted: Sun 25 Feb 2007, 03:53    Post subject:  

How is the drive that is not showing up formated (what file system and what did you use to do it)?
Back to top
View user's profile Send private message 
sml

Joined: 09 Jan 2006
Posts: 162

PostPosted: Sun 25 Feb 2007, 04:32    Post subject:  

John Doe,

I have tried all formats and my thumb drives and external USB CD/DVD dont work with the same error output.

... new high speed device .. not accepting address .. blah blah
Back to top
View user's profile Send private message 
kent41


Joined: 26 Nov 2006
Posts: 242

PostPosted: Sun 25 Feb 2007, 11:23    Post subject:  

sml wrote:
This was my experience ...
http://murga-linux.com/puppy/viewtopic.php?t=14193

I think it is related to USB2.0 module (ehci_hcd) although I cant seem to get it working with USB either.

Try booting with pfix=ram and you should be ok.


sml
I will get back to you on the dmesg data after I talk with my friend and he runs the dmesg command.

BTW where does he put the
Code:

pfix=ram


at startup ?

Thanks for the info

_________________
Toshiba M35X S-111 - Aspire 5100-3357 using puppy 2.12 - 2.13 - 2.14 - 4.3.1 -
Bootable CD and no hard drive

Acer Aspire 1 netbook using thumbdrive or CD
Back to top
View user's profile Send private message 
sml

Joined: 09 Jan 2006
Posts: 162

PostPosted: Sun 25 Feb 2007, 19:57    Post subject:  

Yes. pfix=ram is a boot command. With that it should work. Who knows why!?
Back to top
View user's profile Send private message 
kent41


Joined: 26 Nov 2006
Posts: 242

PostPosted: Sun 25 Feb 2007, 20:42    Post subject:  

sml wrote:
Yes. pfix=ram is a boot command. With that it should work. Who knows why!?

sml
My friend is new to linux and he just called and he is going to login to puppy and get an account so he and post the output from dmesg.

I am also rather new to linux does he add the command pfix=ram just before #exec $CURRENTWM in /root/.xinitrc ?

_________________
Toshiba M35X S-111 - Aspire 5100-3357 using puppy 2.12 - 2.13 - 2.14 - 4.3.1 -
Bootable CD and no hard drive

Acer Aspire 1 netbook using thumbdrive or CD
Back to top
View user's profile Send private message 
kjs

Joined: 06 Jan 2007
Posts: 75
Location: NJ, USA

PostPosted: Sun 25 Feb 2007, 21:13    Post subject:  

during boot when you see the first messages enter pfix=ram , hit enter and it does the job.

Juergen

_________________
-- in a world without fences and walls who needs Windows and Gates? --
>>> winDOS free since 1998 <<<
Back to top
View user's profile Send private message AIM Address Yahoo Messenger 
ICQ Number 
kent41


Joined: 26 Nov 2006
Posts: 242

PostPosted: Sun 25 Feb 2007, 21:26    Post subject:  

kjs wrote:
during boot when you see the first messages enter pfix=ram , hit enter and it does the job.

Juergen

Juergen
at the CD boot when the # comes up I entered pfix=ram
and I got a messge that said something like " I don't understand that command" I am sorry but I guess I don't understand.

_________________
Toshiba M35X S-111 - Aspire 5100-3357 using puppy 2.12 - 2.13 - 2.14 - 4.3.1 -
Bootable CD and no hard drive

Acer Aspire 1 netbook using thumbdrive or CD
Back to top
View user's profile Send private message 
Pizzasgood


Joined: 04 May 2005
Posts: 6266
Location: Knoxville, TN, USA

PostPosted: Sun 25 Feb 2007, 21:33    Post subject:  

use
puppy pfix=ram

_________________
Between depriving a man of one hour from his life and depriving him of his life there exists only a difference of degree. --Muad'Dib

Back to top
View user's profile Send private message Visit poster's website 
kent41


Joined: 26 Nov 2006
Posts: 242

PostPosted: Sun 25 Feb 2007, 21:41    Post subject:  

Pizzasgood wrote:
use
puppy pfix=ram


Pizzasgood

Thanks
It seems a very important part of the command was missing.
I ask my wife if it was April 1st and she said no.
Thanks again

Kent

_________________
Toshiba M35X S-111 - Aspire 5100-3357 using puppy 2.12 - 2.13 - 2.14 - 4.3.1 -
Bootable CD and no hard drive

Acer Aspire 1 netbook using thumbdrive or CD
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [17 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0489s ][ Queries: 11 (0.0082s) ][ GZIP on ]