Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 23 Sep 2014, 10:47
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Fehlendes libqt-mt.so.3
Moderators: MU
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
simeon


Joined: 23 Feb 2007
Posts: 9

PostPosted: Mon 26 Feb 2007, 13:40    Post subject:  Fehlendes libqt-mt.so.3  

Hallo allerseits,

ich bin neu bei PUPPY und habe ein paar Fragen (ich habe diese schon ins englischsprachige Forum getippt, aber leider keine Antwort bekommen):

Scribus fehlt libqt-mt.so.3 nach dem Installieren aus Pupget heraus, obwohl er das qt-Packet mit herunterlädt. Woher bekomme ich das?
Ist er "baugleich" mit dem Scribus in GRAFPUP, heißt, er hat die selbe Architektur?

Ich bin übrigens von PUPPY b e g e i s t e r t, so klein, schnell und fein! Habe nur noch keine Erfahrung mit Slackware, da ich bisher immer Debian benutzt habe (wird auch Zeit langsam).

Vielen Dank erstmal!
Simeon
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 26 Feb 2007, 15:43    Post subject:  

Hallo,

guck mal im Dateimanager, ob es diese Datei in /usr/lib/qt oder ähnlichen Unterordnern gibt.
Falls ja, ist nur ein symbolischer Link falsch gesetzt oder dieser Ordner nicht eingetragen in /etc/ld.so.conf

Hast Du diese Datei?

Mark
Back to top
View user's profile Send private message Visit poster's website 
simeon


Joined: 23 Feb 2007
Posts: 9

PostPosted: Tue 27 Feb 2007, 09:02    Post subject:  

Hallo,

danke erstmal für Deine schnelle Antwort!

Ich hab nachgesehen:

Es gibt unter /usr/lib
zwei qt-Koffer, einer heißt "qt", der andere "qt-x11-free-3.3.6", die Inhalte sind identisch!

Unter den /etc Dateien habe ich unter Deiner beschreibenen conf folgenden Eintrag gefunden:

/lib
/usr/lib
/usr/X11R7/lib
/usr/lib/mozilla
/root/my-applications/lib

*

Beim Deinstallieren von qt-3.3.6 löscht es logischerweise beide Koffer.

Was tun? Soll ich per "root" einen der beiden löschen? Oder im Scribus-Verzeichnis einen Eintrag machen - das hab ich auf die Schnelle nicht gefunden, mir ist die Architektur von PUPPY noch nicht so geläufig Wink

Danke im voraus!
Simeon
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 27 Feb 2007, 15:14    Post subject:  

nein, nicht löschen.
Das eine ist nur ein Link (Verweis) auf den anderen.

Füge stattdessen problehalber mal diese Zeile hinzu zu /etc/ld.so.conf:

/usr/lib/qt/lib

Dann den Computer neustarten.
Vorraussetzung ist, daß
/usr/lib/qt/lib/libqt-mt.so.3 tatsächlich vorhanden ist.
Klappt es dann?

Mark
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 27 Feb 2007, 16:16    Post subject:  

Ich glaub ich weiß...

tipp mal bitte:
cd /usr/lib/qt/lib
ls libqt-mt.s*

Dann schreib hier, was da gelistet wird.
Wenn da NICHT kommt:
libqt-mt.so libqt-mt.so.3 libqt-mt.so.3.3 libqt-mt.so.3.3.6

dann fehlt ein symbolischer Link.
Mehr dann mit Deinem Ergebnis.

Gefunden hier:
http://www.puppyos.net/blog/comments.php?y=07&m=02&entry=entry070226-053033
Quote:
J_Rey
Monday, February 26, 2007, 03:51 PM
When you get to the Qt package that will be used to create the "devx" module, please make sure it has the libqt.so, libqt-mt.so, libqt-mt.so.3 symlinks correct and the actual shared object file (e.g. libqt-mt.so.3.3.Cool. The reason being is that with Puppy 2.14 and devx_214.sfs only 2 out of the three symlinks were there but the .so was not. Thanks!


Mark
Back to top
View user's profile Send private message Visit poster's website 
simeon


Joined: 23 Feb 2007
Posts: 9

PostPosted: Wed 28 Feb 2007, 05:34    Post subject:  

Hallo Mark,

alles in Butter!

Es lag nur an dem Eintrag in "/etc/ld.so.conf " - Habe einfach "/usr/lib/qt/lib" eingetragen, fertig.

(Zum Vorschlag via Konsole: Kam nichts, nachdem ich das so getippt hatte, wie Du geschrieben hattest.)

Also, alles halb so wild Wink
Sonst funktioniert alles bestens.
Mal sehen, wie ich zurecht komme, wenn ich LaTeX-Makros installiere und ein paar "fremde" Programme (siehe meinen anderen Eintrag).

Nochmals Danke (regelrecht ungewohnt auf deutsch in Foren zu schreiben)!
Simeon
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0822s ][ Queries: 11 (0.0361s) ][ GZIP on ]