Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 21 Aug 2014, 10:20
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Gtk-Gnutella 0.96.3 Stable
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
Gekko


Joined: 22 Jul 2006
Posts: 445
Location: Sydney, New South Wales

PostPosted: Sat 03 Mar 2007, 00:34    Post subject:  Gtk-Gnutella 0.96.3 Stable
Subject description: Limewire in GTK
 

This is basically straight from the tarball, except I had to modify the source code and comment out about 5 lines to allow root to run it, stupid people deciding that root isn't allowed to run anything any more, but I digress.

EDIT: Now a .pet and a tar.gz :O
Untar into / for the tar.
Click me for dotpet.
Click me for tarball.
Back to top
View user's profile Send private message 
ecomoney


Joined: 25 Nov 2005
Posts: 2183
Location: Lincolnshire, England

PostPosted: Mon 16 Apr 2007, 16:57    Post subject: 2.02 not working  

Doesnt work with 2.02, after untarring it to the root / . Is this the correct way to install?
_________________
Puppy Linux's Mission

Sorry, my server is down atm!
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 16 Apr 2007, 17:49    Post subject:  

2.02 uses Gtk 2.6, while since 2.10 Gtk 2.8 is used.
Many new programs do not work with Gtk 2.6, as they use new functions like tree-views and such.

To say more, you had to run it from a console, and post the errors here.
If you have luck, just an additional library is missing.

If the problem really is Gtk, you also could upgrade Puppy 2.02 with Gtk 2.8, but backup your personal savefile first, as this is a deep change of your system-libraries.
http://www.murga-linux.com/puppy/viewtopic.php?t=9599

Mark
Back to top
View user's profile Send private message Visit poster's website 
brad_chuck

Joined: 15 Aug 2005
Posts: 284
Location: Appalachian Mountains

PostPosted: Mon 16 Apr 2007, 18:03    Post subject:  

Works for me... Thanks
Back to top
View user's profile Send private message 
irishsage

Joined: 13 Sep 2006
Posts: 4

PostPosted: Mon 16 Apr 2007, 23:51    Post subject:  

I get this with the petpkg:

There was an error expanding package gtk-gnutella-0.96.3.tar.gz.
Either the file is corrupted, or has not expanded into its own directory with
name of gtk-gnutella-0.96.3/ (which is how most packages expand).
You will have to go into /root/.packages/ directory and manually clean it up.

This script will now exit...

I tried other versions too no luck. Will try it from the tarball.
Back to top
View user's profile Send private message 
irishsage

Joined: 13 Sep 2006
Posts: 4

PostPosted: Mon 16 Apr 2007, 23:55    Post subject:  

Same thing with the tarball. Gnutella worked on simple pup for me now I have 2.15 installed on my hard drive and no clue.
Back to top
View user's profile Send private message 
aaa3

Joined: 02 Oct 2013
Posts: 10

PostPosted: Wed 21 May 2014, 20:24    Post subject:  

Code:
gksu -u spot 'gtk-gnutella --daemonize'

and
Code:
su - spot -c 'gtk-gnutella --minimized'

works with unmodified binary packages; freely after http://forums.gentoo.org/viewtopic-t-324025-view-next.html?sid=078ff429a51adf90547b3d4cf696d14e and https://www.google.com/search?q=kdesu+gtk+equivalent

just su-ing doesnt, even after xhost +localhost and lol xhost +0.0.0.0; and it starts but spinlocks if i gksu it w.o. any arguments. necroposting because this is one of the top results on the web...

tho another problem might affect usage, is that it now complains that its old but 0.98.2 (2011) is the latest in the repo for precise and ppm, with upstream being 1.0.1 (2013 or 4), nominally for ubuntu trusty. nevertheless, i tried grabbing it from launchpad web directly, it seems to be running all right ^^ any1 wants sfs?
Back to top
View user's profile Send private message 
RSH


Joined: 05 Sep 2011
Posts: 2390
Location: Germany

PostPosted: Fri 30 May 2014, 17:16    Post subject:  

Quote:
any1 wants sfs?

Exclamation YES! Laughing

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0652s ][ Queries: 11 (0.0097s) ][ GZIP on ]