Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 25 Nov 2014, 19:29
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
How to set up a Wacom Tablet
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 12 of 24 Posts_count   Goto page: Previous 1, 2, 3, ..., 10, 11, 12, 13, 14, ..., 22, 23, 24 Next
Author Message
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Mon 01 Nov 2010, 15:42    Post_subject: success with Wary 094  

I tried out the latest Puppy.

I was able to use my Wacom Bamboo tablet with Wary 094.
The pressure sensitivity worked with mtpaint 3.31
I installed wacom-0.8.4-4_xorg_driver.pet from
http://www.murga-linux.com/puppy/viewtopic.php?t=16491

It was simple to install because xorg.conf already had a
'ServerLayout' section

Note that it wouldn't work when I tried the following:
wacom-0.10.7_xorg_driver.pet
wacom-0.10.8_xorg_driver.pet

___________________________________________________


Note to Joe Jasniewski

It seems like wacom-0.8.4-4_xorg_driver.pet is
the only version that will work with Puppy 4.3.1

_____________________________________________
Back to top
View user's profile Send_private_message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7082
Location: Perth, Western Australia

PostPosted: Mon 01 Nov 2010, 19:17    Post_subject:  

I was thinking that I might buy a tablet input device for testing on Wary, but the Wacom Bamboo is not cheap, $239 (Perth, Australia, AU Dollars -- about same as US):

http://www.ple.com.au/?p=snapshot&inventory_id=749

Any online supplier that is significantly cheaper, or any alternate brand? -- surely something from China can be obtained for far less than that price.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Mon 01 Nov 2010, 20:06    Post_subject: cost of wacom Bamboo  

Here in Canada you can get the WACOM BAMBOO for as little as
$69 CAN +16% sales tax but here's the catch...

The active area is only about 4x6 inches and there's no software inside.
This is good enough for me and probably for you since we get
the 'free' linux software. I like it for small artwork and drawings.
See my puppy on left.


There is a better model that has
Corel® Painter™ Essentials 4 inside the box. It's a good quality
program but it doesn't support layers and it's definitely not for linux.

http://www.wacom.com/bamboo/bamboo_pen.php

There is another competing company in China but who knows if
their product would work in Puppy.

I noticed that Ubuntu linux says it supports AIPTEK

http://www.aiptek.com/Tablets/ST12/Features/

https://help.ubuntu.com/community/AiptekTablet

_________________________________________________
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Mon 01 Nov 2010, 20:28    Post_subject: reporting success  

I was able to use an earlier driver wacom-0.8.4-4-k2.6.30.5.pet

http://www.browserloadofcoolness.com/software/puppy/PETget/wacom/wacom-0.8.4-4-k2.6.30.5.pet

on the latest luci 234 (just released )

However it still requires a pupsave file to be created first
because of period of black screen when choosing 'reboot'

_____________________________________________
Back to top
View user's profile Send_private_message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7082
Location: Perth, Western Australia

PostPosted: Tue 02 Nov 2010, 10:25    Post_subject:  

I have done some research:

http://bkhome.org/blog/?viewDetailed=01918
http://bkhome.org/blog/?viewDetailed=01917
http://bkhome.org/blog/?viewDetailed=01915

I have compiled the Wacom 0.8.8-10 driver for Wary.

I also compiled the Wizardpen driver that supports many brands of tablets other than Wacom. Some of these other brands are about 1/3 the price of Wacom here in Australia.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Wed 03 Nov 2010, 18:07    Post_subject: mtpaint modified  

I tested Barry's new wacom driver that he compiled for Wary
AVAILABLE HERE

I love it . Perfect. I don't have the problems that I still have in Lucid Puppy.
Note that this driver definitely doesn't work with Lucid Puppy


On a related subject...

I received a modified version of mtpaint 3.34.56 from the
maintainer Dimitri Groshev that was compiled in Slack Linux.
He made some quick changes in the method used for mouse position
in the mtpaint window and he succeeded. No problems
now in pressure sensitivity. Very Happy


He asked me to test it. It works perfectly in several version of Puppy linux

Here are some quick notes:

Wary094 excellent except for one minor flaw...it wouldn't launch.
I launched the terminal and typed
Code:
ldd mtpaint

The terminal gave the message 'libtiff.so.4 not found'. So I made a
link to the older version of libtiff I found in /usr/lib/.

mtpaint now launches and works very well.

luci234 and lupq511 don't save the tablet settings each time I quit
and then relaunch mtpaint.

Lighthouse 5F --- mtpaint 3.34.56 now works great with tablet

If you want to try out this application, here's
a download site...

http://www.datafilehost.com/download-ebf11bdd.html

Post any bugs you find.
___________________________________________________________
Edit: Barry Kauler will be incorporating mtpaint 3.34.57 in future
versions of Wary

_______________________________________________________

Edited_time_total
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Mon 08 Nov 2010, 16:30    Post_subject: tablet preferences for mtpaint  

I received a suggestion from Dmitry Groshev, maintainer of mtPaint
to solve the problem of the pressure settings in mtpaint not being
persistant with multiple launches. The solution was simple.

I was setting the mtpaint tablet preference for everything I saw on the list
i.e. pad, erasor, stylus and cursor. Dmitry recommended only setting
the 'stylus' to work on the screen and leave the others alone.

That did the trick and now I can use mtpaint perfectly in
lupq511 and luci 235 (beta of Lucid Puppy5.2)

_____________________________________________

Here's the latest version of mtpaint (version 3.34.57) that fixed
all my problems. Hopefully it will be incorporated into the
next generation of Puppies.

http://www.datafilehost.com/download-fae7d43d.html

__________________________________
Back to top
View user's profile Send_private_message 
charlie6


Joined: 30 Jun 2008
Posts: 1021
Location: South of Belgium

PostPosted: Sun 14 Nov 2010, 14:11    Post_subject: CORRECTED wacom-0.10.8_xorg_driver-lupq511.pet for Lupq-511
Sub_title: corrected wacom xorg driver driver with right driver location
 

Hi,
please find at bottom of page 10 this thread the corrected driver.
Again my apologizes to the forum, and many thanks to forum member Tempestuous.
Cheers, Charlie
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5285
Location: Australia

PostPosted: Mon 15 Nov 2010, 08:50    Post_subject:  

Yes, charlie6 and I have been discussing the confusion in the latter part of this forum thread regarding compatibility of various wacom dotpets with different Puppy versions. Here's the overall situation:
The wacom drivers consist mainly of two components - an Xorg input plugin called wacom_drv.so, and a kernel module called wacom.ko.
There's also a udev rule which should load the kernel module (and plugin?) and some utilities for diagnosis.

The kernel module is obviously compatible only with the kernel version (and thus, Puppy version) it was compiled for.

Significantly, also, are the file location differences between Xorg versions;
Puppy 4.3.x and Wary both have Xorg 7.3 (xorg-server 1.3.0.0),
for which the plugin location is /usr/X11R7/lib/xorg/modules/input/

Puppy 5.x and Quirky both have Xorg 7.5 (xorg-server 1.7.6),
for which the plugin location is /usr/lib/xorg/modules/input/

To add further to this complexity, the very latest wacom drivers have a different release series for versions of Xorg after 7.5.

I have just compiled the latest wacom drivers (released October 2010), and consolidated them for Puppy 5.x and 4.3.x
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5285
Location: Australia

PostPosted: Mon 15 Nov 2010, 08:52    Post_subject:  

Puppy 5.1.x
The wacom drivers in Puppy 5.1.x are reasonably up to date, so the only thing missing is the udev rule, now attached.
After installing this dotpet, reboot.
Now modify your /etc/X11/xorg.conf file as per the instructions in the first post in this thread.
Restart X, or reboot.
wacom-udev.pet
Description 
pet

 Download 
Filename  wacom-udev.pet 
Filesize  433 Bytes 
Downloaded  406 Time(s) 
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5285
Location: Australia

PostPosted: Mon 15 Nov 2010, 08:55    Post_subject:  

But if you want to try the very latest wacom drivers with Puppy 5.1.x, here they are, separated into their 2 main components; Xorg input, and kernel module.
Try just the Xorg input first. It includes the udev rule and the xsetwacom utility.
The updated kernel module supports a few extra USB device ID's than the original version in Puppy 5.1.x Apart from that, I don't know if it's any more advanced.

These dotpets will rename the original Puppy 5.1.x wacom drivers to "wacom_drv.so-old" and "wacom.ko-old", just in case the new versions don't work, and you need to reinstate the originals.
xf86-input-wacom-0.10.8.pet
Description  for Xorg 7.5 up
pet

 Download 
Filename  xf86-input-wacom-0.10.8.pet 
Filesize  81.24 KB 
Downloaded  545 Time(s) 
wacom-module-0.8.8-10-k2.6.33.2.pet
Description  for Puppy 5.1.x
pet

 Download 
Filename  wacom-module-0.8.8-10-k2.6.33.2.pet 
Filesize  14.14 KB 
Downloaded  460 Time(s) 
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5285
Location: Australia

PostPosted: Mon 15 Nov 2010, 08:58    Post_subject:  

Puppy 4.1/4.2 and Puppy 4.3.x
Here is the complete wacom driver package; includes xorg plugin, kernel module, udev rule, and utilities: wacdump, xidump, xsetwacom, libwacomcfg.
Make sure you install the correct version !! Otherwise the wacom kernel module will be incompatible, and will obviously fail.

EDIT: 4.1/4.2 version was corrupt. Now fixed and uploaded.
wacom-0.8.8-10-k2.6.25.16.pet
Description  for Puppy 4.1/4.2
pet

 Download 
Filename  wacom-0.8.8-10-k2.6.25.16.pet 
Filesize  109.73 KB 
Downloaded  323 Time(s) 
wacom-0.8.8-10-k2.6.30.5.pet
Description  for Puppy 4.3.x
pet

 Download 
Filename  wacom-0.8.8-10-k2.6.30.5.pet 
Filesize  110.39 KB 
Downloaded  405 Time(s) 

Edited_times_total
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5285
Location: Australia

PostPosted: Mon 15 Nov 2010, 08:59    Post_subject:  

For Wary, Barry has provided the latest wacom drivers here
http://distro.ibiblio.org/pub/linux/distributions/quirky/pet_packages-wary5/linuxwacom-0.8.8-10-w5.pet
This is exactly the same Xorg plugin I packaged for Puppy 4.3.x
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3379
Location: Ontario

PostPosted: Thu 18 Nov 2010, 15:14    Post_subject: successful test of new drivers  

I was successful with the new driver of charlie6
(at bottom of page10) installing with wacom bamboo tablet.

I tried it on lupq511 and luci236 and it now
allows the proper shutdown procedure
so that a pupsave file can now be created.

______________________________________

mtpaint 3.34.57 works when the tablet preferences are
set up in the following manner....

Set 'stylus' to 'screen'
The other tools leave disabled.

Don't forget to tick 'opacity' and 'size'
or the pressure effect won't be seen .

___________________________________


_____________________________________
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5285
Location: Australia

PostPosted: Thu 18 Nov 2010, 20:09    Post_subject:  

don570 wrote:
I was successful with the new driver of charlie6
(at bottom of page10)

That's the same as "xf86-input-wacom-0.10.8.pet" from above.
The version above is smaller because the binary has been stripped.


charlie6 wrote:
to be used with the the already present wacom.ko

Sure, the existing wacom kernel module should work fine with the upgraded wacom Xorg plugin, but users should consider upgrading the kernel module as well, since this was provided by the wacom developers as part of the 0.10.8 driver package.
The upgraded kernel module I'm referring to is "wacom-module-0.8.8-10-k2.6.33.2.pet"

... and obviously, we're talking about Puppy 5.1.x/5.2
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 12 of 24 Posts_count   Goto page: Previous 1, 2, 3, ..., 10, 11, 12, 13, 14, ..., 22, 23, 24 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1234s ][ Queries: 12 (0.0322s) ][ GZIP on ]