Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 26 Apr 2015, 06:15
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
How to set up a Wacom Tablet
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 24 of 24 [360 Posts]   Goto page: Previous 1, 2, 3, ..., 22, 23, 24
Author Message
don570


Joined: 10 Mar 2010
Posts: 3709
Location: Ontario

PostPosted: Sat 19 Apr 2014, 15:27    Post subject:  

There are actually two drivers

1) kernel
2) Xorg

The kernel driver is built into the puppy distro.
The Xorg driver has to be installed. (Although some distros have
it built-in as well such as Porteus and Ubuntu)


Google 'wacom + driver + linux'
http://sourceforge.net/projects/linuxwacom/files/xf86-input-wacom/



_________________________________________
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1967
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sun 20 Apr 2014, 07:38    Post subject:  

Bonjour don570,
Thanks for info.
Done!
It works perfectly for me, running Puppy Precise 5.7.1. The pet package is too big (304 ko) to be uploaded on the forum. So, for those who are interested in, xf86-input-wacom-k3.9.11-0.24.0.pet is available from the Arrow ToOpPy site repository.

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
charlie6


Joined: 30 Jun 2008
Posts: 1078
Location: South of Belgium

PostPosted: Tue 22 Apr 2014, 10:50    Post subject:  

Hi don570 and all,

here are two xf86-wacom-input drivers download links, both compiled on wheezy-3.5.2.11:
the one is earlier version 0.17;
http://www.datafilehost.com/d/9719651c
this 0.17 runs OK here and ensures smooth cursor motions;

the second is the latest 0.24;
http://www.datafilehost.com/d/3a57b4fc
since version 0.18 (which has been told as "buggy"), i cannot get further versions working as nice as the 0.17 ! Crying or Very sad

Till now... keeping living with 0.17... Cool

I already reported it in earlier posts (around page22): whtever "relative" or "absolute" mode", the cursors arrow runs away to the above left screen corner once the stylus is lifted far away from the pad. I believe the cursor should stay were it has been left then, as it is the case on drivers up to 0.17.
All this using various tablets as Graphire1 , Volito1 and MTE450 (Bamboo) on desktops and laptops.

Do you get such a similar behaviour?

I reported this to wacom projects developper who could not reproduce it.

Thanks for eventual report !

Cheers,
Charlie
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3709
Location: Ontario

PostPosted: Tue 22 Apr 2014, 15:12    Post subject:  

To Charlie .....

My Bamboo tablet has been working fine except Windows XP Rolling Eyes
where there's a bug that forces me to re-install
the driver from time to time.

There may be something wrong with my precise pet package that
I have listed. Did I leave out my script?? I'll download and check at home.

I recompiled the source in Precise 5.7.1 and here it is

http://www.datafilehost.com/d/87525f21

I'll check Argolance's package to see if it was made correctly.

To post it on this page I will drop an app from the package to
reduce it to 250 kb limit.

_________________________________
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1078
Location: South of Belgium

PostPosted: Tue 16 Dec 2014, 16:30    Post subject: cursors behaviour since xf-86-input wacom 0.17.0 [SOLVED]  

Hi don570 and all !
good news ... at least for me ... Laughing
charlie6 wrote:
...blablibla...
since version 0.18 (which has been told as "buggy"), i cannot get further versions working as nice as the 0.17 ! Crying or Very sad

Till now... keeping living with 0.17... Cool

I already reported it in earlier posts (around page22)...
Do you get such a similar behaviour?

I reported this to wacom projects developper who could not reproduce it.


I've just got this "still warm" post from wacom developper Jason Gerecke:
Quote:
Objet: [linuxwacom:bugs] #229 xf86-input driver versions above 0.17.0 : no right-click + unexpected cursor behaviour
De: "Jason Gerecke"
Date: Sam 13 décembre 2014 01:19
À: "[linuxwacom:bugs]" <229@bugs.linuxwacom.p.re.sf.net>
Priorité : Normale
Options: Afficher l'en-tête complet | Voir la version imprimante

status: open --> closed-works-for-me
Comment:

Both of these issues seem to result from an unexpected interaction between our driver and the generic "mouse" driver. As described in [bugs:#240], if you add Option "GrabDevice" "1" to each wacom InputDevice in /etc/X11/xorg.conf then both problems seem to be prevented.


I then compiled and installed version the latest version 0.27.0;
now ..here is xorg.conf edited accordingly (input devices section):
just added
Option "GrabDevice" "1"
in each input device.

Quote:
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
#Screen 1 "Screen1" RightOf "Screen0"
#Screen 2 "Screen2" RightOf "Screen1"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
#from kernel 2.6.35 and later the "SendCoreEvents" after InputDevice is no longer required
InputDevice "stylus"
InputDevice "eraser"
InputDevice "cursor"
InputDevice "pad"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc102"
Option "XkbLayout" "be" #xkeymap0
#Option "XkbVariant" "" #xkbvariant0
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2" #mouse0protocol
Option "Device" "/dev/mouse"
#Option "Emulate3Buttons"
#Option "Emulate3Timeout" "50"
Option "ZAxisMapping" "4 5" #scrollwheel
EndSection


Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "USB" "on"
Option "GrabDevice" "1"
# Option "Mode" "Absolute"
Option "Mode" "Relative"
# Option "AlwaysCore" "on"
Option "Speed" "1.0"
Option "Threshold" "5"
Option "CursorProx" "5"
# Option "Speed" "5"
# # Option "ForceDevice" "ISDV4" # Serial Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "USB" "on"
Option "GrabDevice" "1"
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/input/wacom" # USB ONLY
Option "Type" "cursor"
Option "USB" "on" # USB ONLY
Option "Mode" "Relative"
Option "GrabDevice" "1"
Option "CursorProx" "5"
Option "Speed" "1.0"
EndSection

Section "InputDevice"
Identifier "pad"
Driver "wacom"
Option "Device" "/dev/input/wacom" # USB ONLY
Option "Type" "pad"
Option "USB" "on" # USB ONLY
Option "GrabDevice" "1"
EndSection


restarted X, and the cursors mouse now moves as expected ... Shocked Smile (NB: Option "Mode" "Relative" is my favourite cursors behaviour Rolling Eyes )
just try it !!
hth Smile
charlie
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3709
Location: Ontario

PostPosted: Tue 16 Dec 2014, 21:22    Post subject:  

I found this comment on wacom site

http://sourceforge.net/p/linuxwacom/bugs/229/?limit=25#9c30

I've downloaded version 0.27 and I'll try it on Precise puppy.
__________________________________________________
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1078
Location: South of Belgium

PostPosted: Wed 17 Dec 2014, 01:36    Post subject: xf86-input-wacom driver compiled for kernel 3.17.4  

hi don570 and all,
compiled on Tahr-6.0CE PAE k.3.17.4
here is xf86-input-wacom driver compiled for kernel 3.17.4 (337K ...might be possible to reduce the size under 250K .. Confused )
download link:
http://www.datafilehost.com/d/e3645c6a

NB: the device option #Option "GrabDevice" "1" is included as commented line in the /etc/X11/xorg.conf file (installed by the pinstall.sh) to the four devices:
Code:
#Option "GrabDevice" "1"

just uncomment it to activate that option.

Cheers, Charlie

ps: @don570: lot of thanks for the pinstall.sh ...works nice Smile !!
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3709
Location: Ontario

PostPosted: Wed 17 Dec 2014, 21:38    Post subject:  

charlie6 wrote:
here is xf86-input-wacom driver compiled for kernel 3.17.4
(337K ...might be possible to reduce the size under 250K .


To get the size under 250k I leave the applications out.
xsetwacom is an app I don't use . Also /etc folder isn't needed either since rules are set set elsewhere.

______________________________________________________

I posted a new precise package on the previous page. It works well on my
Bamboo 450. I think your Bamboo 450 has a defect, otherwise more people
would have complained to wacom.

I tried putting

Code:
Option "Mode" "Relative"

into the xorg.conf file but it turned my pressure off.
________________________________________________


New Wacom Bamboo Splash models in store don't mention compatibilty with
Windows XP however on support forum they say it is possible to
use Windows XP and certain posted driver packages.
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3709
Location: Ontario

PostPosted: Thu 18 Dec 2014, 20:58    Post subject: Tahr puppy driver works  

To Charlie:

I tested your pet package in tahr 5.8.3 and it works fine!
Fortunately you commented out the lines for Absolute and Relative position.

I re-packaged the pet

1) I removed everything in /etc i.e the rules since they are in /usr

2) Removed desktop file

3) Removed man files

4) Removed all applications

5) Removed kernel drivers wacom.so

6) Changed the warning message in pinstall.sh so it launches last.
This avoids a confusing jumble of windows.

The size is now well under 250k max so I can post it on the precious page. Laughing


___________________________________________
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3709
Location: Ontario

PostPosted: Tue 30 Dec 2014, 17:27    Post subject:  

I modified the slacko driver so that modprobe wacom isn't needed.
and added my xorg.conf modification

I tested on Slacko 6.0, but should work as far back as 5.6
xf86-wacom-slacko-mod-0.10.9.pet
Description  Slacko version of wacom bamboo driver
pet

 Download 
Filename  xf86-wacom-slacko-mod-0.10.9.pet 
Filesize  250.04 KB 
Downloaded  77 Time(s) 
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3709
Location: Ontario

PostPosted: Wed 31 Dec 2014, 13:07    Post subject:  

I downloaded latest wacom x driver 0.27.99 and tried to make a pet package, however I had problems. Crying or Very sad
So I took the above pet package
0.10 and put the 0.27.99 drivers in it and made a pet package and it
worked Laughing

Also I made a xsetwacom package if anybody needs it. Left in man files as well.

_______________________________________________________

Instructions :

1) install pet package, no 'modprobe wacom' is needed to recognize driver!!
2) Restart X
3) Set preferences of your favorite graphics app to pressure
xf86-wacom-slacko-mod-0.27.99.pet
Description  no modprobe wacom is needed
pet

 Download 
Filename  xf86-wacom-slacko-mod-0.27.99.pet 
Filesize  236.48 KB 
Downloaded  74 Time(s) 
xsetwacom-0.27.99.pet
Description  optional configuration file
pet

 Download 
Filename  xsetwacom-0.27.99.pet 
Filesize  52.2 KB 
Downloaded  64 Time(s) 
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1078
Location: South of Belgium

PostPosted: Wed 04 Mar 2015, 07:06    Post subject: wacom kernel drivers for kernels 3.17.7  

Hi,
here is a pet having wacom kernel drivers (serial & usb) for kernels 3.17.7
compiled on tahr-6.0.2-PAE kernel 3.17.7
enjoy Smile
Charlie
ps: need to have the xf86-input-wacom Xorg driver installed (already present in Tahr-6.0.2's iso)
input-wacom-0.26.0_k3.17.7_PAE.pet
Description  3.17.1 KERNEL wacom drivers (usb and serial)
pet

 Download 
Filename  input-wacom-0.26.0_k3.17.7_PAE.pet 
Filesize  29.24 KB 
Downloaded  48 Time(s) 
Back to top
View user's profile Send private message 
charlie6


Joined: 30 Jun 2008
Posts: 1078
Location: South of Belgium

PostPosted: Wed 04 Mar 2015, 11:57    Post subject: xf86 Xorg driver for Tahr-6.X-PAE kernel 3.17.7  

Hi,
here are as separate pets the Tahr-6.X 's Xorg drivers stuffs compiled on Tahr-6.0.2-PAE with kernel 3.17.7.

These pets are highly inspirated from don570 one's ...excepted for /usr/lib/xorg/modules/input/wacom_drv.so located in /usr/lib/xorg/modules/input/ instead (tons of thanks @ don570 for his xorg.conf configure script)

note: the kernel driver must be already present before installing these pets.

ps: the option GrabDevice=1 is default set as uncommented. Adjust manualy if needed.

Enjoy, Charlie Smile
xsetwacom-0.28.0_k3.17.7.pet
Description 
pet

 Download 
Filename  xsetwacom-0.28.0_k3.17.7.pet 
Filesize  88.39 KB 
Downloaded  45 Time(s) 
xf86-wacom-Tahr-6.X_k.3.17.7-mod-0.28.0.pet
Description 
pet

 Download 
Filename  xf86-wacom-Tahr-6.X_k.3.17.7-mod-0.28.0.pet 
Filesize  224.11 KB 
Downloaded  51 Time(s) 
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3709
Location: Ontario

PostPosted: Sat 07 Mar 2015, 15:30    Post subject:  

I tried xf86-wacom-Tahr-6.X_k.3.17.7-mod-0.28.0.pet
on tahr 5.8.3 which has an earlier kernel.

My cursor was very sensitive for about a minute then it steadied and is
working fine now . mtpaint shows pressure sensitivity with my
wacom bamboo tablet.
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3709
Location: Ontario

PostPosted: Wed 22 Apr 2015, 20:31    Post subject:  

I made a package for wheezy - compiled in Pupjibaro Wheezy 1.0.6 beta
I couldn't get a recent version of wacom to vary the pressure
so I used an old version.
_____________________________________________________
xf86-wacom-wheezy-mod-0.27.0.pet
Description  wheezy package
pet

 Download 
Filename  xf86-wacom-wheezy-mod-0.27.0.pet 
Filesize  226.77 KB 
Downloaded  4 Time(s) 
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 24 of 24 [360 Posts]   Goto page: Previous 1, 2, 3, ..., 22, 23, 24
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1189s ][ Queries: 12 (0.0122s) ][ GZIP on ]