Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 31 Jul 2014, 12:07
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Java Virtual Machine - no (norwegian characters)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
Kark

Joined: 26 Jul 2005
Posts: 26
Location: Norway/France

PostPosted: Mon 15 Aug 2005, 18:28    Post subject:  Java Virtual Machine - no (norwegian characters)  

The programs relying on jre seem to be using a different keymap from the one I
have set as default. I can not use Norwegian characters.

I don't have this problem on other distros. Could it be related to locale setting?

I use Puppy 1.0.3 and jre1.5.0_02

Does anyone know what to do?

Help would be very welcome Very Happy

Kark
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Tue 16 Aug 2005, 03:04    Post subject:  

The language support has only just started

http://www.goosee.com/puppy/wikka/LanguageSupport

- Puppy was designed for the English language
so other language support is a question of using search (keyboards would be a key word) on this forum and then modifying the wiki if you find any answers

There are people using other languages but specifically for Java I do not know

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
Kark

Joined: 26 Jul 2005
Posts: 26
Location: Norway/France

PostPosted: Tue 16 Aug 2005, 03:51    Post subject:  

Thank you Lobster

I'll put something in the Wiki if I find a solution. Very Happy

So far I've managed to get my programs appear in Norwegian by detours around that elusive locale support, but for this one I'm quite shure I need to set another locale to make things work.

The problem is, I am not yet experienced enough to figure out how to add support for new locales. I have tried the guided steps I could find, without success.

But I'm shure the solution will appear one day in this wonderful forum.

In the meantime I'll continue trying
Smile

Kark
Back to top
View user's profile Send private message 
Kark

Joined: 26 Jul 2005
Posts: 26
Location: Norway/France

PostPosted: Tue 16 Aug 2005, 14:24    Post subject:  

Hacao had the solution!

I simply followed parts of his instruction and now it works!

I already had localedef (does it come with gcc?),so I did the following:

First I copied locale no_NO from a different distro
then I opened a teminal and did:

mkdir /usr/share/locale/no_NO.ISO-8859-1
localedef -v -c -i no_NO -f ISO-8859-1 /usr/share/locale/no_NO.ISO-8859-1
cd /usr/lib/locale
ln -s /usr/share/locale/no_NO.ISO-8859-1 no_NO.ISO-8859-1

Then I changed LANG=C to LANG=no_NO.ISO-8859-1 in /etc/profile

Now I don't get any error messages about locale not being supported anymore, and jvm works like it should.

If things stay troublefree I'll try to write a how-to for the wiki

Very Happy Kark
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Tue 16 Aug 2005, 15:50    Post subject:  

kewl - Norwegian Puppy. Hopefully your efforts will encourage others to change to their languages and dialects. Today Norway - tommorrow the world

[maniacal laughter and the sound of restraints . . .]

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
Hacao


Joined: 10 Aug 2005
Posts: 225
Location: Saigon, Vietnam

PostPosted: Fri 19 Aug 2005, 02:25    Post subject: congratulation !  

Hi !

Puppy will more well know !

1. Norwegian Puppy
2. Vietnamese Puppy
...
...
......l. other country's Puppy Smile

Are you thinks so ?

Thanks,


P/S: Puppy should set up UTF- 8 encoding for default. Smile, may be (en_US.UTF-Cool !
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0564s ][ Queries: 11 (0.0094s) ][ GZIP on ]