Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 11:13
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
1.0.2 won't boot my machine(without some intervention)
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
everettattebury


Joined: 08 May 2005
Posts: 14
Location: Sarasota, Florida

PostPosted: Tue 17 May 2005, 10:32    Post_subject:  1.0.2 won't boot my machine(without some intervention)  

I think this is due to the kernel upgrade. All of the other live cd's I have tried that were based on the 2.6 kernels required the "acpi=off" argument to boot, otherwise they would either hang, or continually reboot. Puppy 1.0.2 continually reboots my machine.

I was able to hit escape, then type "vmlinuz acpi=off" and it would start to boot, but then would get a kernel panic when it couldn't find the virtual file system.

I finally figured it out, and after reading the isolinux.cfg file on the cd, I was able to boot normally by hitting escape to abort the default boot, then typing "vmlinuz root=/dev/ram0 initrd=image.gz acpi=off".

I know the idea is to keep puppy simple, that's probably why there's not a boot option screen, and some other live cd's really have way too many boot options. But how about an iso with a different isolinux.cfg for people with this problem?
Back to top
View user's profile Send_private_message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7083
Location: Perth, Western Australia

PostPosted: Tue 17 May 2005, 21:20    Post_subject:  

I had thought that I could get away with compiling the kernel not to use acpi if it sees the pc was manufactured before 2001, reasoning that 2001 and later pcs should have a less buggy acpi bios.

So, I really do need to look at a boot menu for 1.0.3.
It doesn't have to delay the boot by much, maybe just a few seconds.
It would be good if the isolinux.cfg could detect, a key held down, say the ctrl or shift key -- preferably some key that is the same on many different keyboard layouts.
Back to top
View user's profile Send_private_message Visit_website 
wscarl

Joined: 16 May 2005
Posts: 99
Location: NY

PostPosted: Wed 18 May 2005, 12:00    Post_subject: Same problem cd and HD boot hang!  

Pupply hung whem I tried to boot 1.0.2 On a Gateway Solo 1200 laptop
800 celeron 128ram (shared 16meg Video) 30gig hd. Also Remove HD and load Puppy on HD FUll Grud boot then re-install same thing -Puppy Hung on boot.
Back to top
View user's profile Send_private_message 
wscarl

Joined: 16 May 2005
Posts: 99
Location: NY

PostPosted: Wed 18 May 2005, 17:54    Post_subject: Got this email - more of boot problems with 1.0.2  

Dear WSCarl,

In responding to a query of mine on the newsgroup,
you kindly said I might email you if I needed more
information. I certainly do. Briefly, I'm 75 and
have no theoretical knowledge of computing although
I've been running Debian for some time without any
real difficulties (from Slink up to Sid).

When you first posted, I was trying to install v.1.0.0
on to hard disk. Yesterday v.1.0.2 came out, and I
downloaded that and burned it to CD - it doesn't boot.
I got another copy from a different site and that is
the same - I get the error message '<0> Kernel panic -
not syncing: Attempted to kill the idle task'
Knoppix, and Kanotix boot without problem, so I doubt
the problem is due to the box.

Going back to v.1.0.0, and your advice on using grubhd.zip.
I can boot from the CD, but:-

a. If I create /dev/hda1 before booting (using a Linux
fdisk or cfdisk), the partition is not and cannot be
mounted. If I create it after booting the position is the
same. I cannot mount it either using the puppy tool or the
command line. (I can mount and unmout both the CDRom and
Floppy).

b. I have grubhd.zip on a floppy (downloaded on my main
box). By mounting the floppy, I get access to the file
but cannot use it - clicking on it unzips fine, but there
I'm stuck.

c. I've tried numerous times without success. Trying
just to use the HD install wizard get me nowhere either.
I've read as much as I can find but can't find the answer.
One thing I'm not sure about is that I have over 900M of
RAM - is this a problem? (I put this box together a week
ago using bits and pieces from earlier upgrades).

d. I'm particularly concerned that v.1.0.2 results in a
Kernel panic - has anyone else had this problem.

If you can help or point me in the right direction, I'd
be most grateful.

Regards,

achilles.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0543s ][ Queries: 11 (0.0048s) ][ GZIP on ]