Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Jan 2020, 08:57
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message

Joined: 08 May 2007
Posts: 4

PostPosted: Tue 19 Jun 2007, 04:07    Post subject:  USB ADSL Modem
Subject description: Works in Ubuntu but not in Puppy

This is an old problem. But, Puppy 2.16.1 is not fixed it.

you have an ADSL modem, and it connected to your computer via USB cable.
So, puppy 2.16.1 detect that 1 device connected to pc by usb cable, but it cannot using this usb device.
but, when i try ubuntu 6. It seems to be ok. Ubuntu detect my modem, get IP address via DHCP and i connected to the net.

So, is there a missing driver in puppy??
i found eagleusb lib on sourceforge, is it help us?
Back to top
View user's profile Send private message 
Puppy Master

Joined: 09 May 2005
Posts: 9172
Location: Perth, Western Australia

PostPosted: Tue 19 Jun 2007, 08:05    Post subject:  

You need to read down through the Developer News to find out what is going on with modems.

Back to top
View user's profile Send private message Visit poster's website 

Joined: 21 Nov 2006
Posts: 11775
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Tue 19 Jun 2007, 10:12    Post subject:  

It is not clear if you would like to use a ADSL modem (so high speed) or a dial up (slow speed) modem.
You speak of a ADSL modem but you ask the question in the dialup group.
More details on you hw would be nice to give.
Back to top
View user's profile Send private message 

Joined: 25 Nov 2007
Posts: 2

PostPosted: Sat 15 Mar 2008, 18:04    Post subject: USB ADSL Modem
Subject description: Sagem F@st 800 E2

First, two quick messages:
1. Bad news: as long as I know, Puppy Linux v3.01 does not support USB ADSL modems.
2. Good news: I've managed to establish the working connection with my provider on a 3.01 distro with Sagem F@st 800 E2 modem.

Now follow the details.
Add. point 1: the lack of support means that there are no readily compiled modules nor software for setting up and managing your connection. Fortunately, the kernel ( does support it. This means, that in order to run your modem you need to compile the module from the sources.

1. So first of all you need to install the development environment and the kernel sources. You need the devx_301.sfs and kernel-src_301.sfs packages that can be got here. How to install them you need to learn elsewhere. Basicaly you don't really install these packages but just copy the folder from the squash file system package to your root directory (if you have your Puppy installed on your hd that is). There is somewhere a good article about sfs installation.

2. Now the hard part. It is quite possible, it can be done easier. I just didn't find a strightforward explanation. What I found is this:

- in your kernel directory (/usr/src/'uname -r'/) #make xconfig
- now, in principle, you should load the configuration of your kernel. There should be a file config or config.gz somewhere. To be frank, there is a lot things you should do in the case something goes wrong like saving somewhere current modules and/or the working config file. I didn't care as it was a fresh Puppy instalation. Anyway, it seem that in Puppy xconfig loads the most recent config anyway.
- find Networking->Networking option and mark Asynchronus Transfer mode (ATM) and all subkeys.
- find Device Drivers->Network device support->PPP and mark PPP over ATM
- find Device Drivers->Network device support->ATM drivers and mark whatever you seem may have something to do with your particular device. Not sure if anything is really required.
- find Device Drivers->USB support->USB DSL modem support and mark everything
- perhaps this is a good moment to check other keys and unmark things you know for sure that you do not use. If you are unsure, don't change anything.
- save and exit
- #make modules
At this moment I do repeat, you are recompiling all kernel modules now!
- go and see some good movie. On my high-end machine (at least in 1997 it was a high-end one that is) it took a night to compile those modules.
- if something went wrong, it means you have screwed something hopelessly. Don't ask me what. You may ignore the warnings.
-#make modules_install
Now the modules are going to be copied from the kernel directory to the place they belong (/lib/modules/ and/or something like that). You may later remove most of the kernel source directories. Or at least the created objects. They take a lot of place and are completely usless, unless you plan to fiddle with compilation of kernel some more. Besides you still have that kernel sfs file.

Mind that you have just screwed all the external module instalations. Such as your nVidia driver. You need to reinstall all of them at this point.

You also need the firmware of your modem. I have got mine from here. There is also the explanation how to install it (no big deal as well, you need to identify the correct directory and extract the files there).
By the way, you will also find the driver for your modem there as well. However it won't work. Starting from kernel 2.6.19 usb adsl modem support is integrated into kernel and further development is supported by kernel developers. You just won't compile those drivers. However, it may be worthy to download them since you will find there some helpful hints what to do with the compiled module.

Now you can
#modprobe ueagle-atm
and pray. Here goes a remark. Puppy linux has some usb sniffing utility. You can run it beforehand and check how is your modem recognized. Mine was, so no surprise that the module had loaded. If you fail at this point it may mean that your mainboard it too old. Did you succeed installing this modem on other OS on this machine?
If everything's o.k.
#modprobe pppoatm
and you are almost there.
Unfortunately 'working device' doesn't mean 'working connection'. You need a configuration file in /etc/ppp/peers/ and edit two authorization files 'something-chaps' in the parent directory. How to do it you can read in the readme file you will find in the drivers mentioned earlier - those you get from the same place you got the firmware. I found the easier solution. I had an earlier, working installation of Mandriva on my system. My adsl modem was configured with some automagic tools there so now I simply copied all those configuration files. I guess you may use (if sufficiently determined) a live version of Mandriva or Ubuntu and use their automagic tools to generate the required files.
If you have those files (two authorization files in /etc/ppp/ and configuration file in /etc/ppp/peers/) you can start the connection:
#pppd call <the name of that config file>
Give it some time to negotiate the connection and you should see your ppp0 interface in #ifconfig
Whether you can use this connection or not depends on many factors. All those factors sum up to what you have now in your routing table. You can see it this way:
Comprehensive guide about routing that will explain what to do and how to make things working you can find here.

If the routing table is correct, i.e. at least your default route points at ppp0, you may launch your browser and enjoy.

What I've just described is of course a sort of a hack. You have (hopefully) things working, but it would be nice to have some tool for easier and automatic handling of your connections and interfaces. Something like nm-manager from Ubuntu, or net-applet from Mandriva. Please continue this thread if you find the way how to install something like this on Puppy. Basically we need some nice application for switching/turning on and off other network interfaces. I prepare this system for my mother, and I had enough problems explaining her that she has two separate network adapters (ethernet card and adsl modem), and that the computer can't guess her thoughts and decide which of them use when needed. So I somehow don't accept the challenge of teaching her opening console, loading modules and modifying routing tables.
Good luck.

Keywords: Puppy linux, usb adsl modem, neostrada, net24, ueagle-atm
Back to top
View user's profile Send private message 

Joined: 03 Jul 2007
Posts: 57

PostPosted: Mon 05 May 2008, 16:52    Post subject:  

I think I am trying to do very similar thing as you. Please let me know.
I am still a green to all this and don\'t know what I\'m doing..
Puppy 4 using Palm Treo 700p via USB as modem.
App and simple linux instructions here.

I got this setup working under great Ubuntu without a problem.

Im trying to use it native Puppy build.
When I tried in Puppy and run the ;
pppd /dev/ttyACM0 call ppp-script-evdo-template
Failed to open /dev/ttyACM0: No such device or address

The file is created when I typed;
mknod /dev/ttyACM0 c 166 0

I have cdc-acm.ko loaded.
When I look in Hardinfo it recognizes the Treo Modem under USB device as;
product; Treo 755 USB Modem
manufacturer; Mobile Stream

But wonder if the module is actually loading / recognizing.. I don\'t know enough about puppy / linux from here..

When using the connect wizard and select connect via dialup analog mode, it doesn\'t detect it.
Should it?

Being a different modem should I still use the
procps-3.2.7.pet & dgcmodem103.tar.gz ?
I assume from looking at it dgcmodem file are specific drivers for a different modem.

Am I making any sense?
Any ideas?

Please ... would like to get this working..
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0455s ][ Queries: 11 (0.0090s) ][ GZIP on ]