Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 00:28
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Pidgin (Gaim instant messenger) 2.02 dotpups
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Author Message
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Thu 26 Jul 2007, 19:09    Post_subject:  

yes, you need that library.
Solution1 (not recommended):
Do it the bad way I described.

Solution2 (better):
install gslapt:
http://murga-linux.com/puppy/viewtopic.php?t=11929

Run it.
In the options, go to "sources", remove slacky.it
Add this location:
http://www.slacky.eu/repository/slackware-11.0/

Confirm, and "refresh".
Now enter "gstreamer" in the searchfield.
Check the checkbox on the "gstreamer" package -> install.

Then click on "execute".
Now it will install a correct version of gstreamer, and you can start pidgin by dragging /usr/local/bin/pidgin on your desktop.

It is late at night here, so no dotpup, must sleep...

Mark
Back to top
View user's profile Send_private_message Visit_website 
eddie_konczal


Joined: 12 Jul 2007
Posts: 22
Location: New Jersey, USA

PostPosted: Fri 27 Jul 2007, 17:15    Post_subject: Pidgin (Gaim instant messenger) 2.02 dotpups
Sub_title: Pidgin (Gaim instant messenger) 2.02 dotpups
 

I followed the directions in the last post and everything works a treat!

I was concerned when I saw the error message when selecting "Install" for "gstreamer":

glibc-solibs, which is required by gstreamer, is excluded

But it allowed me to continue and install gstreamer and I can now launch Pidgin!

Then I was able to follow these directions;
http://www.google.com/support/talkgadget/bin/answer.py?answer=24073

Cheers!
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Fri 27 Jul 2007, 17:27    Post_subject:  

fine Smile

Yes, the solibs I deactivated. They would break Puppy, so they cannot be installed.
Like this gstreamer thinks the dependencies are not met, and tells you this error.
But it can be ignored, as Puppy has these libs already in an own version.

Glad it works.

Mark
Back to top
View user's profile Send_private_message Visit_website 
william7


Joined: 12 Jul 2007
Posts: 71

PostPosted: Fri 27 Jul 2007, 17:33    Post_subject:  

Well I found new bug - when I want run Ctrl + P in pidgin. Pidgin is quit...
Back to top
View user's profile Send_private_message 
kombucha


Joined: 19 Aug 2007
Posts: 9
Location: Western Mass

PostPosted: Mon 20 Aug 2007, 14:44    Post_subject: No preferences  

Tis true, I can't figure out any way to access the preferences dialogue without Pidgin crashing immediately. Any sort of workaround? Or are other people not encountering this bug?
Back to top
View user's profile Send_private_message 
eddie_konczal


Joined: 12 Jul 2007
Posts: 22
Location: New Jersey, USA

PostPosted: Mon 20 Aug 2007, 15:00    Post_subject: Pidgin (Gaim instant messenger) 2.02 dotpups
Sub_title: Pidgin (Gaim instant messenger) 2.02 dotpups
 

I just got the same error when trying to launch Preferences from Pidgin - it just closes completely and I have to re-launch it.
_________________
--
http://www.eddiekonczal.com/
-----------------------------------------------
"The dog has the soul of a philosopher." - Plato
Back to top
View user's profile Send_private_message 
Soupbean


Joined: 24 Aug 2007
Posts: 20
Location: China

PostPosted: Fri 24 Aug 2007, 00:25    Post_subject:  

i initially had the same problem when trying to access preferences. i *THINK* what i did to fix the problem was updating my GTK library.

you can still manually edit the preferences by changing the file /root/.purple/prefs.xml

also, there is no sound in invisible mode - it took me a while playing around with the aplay %s command until i figured that one out...

hope this helps.
Back to top
View user's profile Send_private_message Visit_website 
phantrongnghia


Joined: 24 Apr 2006
Posts: 205
Location: Hanoi,Vietnam

PostPosted: Fri 24 Aug 2007, 01:29    Post_subject:    

Here is dotpups for gstreamer 0.10, hope pidgin won't crash.

Sorry, I forgot to post the link to download, updated.
Code:
http://www.megaupload.com/?d=9PDGH6TO
Back to top
View user's profile Send_private_message Visit_website YIM 
eddie_konczal


Joined: 12 Jul 2007
Posts: 22
Location: New Jersey, USA

PostPosted: Thu 06 Sep 2007, 15:42    Post_subject: Pidgin (Gaim instant messenger) 2.02 dotpups
Sub_title: Pidgin (Gaim instant messenger) 2.02 dotpups
 

Gaa... I installed gstreamer 0.10 using the steps in the last post, and now Pidgin will not launch at all! Sad

After upgrading to gstreamer 0.10 does something else need to be done?

Cheers

_________________
--
http://www.eddiekonczal.com/
-----------------------------------------------
"The dog has the soul of a philosopher." - Plato
Back to top
View user's profile Send_private_message 
eddie_konczal


Joined: 12 Jul 2007
Posts: 22
Location: New Jersey, USA

PostPosted: Thu 06 Sep 2007, 15:53    Post_subject: Pidgin (Gaim instant messenger) 2.02 dotpups
Sub_title: Pidgin (Gaim instant messenger) 2.02 dotpups
 

OK, I reinstalled gstreamer using gslapt. Preferences still crashes Pidgin but at least I can use it to chat.
Cheers Eddie

_________________
--
http://www.eddiekonczal.com/
-----------------------------------------------
"The dog has the soul of a philosopher." - Plato
Back to top
View user's profile Send_private_message 
Soupbean


Joined: 24 Aug 2007
Posts: 20
Location: China

PostPosted: Sat 27 Oct 2007, 05:52    Post_subject:  

for those still having problems opening preferences from within pidgin, just install this dotpup: http://dotpups.de/dotpups/Libraries/Gtk-2.8.20/Gtk-2.8.20-Glib-2.9.3-Atk-1.10.3-Pango-1.10.4-Cairo-1.2.0.pup
reboot, and then try again.

worked for me.
Back to top
View user's profile Send_private_message Visit_website 
eddie_konczal


Joined: 12 Jul 2007
Posts: 22
Location: New Jersey, USA

PostPosted: Mon 29 Oct 2007, 11:13    Post_subject: Pidgin (Gaim instant messenger) 2.02 dotpups
Sub_title: Pidgin (Gaim instant messenger) 2.02 dotpups
 

It worked! I installed the dotpup referenced in the last post and I can now access Preferences.

Thanks!

_________________
--
http://www.eddiekonczal.com/
-----------------------------------------------
"The dog has the soul of a philosopher." - Plato
Back to top
View user's profile Send_private_message 
Soupbean


Joined: 24 Aug 2007
Posts: 20
Location: China

PostPosted: Mon 29 Oct 2007, 11:51    Post_subject:  

no worries eddie Smile

glad to hear that it worked out for you.
Back to top
View user's profile Send_private_message Visit_website 
djringjr

Joined: 14 Jan 2007
Posts: 156

PostPosted: Sat 08 Mar 2008, 17:00    Post_subject:  

CORRECTION to slacky.eu respoitory location!

http://repository.slacky.eu/slackware-11.0/

Quote:
Solution2 (better):
install gslapt:
http://murga-linux.com/puppy/viewtopic.php?t=11929

Run it.
In the options, go to "sources", remove slacky.it
Add this location:
http://www.slacky.eu/repository/slackware-11.0/

Confirm, and "refresh".
Now enter "gstreamer" in the searchfield.
Check the checkbox on the "gstreamer" package -> install.

Then click on "execute".
Now it will install a correct version of gstreamer, and you can start pidgin by dragging /usr/local/bin/pidgin on your desktop.

It is late at night here, so no dotpup, must sleep...

Mark


The URL for the updated slacky.eu isn't correct.

It now is: http://repository.slacky.eu/slackware-11.0/
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0850s ][ Queries: 11 (0.0184s) ][ GZIP on ]