Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 27 Aug 2014, 07:17
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
ToutouLinux 02-17.1 : Mise à jour de la version précédente
Moderators: Béèm, darkerror05
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 4 of 4 Posts_count   Goto page: Previous 1, 2, 3, 4
Author Message
Cubytus

Joined: 28 Dec 2007
Posts: 13

PostPosted: Sat 05 Jan 2008, 21:19    Post_subject:  

Alors...
J'ai ouvert cf.map, sans avoir oublié de le copier avant.
La ligne "keycode 3 = two quotedbl at" décrit ce qui est écrit sur la touche.
Alt+2 a le même effet que AltGr+2, soit passer sur le second bureau, c'est l'action "Meta_two", qui doit être définie ailleurs (Je sais pas où)
Shift+Alt+2 ne donne rien de visible.

J'ai mis les lignes suivantes pour la touche 2:

Code:
#   shift   alt   keycode   3 = Meta_at
   altgr keycode 3 = Meta_at


puis redémarré le serveur X, ben ca n'a rien changé au comportement initial.

Y'a donc un autre fichier de config (de raccourcis?) qui prend le pas sur celui du layout de clavier, mais quel est-il?
Back to top
View user's profile Send_private_message 
Botanic


Joined: 05 Sep 2007
Posts: 241
Location: Toulouse, France

PostPosted: Mon 07 Jan 2008, 18:39    Post_subject:  

non en fait tu as modifié mais seulement pour le mode texte (fais Ctrl+Alt+Retour arrière, tape 'loadkeys cf', et tu constateras tes modifs).

pour le X...mystère. il faudrait s'y pencher Smile
Back to top
View user's profile Send_private_message 
Cubytus

Joined: 28 Dec 2007
Posts: 13

PostPosted: Thu 10 Jan 2008, 20:45    Post_subject:  

Dsl pr le délai, pas eu trop le temps cette semaine à cause du retour des cours!

Alors j'ai fait comme t'as dit, modifié cf.map, passé en mode console, puis essayé. Ben, AltGr+2 ne donne rien. En défaisant la modif (état d'origine), AltGr+2 donne bien l'arobas, mais seulement en mode console. Que ca soit changé ou pas, une fois dans X, aucune différence, ca passe toujours sur le second bureau.

Y'a un bout de la solution...mais cf.map ne contrôle pas les touches dans X on dirait, si?
Back to top
View user's profile Send_private_message 
Botanic


Joined: 05 Sep 2007
Posts: 241
Location: Toulouse, France

PostPosted: Fri 11 Jan 2008, 05:49    Post_subject:  

non. et c'est ça le problème.
mais je viens de trouver les fichiers qui gèrent le clavier sous X !
il s'agit de /etc/X11/xkb, les fichiers spécifiques de chaque langue dans /etc/X11/xkb/symbols/pc/
par contre ça a l'air autrement plus évolué... bon courage !
Back to top
View user's profile Send_private_message 
Cubytus

Joined: 28 Dec 2007
Posts: 13

PostPosted: Sat 12 Jan 2008, 14:39    Post_subject:  

Alors dans le chemin /etc/X11/xkb/symbols/pc/, j'ai ouvert celui qui s'appellait ca. Il contient les définitions de touches pour les claviers canadiens, et la première section entre les lignes 5 et 63 définit justement le clavier le plus courant ici.

La ligne 10:
Code:
    key <AE02>   { [         2,   quotedbl,            at ]   };

est justement ce qui est écrit sur la touche 2, mais elles sont toutes exactes en fait.

Est-ce que le problème avec la reconnaissance du AltGr serait la ligne 62?

Code:
include "level3(ralt_switch)"


Le niveau 3 d'une touche devrait correspondre au AltGr (ralt), d'après le fichier ralt, dans /etc/X11/xkb/symbols.

Même dans le fichier level3 du même répertoire, ca dit: "// the default behavior is for the right Alt key (AltGr) to generate the
// third engraved symbol"

Pour tester, j'ai commenté toutes les lignes après la section qui définissait le comportement par défaut, ca ne change rien. Alt+2 ou AltGr+2 ont le même comportement.

Tiens, la cédille ne marche pas non plus..

Bon, alors je suis allé voir aussi dans JWM configuration manager, et effectivement, le raccourci Alt+# aboutit sur le bureau virtuel dont le numéro est choisi. Il ne fait pas la distinction entre Alt et AltGr. Ce que je comprends pas, c'est qu'en enlevant ce raccourci et redémarrant X et JWM, ca n'a rien changé: AltGr+2 passe toujours sur le second bureau virtuel!

Est-ce que ce raccourci est défini ailleurs?
Back to top
View user's profile Send_private_message 
Botanic


Joined: 05 Sep 2007
Posts: 241
Location: Toulouse, France

PostPosted: Mon 14 Jan 2008, 12:16    Post_subject:  

salut,
je crois avoir résolu ce problème de clavier. Il apparaît que la config par défaut "Canada"
Code:
default partial
xkb_symbols "fr" {
    name[Group1] = "Canada";

est bien la tienne, avec la çédille, le @ et le #. Mais une des variantes (multi) est mise par défaut sans aucune raison. D'ailleurs quelle que soit la variante qu'on choisit on est toujours sur multi.
Pour remédier à ça il faut enlever (ou commenter avec //) deux lignes du fichier /etc/X11/xkb/rules/xorg
Quote:
$pcmodels ca = pc/pc(%m)+pc/ca(multi)+pc/ca(multi-2gr):2+group(rctrl_switch)
* ca = pc/pc(pc105)+pc/ca(multi)+pc/ca(multi-2gr):2+group(rctrl_switch)

(lignes 316 et 317 chez moi)
et là ça marche: tu vas dans la config avancée de Xorg, tu te mets en "ca", mais sans variante (tu peux vérifier ça quand tu cliques sur variante, la boite de dialogue affiche "Choisissez la variante que vous etc..." et non pas "Vous utilisez actuellement etc."
Back to top
View user's profile Send_private_message 
Cubytus

Joined: 28 Dec 2007
Posts: 13

PostPosted: Mon 14 Jan 2008, 22:56    Post_subject: Au risque de passer pour un demeuré..  

alors j'ai commenté les lignes 316 et 317 du fichier /etc/X11/xkb/rules/xorg (c'était les mêmes, comme le ficheir n'avait pas été édité), puis ouvert Paramètres>Assistant Souris/clavier>Configuration avancée Xorg>Dispositions, où une boîte de dialogue "Ajoutez une disposition ou changer l'existante", là je clique sur "Changer", et la boîte suivante est "Vous utilisez actuellement", et il n'y a rien en-dessous. Idem si je clique sur "Ajouter", la même phrase, mais rien en-dessous. (Il n'y a pas le terme "Variante" dans Toutou 03-01.1)

Là j'ai changé pour "ca", redémarré X et JWM (on sait jamais), et rien du tout: La cédille ne marche toujours pas, ni aucun caractère commencant par AltGr. Ca passe toujours sur le 2e bureau avec AltGr+2, comme si le paramètre JWM de raccourci clavier était présent ailleurs.

Où c'est que je dois continuer à chercher?
Back to top
View user's profile Send_private_message 
Botanic


Joined: 05 Sep 2007
Posts: 241
Location: Toulouse, France

PostPosted: Tue 15 Jan 2008, 04:23    Post_subject:  

que veux-tu dire, "rien en-dessous" ? tu n'as plus la liste des dispositions?
il faut bien faire "changer" et non pas "ajouter"; quant à "variante", c'est "dispositions différentes" dans Toutou

j'ai oublié quand même de préciser quelque chose d'important et qui n'est pas du tout intuitif, dans cet interface: rien ne marchera si, après avoir changé une disposition et/ou variante, on ne clique pas sur "Appliquer immédiatement" au bas de la boite de dialogue.

mais bon cet interface ne sert qu'à écrire deux lignes dans etc/X11/xorg.conf Smile
il faut que tu ait ça d'écrit (lignes 76 et des poussières)
Code:
    Option         "XkbLayout" "ca" #xkeymap0
    Option         "XkbVariant" ""
Back to top
View user's profile Send_private_message 
Cubytus

Joined: 28 Dec 2007
Posts: 13

PostPosted: Tue 15 Jan 2008, 13:45    Post_subject: Ceci étant clair..  

Rien en-dessous faisait référence à la ligne immédiatement après; la liste des dispositions possibles est toujours présente.

Alors j'ai refait l'opération pour être sûr, dans la boîte de dialogue XKB Configuration manager, j'ai cliqué sur Disposition>Changer>ca>Ok. Là, une petite fenêtre "Success" est apparue, puis j'ai cliqué sur "Yes", et là, une fenêtre "Error: a problem has occured" est apparue.

Comme ca n'avait pas l'air de fonctionner, j'ai édité à la main Xorg pour ajouter la seconde ligne que tu as indiquée (ligne 91, pour moi), puis redémarré X. Ben ca n'a rien changé.

Apparemment le message d'erreur affiché n'est pas un bug, y'a vraiment un pb qq part..mais où?

J'ai comparé le xorg.conf de Toutou avec celui d'Ubuntu, il n'y a presque pas de différences. Est-ce que ca serait utile de faire une comparaison entre les fichiers problématiques de Toutou et ceux, fonctionnels, de Ubuntu, ou c'est trop différent?
Back to top
View user's profile Send_private_message 
Botanic


Joined: 05 Sep 2007
Posts: 241
Location: Toulouse, France

PostPosted: Fri 01 Feb 2008, 18:09    Post_subject:  

voir le post suivant:
http://www.murga-linux.com/puppy/viewtopic.php?t=25990

_________________
Puppy 2.16 on HP Vectra VL400 - PIII 800 MHz - 320M RAM
Wary on Acer Aspire X3200 - Phenom X4 - 2.2GHz - 4G RAM
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 4 of 4 Posts_count   Goto page: Previous 1, 2, 3, 4
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0724s ][ Queries: 11 (0.0050s) ][ GZIP on ]