Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 20:56
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
touchscreen in puppy.
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
ruler-nrg
Guest


PostPosted: Fri 16 Sep 2005, 03:56    Post_subject:  touchscreen in puppy.  

I have a problem.
I'm using puppy for about 2 weeks now. Everything works fine.

however:
ik have a touchscreen. It coms with drivers for linux and works fine on redhat 6 and fedora3.

The driver needs to be installed in /usr/X11/lib/modules and i need to edit my xconfig or xorg config file. However i cant find the map and the xconfig file.

Is there any way i can get my touchscreen to work under puppy ?

thanks.

ps: as an Attachment i wil put the readme from the driver.
Back to top
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Fri 16 Sep 2005, 04:31    Post_subject:  

Puppy uses the Kdrive-Xserver, which has no configurationfile like XFree or Xorg.

There is a Puppy with XFree 4.5, please try to find it with the forum-search.

I had success in compiling xorg yesterday, but it has to be optimized a lot (currently 100 MB in size).
Maybe this weekend, maybe during the week I can tell more.

But don't be too hopefull, my mousedriver and keyboard-driver does not work, so it uses default drivers (no mousewheel, no german keymap, feel like sitting on good old C64 Wink ).

So I fear there could be trouble with touchscreendrivers too.

The best really will be to try the XFree-Puppy.

Mark
Back to top
View user's profile Send_private_message Visit_website 
Ruler-Nrg
Guest


PostPosted: Fri 16 Sep 2005, 04:53    Post_subject:  

yes i have seen that one.. the only problem is that the link is down Sad and i can t find it anywere else... i would love to try it.. if there is anyone with a working link... please post it.

Thnx
Back to top
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sat 17 Sep 2005, 08:09    Post_subject:  

http://www.murga.org/~puppy/viewtopic.php?t=2303

Smile

Now my mousewheel is working too, there just was missing a symbolic link in /dev
So it should work with your driver too.

Mark
Back to top
View user's profile Send_private_message Visit_website 
Ruler-Nrg
Guest


PostPosted: Mon 19 Sep 2005, 06:45    Post_subject:  

OK ! Thats great! now i finely have al the maps en the xorg.conf. Thanks for That.

But...

My driver readmy says that i have to edit The "Serverlayout" Section But In the Xorg.conf
I cant find that... I tryed adding it myself But if i do so X wil not start anymore..
Anyone ho knows how to fix that ?
Back to top
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0428s ][ Queries: 11 (0.0036s) ][ GZIP on ]