Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 25 Nov 2014, 20:27
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
XFCE-4.4.1.SFS and XFCE-4.4.1.PET for Puppy 3.0+ FINAL
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 5 Posts_count   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Fri 19 Oct 2007, 18:38    Post_subject:  

The petget script up to 3.0 checked to see if you had 5 times the size of the package before installing. In 3.01 Barry dropped this to 3 times.

Look for this line in /usr/sbin/petget

XPNEEDB=`expr $EXPFILEB \* 5`

and change the "5" to a "3"

This would match v3.01

JB

Edited_time_total
Back to top
View user's profile Send_private_message YIM 
SirDuncan


Joined: 09 Dec 2006
Posts: 836
Location: Ohio, USA

PostPosted: Fri 19 Oct 2007, 19:32    Post_subject:  

Wow, that was a simple fix. I wish I had known that earlier. It would have made the installation of quite a few large apps far easier.

Thanks for letting us know.

_________________
Be brave that God may help thee, speak the truth even if it leads to death, and safeguard the helpless. - A knight's oath
Back to top
View user's profile Send_private_message Visit_website 
Timelord

Joined: 29 Jul 2007
Posts: 38

PostPosted: Fri 19 Oct 2007, 23:19    Post_subject:  

Hi there!

Unfortunately, the "glitch" (please notice I am not assuming it is the same one addressed by Barry with the fix just mentioned) does not seem to be fixed in puppy 3.01. I'm far from being a Puppy and Linux expert. However, I was having problems with EZPup3 in puppy 3.00 (unfinished installs and not enough space messages). Tried fresh Puppy 3.01 install, but same problem. I'll expand on a separate thread.

timelord
Back to top
View user's profile Send_private_message 
Puppetmaster

Joined: 19 Oct 2007
Posts: 4

PostPosted: Sat 20 Oct 2007, 05:49    Post_subject:  

JB4x4 wrote:
The petget script up to 3.0 checked to see if you had 5 times the size of the package before installing. In 3.01 Barry dropped this to 3 times.

Look for this line in /usr/sbin/petget

XPNEEDB=`expr $EXPFILEB \* 5`

and change the "5" to a "3"

This would match v3.01

JB


I had to change mine down "1" to get it to install... strange, but it did install! Thanks! Now I just have the slight issue that every time I start Puppy, I'm first shown the JWM-desktop and I have to click it with the mouse for xfce to appear. Why is that? Sorry about all my stupid questions and thanks for all your patience Smile
Back to top
View user's profile Send_private_message 
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Sat 20 Oct 2007, 06:50    Post_subject: Re: XFCE-4.4.1.SFS and XFCE-4.4.1.PET for Puppy 3.0+ FINAL  

JB4x4 wrote:


In either case, to keep the rox pinboard from showing up before the XFCE desktop, find this line in /root/.xinitrc

rox -p /root/Choices/ROX-Filer/PuppyPin

and comment (#) out

#rox -p /root/Choices/ROX-Filer/PuppyPin



From the first post...
Back to top
View user's profile Send_private_message YIM 
giac_fab

Joined: 25 Jan 2007
Posts: 114

PostPosted: Sat 20 Oct 2007, 08:45    Post_subject:  

Two things :

First :

You can easly use plugins already compiled for debian ( only merge them to filesystem)

google > search needed plugin

Second :

How to organize the menu ???

Example :
In Internet menu I have some browser, I want an sub menu with into them ... HOW ????

_________________
Embarassed I know, my english is very bad Embarassed
Give a man a fish and he eats for a day, teach a man to fish and he eats for a lifetime.
Back to top
View user's profile Send_private_message 
Puppetmaster

Joined: 19 Oct 2007
Posts: 4

PostPosted: Sat 20 Oct 2007, 09:12    Post_subject: Re: XFCE-4.4.1.SFS and XFCE-4.4.1.PET for Puppy 3.0+ FINAL  

JB4x4 wrote:


From the first post...


As I said, sorry about my stupid questions Embarassed
And thanks again for all the good advice!
Back to top
View user's profile Send_private_message 
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Sun 21 Oct 2007, 21:37    Post_subject:  

Updated download location, see first post.....

Thanks go to user "caneri" - http://www.puppylinux.ca/
Back to top
View user's profile Send_private_message YIM 
panda_watch

Joined: 09 May 2007
Posts: 32

PostPosted: Tue 23 Oct 2007, 02:28    Post_subject:  

G'day,

I was just wondering if this package works with earlier versions of puppy or just 3.00 and 3.01.

Cheers
Back to top
View user's profile Send_private_message 
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Tue 23 Oct 2007, 06:46    Post_subject:  

panda_watch-

I did some basic testing with Puppy 2.17.1 and the XFCE package caused X to fail. This is probably due to using Slackware 12.0 libraries (newer xorg). Looks like you will have to upgrade Puppy.

JB

P.S. If there is enough interest, I could look into recompiling XFCE for the Puppy 2.X series.
Back to top
View user's profile Send_private_message YIM 
panda_watch

Joined: 09 May 2007
Posts: 32

PostPosted: Tue 23 Oct 2007, 09:50    Post_subject:  

Thanks for the swift reply JB4x4! I think I will have to upgrade because I'm very keen to try out your package. Could be interested in a 2.xx recompile if enough people put up there hands.

Thanks again
Back to top
View user's profile Send_private_message 
Caneri

Joined: 04 Sep 2007
Posts: 1580
Location: Canada

PostPosted: Tue 23 Oct 2007, 14:44    Post_subject:  

XFCE-4.4.1.sfs/.pet is available at......

http://www.puppylinux.ca/members/experimental/

oops....I see now the link is already there..sorry

Eric

_________________
Be not afraid to grow slowly, only be afraid of standing still.
Chinese Proverb

Back to top
View user's profile Send_private_message 
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Sun 04 Nov 2007, 16:02    Post_subject:  

Updated XFCE 4.4.1 package - see first post.....

JB
Back to top
View user's profile Send_private_message YIM 
Caneri

Joined: 04 Sep 2007
Posts: 1580
Location: Canada

PostPosted: Sun 04 Nov 2007, 16:56    Post_subject:  

XFCE-441b.pet and XFCE-441b.sfs are ready for downloading as follows.

http://www.puppylinux.ca/members/experimental/

JB..I found them even without my glasses..Wink
When these files are getting to be stable we should move to stable....What do you think...let me know

md5sum is ok.

_________________
Be not afraid to grow slowly, only be afraid of standing still.
Chinese Proverb

Back to top
View user's profile Send_private_message 
castalla2007

Joined: 29 Oct 2007
Posts: 45
Location: Communidad Valenciana, Spain

PostPosted: Tue 13 Nov 2007, 18:40    Post_subject: Why oh Why?  

Using Puppy 3.01 ....

I've dloaded the pet package 3 times now - each time I try to install I get a message saying that it needs so many zillion blocks and I have less than this. I have increased the personal storage file twice so far - I think the last was 250mb. It still comes back with the blocks message.

What should I do? Newbie here - so simple instructions needed!
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 5 Posts_count   Goto page: Previous 1, 2, 3, 4, 5 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0865s ][ Queries: 12 (0.0174s) ][ GZIP on ]