Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 10 Jul 2020, 09:05
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Post new topic   Reply to topic View previous topic :: View next topic
Page 5 of 5 [67 Posts]   Goto page: Previous 1, 2, 3, 4, 5
Author Message

Joined: 29 Dec 2008
Posts: 23

PostPosted: Sat 04 Apr 2009, 00:46    Post subject:  


Well, I may have set a speed record for fixing my own problem...

Shortly after my previous post I discovered that my Profile list issue (number 2) was of my own creation because of an entry I had in a script file that was invoking Pwireless. Multiple instances of Pwireless definitely does not cause Profile loss.

After my fix for one minor issue (item 1) everything is now perfect. Works like a charm...
Back to top
View user's profile Send private message 

Joined: 22 Mar 2007
Posts: 420
Location: Kerry, Ireland

PostPosted: Fri 03 Jul 2009, 23:21    Post subject:  

This is not working for me. I'm running pwireless 0.8.4. When I start up the application I don't seem to get any networks whatsoever coming up in the pwireless networks tab. It may have something to do with my having 2 wireless internet commections (only 1 of which I am using); the other is sitting there. I have tried to down this one with another application but failed.

It also says on the pwireless gui (top left corner, beneath tabs), that wlan0 IP address is unknown, wlan1 (which I am using)

Update: I booted puppy and ran the app on another machine (which only has one wireless adapter) and it worked fine. So there seems to be a problem with machines that have more than one wireless adapter.

Additional issue: there also appears to be a conflict with network wizard; if you connect with pwireless, break that and connect with network wizard, the connection with network wizard will not transmit any data(even though the wizard and blinky tell me I'm connected). A functioning network connection can only be obtained by reverting back to pwireless to handle the connection process.

This has probably been mentioned before on this thread, but it would be useful if pwireless could recognise and display WAP (when appropriate) in the encryption column.

A second annoyance that I find is I don't know what network I am connected to! It would be great if blinky could be configured to display network E/BSSID, so that the user knows which network s/he is connected to. Just a suggestion. Or just have pwireless display it somewhere in GUI.

Buy silver, crash JPMorgan
Back to top
View user's profile Send private message 

Joined: 27 May 2006
Posts: 400
Location: Portugal - Lisbon

PostPosted: Sun 31 Jan 2010, 06:28    Post subject:  

Does Pwireless handles PEAP/MSCHAP certificates?
Idea Rebuilding old DOS Machine for Wing Commander Privateer and Puppy Exclamation Old spare parts to give away - anyone interested Question
Back to top
View user's profile Send private message 

Joined: 11 Aug 2008
Posts: 374
Location: Melbourne, Aus

PostPosted: Thu 15 Apr 2010, 01:48    Post subject:
Subject description: Scanning and Connecting

I'm having some trouble understanding how things work. I don't use wireless at home, but have tried at my college without success on this setup.

If I use Pwireless, I can discover what is around, and do get an IP number, but cannot use the internet. At best, I do only get a reading of 25/70, and often less than that.

If I use the Connect or Network Wizard, these utilities either don't even find what Pwireless finds, and if it does, it still won't connect.

Any thoughts would be greatly appreciated.


Dell Latitude D630 running Puppy 5.2.8 frugal, Macpup 525 frugal (if I can get it working again. Sadly, I couldn't get it fixed Confused )
Precise Puppy 5.4 live DVD
Precise 5.7.3 on USB
Back to top
View user's profile Send private message 

Joined: 23 Aug 2010
Posts: 55

PostPosted: Tue 28 Jun 2011, 14:16    Post subject: question... regarding wag... maybe.
Subject description: not a network wizard... by far.

being said... decided to learn abit about networking, IP's... blah.

so... stripped down pwireless-0.8.4... to make my learning curve less.

well...hmm... still not a wizard.

tryin' to solve current issue... rtl8187se pci-wireless... for ex... only.

pwireless... no... reports nothing... seems to be either a root or wag thing. same card using net-setup... good.

afterwords... pwireless detects and runs card... but only on given session... meaning rebooting requires re-running net-setup over...

tried abit of tinkerin' with iwconfig...etc.

from rxvt seems to be a permission thing... again no wizard in networking-101... that's what pwireless and like are for... right???

have seen this over the years with pwireless... meaning some cards simply don't work.

not a big thing... for my spoil of cleaning up pwireless for learning... resulted in alot faster pwireless... so I'm content... knowing no program can cover all possibles... yet wonderin' how it can work within same session under net-setup and not pwireless... less latter ran first... when other that wag/wpa scripting inside net-setup... nothing appears to trigger event... otherwords... workin' now.

only thing I could find seems to be a few /tmp/wag...docs/etc created by net-setup... but nothing within that would suggest... why it's now workin'...

either way... checked-out latest pwireless-2... yeap it'a solve this issue... but abit to bulky... due to such... meaning not size... memory usage... and definitely way above me for tinkerin'... being it consists of many scripts...
Back to top
View user's profile Send private message 

Joined: 13 Jun 2007
Posts: 614
Location: The old Lone Wolf

PostPosted: Sun 11 Sep 2011, 11:10    Post subject:  

Hi plinej,

Are you going to continue maintaining and updating Pwireless? are there plans to add new features or support the gtkdialog version developed by thunor?.

I like Pwireless, it´s small, easy to use and has a nice GUI. I hope you furter support this great application.

Meanwhile I have found some problems in Pwireless saving a Profile that I want to report. (I modified the Pnethood version inclued in Puppy 214X long time ago to fix these problems, could you please take a look to them.)

Sometimes when you save the profile Pwireless freeze, the cause is the "tee" command used to write the file.

I have implement the following solution.

LINES 369 and 399:
original code:

   <action>echo \$IWCONFIG | tee $HOME/.config/Pwireless/\$SSID-IWCONFIG</action>
      <action>echo \$GETIP | tee $HOME/.config/Pwireless/\$SSID-GETIP</action>
      <action>echo ESSID=\$ESSID | tee $HOME/.config/Pwireless/\$SSID</action>   
   <action>echo CHANNEL=\$CHANNEL | tee -a $HOME/.config/Pwireless/\$SSID</action>
   <action>echo ENCRYPTION=\$ENCKEY | tee -a $HOME/.config/Pwireless/\$SSID</action>
   <action>echo APMAC=\$APMAC2 | tee -a $HOME/.config/Pwireless/\$SSID</action>
   <action>echo MODE=\$MODE2 | tee -a $HOME/.config/Pwireless/\$SSID</action>

New code:

     <action>[ -d $HOME/.config/Pwireless ]  || mkdir $HOME/.config/Pwireless</action>
      <action>echo \$IWCONFIG | tee $HOME/.config/Pwireless/\${SSID:-default}-IWCONFIG</action>
      <action>echo \$GETIP | tee $HOME/.config/Pwireless/\${SSID:-default}-GETIP</action>
      <action>echo ESSID=\$ESSID | tee $HOME/.config/Pwireless/\${SSID:-default}</action>   
   <action>echo CHANNEL=\$CHANNEL | tee -a $HOME/.config/Pwireless/\${SSID:-default}</action>
   <action>echo ENCRYPTION=\$ENCKEY | tee -a $HOME/.config/Pwireless/\${SSID:-default}</action>
   <action>echo APMAC=\$APMAC2 | tee -a $HOME/.config/Pwireless/\${SSID:-default}</action>
   <action>echo MODE=\$MODE2 | tee -a $HOME/.config/Pwireless/\${SSID:-default}</action>
      <action type=\"launch\">DIALOG</action>

Note that it really solve two problems:

1. IF $HOME/.config/Pwireless does not exist, then create it.
2. If SSID is "null or empty", then use the value "default". Something common when user left the SSID blank on Profile configuration tab.

I hope this can be helpful to improve Pwireless.

Thank you for the attention plinej.

Back to top
View user's profile Send private message 

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Sun 01 Nov 2015, 01:21    Post subject: to connect wireless with CSL dongle  

Pet installed Molinux zero (2010) to connect wireless with CSL dongle and driver RTL8192CU for kernel
Wizard by defaut was not efficient. Pwireless did it.
PeasyWifi added beside to keep stable
 Filesize   69.36 KB
 Viewed   157 Time(s)


Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 5 of 5 [67 Posts]   Goto page: Previous 1, 2, 3, 4, 5
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0791s ][ Queries: 12 (0.0189s) ][ GZIP on ]