Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Dec 2014, 03:24
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Minisys-Linux Muppy008 (dec, 20, 2007) / SP3 (jan, 13, 2008)
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 9 Posts_count   Goto page: 1, 2, 3, ..., 7, 8, 9 Next
Author Message
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Wed 07 Nov 2007, 20:59    Post_subject:  Minisys-Linux Muppy008 (dec, 20, 2007) / SP3 (jan, 13, 2008)
Sub_title: with OpenOffice 2.3, Gimp 2.4rc3, jre 1.6 and more
 

----------------------------------------------
News: new version 008.1 availabe.
Details:
http://murga-linux.com/puppy/viewtopic.php?p=166662#166662

DO NOT DOWNLOAD THE OLD 008 ANY MORE!
----------------------------------------------

screenshot:


Full-size (400 kb):
http://noforum.de/pics/Muppy008-1600.jpg


There are 2 isos, one is english, the other partially german.

It runs well and pretty fast on my IBM Thinkpad with 256 MB Ram and 800 Mhz.
I run it as frugal installation, is also runs fine from a fast CD-drive.
The ISO works too in qemu, with at least 128 MB ram assigned.

You can see a list of included programs and screenshots and download-links at:
http://dotpups.de/Minisys-Linux/

Some programs were tweaked, e.g. the Installer PSI now uses petget directly for pets.
Older version uses pkgtool instead.
I'll update the corresponding dotpups next week, so other pupletts can use them.

Hardware accelleration for graficscard is enabled by default using free drivers, so you can play tuxracer or descent2 immedeatly from the Live-CD.
Propriatary Nvidia-drivers are included, too, Muppy will detect such cards and launch an installer.


Feel free to post suggestions, and please report bugs you find.
Muppy 009 in some months will contain even more german, and enhanced wizards, e.g. for Icewm.

I want to thank especially Barry for Puppy and encouraging me in continuing the Muppy-Series.
And Whodo for Ezpup, that is a great refinement and enhancement of the icewm-ultra dotpup I made long ago, and that is very outdated meanwhile.
I could mention many more, like Pliney and Zigbert who have coded so many wonderfull wizards meanwhile.
Take these name as representatives for all other contributors, who I do not name directly, please Smile

Please install the Service-Pack 3, too:
http://www.murga-linux.com/puppy/viewtopic.php?p=166583#166583

Mark

related links:

Installation to harddisk (fix problems):
http://murga-linux.com/puppy/viewtopic.php?t=24892

Installation auf Festplatte (Problembehebung, deutsch):
http://murga-linux.com/puppy/viewtopic.php?t=25425

Mini-Muppy (smaller version):
http://murga-linux.com/puppy/viewtopic.php?t=25414

build-a-muppy (create your custom Muppy):
http://murga-linux.com/puppy/viewtopic.php?t=23272

bugfix for puppys initrd.gz:
http://murga-linux.com/puppy/viewtopic.php?t=23381

gslapt packagemanager:
http://murga-linux.com/puppy/viewtopic.php?t=21908

Edited_times_total
Back to top
View user's profile Send_private_message Visit_website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15122
Location: Paradox Realm

PostPosted: Wed 07 Nov 2007, 21:59    Post_subject:  

Smile
Hi Mark

Only seems to be 17MB - or is that a zipped iso and I had a faulty download?

Quote:
Download (400 MB) from here, scroll down to see it:
http://sourceforge.net/project/showfiles.php?group_id=141936


good to see graphic acceleration included Smile

_________________
Puppy WIKI

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Wed 07 Nov 2007, 22:04    Post_subject:  

no, you chose minisys without muppy Wink

Muppy is at bottom, under "file-releases".
Click on
Minisys-Linux-Muppy008a
there to see the isos and checksums Smile

Mark
Back to top
View user's profile Send_private_message Visit_website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15122
Location: Paradox Realm

PostPosted: Wed 07 Nov 2007, 22:14    Post_subject:  

Embarassed

my only excuse is stupidity

thanks Cool

_________________
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Wed 07 Nov 2007, 22:18    Post_subject:  

no, sourceforge really could need a good screendesigner.
The page is confusing.

It really was an adventure, to find out how to upload, luckily I started another project there some years ago, so we finally succeeded in less than an hour Laughing
But having those mirrors is great and worth the effort.

Time to sleep, have a good night Smile
Mark
Back to top
View user's profile Send_private_message Visit_website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15122
Location: Paradox Realm

PostPosted: Thu 08 Nov 2007, 02:52    Post_subject:  


Wiki needs updating
http://puppylinux.org/wikka/MuppyPuppy

OK I am in and running from CD

First of all it looks and feels very usable. Very Happy
The early Muppy was rather overwhelming

Quote:
3DCC - Muppy edition
Drivers and OpenGL are already installed.


I have an Nvidia Geforce AGP card and was expected it to be running?
Was not Crying or Very sad
The inclusion of Pupracer and Descent . . . only Pupracer was working but too slow to use . . . (full screen)
Even though Pupracer is 16MB (from what I remember) I rather like the idea of two 3D games included - Warren did this in a Alpha of 2.15CE which would have made it a non-Puppy
- but now we have Muppy Smile

I notice you have Wine included . . .
there is a game called Soldat that is supposed to work with Wine very well (on their platinum list) and it is 2.6MB

Expose 2.4 was not running from the menu

I am intrigued by the Minisys systrem - The Babelfish
translation was not easy to follow (what do you expect from a fish) Razz

When I rebooted (I did save the Muppy config) it picked up another
configuration Not Muppy -- this might be Puppy 3.01 but it is new to me . . .

Now this is interesting. This is a 400MB distro. That is big.
What should be cut? Nothing.
I can honestly say that the games. The Java, the themes and backgrounds etc make it all very usable.
Muppy will run on a modern computer, fast and efficiently.
I am running with 512MB of Ram but 256 should be ok?

I like it.

Now I am gonna try and fathom that Minisys part . . .

woof woof Very Happy

_________________
Puppy WIKI

Edited_times_total
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Thu 08 Nov 2007, 12:31    Post_subject:  

with build-a-muppy it is very easy, to create different flavours.
In future, we plan a desktop-muppy (almost as it is now), a game-muppy, and a server-muppy. When I release the final, I also will upload the whole buildscript with all packages, so you quickly can build a custom version.

I think the current version should satisfy a wide range of needs until then.

Non-free Nvidia-drivers will be added later, I must check out first what they overwrite, so that I can add a "restore" program in case a nvidia-installation breaks things. This would restore the inbuilt open-gl drivers and such.

As muppy comes with a business-background, stability has a higher priority than in older muppys, and new programs will be tested longer as before.

But compatibility with new nvidia-cards is important of course. We will try to get a testmachine by one of our customers.

thanks for reporting your impressions Smile
Mark
Back to top
View user's profile Send_private_message Visit_website 
willhunt


Joined: 05 Oct 2005
Posts: 495

PostPosted: Thu 08 Nov 2007, 20:07    Post_subject:  Another great puppy  

I Did not see my hdb10 part but the
Code:
mknod /dev/hdb10 b 3 74
from the 301 bug thread fixed that
# ldconfig -v
ldconfig: Can't stat /opt/kde/lib: No such file or directory
ldconfig: Can't stat /opt/kde3/lib: No such file or directory
ldconfig: Path `/lib' given more than once
ldconfig: Path `/usr/lib' given more than once
ldconfig: Cannot stat /usr/lib/libvga.so.1: No such file or directory

Thanks MU I got it up and running first try and am posting with it Smile

Is there a way to set the lang to en?

_________________
176 Icewm Themes Exclamation
vlc-0.8.6c-i586.pet
vlc-0.8.6c-i586.pet

Edited_time_total
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Thu 08 Nov 2007, 20:25    Post_subject:  

You downloaded the german iso?
to set the lang to en click on start-desktop-chooselocale.

But firefox and openoffice will remain german, as I had to use german versions as a whole.

If you want english versions, please use the english iso.

Docs for minisys itself are german, you just can use the translation-link on http://www.minisys.org .
Though minisys itself supports several languages.
We soon will enhance the language-choice.

Mark
Back to top
View user's profile Send_private_message Visit_website 
veronicathecow


Joined: 21 Oct 2006
Posts: 536

PostPosted: Fri 09 Nov 2007, 04:15    Post_subject:  

Hi Mark, just tried your ISO (frugal) but I just get the 3.01 desktop (It picked up a current pu_save file. I tried fix menus but no joy.
any thoughts appreciated
Many thanks
Tony
Back to top
View user's profile Send_private_message 
klu9

Joined: 27 Jun 2007
Posts: 345

PostPosted: Sun 11 Nov 2007, 11:30    Post_subject:  

Hi Mark,

I'm updating the wiki page on Muppy and would like to know: what's the main idea of Muppy? Its distinguishing features or basic description etc.

Thanks
Back to top
View user's profile Send_private_message 
geneven

Joined: 04 Oct 2007
Posts: 87
Location: Agoura Hills, California

PostPosted: Mon 12 Nov 2007, 06:13    Post_subject: The Mup  

I installed Muppy tonight and it went pretty well. It looks like a nice setup, close to what I want. I was happy to see an old friend, the file manager xfe, among the programs. Thanks!
Back to top
View user's profile Send_private_message 
geneven

Joined: 04 Oct 2007
Posts: 87
Location: Agoura Hills, California

PostPosted: Mon 12 Nov 2007, 06:24    Post_subject: Things I forgot to say  

I installed on a 2 gig flash drive.

I have the infamous bcm43xx wireless, which worked fine after the standard things I have to do, which is run the standard connection setup for wireless. I go to the advanced area and fill in everything that I can. THEN, I still can't access the Internet. So I go to the Wiki and find the WIFI section and the instructions for manual setup that follow the instructions for the connection dialog stuff.

I put in the first two lines of the manual setup. Then I can access the Internet.

All this is just for the first time thru. I save my settings, of course, and I take the lines I needed from the manual setup and put them in a text file, which I make executable and all I have to do from then on is execute that file and I'm on the internet.

This has not much to do with Muppy; I have to do this with Puppy proper 3.00 or 3.01 as well and every other version of Puppy I've tried.
Back to top
View user's profile Send_private_message 
klu9

Joined: 27 Jun 2007
Posts: 345

PostPosted: Mon 12 Nov 2007, 14:26    Post_subject:  

I've added multiple download methods to the Muppy wiki page

BTW you can make a more direct sourceforge link by right-clicking the download section heading for muppy008a, which gave me this:

http://sourceforge.net/project/showfiles.php?group_id=141936&package_id=238140&release_id=552584

just the muppy008a downloads, nothing else in between.
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Wed 28 Nov 2007, 21:37    Post_subject:  

I currently uploaded Alpha2.
Tomorrow there will follow the Beta-version.

The only difference will be an updated minisys, as Stefan currently is fixing a nasty bug.

Muppy itself will contain no further changes I think.

One thing is absolutely untested:
If you have a Nvidia-graficscard, it uses the free xorg-drivers (xorgwizard will use them).
Then when X starts, Muppy detects this driver, and offers to install the propriatary drivers instead.
If that fails, you can restore the free driver in the comandline by typing:
uninstall-nvidia

I have no nvidia-card here, so I have no idea, if it really works.
I leave for 1-2 weeks on friday, so I'd be glad to get a feedback until tomorrow, if it works or not.
If it fails, I'll remove this from the Beta.


** this version is outdated, use the beta instead! **
Download using wget like this:
wget -c --referer=http://puppyisos.org http://puppyisos.org/isos/2007-07-to-12/pfiles/muppy-008c-DE.iso

or
wget -c --referer=http://puppyisos.org http://puppyisos.org/isos/2007-07-to-12/pfiles/muppy-008c-EN.iso


The beta-version will be uploaded to sourceforge.net tomorrow.

So what is new?
I added several gtkbasic based programs I already announced.
I fixed several bugs.
I added more german translations.

Mark

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 9 Posts_count   Goto page: 1, 2, 3, ..., 7, 8, 9 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0927s ][ Queries: 12 (0.0052s) ][ GZIP on ]