Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 08:57
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
Gxine Configuration HOWTO for Puppy 2.16 to 3.01 and further
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Wosh


Joined: 09 Jul 2007
Posts: 60
Location: Nuremberg Germany

PostPosted: Wed 21 Nov 2007, 13:59    Post_subject:  Gxine Configuration HOWTO for Puppy 2.16 to 3.01 and further
Sub_title: Knowledge Base for Gxine in Puppy Linux
 

Gxine Configuration HOWTO for Puppy 2.16 to 3.01 and further

Knowledge Base for Gxine in Puppy Linux

Introduction

This HOWTO wants to describe the configuration of the gxine media player for Puppy Linux for beginners and advanced Puppy users. So you must not be ashamed to post questions within this forum about the configuration of gxine.

Me myself I am also rather a beginner than an expert with gxine but I have found some topics, problems and solutions that I want to share with others.

My target is to create a comprehensive HOWTO by the means of this forum that can be added to the Puppy manual and wikka.

First of all:
Gxine as it is shipped with Puppy runs a lot of media formats like CDs, DVDs and videos without problem and even the Windows media formats are supported rather good.

Additional Packages

The Puppy-Paket-manager offers 3 pakets for (g)xine:

xine_extra_codecs-1: RealVideo, Quicktime, etc.
xine_lib_DOC-1.1.4" Documentation about xine
xine_lib_NLS-1.1.4" Translations of the xine-library to Spanish German French Italian ...

So the first thing you should do if a media format can not be played is to install the xine_extra_codecs-1 package.

After you have installed this package you have to open the gxine dialog :

File/Configure/Preferences

Within the gui-register you have to select at least "Advanced"
Now you see more registers.
Select decoders and make shure that the path is set to:

/usr/lib/win32 for real_codecs_path and win32_codecs_path

Now after a restart of gxine you are able to use the installed codecs.

Problems

1. Gxine freezes
Starting with Puppy 3.01 gxine has the tendency to freeze if it starts playing new media. It is not clear whether this behavior is due to the new kernel version 2.6.21.7 or the new gxine version 0.5.11. I had some cases that it sometimes recovered if it was left alone some minutes. So I think it is a loading problem of gxine.

Anyway in this state it doesn't react on input anymore. The only way to finish it, seems to be the kill popup. But if you try to start gxine again nothing will happen. The reason is that a gxine process is still running without user interface. Only if it has been killed by KP or a Console kill gxine can be started again.

On my PC calling KCCG-TV2 from Media/TV always leeds to this freezing.

2. RealAudio COOK audio decoder missing
After installation of the xine_extra_codecs-1 package you are able to watch, for example, the TV-program Media/TV/Boston Channel 22 Life. But you have no sound.
If you try to find the reason within View/Engine Log/messages you see the message:

audio_decoder: no plugin available to handle 'RealAudio COOK'

According the information about MPlayer-codecs in

http://www.mplayerhq.hu/DOCS/codecs-status.html

RealAudio COOK resides within cook.so.6.0 which is within /usr/lib/win32.
Has anyone any idea?

3. The media list is obsolete
Calling for example CSPAN-1 will generate the two Errors:
1. "Unknown host: unable to resolve wms-rbn-sea18.rbn.com" and

2. "The xine engine failed to start.
No input plugin was found.
Maybe the file does not exist or cannot be accessed,
or there is an error in the URL."

4. Some programs take a long time until they are displayed
After calling for example alternative.nu gxine doesn't react nearly 30 seconds. Watching the engine log you find no error message and "oops" after about one minute the program runs without problem.

5. Streams from SeaMonkey are not displayed
Calling streams from a homepage like
http://global-itv.com
will cause SeaMonkey to display a message like:
The file "germany00000079.asx" is of type video/x-ms-asf, and SeaMonkey does not know how to handle this file type.

Opening the file with defaultmediaplayer (gxine) will show no result.

6. audio/x-pn-realaudio-plugin
Trying to watch streams from some pages leeds to the message:

This page contains information of a type (audio/x-pn-realaudio-plugin) that can only be viewed with the appropriate Plug-in

Click OK to download Plugin

Clicking OK leeds to

http://plugindoc.mozdev.org/linux.html#RealPlayer

asking to install RealPlayer10.
Maybe someone knows whether it is possible to activate this plugin for gxine withot installing RealPlayer. If it is impossible it is a valid information for this HOWTO.

So far so good.
That is what I was able to contribute to this xine-configuration-HOWTO up to now.
Feel free to add posts.
Feel free to correct my English, because I am not native English speaking.
Add your experiences, solutions or bugs.
I will try to update this HOWTO from time to time and offer it as download within this forum until it can be released.
The aim should be a HOWTO that satisfies a wide range of people and leads to a gxine packet within Puppy-Linux that leaves as few questions open as possible.

Cheers

Wosh
[/b]
Back to top
View user's profile Send_private_message 
floborg


Joined: 25 Oct 2007
Posts: 194
Location: Fort Worth, TX

PostPosted: Wed 21 Nov 2007, 18:49    Post_subject:  

On the "engine failed to start" error...I get this a lot with some media streams (like Chronix radio). I find that just trying to start the stream again (select from Media menu) does the trick. It sometimes takes 2 or 3 attempts.
Back to top
View user's profile Send_private_message 
T_Hobbit


Joined: 27 May 2006
Posts: 400
Location: Portugal - Lisbon

PostPosted: Wed 21 Nov 2007, 19:54    Post_subject:  

Any way to turn on external subtitles? I mean, a movie.avi with movie.sub (or .srt or .txt or .etc)
Back to top
View user's profile Send_private_message 
Wosh


Joined: 09 Jul 2007
Posts: 60
Location: Nuremberg Germany

PostPosted: Fri 23 Nov 2007, 09:23    Post_subject:  Gxine Configuration HOWTO moved to Wiki  

Hi folks

I have moved the Gxine Configuration HOWTO to the Puppy-Linux-Wikka. So the recent version can be read and updated at:

http://puppylinux.org/wikka/GxineHOWTO

http://puppylinux.org/wikka/GxineHOWTO

Feel free to add posts there.
Feel free to correct my English, because I am not native English speaking.
Add your experiences, solutions or bugs found.
If you never have edited a Wiki. It is quite easy, read http://puppylinux.org/wikka/UsingThisWiki for more information.
The aim of this HOWTO is to answer as much as possible questions about the use and configuration of gxine within Puppy-Linux.

There I also have posted two more topics:
4. Gxine within SeaMonkey
5.3. Is the RealAudio COOK audio decoder needed?

In my opinion this forum should be used further to solve problems around gxine that haven't been answered yet.

So go on posting.

Cheers and success

Wosh

Hi T_Hobit

Maybe your question is answered at: http://www.xinehq.de/index.php/faq

They write:
How can I watch files with external AVI subtitles?

In xine 0.9.13 this used to be:

xine foo.avi%bar.sub

Latest xine-lib modules (1-beta3 or newer) support external subtitles for any media file, not only AVI. In order to use it you can pass a special MRL construction like:

xine test.mpg#subtitle:file.sub

The external subtitles support can also be used by any xine frontend. Currently xine-ui and kaffeine implement this feature with a subtitle selection dialog.
Back to top
View user's profile Send_private_message 
T_Hobbit


Joined: 27 May 2006
Posts: 400
Location: Portugal - Lisbon

PostPosted: Thu 29 Nov 2007, 07:33    Post_subject:  

Gxine frontend doesn't support/handle external subtitles... Should we change the xine frontend of Puppy? I say we should!
Back to top
View user's profile Send_private_message 
klu9

Joined: 27 Jun 2007
Posts: 345

PostPosted: Sat 01 Dec 2007, 01:25    Post_subject:  

it doesn't seem to handle multiple subs/multiple audio in Mastroska (.mkv) video files either.

And I'm not just saying that because I hate Xine & its various front-ends with a passion... Wink
Back to top
View user's profile Send_private_message 
nutts4life


Joined: 15 Feb 2008
Posts: 263
Location: UK

PostPosted: Fri 07 Mar 2008, 08:52    Post_subject:  

Ok,

this is probably a dumb question. But i don't want gxine on my puppy version Instead i want to use xine-ui.

But when i open Seamonkey it's still looking to open gxine ( assume this is becuase the gxine seadmonkey library only opens gxine.

Is there any way to get round this and have xine-ui opened from seamonkey?

Thanks,

n4l
Back to top
View user's profile Send_private_message 
georgepds

Joined: 03 Dec 2005
Posts: 19

PostPosted: Thu 24 Apr 2008, 18:00    Post_subject: Tip on using gxine on old machines  

On my 500 MHz celeron gxine was using 100% of the cpu cycles listening to internet radio. By simply turning off the visualization, the load went to 50% CPU

This change made it possible to listen to xmradio via gxine/seamonkey imn puppy 3.01
Back to top
View user's profile Send_private_message 
bforiest

Joined: 08 May 2008
Posts: 1

PostPosted: Thu 08 May 2008, 13:16    Post_subject: squished dvd playback  

Using Puppy 4.00 - when I tried to play a couple of dvds, the picture is squished into a very narrow band. I've tried changing aspect ratios and every other setting I could find.

Any suggestions?
Back to top
View user's profile Send_private_message 
caiooiac

Joined: 09 May 2008
Posts: 17

PostPosted: Fri 09 May 2008, 13:36    Post_subject: Choppy sound  

I think I just want to thanks georgepds!

I have a PIII 600MHz and 768M of Ram but everything I played in gxine (I still never tried videos) was choppy. CDs, mp3s, etc... so I noticed gxine was using too much cpu (99% or 100%). And just turning off the visualization that number went down do 20%, and the sond is good.

Thank you once again

Caio
Back to top
View user's profile Send_private_message 
hanzf


Joined: 11 Mar 2009
Posts: 128
Location: Belzig, Germany

PostPosted: Sun 20 Sep 2009, 11:21    Post_subject: Re: Gxine Configuration HOWTO for Puppy 2.16 to 3.01 and further
Sub_title: Knowledge Base for Gxine in Puppy Linux
 

I have a problem with a DVD: gxine shows the title but doesn't react when I click the button that should start the film.
Wosh wrote:
The Puppy-Paket-manager offers 3 pakets for (g)xine:

xine_extra_codecs-1: RealVideo, Quicktime, etc.
xine_lib_DOC-1.1.4" Documentation about xine
xine_lib_NLS-1.1.4" Translations of the xine-library to Spanish German French Italian ...

So the first thing you should do if a media format can not be played is to install the xine_extra_codecs-1 package.
I choose menu -> setup -> puppy package manager but it has none of them. (Puppy 4.1.2)
_________________
Precise 5.7.1 frugal with .2fs (+ Windows XP double boot)
AMD Athlon 64 3700+
1000 MB RAM
Back to top
View user's profile Send_private_message 
pug


Joined: 03 Jun 2010
Posts: 2
Location: in a bunker, near a computer and some alcohol.

PostPosted: Mon 14 Jun 2010, 05:31    Post_subject: Re: Gxine Configuration HOWTO for Puppy 2.16 to 3.01 and further
Sub_title: Knowledge Base for Gxine in Puppy Linux
 

hanzf wrote:
I have a problem with a DVD: gxine shows the title but doesn't react when I click the button that should start the film.
Wosh wrote:
The Puppy-Paket-manager offers 3 pakets for (g)xine:

xine_extra_codecs-1: RealVideo, Quicktime, etc.
xine_lib_DOC-1.1.4" Documentation about xine
xine_lib_NLS-1.1.4" Translations of the xine-library to Spanish German French Italian ...

So the first thing you should do if a media format can not be played is to install the xine_extra_codecs-1 package.
I choose menu -> setup -> puppy package manager but it has none of them. (Puppy 4.1.2)


you can go to here http://www.filewatcher.com/m/xine_extra_codecs-1-1.pet.5241987.0.0.html
they list all the site that give xine extra codecs. Just choose one of them and install like normal .pet file.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0904s ][ Queries: 11 (0.0039s) ][ GZIP on ]