Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 28 Nov 2014, 19:16
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
ATI fglrx 7.11 (8.43.2) video driver for puppy 3
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [14 Posts]  
Author Message
kirk

Joined: 11 Nov 2005
Posts: 1436
Location: florida

PostPosted: Wed 28 Nov 2007, 00:13    Post subject:  ATI fglrx 7.11 (8.43.2) video driver for puppy 3  

Here's a pet package for ATI's fglrx 7.11 (8.43.2) video driver.

Your /etc/X11/xorg.conf file will be modified, but a backup is made first, /etc/X11/xorg.conf.orginal-0. The missing GL libs will be installed too. Uninstalling using pet get should put things back to how they where (cross your fingers). But, you should probably test by making a new pup_save file. After installing you'll have to restart X or reboot.

Note: After the fglrx driver is installed and is in use, you cannot restart X. If you try the file system becomes unstable. You must reboot.

To test if acceleration is working, open a terminal and type:

Quote:
# fgl_glxgears


Here's the release notes:

https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/catalyst_711_linux.html

And here's the package (15MB):

http://dotpups.de/puppy3/dotpups/XServer/ATI_fglrx-7.11.pet


This driver seems to have better rendering in the games I tried, but in-game adjustments of brightness don't work. Tried the next older fglrx driver with the same results. The amdcccle does work. It didn't in the older version I posted here:

http://www.murga-linux.com/puppy/viewtopic.php?t=22189
Back to top
View user's profile Send private message 
tombh


Joined: 12 Jan 2007
Posts: 422
Location: Bristol, UK

PostPosted: Sun 02 Dec 2007, 08:26    Post subject:  

Thanks for posting this kirk Smile

You beat me to it -- well I did try but it never worked Sad So I'm going to try and include this in future versions of wNOP (Puplet that uses Compiz-Fusion). I would have used the open-source radeon driver that comes with Puppy but unfortunately it doesn't support 5th generation ATIs. So this is going to come in very useful indeed!

What I wanted to ask was if you could describe more about this:
Quote:
Note: After the fglrx driver is installed and is in use, you cannot restart X. If you try the file system becomes unstable. You must reboot.
Back to top
View user's profile Send private message Visit poster's website 
kirk

Joined: 11 Nov 2005
Posts: 1436
Location: florida

PostPosted: Sun 02 Dec 2007, 14:51    Post subject:  

It seems to be a unionfs problem. Once you're using fglrx if you restart X, the xorgwizard will run. It's like xorg.conf becomes invisible. If you reboot, all is fine.
Back to top
View user's profile Send private message 
tombh


Joined: 12 Jan 2007
Posts: 422
Location: Bristol, UK

PostPosted: Fri 29 Feb 2008, 17:15    Post subject:  

I've attempted to make a dotpet of the latest fglrx driver, version 8.2.
ATI_fglrx-8.2.pet
Would it be alright if someone could test it out as I don't have a compatible card -- it's for the new version of wNOP you see.

What I did was use the installer from the ATI website to create a slackware package and then use that to replace the relevant files in the current 7.11 dotpet. Seemed a bit of a crude way of doing it to me, but new2dir didn't seem to work with the installer. Also I notice that, kirk, you had put some extra files in the 7.11 dotpet that weren't present in the automated slackware package? libGLw, libglut and such like. Are they part of xorg?

Thanks for any feedback Smile

Here is a list of the files I replaced:

drm.ko
fglrx.ko
amdnotifyui
atieventsd
atigetsysteminfo.sh
amdcccle
aticonfig
fglrx_dri.so
fglrx_drv.so
libfglrxdrm.so
esut.a
glesx.so
libfglrx_dm.a
libfglrx_dm.so.1.0
libfglrx_gamma.a
libfglrx_gamma.so.1.0
libfglrx_pp.a
libfglrx_pp.so.1.0
libfglrx_tvout.a
libfglrx_tvout.so.1
libfglrx_tvout.so.1.0
libGL.so
libGL.so.1
libGL.so.1.2
Back to top
View user's profile Send private message Visit poster's website 
kirk

Joined: 11 Nov 2005
Posts: 1436
Location: florida

PostPosted: Sun 02 Mar 2008, 14:31    Post subject:  

Quote:
libGLw, libglut and such like. Are they part of xorg?


Yes, I included files that where cut from Xorg for puppy. Might not be needed for most. Can't test, I'm not using puppy 3 anymore.
Back to top
View user's profile Send private message 
papos


Joined: 21 Dec 2006
Posts: 120
Location: france

PostPosted: Thu 13 Mar 2008, 07:25    Post subject:  

I test ATI_fglrx-8.2.pet but it sem's not functional
ATI fglrx ATI_fglrx-8.2.pet ATI Radeon™ Xpress 1100 (HyperMemory combination of local and shared system memory)
fglrx_xgamma: error while loading shared libraries: libfglrx_gamma.so.1: cannot open shared object file: No such file or directory

is in /usr/X11R7/lib/xorg/modules/libfglrx_gamma.so.1
I put it in /usr/X11R7/lib/xorg/libfglrx_gamma.so.1
ok but
# fglrx_xgamma
Unable to get gamma table size


I download from http://ati.amd.com/support/drivers/linux/linux-radeon.html
and make a slackware package with
# sh ./ati-driver-installer-8-3-x86.x86_64.run --buildpkg Slackware/All
and buil a ATI_fglrx-8.4.pet same as fglrx 7.11 from Kirk
fgl_glxgears run without problem.
and all seem's ok first time I have openGL with my Acer Aspire 5100
good news for me if I can view the desktop with wNOP (Itest this later)
you can download the ATI_fglrx-8.4.pet here
http://files.filefront.com/ATI+fglrx+84pet/;9809066;/fileinfo.html
Back to top
View user's profile Send private message Visit poster's website 
mac84

Joined: 18 Feb 2008
Posts: 43

PostPosted: Fri 14 Mar 2008, 22:33    Post subject:  

thank you papos, works great!
Back to top
View user's profile Send private message 
tombh


Joined: 12 Jan 2007
Posts: 422
Location: Bristol, UK

PostPosted: Mon 24 Mar 2008, 16:56    Post subject:  

Hey papos,

Nice work, there are good reports form the wNOP thread here. It does work but someone reported that the Opera window wouldn't resize when using your driver. Have you tried this driver with wNOP or Compiz-Fusion? Have you had any bugs or niggles?
Back to top
View user's profile Send private message Visit poster's website 
stevenbinion


Joined: 24 Aug 2007
Posts: 180
Location: Pittsburgh, PA - United States

PostPosted: Tue 25 Mar 2008, 13:45    Post subject:  

tombh wrote:
I've attempted to make a dotpet of the latest fglrx driver, version 8.2.
ATI_fglrx-8.2.pet
Would it be alright if someone could test it out as I don't have a compatible card -- it's for the new version of wNOP you see.

What I did was use the installer from the ATI website to create a slackware package and then use that to replace the relevant files in the current 7.11 dotpet. Seemed a bit of a crude way of doing it to me, but new2dir didn't seem to work with the installer. Also I notice that, kirk, you had put some extra files in the 7.11 dotpet that weren't present in the automated slackware package? libGLw, libglut and such like. Are they part of xorg?

Thanks for any feedback Smile


Thanks for the updated drivers. Isn't this the same as ATI CATALYST 8.2? what is "FGLRX"?

_________________
[Home of Wolf Pup Linux]
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger 
ICQ Number 
tombh


Joined: 12 Jan 2007
Posts: 422
Location: Bristol, UK

PostPosted: Thu 27 Mar 2008, 09:36    Post subject:  

Fglrx is just another name for the ATI driver and so yes it is the same as the Catalyst driver.
Back to top
View user's profile Send private message Visit poster's website 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Tue 22 Apr 2008, 15:32    Post subject: fglrx (Catalyst Linux) + Radeon cards = no 2D acceleration ?  

Does 2D acceleration or Xv work at all with these Catalyst/fglrx drivers?

I can get 3D acceleration to work,all controls in CCC work fine,ultra high resolutions and high refresh rates work (finally!),but 2D is painfully slow Sad
Scrolling text in the rvxt window is unbearably slow,mousing over the Puppy menu produces bad flickering,Xv output is unusable (produces a garbled image pattern) and a slew of other problems...all signs of a lack of 2D acceleration. What's funny is everything runs smoothly with the 'xvesa' driver.

Most people here install Compiz Fusion after installing these drivers,so that's why they don't experience any of these problems (the whole desktop is 3D accelerated),but have you ever tried these drivers without Compiz Fusion and what's your experience (especially with the R(V)6xx / RadeonHD series) ?

panzer

Last edited by panzerpuppy on Wed 21 May 2008, 22:34; edited 1 time in total
Back to top
View user's profile Send private message 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Wed 21 May 2008, 22:30    Post subject:  

FYI, ATI Catalyst 8.5 for Linux has been released today.
You can read more about it here:
http://www.phoronix.com/scan.php?page=article&item=catalyst_85_linux&num=1

Improved 2D acceleration and more features sound nice,but it looks like the 3D performance is now about 7% slower (with the HD2xxx series of cards) than the driver included in the fglrx-8.4 .pet package.

Still no love for users of AGP HD3xxx cards,even with this latest driver Sad
Back to top
View user's profile Send private message 
pdrito

Joined: 18 Jan 2007
Posts: 50

PostPosted: Fri 06 Jun 2008, 23:19    Post subject: ATI_fglrx-8.4.pet  

papos,

Plis, plis upload your ATI_fglrx-8.4.pet again !!!!
The actual server it is NOT working.

Any one could download the ATI_fglrx-8.4.pet from papos ?
If yes , could be so kind to upload too ?

Thanks in advance.

pdrito.
Back to top
View user's profile Send private message 
Farwater


Joined: 24 Mar 2008
Posts: 28
Location: Singapore

PostPosted: Sun 08 Jun 2008, 19:17    Post subject:  

Hey,
I built fglrx-8.493 (the latest so far) for Puppy 3.01. Please, read the instructions and dowload it from here.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [14 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0799s ][ Queries: 11 (0.0030s) ][ GZIP on ]