Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Dec 2014, 23:04
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Can't install "Opera 8.5" as alien package(Solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [20 Posts]   Goto page: Previous 1, 2
Author Message
klhrevolutionist


Joined: 08 Jun 2005
Posts: 1124

PostPosted: Sun 25 Sep 2005, 17:35    Post subject: stop  

for one, you don't install the dotpup as an alien package.
If you install a dotpup it is a seperate installer/packager itself
You are trying to install it as an alien package with pupget, don't
some dotpups do have an option of registering with pupget
but apparently rarsa's opera.pup does'nt. <- I don't know for sure as I have'nt seen
nor use.
So, what have you learned?
Pupget, Dotpup are two different package manager's

_________________
Heaven is on the way, until then let's get the truth out!
Back to top
View user's profile Send private message 
rarsa


Joined: 29 May 2005
Posts: 3053
Location: Kitchener, Ontario, Canada

PostPosted: Sun 25 Sep 2005, 17:43    Post subject:  

Mu,

Wow, this thread sure moved fast today.

Actually he did not have to comment the wget line, I am using wget -c which will continue a download. If he already downloaded it in full, wget will know this and won't try to download.

I actually point to this at the end of the install process. When my DotPup asks if it should delete the installer (tar.gz) it advises that if the user wants to install it in other computer, the file should not be deleted, It can be copied to /root in the second computer and the DotPup will skip the download.

Helpee wrote:
Dear Rarsa, I am sorry if my using the word urgent got you this angy with me.
Do I look like an angry man? I was just trying to be very direct. I think that the more direct one is, the easier the communication.

I am glad that you were able to install the Opera 8.50. Actually you did not need to unzip the dotpup, Once you downloaded the installer, you could have executed the dotpup and it would have used your downloaded file.

I think that the main thing to worry here is "why did the download fail?".

My guess is that the Opera server was too busy. My script has a message that should show when there is a problem downloading but it has a problem:

I am executing the wget inside a xterm terminal to show progress. The problem is that if it fails, it returns the error code to that xterm, but the xterm returns 0 to my script. Is there a way to have the xterm return the same exit code as the wget?

here is the coresponding code
Code:
# xterm -bg lightblue -e wget -c -P /root ftp://ftp.opera.com/pub/opera/linux/850/final/en/i386/shared/opera-8.50-20050916.5-shared-qt.i386-en.tar.gz
# [ $? -eq 0 ] || showError "downloading"
Back to top
View user's profile Send private message Visit poster's website 
Bruce B


Joined: 18 May 2005
Posts: 11131
Location: The Peoples Republic of California

PostPosted: Sun 25 Sep 2005, 18:22    Post subject:  

Yes, rasa, the Opera servers have done like a 1.5 million downloads the last few days, and it's not stopping.

Even I'm using Opera now and normally I don't even have it installed.

PS - it is not urgent that you read this, but it is imperative Wink
Back to top
View user's profile Send private message 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Sun 25 Sep 2005, 18:41    Post subject:  

there might be a way to return an error code from rxvt ... i've used a few workarounds for this problem, simply because it's quicker to write a workaround than to find the "right" answer

one workaround is to run wget from another script, that can create an error file that the first script can read ... a general-purpose script that any dotpup could use might be a good thing to be included with the Puppy distro ... something like:
[b]wget "$@" || touch /tmp/wgeterror[b]

with quotes and { brackets } it might be possible to run it without needing a second script

what i usually do is check the md5sum of the downloaded file ... if it's ok, it doesn't need to be downloaded ... if it's not ok, wget -c tries to finish the download and tests the md5sum again ... if the md5sum is not ok, then it didn't finish downloading properly ... this works around the problem, and makes sure the file downloaded perfectly too
Back to top
View user's profile Send private message 
Ian
Official Dog Handler


Joined: 04 May 2005
Posts: 1237
Location: Queensland

PostPosted: Sun 25 Sep 2005, 20:58    Post subject:  

I'm going to mark this as solved as it looks like Opera is installed and working.

rasa have you tried the -o option.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [20 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0661s ][ Queries: 12 (0.0104s) ][ GZIP on ]