Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 19 Nov 2019, 17:41
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Does QWin98 work with puppy 301?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [14 Posts]  
Author Message
Bikerbob


Joined: 16 Jul 2007
Posts: 30
Location: Mississauga, ON, Canada

PostPosted: Fri 14 Dec 2007, 17:07    Post subject:  Does QWin98 work with puppy 301?  

I am trying to use this in 301 does it work?

This is the error I get after I run the script.

# qwin98
FATAL: Error inserting kqemu (/lib/modules/2.6.21.7/misc/kqemu.ko): Invalid module format
ok
Listening...
101
./qemu: error while loading shared libraries: libSDL-1.2.so.0: cannot open shared object file: No such file or directory

Any help would be great.

Thanks

James
Back to top
View user's profile Send private message MSN Messenger 
Wolf Pup

Joined: 27 Apr 2006
Posts: 637

PostPosted: Fri 14 Dec 2007, 19:25    Post subject:  

you need sdl + kqemu module from here
http://puppylinux.ca/bugs

_________________

Visit The Repository - Helpful and hard-to-find treats for Puppy 3.
Click Here for Puppy Support Chat, + Helpful Links.
Back to top
View user's profile Send private message 
Bikerbob


Joined: 16 Jul 2007
Posts: 30
Location: Mississauga, ON, Canada

PostPosted: Mon 17 Dec 2007, 15:53    Post subject:  

thanks for the pet list.. there are some other items on there I wanted as well.

But when you say sdl +kqemu

DO you mean download sdl 1.2.9 and kqemu-1.3pre11.pet??

or is that a different fix by itself?

Thanks

James
Back to top
View user's profile Send private message MSN Messenger 
Wolf Pup

Joined: 27 Apr 2006
Posts: 637

PostPosted: Mon 17 Dec 2007, 16:20    Post subject:  

both sdl and kqemu
_________________

Visit The Repository - Helpful and hard-to-find treats for Puppy 3.
Click Here for Puppy Support Chat, + Helpful Links.
Back to top
View user's profile Send private message 
Bikerbob


Joined: 16 Jul 2007
Posts: 30
Location: Mississauga, ON, Canada

PostPosted: Mon 17 Dec 2007, 16:32    Post subject:  

Ran it all again.. this time I get this Xmessage after I copy the win98 directory to the img.



------------------------
this does not work?:
------------------------
To exchange files with Puppy, use LeechFtp
or another Ftp-client
with these values:

Host: 10.0.2.2

User: anonymous
Port: 2121
Passwort: (none)

Download a client using Puppys internet-connection,
the Internet Explorer will use it automatically.

http://dotpups.de/files/Windows/

NO IDEA..

James
Back to top
View user's profile Send private message MSN Messenger 
Bruce B

Joined: 18 May 2005
Posts: 11488
Location: The Peoples Republic of California

PostPosted: Tue 18 Dec 2007, 06:12    Post subject:  

Biker Bob,

Seems like Wolf Pup is giving right answers, but I've got some questions.

1. What script are you talking about?

2. Where did you get qwin98? I gather it's about running Windows in qemu, but Windows 95 would be just as well also.

3. About copying the win98 directory to the image. I copy the setup and cab files and set it up within the image. Are you doing something different?

4. Are you having some kind of problems getting files to and from qemu hd image to outside the image? If so what is it?
Back to top
View user's profile Send private message 
Bikerbob


Joined: 16 Jul 2007
Posts: 30
Location: Mississauga, ON, Canada

PostPosted: Tue 18 Dec 2007, 10:17    Post subject:  

Bruce B wrote:
Biker Bob,

Seems like Wolf Pup is giving right answers, but I've got some questions.

1. What script are you talking about?

2. Where did you get qwin98? I gather it's about running Windows in qemu, but Windows 95 would be just as well also.

3. About copying the win98 directory to the image. I copy the setup and cab files and set it up within the image. Are you doing something different?

4. Are you having some kind of problems getting files to and from qemu hd image to outside the image? If so what is it?


1. The script I am running is one MU wrote to get the pup pkg Qwin98 installed.

2. Qwin98 is a pup package you can get when using PSI_07 - a couple of the items are what Wolf pup said I should update from his /bugs listing.

3. The Qwin98 package included 2 image files that can be uncompressed and used to copy the setup and cab files ( I copied the contents of the win98 directory to the image) This works fine.. and I can re-mount the image and the files are there.

4. This is the point I am stuck in the script. WHen I copy the win98 files to the image the script askes me to close all filemanager windows and unmount the image.. it then wants to restart the program called Qwin98 - Says it will be starting it in DOS and I can then run the SETUP program. But I get the response you saw in the last post... and I am stuck.

I can post the script to the forum if you would like?

James
Back to top
View user's profile Send private message MSN Messenger 
Bruce B

Joined: 18 May 2005
Posts: 11488
Location: The Peoples Republic of California

PostPosted: Wed 19 Dec 2007, 18:07    Post subject:  

James,

I installed qemu the long way by hand. I must say it really runs W98 and W95 great.

I'd be very interested if you'd post the script and we can continue the discussion.

I've just located QWin98.pup and downloaded it, so we can be on the same page about how it's built.

Bruce
Back to top
View user's profile Send private message 
Bruce B

Joined: 18 May 2005
Posts: 11488
Location: The Peoples Republic of California

PostPosted: Wed 19 Dec 2007, 18:58    Post subject:  

James,

I downloaded it and broke the package down.

Here are my comments:

1. you don't need to post the scripts

2. the qemu version is 8.2 and mine is 9.0, I'm wondering if you want to install the newer release.


Bruce
Back to top
View user's profile Send private message 
Bikerbob


Joined: 16 Jul 2007
Posts: 30
Location: Mississauga, ON, Canada

PostPosted: Thu 20 Dec 2007, 22:57    Post subject:  

Well Bruce I did that..

I forgot about Qwin98 and download Qemu directly.. installed it and went that way.. go windows 98 installed no problem.

Now controlling Qemu is a little more hassle than I liked and trying to get GUI front end is a pain in the butt..

I think I am going to try Vbox next...

Thanks.. I guess we can solve this thread as NO- does not run with 301.

It would be nice if the .pups were updated with info on what distro they run with. Even a .pup wiki so people could look it up somewere would be nice..


James
Back to top
View user's profile Send private message MSN Messenger 
Bruce B

Joined: 18 May 2005
Posts: 11488
Location: The Peoples Republic of California

PostPosted: Fri 21 Dec 2007, 05:31    Post subject:  

James

Having not tried Vbox, please keep me posted on this thread if you don't mind.

I totally don't understand this part as worded:

    Now controlling Qemu is a little more hassle than I liked and trying to get GUI front end is a pain in the butt..

Whatever it is can be resolved, but I don't have enough specifics to go on. So if you want to continue with qemu to resolve this, I'll continue with the support.

If you want to continue, please outline for me all the steps you have taken and where you got stopped, in order that we can be on the same page with this.


Bruce
Back to top
View user's profile Send private message 
Bruce B

Joined: 18 May 2005
Posts: 11488
Location: The Peoples Republic of California

PostPosted: Fri 21 Dec 2007, 05:33    Post subject:  

James,

After thought. What GUI front end?

I do it all with scripts, which I've got down fairly pat.

Bruce
Back to top
View user's profile Send private message 
Bikerbob


Joined: 16 Jul 2007
Posts: 30
Location: Mississauga, ON, Canada

PostPosted: Sat 22 Dec 2007, 20:16    Post subject:  

The front ends I was trying to use were QTemu and qemu-launcher.. each had its own issues and i was not able to get either running before I trashed my 3.0.1 install and am starting again.

Qemu did install and get win98 running with no issues ... I did not have a functioning internet machine yet because it did not find the pnp OS or the network adapter in the "machine" so I think i need to add it manually and provide the correct driver.

Anyway.. I will report my success etc.. with Vbox.. users on #puppylinux report it works well.. so I am hoping for better success with that.

James
Back to top
View user's profile Send private message MSN Messenger 
Bruce B

Joined: 18 May 2005
Posts: 11488
Location: The Peoples Republic of California

PostPosted: Sun 23 Dec 2007, 04:02    Post subject:  

James,

I think the NIC driver as well as Video and Sound card drivers are part of the .CAB files in W98SE

Here is a command line for you to work with.

qemu -boot c -m 368 -no-reboot -localtime \
-net user -net nic,model=rtl8139 \
-hda w98.fat -hdb w98d.fat -smp 2


-no-reboot is a matter of preference
-full-screen is a matter of preference otherwise use left alt + ctrl + f to go in and out of full screen

for sound support
-soundhw es1370
-soundhw sb16


The last line of the posted command line is user specific, so you have to make your substitutions as required.

Your video adapter is:

Cirrus Logic 5446 PCI
CL-GD5446 Rev 0
4MB Memory


Your NIC is:

Realtek RTL8139 C+ Fast Ethernet NIC

Bruce
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [14 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0458s ][ Queries: 11 (0.0067s) ][ GZIP on ]