Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 26 Apr 2019, 02:27
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Puppy 2.16.1 Gxine volume control is weird
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
PaulBx1

Joined: 16 Jun 2006
Posts: 2307
Location: Wyoming, USA

PostPosted: Sat 22 Dec 2007, 19:36    Post subject:  Puppy 2.16.1 Gxine volume control is weird  

I am using Puppy 2.16.1 at the moment.

Sometimes I need to boost the volume of some youtube I am listening to with gxine, using the gxine volume control. If I leave it high, next time I boot the "woof, woof" almost blows my speakers out!

Why not use the taskbar volume control instead? Because it is sitting at 90% already so there is little "headroom".

It's strange to me that gxine controls the overall volume even when it is not running. It is strange that gxine retains its volume setting when the system is shut down, but the volume control on the taskbar does not, and goes back to 90%.

Is there any way to change this state of affairs? I'd prefer the gxine volume control to only control gxine sound, and to go back to 50% when it is closed (or re-opened). I'd also like the taskbar volume control to default to 50% rather than 90%, and for 50% to be something that is actually reasonably audible. That way I can increase the volume if I need it and not be immediately bumping into 100 percent. I'd (maybe) like the taskbar volume control to be persistent as well, although that is less important.
Back to top
View user's profile Send private message 
trapster


Joined: 28 Nov 2005
Posts: 2119
Location: Maine, USA

PostPosted: Sat 22 Dec 2007, 19:42    Post subject:  

For starting your system with a specific volume, try:
setvol 0 50 in .xinitrc.
Type setvol in a console for help.

_________________
trapster
Maine, USA

Asus eeepc 1005HA PU1X-BK
Frugal install: Slacko
Currently using full install: DebianDog
Back to top
View user's profile Send private message Visit poster's website 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 13212
Location: Arizona USA

PostPosted: Sat 22 Dec 2007, 22:53    Post subject:  

It looks like you can set Gxine's startup volume from within Gxine. Go to File > Configure > Preferences, choose "Advanced" for your experience level, open the audio tab, then the volume tab, set the volume you want Gxine to open with, then check "Remember volume."

Let us know if that works, will you?
Back to top
View user's profile Send private message 
Bruce B

Joined: 18 May 2005
Posts: 11488
Location: The Peoples Republic of California

PostPosted: Sun 23 Dec 2007, 03:42    Post subject:  

Then I'd probably edit the config file

from

# startup audio volume
# [0..100], default: 50
#audio.volume.mixer_volume:50

# restore volume level at startup
# bool, default: 0
#audio.volume.remember_volume:0


to

# startup audio volume
# [0..100], default: 50
audio.volume.mixer_volume:70

# restore volume level at startup
# bool, default: 0
audio.volume.remember_volume:1


Hope you aren't throughly confused by now.
Back to top
View user's profile Send private message 
PaulBx1

Joined: 16 Jun 2006
Posts: 2307
Location: Wyoming, USA

PostPosted: Tue 25 Dec 2007, 19:57    Post subject:  

Bruce, can you tell me what config file you are talking about? And give me a hint what this change is supposed to do?

Flash, I was hopeful about this change. I'd been in preferences before but didn't notice that. Anyway it doesn't really work. Yes, if you set the volume high, exit gxine, and restart it you get it set back to 50% again. However if you set the volume high, and just reboot, the "woof, woof" comes out very loud still. So across reboots it doesn't work.

Trapster, your item works as advertised. However it does not give an increased volume for 50%. In other words to hear anything at all I have to move it back up to around 90% anyway, and then again there is little headroom left. What I need is the default volume set at 50%, with that corresponding to a reasonable volume that I can hear, so that 10% would be very quiet and 90% would be very loud.

I imagine all Puppys are like this.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0649s ][ Queries: 11 (0.0220s) ][ GZIP on ]