Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 19 Nov 2019, 04:15
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Puppy 3.01 hard drive install, desktop missing after SFScopy
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
wb0gaz

Joined: 14 Nov 2006
Posts: 62

PostPosted: Sun 23 Dec 2007, 12:57    Post subject:  Puppy 3.01 hard drive install, desktop missing after SFScopy  

Installed Puppy 3.01 onto a hard drive (boot with GRUB), then fetched the three SFS files (dev, kernel-source, openoffice-2.2), and for each one, mounted -o loop -t squashfs, then cp -r from the mountpoint to /.

The applications work, however, upon first reboot, the desktop is now all white except for the six Openoffice.org icons. The Menu (start) works fine, but the array of apps and links normally on the desktop are missing.

I didn't expect this, so I don't know which of the three file sets might have caused this. I also doubt I can undo the cp -r due to the nature of the process.

Any thoughts on how to rebuild the desktop? This isn't world-ending as I primarily plan to use the machine as a server and access it via vncserver from afar, but I would prefer the desktop be intact.

Very tks,

Dave
wb0gaz@hotmail.com
Back to top
View user's profile Send private message 
paultheg33k

Joined: 26 Dec 2007
Posts: 1

PostPosted: Wed 26 Dec 2007, 17:57    Post subject:  

Hi,

I've just fallen into this trap myself. Fixing it was easy enough, however...

The OO SFS, when copied from the loop mount, will overwrite /root/Choices/ROX-Filer/*. To fix it, I did the following:

* Mounted the Puppy LiveCD as /mnt/cdrom
* Loop mounted the pup_301.sfs file as /mnt/tmp using mount -t squashfs
* mv PuppyPin [and globicons] to .oo filenames
* cp the two original files from under /mnt/tmp to the /root/Choices...etc directory as above.
* cat <.oo_file> >> <original_file> to append the .oo icon data to the two files as above.
* e3pi to edit the two <original_files> and remove the overlapping XML schema definitions to 'run' the two files together correctly.
* Restart X

HTH, PC
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0431s ][ Queries: 11 (0.0192s) ][ GZIP on ]