Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Dec 2014, 08:39
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Mozilla only app able to connect thru proxy server
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 3 Posts_count   Goto page: Previous 1, 2, 3 Next
Author Message
pitbos
Guest


PostPosted: Wed 28 Sep 2005, 18:49    Post_subject:  

was not able to ip address after turning proxy off in mozilla
Back to top
Bruce B


Joined: 18 May 2005
Posts: 11131
Location: The Peoples Republic of California

PostPosted: Wed 28 Sep 2005, 19:35    Post_subject:  

In that case, I'm tempted to think all you have in terms of Internet connection is a proxy service.
Back to top
View user's profile Send_private_message 
pitbos
Guest


PostPosted: Wed 28 Sep 2005, 19:52    Post_subject:  

So, where do we go from here ?
Back to top
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11180
Location: Arizona USA

PostPosted: Wed 28 Sep 2005, 22:33    Post_subject:  

What happens if you go to Start -> Setup -> Ethernet network Wizard -> Configure eth_whaterver -> Auto DHCP?
Back to top
View user's profile Send_private_message 
Bruce B


Joined: 18 May 2005
Posts: 11131
Location: The Peoples Republic of California

PostPosted: Wed 28 Sep 2005, 23:21    Post_subject:  

pitbos wrote:
So, where do we go from here ?


Try what Flash said
Back to top
View user's profile Send_private_message 
pitbos
Guest


PostPosted: Thu 29 Sep 2005, 03:11    Post_subject:  

been there, done that, but failed
Back to top
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Thu 29 Sep 2005, 03:52    Post_subject:  

you had an internet connection setup before
if it isn't working now, set it up again the same way
then try:

click Home on the desktop to run rox file manager
click the up arrow on the left a few times
click the etc folder
right click profile and click Copy ... press the right-arrow key then type .local (to copy the file profile to profile.local
right click profile and click Open As Text
type in this, changing the ip numbers to the correct ones:
Code:
export https_proxy=http://111.111.111.111:8088
export http_proxy=http://111.111.111.111:8088
export ftp_proxy=http://111.111.111.111:8088

or you can copy it from this page and paste it into the text editor ... mark the text with the mouse to copy, click the middle mouse button to paste

save the file (click File ... or press ctrl+S then ctrl+Q)
reboot

hopefully, some of your programs should now work with your proxy ... it works with Dillo and Privoxy, i didn't test it with anything else

the instructions sound complicated, but you are just making a file with 3 lines in it then rebooting
Back to top
View user's profile Send_private_message 
Guest
Guest


PostPosted: Thu 29 Sep 2005, 08:28    Post_subject:  

Quote:

ERROR: 11 IS UNREACHABLE!
...are you connected to the Internet?
...maybe that site is down? Try another.

You have chosen to install these packages in Puppy:
"abs-0.908"

Please connect to the Internet then press a button to choose download site.
If you click on "Local" button, the packages must already be downloaded,
that is, somewhere local.


Dear GuestToo

I did what you advised, and tried to download a package usin Pupget Package Manager. Above is the response I got from it.

Any more ideas guys. It's really getting to a point where I am just gonna Flip out.

When it comes to Puget Packages, I just download them using my Browser to a local directory and Use PupGet Package Manager with Alien option, but what do I do to download my Mail from my POP3 mail account. I get the Connection Error Message in Sylpheed and it really satinks, I followed each of the great helping advices from this thread and still not getting anywhere.

I am using Puppy 1.0.4, liveCD running in ramdisk
Back to top
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11180
Location: Arizona USA

PostPosted: Thu 29 Sep 2005, 11:23    Post_subject:  

pitbos wrote:
been there, done that, but failed

My question was, what happened when you tried? Did you get any error messages?
Back to top
View user's profile Send_private_message 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Thu 29 Sep 2005, 13:23    Post_subject:  

you could try changing
export ftp_proxy=http://111.111.111.111:8088
to
export ftp_proxy=ftp://111.111.111.111:8088
it might or might not work

you could also try configuring a .wgetrc file in /root
see: here

it's possible that wget is working, but the ping test that pupget does is not working through your proxy ... you could test wget by using it to download a file ... for example,

open a console (rxvt window) and type
wget www.google.com/favicon.ico
and see if it downloads the favicon.ico file or prints error messages
Back to top
View user's profile Send_private_message 
pitbos
Guest


PostPosted: Thu 29 Sep 2005, 13:58    Post_subject:  

This is what i get in response
Quote:

BusyBox v0.60.5 (2004.09.18-02:04+0000) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

# wget http://www.google.com/favicon.ico
--22:37:26-- http://www.google.com/favicon.ico
=> `favicon.ico'
Resolving www.google.com... failed: Host not found.
#
Back to top
Guest
Guest


PostPosted: Thu 29 Sep 2005, 14:05    Post_subject:  

Flash wrote:
My question was, what happened when you tried? Did you get any error messages?


Yes I get an error message probably my LAN Server is not compliant with this protocol.
Back to top
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Thu 29 Sep 2005, 14:49    Post_subject:  

pitbos wrote:
# wget http://www.google.com/favicon.ico
resolving www.google.com... failed: Host not found


wget is what pupget uses to download files
wget is using http protocol to download favicon.ico from google ... that same as Mozilla

basically, wget is trying to get the file directly from the internet and is not using your proxy

when i type in a console (rxvt window):
export http_proxy=http://111.111.111.111:8088
wget http://www.google.com/favicon.ico


it tries to use that proxy (it doesn't work of course, i don't have a proxy there to use)

--14:18:45-- http://www.google.com/favicon.ico
=> `favicon.ico'
Connecting to 111.111.111.111:8088...

the method does seem to work

are you sure you have http_proxy setup?
what do you get if you type in a console:
set | grep -i proxy

pupget might work if you type this in a console:

export http_proxy=http://111.111.111.111:8088
pupget


(using the correct proxy address of course)
Back to top
View user's profile Send_private_message 
Guest
Guest


PostPosted: Thu 29 Sep 2005, 15:32    Post_subject:  

pitbos wget does work with the proxy variable. I installed a localhost proxy yesterday

Here is the input

    wget http://www.google.com/favicon.ico


----------------------------------------------

Here is the output


    wget http://www.google.com/favicon.ico
    --11:59:42-- http://www.google.com/favicon.ico
    => `favicon.ico'
    Connecting to 127.0.0.1:9090... connected.
    Proxy request sent, awaiting response... 200 OK
    Length: 1,406 [image/x-icon]

    100%[====================================>] 1,406 1.34M/s ETA 00:00

    11:59:44 (1.34 MB/s) - `favicon.ico' saved [1406/1406]
-----------------------------------------------

As far as your computer is concerned, the guy is apparently not providing you with DHCP. It may be the only thing he is providing you is an HTTP proxy.

If true, then you are limited to HTTP. I think most programs that use HTTP will use the variable. I think programs that have entries for setting up a proxy like Mozilla, may not use it, but that's not a problem.

Sincerely, it appears you are expecting more than what is made available to you by the host. Also I don't think you have your http_proxy environment set, but that is beside the major point I wish to make, which is: maybe all you got is an HTTP proxy available to you.
Back to top
Bruce B


Joined: 18 May 2005
Posts: 11131
Location: The Peoples Republic of California

PostPosted: Thu 29 Sep 2005, 15:34    Post_subject:  

The post above was by me.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 3 Posts_count   Goto page: Previous 1, 2, 3 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0815s ][ Queries: 11 (0.0087s) ][ GZIP on ]